Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 236905 - dev-util/catalyst-2.0.6: argument "stage4/users" not recognized
Summary: dev-util/catalyst-2.0.6: argument "stage4/users" not recognized
Status: IN_PROGRESS
Alias: None
Product: Gentoo Hosted Projects
Classification: Unclassified
Component: Catalyst (show other bugs)
Hardware: AMD64 Linux
: High minor (vote)
Assignee: Gentoo Catalyst Developers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-06 23:18 UTC by Peter Abrahamsen
Modified: 2019-12-02 07:52 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
enable 'stage4/users' feature (allow_stage4_users.patch,1.35 KB, patch)
2014-03-27 20:12 UTC, Proneet Verma
Details | Diff
enable 'stage4/users' feature (stage4_users.patch,1.35 KB, patch)
2014-04-03 22:19 UTC, Proneet Verma
Details | Diff
bug fix (0001-Seems-to-be-fixed.patch,2.87 KB, patch)
2019-11-29 13:46 UTC, David Palao
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Abrahamsen 2008-09-06 23:18:43 UTC
Hi,

I read about an spec file option "stage4/users" in a spec from kyron's SoC SSI project, but when I try to use it, I get:

!!! catalyst: Argument "stage4/users" not recognized.

My apologies if this isn't supposed to be a supported option, but if it's simple to make it work again, that'd be awesome.

Reproducible: Always
Comment 1 Andrew Gaffney (RETIRED) gentoo-dev 2008-09-15 03:10:07 UTC
Well, this option is in the example stage4 spec, and there's no reason it shouldn't be supported. However, the option isn't in the list of valid options in stage4, and the code to handle it is in livecdfs-udpate.sh.
Comment 2 Proneet Verma 2014-03-27 20:12:37 UTC
Created attachment 373660 [details, diff]
enable 'stage4/users' feature

This patch would enable 'stage4/users' feature while building stage4 archive.
Comment 3 Proneet Verma 2014-03-28 10:51:54 UTC
FYI: The patch I have attached before would work only with [3.0] branch. Not supported with version <3.0
Comment 4 Proneet Verma 2014-04-03 22:19:17 UTC
Created attachment 374208 [details, diff]
enable 'stage4/users' feature
Comment 5 David Palao 2019-10-28 10:32:37 UTC
Hello,
In the (stable) version on my system (dev-util/catalyst-3.0.5) the "stage4/users" is still not recognized:

ERROR   : CatalystError: Argument "stage4/users" not recognized.

Is there an important reason why the patch is not yet, after 5 years, in catalyst?

Best
Comment 6 Ben Kohler gentoo-dev 2019-10-28 14:08:13 UTC
I tried this patch (after a bit of work to port it to newest codebase) and it didn't work as-is.  So that's why I personally haven't done anything with it.

Can you test & confirm that it works for you?
Comment 7 David Palao 2019-10-29 11:48:27 UTC
Hi,
After looking at the code, I don't see why this patch should work in the current codebase...

I'll try to implement it.

What testing strategy is followed in the development of Catalyst? I don't find much info...
Comment 8 David Palao 2019-11-29 13:46:57 UTC
Created attachment 597844 [details, diff]
bug fix

At least it works for me. I think there must be 100 things to improve though.
Comment 9 David Palao 2019-12-02 07:52:46 UTC
There is at least one issue: the docs (man catalyst-spec, section miscellaneous) claims that <target>/users creates users belonging "to the following groups: users, wheel, audio, games, cdrom, and usb"

This patch does not do that because the group "games" does not exist.

Should I create the group "games" too, to comply with the docs, or should the man page be modified?