Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 234938 - media-sound/rhythmbox-0.12.5-r2: Stabilization request
Summary: media-sound/rhythmbox-0.12.5-r2: Stabilization request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Low normal with 1 vote (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: STABLEREQ
: 290072 (view as bug list)
Depends on: 286074
Blocks: CVE-2009-2462
  Show dependency tree
 
Reported: 2008-08-16 16:48 UTC by Lars Strojny
Modified: 2010-01-05 18:37 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Strojny 2008-08-16 16:48:18 UTC
$ emerge -pv rhythmbox

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] media-sound/rhythmbox-0.11.6 [0.11.5] USE="X%* cdr%* daap dbus gnome-keyring%* hal ipod libnotify musicbrainz python tagwriting -debug -doc -lirc -mtp% (-keyring%*)" 0 kB [?=>0]


$ emerge rhythmbox
[...]
 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I.. -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/lib64/mozilla-firefox/include/java -I/usr/lib64/mozilla-firefox/include/plugin -I/usr/include/nspr -O2 -pipe -march=nocona -fomit-frame-pointer -mno-tls-direct-seg-refs -MT librhythmbox_itms_detection_plugin_la-rhythmbox-itms-plugin.lo -MD -MP -MF .deps/librhythmbox_itms_detection_plugin_la-rhythmbox-itms-plugin.Tpo -c rhythmbox-itms-plugin.cpp  -fPIC -DPIC -o .libs/librhythmbox_itms_detection_plugin_la-rhythmbox-itms-plugin.o
rhythmbox-itms-plugin.cpp:31:19: Fehler: npupp.h: Datei oder Verzeichnis nicht gefunden
rhythmbox-itms-plugin.cpp:33: Fehler: »NPNetscapeFuncs« bezeichnet keinen Typ
rhythmbox-itms-plugin.cpp:35: Fehler: »NPError« bezeichnet keinen Typ
rhythmbox-itms-plugin.cpp:47: Fehler: »NPError« bezeichnet keinen Typ
rhythmbox-itms-plugin.cpp:54: Fehler: »NPError« bezeichnet keinen Typ
rhythmbox-itms-plugin.cpp:64: Fehler: »NPError« bezeichnet keinen Typ
rhythmbox-itms-plugin.cpp:72: Fehler: »NPError« bezeichnet keinen Typ
rhythmbox-itms-plugin.cpp:80: Fehler: »int32« bezeichnet keinen Typ
rhythmbox-itms-plugin.cpp:87: Fehler: »int32« bezeichnet keinen Typ
rhythmbox-itms-plugin.cpp:97: Fehler: »NPError« bezeichnet keinen Typ
rhythmbox-itms-plugin.cpp:125: Fehler: »NPError« bezeichnet keinen Typ
rhythmbox-itms-plugin.cpp: In function »char* NP_GetMIMEDescription()«:
rhythmbox-itms-plugin.cpp:136: Warnung: veraltete Konvertierung von Zeichenkettenkonstante in »char*«
rhythmbox-itms-plugin.cpp: At global scope:
rhythmbox-itms-plugin.cpp:139: Fehler: »NPError« bezeichnet keinen Typ
rhythmbox-itms-plugin.cpp:211: Fehler: »NPError« bezeichnet keinen Typ
make[2]: *** [librhythmbox_itms_detection_plugin_la-rhythmbox-itms-plugin.lo] Fehler 1
make[2]: *** Warte auf noch nicht beendete Prozesse...
 x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -DGNOMELOCALEDIR=\"/usr/share/locale\" -DG_LOG_DOMAIN=\"Rhythmbox\" -I.. -I../lib -I../rhythmdb -I../widgets -I../shell -I../metadata -I../library -I../lib -DORBIT2=1 -pthread -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/pixman-1 -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/gail-1.0 -I/usr/include/libglade-2.0 -I/usr/include/gnome-vfs-module-2.0 -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -pthread -DORBIT2=1 -I/usr/include/totem-pl-parser/1/plparser -I/usr/include/libxml2 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/gnome-vfs-module-2.0 -I/usr/include/evolution-data-server-2.22 -I/usr/include/gtk-2.0 -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/pixman-1 -O2 -pipe -march=nocona -fomit-frame-pointer -mno-tls-direct-seg-refs -MT rb-podcast-manager.lo -MD -MP -MF .deps/rb-podcast-manager.Tpo -c rb-podcast-manager.c  -fPIC -DPIC -o .libs/rb-podcast-manager.o
rm -fr .libs/librbpodcast_parse.lax
mkdir .libs/librbpodcast_parse.lax
rm -fr .libs/librbpodcast_parse.lax/librb.a
mkdir .libs/librbpodcast_parse.lax/librb.a
(cd .libs/librbpodcast_parse.lax/librb.a && x86_64-pc-linux-gnu-ar x /var/tmp/portage/media-sound/rhythmbox-0.11.6/work/rhythmbox-0.11.6/podcast/../lib/.libs/librb.a)
x86_64-pc-linux-gnu-ar cru .libs/librbpodcast_parse.a .libs/rb-podcast-parse.o  .libs/librbpodcast_parse.lax/librb.a/rb-stock-icons.o .libs/librbpodcast_parse.lax/librb.a/rb-tree-dnd.o .libs/librbpodcast_parse.lax/librb.a/eel-gconf-extensions.o .libs/librbpodcast_parse.lax/librb.a/rb-glade-helpers.o .libs/librbpodcast_parse.lax/librb.a/rb-cut-and-paste-code.o .libs/librbpodcast_parse.lax/librb.a/rb-proxy-config.o .libs/librbpodcast_parse.lax/librb.a/rb-debug.o .libs/librbpodcast_parse.lax/librb.a/rb-string-value-map.o .libs/librbpodcast_parse.lax/librb.a/md5.o .libs/librbpodcast_parse.lax/librb.a/rb-util.o .libs/librbpodcast_parse.lax/librb.a/rb-async-queue-watch.o .libs/librbpodcast_parse.lax/librb.a/rb-marshal.o .libs/librbpodcast_parse.lax/librb.a/rb-file-helpers.o 
 x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -DGNOMELOCALEDIR=\"/usr/share/locale\" -DG_LOG_DOMAIN=\"Rhythmbox\" -I.. -I../lib -I../rhythmdb -I../widgets -I../shell -I../metadata -I../library -I../lib -DORBIT2=1 -pthread -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/pixman-1 -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/gail-1.0 -I/usr/include/libglade-2.0 -I/usr/include/gnome-vfs-module-2.0 -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -pthread -DORBIT2=1 -I/usr/include/totem-pl-parser/1/plparser -I/usr/include/libxml2 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/gnome-vfs-module-2.0 -I/usr/include/evolution-data-server-2.22 -I/usr/include/gtk-2.0 -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/pixman-1 -O2 -pipe -march=nocona -fomit-frame-pointer -mno-tls-direct-seg-refs -MT rb-podcast-manager.lo -MD -MP -MF .deps/rb-podcast-manager.Tpo -c rb-podcast-manager.c -o rb-podcast-manager.o >/dev/null 2>&1
x86_64-pc-linux-gnu-ranlib .libs/librbpodcast_parse.a
rm -fr .libs/librbpodcast_parse.lax
creating librbpodcast_parse.la
(cd .libs && rm -f librbpodcast_parse.la && ln -s ../librbpodcast_parse.la librbpodcast_parse.la)
mv -f .deps/rb-podcast-manager.Tpo .deps/rb-podcast-manager.Plo
make[2]: Leaving directory `/var/tmp/portage/media-sound/rhythmbox-0.11.6/work/rhythmbox-0.11.6/podcast'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/var/tmp/portage/media-sound/rhythmbox-0.11.6/work/rhythmbox-0.11.6'
make: *** [all] Fehler 2
 * 
 * ERROR: media-sound/rhythmbox-0.11.6 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2947:  Called gnome2_src_compile
 *             environment, line 2136:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-sound/rhythmbox-0.11.6/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/rhythmbox-0.11.6/temp/environment'.
 * 

 * GNU info directory index is up-to-date.

$ emerge --info
Portage 2.2_rc8 (default-linux/amd64/2007.0, gcc-4.3.1, glibc-2.7-r2, 2.6.25.3-mactel x86_64)
=================================================================
System uname: Linux-2.6.25.3-mactel-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7500_@_2.20GHz-with-glibc2.2.5
Timestamp of tree: Sat, 16 Aug 2008 06:36:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=nocona -fomit-frame-pointer -mno-tls-direct-seg-refs"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=nocona -fomit-frame-pointer -mno-tls-direct-seg-refs"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache collision-protect distlocks metadata-transfer multilib-strict parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,--as-needed"
LINGUAS="de en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/dang-maintainer /usr/portage/local/layman/java-overlay /usr/portage/local/layman/mozilla /usr/portage/local/layman/sunrise /usr/portage/local/layman/gentopia /usr/portage/local/layman/x11 /usr/portage/local/layman/picoverlay /usr/local/overlays/lars /usr/local/overlays/party-ebuilds /usr/local/overlays/php-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi admin aiglx alsa amd64 apache2 applet asyncns audioscrobbler autoipd automount avahi bash-completion beagle berkdb binfilter bluetooth bonjour bookmarks bzip2 cairo cdda cddb cdparanoia cdr chm consolekit cpudetection cracklib crypt cscope cups curl cvs daap dbus dell device-mapper dga dia disk-partition djvu dmi dpms dri dts dv dvb dvd dvdnav dvdr dvdread dvi eds enca encode eog esd evo exif extraengine extras fbsplash ffmpeg firefox flac fontconfig ftp fuse gajim galago gdbm gedit gif gimp gimp-print gimpprint git glitz gnet gnome gnome-keyring gnome-print gphoto2 gpm gsf gsm gstreamer gstreamer010 gtk gtkhtml guile gzip hal howl hvm iconv idle idn ieee1394 ilbc inkjar ipod ipv6 jabber jack java5 jingle jpeg jrtplib kdeenablefinal keyring laptop lcms ldap libcaca libgda libnotify libsexy live logrotate lua lzo mactel mad matroska mhash midi mmx mng mono mozdevelop mp2 mp3 mpeg mpm-worker msn multiuser musepack musicbrainz mysql nautilus ncurses networkmanager newspr nfs njb nls nntp no-old-linux nptl nptlonly nsplugin ntp ntplonly office ogg opengl ortp pam pango pcre pdf php png portaudio ppds prediction print printer pygrub python quicktime rar readline ruby samba slp smp soap sockets speex spell sqlite sqlite3 srt srv srvdir sse sse2 ssh ssl ssse3 startup-notification subversion svg t1lib tagwriting theora threads tiff tracker trayicon truetype unicode usb v4l v4l2 vim-pager vim-syntax vorbis vorbis-psy webdav wma wmf x264 xanim xattr xcb xcomposite xforms xft xhtml xinerama xml xml2 xorg xprint xv xvid yahoo zeroconf zlib" ALSA_CARDS="hda-intel als4000" ALSA_PCM_PLUGINS="adpcm alaw copy dshare dsnoop extplug file hooks ladspa lfloat linear meter mulaw multi null rate route share shm asym dmix empty iec958 ioplug plug softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" LIRC_DEVICES="macmini" USERLAND="GNU" VIDEO_CARDS="intel i810"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Panagiotis Christopoulos (RETIRED) gentoo-dev 2008-08-16 18:45:18 UTC
spirit@Vereniki /mnt/atlantis/tree/gentoo-x86/media-sound/rhythmbox $ find /usr/include/ -iname "npupp.h"
/usr/include/xulrunner-1.9/stable/npupp.h
/usr/include/xulrunner-1.9/unstable/npupp.h

so, maybe,  the new version really needs net-libs/xulrunner.

Lars, can you try emerging net-libs/xulrunner, and then to rebuild rhythmbox? Comment here with the result please.
Comment 2 Rob MacKinnon 2008-11-27 16:59:39 UTC
as of 0.11.6-r1, the configure does look for a gecko engine (and if it's already installed polls for xulrunner)

.
.
.
checking which gecko to use... xulrunner
checking for BROWSER_PLUGIN... yes
.
.
.

My quick fix was just after the G2CONF variable setup, add an export MOZILLA_PLUGINDIR=/opt/netscape/plugins, add a xulrunner? ( >=net-libs/xulrunner-1.8 )  into the RDEPENDS list, and add the IUSE flag xulrunner.

Now that doesn't stop it from checking on it's own, does add the deps for portage to check for xulrunner first.
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-11-27 23:47:52 UTC
we need to fix the automagic
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-02-22 14:37:35 UTC
The automagic is now fixed in 0.11.6-r1 without a bump. xulrunner 1.8 and 1.9 provide the required header and rhythmbox builds fine against both on machine which have only one slot of xulrunner installed. If firefox or seamonkey doesn't please fill a bug against them. Thanks for reporting and sorry for taking so long to actually dig in this issue.
Comment 5 Ian Stakenvicius (RETIRED) gentoo-dev 2009-07-29 18:24:24 UTC
This bug may need to be reopened, as xulrunner-1.9.1 does not contain 'npupp.h'.

Hopefully >=rhythmbox-0.12 will have taken this into account, and so for this version changing the dependency from "net-libs/xulrunner" to "<net-libs/xulrunner-1.9.1" (to inform those of us that like to run ~arch mozilla stuffs) should suffice.



Comment 6 Fabiano Francesconi 2009-09-26 17:49:07 UTC
Unmasking firefox (to 3.5 and so using xulrunner 1.9.1) seems to make rhythmbox not compiling.

Same error.

It's just a guess.. didn't try a downgrade
Comment 7 paolo muratore-ginanneschi 2009-10-20 13:28:57 UTC
(In reply to comment #5)
> This bug may need to be reopened, as xulrunner-1.9.1 does not contain
> 'npupp.h'.
> 
> Hopefully >=rhythmbox-0.12 will have taken this into account, and so for this
> version changing the dependency from "net-libs/xulrunner" to
> "<net-libs/xulrunner-1.9.1" (to inform those of us that like to run ~arch
> mozilla stuffs) should suffice.
> 
I confirm that rhythmbox does ot compile with net-libs/xulrunner-1.9.1.2-r2
(stable branch now). The topmost error is

rhythmbox-itms-plugin.cpp:31:19: error: npupp.h: No such file or directory

Neither the workaround suggested above nor the one of Comment #2 solve the
problem for me.
Comment 8 Ryan May 2009-10-20 17:04:15 UTC
Seeing the same problem here.  Stable xulrunner (1.9.1.2-r2) + stable rhythmbox (0.11.6-r1) fail to build.
Comment 9 Jacson Passold 2009-10-22 12:25:08 UTC
this workaround works for me! 
For media-sound/rhythmbox-0.11.6-r1:

in /etc/portage/package.use
media-sound/rhythmbox -nsplugin
Comment 10 Gilles Dartiguelongue gentoo-dev 2009-10-22 20:00:40 UTC
*** Bug 290072 has been marked as a duplicate of this bug. ***
Comment 11 Arnaud Launay 2009-10-24 13:08:28 UTC
I don't get it. I'm running into this bug, why is it closed ? Either stabilize one of the 0.12 release, or correct this, for example by including npupp.h in the sources ?
Comment 12 Andrey Vihrov 2009-10-27 12:31:15 UTC
(In reply to comment #11)

I second this, why is it RESOLVED/FIXED while the bug actually still exists?
Comment 13 Ryan May 2009-10-27 13:19:57 UTC
It's marked resolved/fixed because it *was* fixed and nobody has changed it (you need special permissions).  The new version of xulrunner is what has broken this again.
Comment 14 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-10-27 16:59:00 UTC
OK, we need a new rhythmbox stable.

@herd: 0.12.5 seems to be working well on my 2.26 stable system
Comment 15 Gilles Dartiguelongue gentoo-dev 2009-10-27 17:06:48 UTC
requires a new udev...
plus fixing of bug #287604 (easy)
Comment 16 Ryan May 2009-10-27 17:09:10 UTC
My own work around was to install rhythmbox-0.12.3-r2 (since I didn't want to install an unstable udev). That's working fine for me here (on a mostly stable amd64 system).
Comment 17 Derk W te Bokkel 2009-11-04 01:35:01 UTC
as part of stabilization please add a dependancy on libxml2 to rhythmbox-0.12.5-r2 et.al. as if libxml2 is not it installed the compile fails.
Comment 18 Gilles Dartiguelongue gentoo-dev 2009-11-08 20:16:02 UTC
(In reply to comment #17)
> as part of stabilization please add a dependancy on libxml2 to
> rhythmbox-0.12.5-r2 et.al. as if libxml2 is not it installed the compile fails.
> 

Except that it's not possible to build dependencies of rhythmbox without libxml2 (gconf, gnome-desktop, gnome-medias, ... depend on libxml2 already).
Comment 19 Christian Faulhammer (RETIRED) gentoo-dev 2009-11-09 11:37:11 UTC
(In reply to comment #18)
> (In reply to comment #17)
> > as part of stabilization please add a dependancy on libxml2 to
> > rhythmbox-0.12.5-r2 et.al. as if libxml2 is not it installed the compile fails.
> > 
> 
> Except that it's not possible to build dependencies of rhythmbox without
> libxml2 (gconf, gnome-desktop, gnome-medias, ... depend on libxml2 already).

 A direct dependency should be added nonetheless in my opinion.  For a discussion please mail me directly, to not pollute this bug.

Comment 20 Christian Faulhammer (RETIRED) gentoo-dev 2009-11-09 12:25:17 UTC
x86 stable
Comment 21 Brent Baude (RETIRED) gentoo-dev 2009-12-09 17:37:59 UTC
ppc64 done
Comment 22 Pacho Ramos gentoo-dev 2009-12-18 13:49:44 UTC
amd64 stable
Comment 23 Raúl Porcel (RETIRED) gentoo-dev 2009-12-30 13:12:21 UTC
sparc stable
Comment 24 nixnut (RETIRED) gentoo-dev 2010-01-05 18:37:22 UTC
ppc stable