Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 290072 - media-sound/rhythmbox-0.11.6-r1 fails with USE="nsplugin"
Summary: media-sound/rhythmbox-0.11.6-r1 fails with USE="nsplugin"
Status: RESOLVED DUPLICATE of bug 234938
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-21 22:16 UTC by Andrey Vihrov
Modified: 2009-10-22 20:00 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Vihrov 2009-10-21 22:16:23 UTC
This appeared after upgrading to xulrunner 1.9.1.

 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I.. -DXP_UNIX -DOJI -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/xulrunner-1.9.1.2/unstable -I/usr/include/nspr -O2 -march=native -msse4.1 -pipe -MT librhythmbox_itms_detection_plugin_la-rhythmbox-itms-plugin.lo -MD -MP -MF .deps/librhythmbox_itms_detection_plugin_la-rhythmbox-itms-plugin.Tpo -c rhythmbox-itms-plugin.cpp  -fPIC -DPIC -o .libs/librhythmbox_itms_detection_plugin_la-rhythmbox-itms-plugin.o
rhythmbox-itms-plugin.cpp:31:19: error: npupp.h: No such file or directory

Reproducible: Always

Steps to Reproduce:
1. USE="nsplugin" emerge =media-sound/rhythmbox-0.11.6-r1




Portage 2.1.6.13 (default/linux/amd64/10.0/desktop, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.30-gentoo-r5-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T8100_@_2.10GHz-with-gentoo-1.12.11.1
Timestamp of tree: Wed, 21 Oct 2009 19:45:01 +0000
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -msse4.1 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -msse4.1 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--ask --jobs=2 --load-average=3"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.tups.lv/source/"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="ru en lv"
MAKEOPTS="-j3 -l3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/armagetron /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa amd64 avahi bash-completion berkdb bluetooth bonjour branding bzip2 cairo cdr cli consolekit cracklib crypt cups dbus djvu dri dts dvd dvdr eds emboss encode evo exif fam ffmpeg firefox flac fortran gdbm gif gnome gnome-keyring gpm gstreamer gtk hal hddtemp iconv id3tag ieee1394 ipod isdnlog jpeg libnotify lm_sensors mad matroska mikmod mmx mmxext modules mp3 mp4 mpeg mudflap multilib nautilus ncurses networkmanager nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support quicktime readline reflection rtc samba sdl session smp spell spl sqlite sse sse2 sse3 sse4_1 ssl ssse3 startup-notification svg sysfs tcpd theora threads thunar tiff totem truetype unicode upnp usb v4l2 vim-syntax vorbis x264 xml xorg xulrunner xv xvid xvmc zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en lv" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 paolo muratore-ginanneschi 2009-10-22 14:17:52 UTC
(In reply to comment #0)
Hi,
just to notice that the issue is also discussed in

http://bugs.gentoo.org/show_bug.cgi?id=234938

It seems that npupp.h is missing in xulrunner 1.9.1.

so rhythmbox seems to compile only with
USE="-nsplugin"

Comment 2 Andrey Vihrov 2009-10-22 14:30:28 UTC
(In reply to comment #1)

Thanks, I missed it because bug 234938 is marked as fixed.
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-10-22 20:00:40 UTC

*** This bug has been marked as a duplicate of bug 234938 ***