Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 233354 - LDFLAGS used for Module-Build packages are LDFLAGS from dev-lang/perl
Summary: LDFLAGS used for Module-Build packages are LDFLAGS from dev-lang/perl
Status: RESOLVED DUPLICATE of bug 261375
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Eclasses (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Perl team
URL: http://tinderbox.x86.dev.gentoo.org/m...
Whiteboard:
Keywords:
: 250724 250726 250727 250730 250732 250734 332835 451104 (view as bug list)
Depends on: 264155 264186 308629
Blocks: perl-eclass ldflags
  Show dependency tree
 
Reported: 2008-07-30 07:36 UTC by Torsten Veller (RETIRED)
Modified: 2017-01-01 10:20 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
perl-module.eclass-LDFLAGS.patch (perl-module.eclass-LDFLAGS.patch,368 bytes, patch)
2008-09-10 18:31 UTC, Arfrever Frehtes Taifersar Arahesis (RETIRED)
Details | Diff
adding OTHERLDFLAGS during install phase (perl-module.eclass-LDFLAGS_make_install.patch,275 bytes, patch)
2010-05-24 14:48 UTC, Kacper Kowalik (Xarthisius) (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Torsten Veller (RETIRED) gentoo-dev 2008-07-30 07:36:05 UTC
What's the right way to pass LDFLAGS in perl-modules.eclass?
For ExtUtils::MakeMaker modules i started playing with OTHERLDFLAGS

| - make ${mymake}
| + make OTHERLDFLAGS="${LDFLAGS}" ${mymake}

Comments?
Comment 1 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2008-08-08 19:03:07 UTC
+1.
Comment 2 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2008-09-10 18:31:18 UTC
Created attachment 165151 [details, diff]
perl-module.eclass-LDFLAGS.patch

Patch based on Tove's suggestion.
Comment 3 Davide Pesavento gentoo-dev 2008-09-11 14:37:54 UTC
I'm getting the "QA Notice: Files built without respecting LDFLAGS have been detected" message from several perl modules.
Arfrever: is your patch supposed to fix these warnings?
Comment 4 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2008-09-11 14:51:48 UTC
(In reply to comment #3)
> I'm getting the "QA Notice: Files built without respecting LDFLAGS have been
> detected" message from several perl modules.
> Arfrever: is your patch supposed to fix these warnings?

This patch fixes these warnings only in a part of Perl modules.
Comment 5 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-11-18 17:22:16 UTC
tove: Think we can do this now, it is pretty trivial and will help with many packages.
Comment 6 Chris Slycord 2008-11-18 17:24:34 UTC
When this gets added can the packages affected be bumped so that they will actually get reinstalled (and thereby no longer be affected by the issue)?
Comment 7 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-12 19:20:56 UTC
*** Bug 250724 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-12 19:21:06 UTC
*** Bug 250726 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-12 19:21:11 UTC
*** Bug 250727 has been marked as a duplicate of this bug. ***
Comment 10 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-12 19:21:16 UTC
*** Bug 250730 has been marked as a duplicate of this bug. ***
Comment 11 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-12 19:21:21 UTC
*** Bug 250732 has been marked as a duplicate of this bug. ***
Comment 12 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-12 19:21:26 UTC
*** Bug 250734 has been marked as a duplicate of this bug. ***
Comment 13 Torsten Veller (RETIRED) gentoo-dev 2009-03-06 11:47:57 UTC
Fixed.
Comment 14 Torsten Veller (RETIRED) gentoo-dev 2009-03-29 17:39:07 UTC
--extra_linker_flags doesn't work for Module::Build distributions.
It replaces the settings in Build.PL.

So can we do now?
Comment 15 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2010-05-24 14:48:46 UTC
Created attachment 232721 [details, diff]
adding OTHERLDFLAGS during install phase

OTHERLDFLAGS should also be used in src_install. I've found at least one pkg that needs it:

emerge -1 =dev-perl/perl-tk-804.028-r3

 * QA Notice: Files built without respecting LDFLAGS have been detected
 *  Please include the following list of files in your report:
 * /usr/lib64/perl5/vendor_perl/5.10.1/x86_64-linux/auto/Tk/Tk.so
Comment 16 Torsten Veller (RETIRED) gentoo-dev 2010-05-24 17:08:08 UTC
(In reply to comment #15)
> OTHERLDFLAGS should also be used in src_install. I've found at least one pkg
> that needs it:
> 
> emerge -1 =dev-perl/perl-tk-804.028-r3

Try with MAKEOPTS=-j1. Looks like a parallel make issue.
Comment 17 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2010-05-24 17:23:18 UTC
(In reply to comment #16)
> Try with MAKEOPTS=-j1. Looks like a parallel make issue.
Parallel build issue it is... Sorry for the noise 

Comment 18 Torsten Veller (RETIRED) gentoo-dev 2010-08-15 11:51:32 UTC
*** Bug 332835 has been marked as a duplicate of this bug. ***
Comment 19 Jeroen Roovers gentoo-dev 2010-08-16 18:38:39 UTC
*** Bug 333049 has been marked as a duplicate of this bug. ***
Comment 20 Torsten Veller (RETIRED) gentoo-dev 2010-08-16 19:12:10 UTC
Only Module-Build packages [0] ignore LDFLAGS.
All others work (but they might not know it yet).

[0] http://tinderbox.x86.dev.gentoo.org/misc/dindex/virtual/perl-Module-Build
Comment 21 Torsten Veller (RETIRED) gentoo-dev 2010-09-21 14:44:04 UTC
Things changed:
dev-lang/perl-5.12.2-r1 respects LDFLAGS.

Furthermore it records and uses its ldflags, lddlflags (see perl -V) later on for building modules. It still doesn't use the LDFLAGS from env for Module-Build modules but the recorded perl LDFLAGS.

So it's the same as bug 236200.
Comment 22 Torsten Veller (RETIRED) gentoo-dev 2011-03-31 08:18:10 UTC
bug 308629:
app-pda/pilot-link uses OTHERLDFLAGS in Makefile.PL which are replaced by
setting OTHERLDFLAGS in perl-module.eclass.

So neither
OTHERLDFLAGS for ExtUtils::MakeMaker
nor
--extra_linker_flags for Module::Build
distributions works reliably.

We are still looking for a correct way to pass
LDFLAGS, CFLAGS (bug #261375, bug #236200 ) ,...
Comment 23 Torsten Veller (RETIRED) gentoo-dev 2013-01-10 04:13:58 UTC
*** Bug 451104 has been marked as a duplicate of this bug. ***
Comment 24 Andreas K. Hüttel gentoo-dev 2015-12-10 23:24:23 UTC
Upstream is working on it. Deferred for EAPI=7
Comment 25 Andreas K. Hüttel gentoo-dev 2017-01-01 10:20:00 UTC

*** This bug has been marked as a duplicate of bug 261375 ***