Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 236200 - dev-lang/perl and xs: bad CFLAGS and LDFLAGS handling
Summary: dev-lang/perl and xs: bad CFLAGS and LDFLAGS handling
Status: RESOLVED DUPLICATE of bug 261375
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
: 317477 451102 461808 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-08-30 11:42 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2014-06-21 15:49 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-08-30 11:42:52 UTC
I'm doing some experiments with CFLAGS, in particular I've assigned a unique flag to each package, to see if the flags used to build the package "creep in" into other packages (through means of *-config scripts and similar). It seems like this happens when XS is used with perl:

/usr/bin/perl5.8.8 /usr/lib/perl5/5.8.8/ExtUtils/xsubpp  -typemap /usr/lib/perl5/5.8.8/ExtUtils/typemap  gettext.xs > gettext.xsc && mv gettext.xsc gettext.c
Please specify prototyping behavior for gettext.xs (see perlxs manual)
i686-pc-linux-gnu-gcc -c   -fno-strict-aliasing -pipe -Wdeclaration-after-statement -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -pipe -include /var/tmp/portage/dev-lang/perl-5.8.8-r5/temp/flagscheck.h   -DVERSION=\"1.05\" -DXS_VERSION=\"1.05\" -fPIC "-I/usr/lib/perl5/5.8.8/i686-linux/CORE"   gettext.c
cc1: error: /var/tmp/portage/dev-lang/perl-5.8.8-r5/temp/flagscheck.h: No such file or directory

in this case "-pipe -include /var/tmp/portage/dev-lang/perl-5.8.8-r5/temp/flagscheck.h" are the CFLAGS used to build perl itself, and shouldn't be used to build gettext; on the other hand the CFLAGS assigned to gettext are not being respected.

This does not seem to be the correct approach in Gentoo, to me. Can someone who knows a bit of Perl check if there's anything doable to resolve this problem?

Thanks,
Diego
Comment 1 Matt Turner gentoo-dev 2009-11-19 18:17:02 UTC
Ping. This appears to still be a problem (Just noticed it myself.)
Comment 2 Panagiotis Christopoulos (RETIRED) gentoo-dev 2010-05-03 12:34:26 UTC
*** Bug 317477 has been marked as a duplicate of this bug. ***
Comment 3 Matt Turner gentoo-dev 2010-12-21 00:07:43 UTC
Can a Perl dev please take a look at this?
Comment 4 Torsten Veller (RETIRED) gentoo-dev 2013-01-10 04:15:18 UTC
*** Bug 451102 has been marked as a duplicate of this bug. ***
Comment 5 Torsten Veller (RETIRED) gentoo-dev 2013-03-17 09:31:24 UTC
*** Bug 461808 has been marked as a duplicate of this bug. ***
Comment 6 Andreas K. Hüttel gentoo-dev 2014-06-18 20:57:45 UTC
This is the same issue as discussed in bug 261375, I think. I'm closing this one since the other one contains more useful info by now.

(Unless OPTIMIZE is set, the perl buildsystems use the optimize variable from the perl install, which defaults to (some of) the flags used during dev-lang/perl build.)

*** This bug has been marked as a duplicate of bug 261375 ***