Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 231743 - gnome-extra/yelp requires firefox-2*
Summary: gnome-extra/yelp requires firefox-2*
Status: RESOLVED DUPLICATE of bug 204632
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-14 06:50 UTC by Roger
Modified: 2008-07-15 15:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roger 2008-07-14 06:50:19 UTC
gnome-extra/yelp requires firefox-2* even when firefox-3.0* is installed.

This seems to be caused by firefox-3.0* requiring xulrunner as a depend to be installed.  And, once xulrunner is installed, yelp's ebuild notices xulrunner is installed -- as such, then wants firefox-2.* installed/downgraded.


Reproducible: Always

Steps to Reproduce:
1. emerge -u firefox-3.0*
2. firefox-3.0* pulls in xulrunner, builds & installs
3. emerge -uDNpv world then calls the yelp ebuild, and recognizes it requires firefox-2*


Actual Results:  
Forces a downgrade to firefox-2*

Expected Results:  
We want firefox-3* don't we??
Comment 1 Roger 2008-07-14 06:57:43 UTC
BTW: From what I see, yelp is a Gnome depend.  A temporary solution might be to remove the Gnome Use Flag, uninstall Gnome and just stick with Xfce.


Another ebuild affected by this is:
/usr/portage/dev-util/devhelp/devhelp-0.19.1.ebuild

For now, I just simply hacked these two ebuild's depends.  I have no idea what xulrunner is.
Comment 2 Roger 2008-07-14 07:44:29 UTC
This looks like fun:

# fgrep /usr/portage/ -r -e "xulrunner? ( =www-client/mozilla-firefox-2" -e ^packages -e ^distfiles -e ^metadata |less
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-07-14 10:53:54 UTC

*** This bug has been marked as a duplicate of bug 204632 ***
Comment 4 Roger 2008-07-14 21:31:01 UTC
This is more of an issue with the ebuilds requiring firefox-2* to be installed when firefox-3* is installed.


Although Bug# 204632 is part of the issue.  I've been compiling just fine & dandy with xulrunner-1.9 for the past month.  Probably all the ebuilds from the output from the above fgrep need updated depends.  But right now, for me, it's just dev-help & yelp ebuild depends.

I won't bother reopening with my scribbles here, but it does look like a sincere issue affecting more then just these two ebuilds.
Comment 5 Rafał Mużyło 2008-07-14 22:17:42 UTC
AFAICT, the problem is simply that firefox-2 didn't depend on xulrunner, as it (xulrunner, that is) got into the tree relatively recently, while firefox-3 is built by default as xulrunner app, as it's preferred by upstream,
so all those problems, you described, are due to packaging change,
cause xulrunner provides all the libs, that all those programs actually depend on.
Comment 6 Roger 2008-07-15 15:40:03 UTC
Ok.  Thanks.  Just checking to make sure before moving on here.

Thanks for your time!