Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 204632 - >=gnome-extra/yelp-2.20.0 fails to compile with newest xulrunner
Summary: >=gnome-extra/yelp-2.20.0 fails to compile with newest xulrunner
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard:
Keywords:
: 213344 227987 231743 (view as bug list)
Depends on:
Blocks: xul-1.9
  Show dependency tree
 
Reported: 2008-01-06 17:51 UTC by Mark Loeser (RETIRED)
Modified: 2008-09-12 15:00 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch to build with xulrunner 1.9 (gecko-1.9.patch,18.67 KB, patch)
2008-06-22 16:02 UTC, Rafał Mużyło
Details | Diff
ebuild including the patch proposed by Rafal (yelp-2.22.1-r1.ebuild,2.01 KB, text/plain)
2008-06-22 16:29 UTC, drhopfen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Loeser (RETIRED) gentoo-dev 2008-01-06 17:51:59 UTC
The newer versions of xulrunner that will be with Firefox 3 redefined one of the functions that yelp uses.  There is a patch waiting to be accepted by upstream:  http://bugzilla.gnome.org/show_bug.cgi?id=499744  (http://bugzilla.gnome.org/attachment.cgi?id=99663&action=view)  I applied it locally and it works fine with the newest xulrunner snapshots.
Comment 1 Daniel Gryniewicz (RETIRED) gentoo-dev 2008-01-29 19:16:38 UTC
That bug says there's still changes in the works.  We'll wait for an updated patch.
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-04-10 22:50:11 UTC
*** Bug 213344 has been marked as a duplicate of this bug. ***
Comment 3 Mike Gilbert gentoo-dev 2008-06-09 00:37:13 UTC
Upstream has committed the latest version of their patch.  I tested on my system against 2.20.0 and it seems to work ok.
Comment 4 Arun Raghavan (RETIRED) gentoo-dev 2008-06-13 21:03:35 UTC
(In reply to comment #3)
> Upstream has committed the latest version of their patch.  I tested on my
> system against 2.20.0 and it seems to work ok.

2.22.1-r1 seems to compile and run fine with xulrunner-1.9. Good to close?
Comment 5 Mart Raudsepp gentoo-dev 2008-06-18 07:12:54 UTC
*** Bug 227987 has been marked as a duplicate of this bug. ***
Comment 6 Fabian Fingerle 2008-06-20 11:37:22 UTC
> 2.22.1-r1 seems to compile and run fine with xulrunner-1.9. Good to close?

from yelp-2.22.1-r1.ebuild:
 !xulrunner? ( =www-client/mozilla-firefox-2* )
 xulrunner? ( =net-libs/xulrunner-1.8* )

perhaps it runs fine with xulrunner-1.9 ....
mozilla-firefox-3.0 is out

ebuild has to be fixed ...
Comment 7 Rafał Mużyło 2008-06-22 15:57:50 UTC
I was trying to make yelp build with xulrunner 1.9
and though I think I succeeded (it did emerge and didn't crash at start),
I still have a few questions:
1. Is there any reason why that macro seems to prefer libxul-embedding to libxul ?
2. Why are the libs split between $sdkdir and $sdkdir/lib/sdk (some are duplicated there) ?
That's all I remember right now.
BTW, unless I'm missing something, it's a bit annoying that for 1.8 it should be set to xulrunner and for 1.9 - to libxul.
Comment 8 Rafał Mużyło 2008-06-22 16:02:05 UTC
Created attachment 158013 [details, diff]
patch to build with xulrunner 1.9

For future reference, the patch I used to build it.
I'm not sure if I accidentally broke it for 1.8 or not.
Comment 9 drhopfen 2008-06-22 16:27:00 UTC
The patch works fine for me with xulrunner-1.9. 
Comment 10 drhopfen 2008-06-22 16:29:29 UTC
Created attachment 158015 [details]
ebuild including the patch proposed by Rafal

I changed the ebuild to configure --with-gecko=libxul if the xulrunner USE flag is set.
Comment 11 Rafał Mużyło 2008-06-22 16:47:57 UTC
The real question is: does it still build with 1.8 ?
Comment 12 Gilles Dartiguelongue gentoo-dev 2008-07-14 10:53:54 UTC
*** Bug 231743 has been marked as a duplicate of this bug. ***
Comment 13 Roger 2008-07-14 21:56:15 UTC
I've been building firefox-3* against xulrunner-1.9 w/o issue.

However, Bug 231743 has been marked a duplicate of this bug concerning the depends with the Yelp ebuild?
Comment 14 Daniel Gryniewicz (RETIRED) gentoo-dev 2008-07-19 01:51:56 UTC
Similar to epiphany, I've committed yelp-2.22.1-r10 that uses xulrunner 1.9.