Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 230817 - dev-db/postgresql-{base,server,docs} stable request
Summary: dev-db/postgresql-{base,server,docs} stable request
Status: RESOLVED DUPLICATE of bug 285475
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 2 votes (vote)
Assignee: PgSQL Bugs
URL:
Whiteboard:
Keywords:
: 215949 (view as bug list)
Depends on:
Blocks: 255182
  Show dependency tree
 
Reported: 2008-07-05 05:34 UTC by Caleb Cushing
Modified: 2009-10-22 20:01 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Caleb Cushing 2008-07-05 05:34:12 UTC
unless bugs are pending please mark the following ebuilds stable (latest version) these ebuilds seem stable... (I know they are new) and the postgresql versions with the exception of 8.3.x have been out for years (and 8.3.3 seems stable enough to me). Since they are slotted they shouldn't cause problems with existing installs.

virtual/postgresql-base
virtual/postgresql-server
dev-db/postgresql-base
dev-db/postgresql-docs
dev-db/postgresql-server
        (7.3)   (~)7.3.21
        (7.4)   (~)7.4.21
        (8.0)   (~)8.0.17
        (8.1)   (~)8.1.13
        (8.2)   (~)8.2.9
        (8.3)   (~)8.3.3

Reproducible: Always
Comment 1 Tiziano Müller gentoo-dev 2008-07-05 16:34:05 UTC
Yes, I agree. They're ready to go stable.
Thing is: I'll be in holidays for 2 weeks so I'd really like to wait afterwards to be able to coordinate it.
Comment 2 Caleb Cushing 2008-07-05 17:37:34 UTC
no problem, I'm happy as long as things are going forward, so we can wait a couple more weeks.
Comment 3 Caleb Cushing 2008-08-11 00:15:44 UTC
bump.
Comment 4 aditsu 2008-08-31 16:36:10 UTC
Come on guys, at least postgresql 8.2 has been stable for years. It's a shame to be still "stuck" at 8.0. And I heard only good things about 8.3.
Comment 5 aditsu 2008-08-31 16:49:09 UTC
Also, guides and wikis need to be updated with information about "postgresql" vs "postgresql-server" etc.
Comment 6 Caleb Tennis (RETIRED) gentoo-dev 2008-09-23 11:49:46 UTC
any progress on this?
Comment 7 Caleb Tennis (RETIRED) gentoo-dev 2008-09-27 18:59:47 UTC
I plan to move forward with this unless someone from the pg team objects.
Comment 8 Tiziano Müller gentoo-dev 2008-09-27 19:36:55 UTC
please check out the other bugs and solve them first before going stable with postgresql-{server,docs,base} if you really want to help.
Comment 9 Caleb Tennis (RETIRED) gentoo-dev 2008-09-28 22:40:13 UTC
*** Bug 215949 has been marked as a duplicate of this bug. ***
Comment 10 svrmarty 2008-12-08 18:26:35 UTC
(In reply to comment #8)
> please check out the other bugs and solve them first before going stable with
> postgresql-{server,docs,base} if you really want to help.
> 


how about using the "depends" and "blocks" features to make it easier ?
Comment 11 Caleb Cushing 2009-01-08 12:32:47 UTC
which bugs specifically are holding this back?
Comment 12 Caleb Cushing 2009-01-17 20:16:16 UTC
I've fixed this in funtoo's tree, should I resolve wontfix here?
Comment 13 svrmarty 2009-01-25 18:38:32 UTC
(In reply to comment #11)
> which bugs specifically are holding this back?
> 


_NOTHING_ is blocking this, so just go on and mark 8.1 stable
Comment 14 Alexander Bezrukov 2009-03-17 11:30:52 UTC
1 year passed since =dev-db/postgresql-8.3.1 has been hard-masked:

# Caleb Tennis <caleb@gentoo.org> (26 Mar 2008)
# Masking per dev-zero request for more testing time

This is already not the day zero. Please remove at least the hard mask.

Thank you.
Comment 15 Alexander Bezrukov 2009-03-17 11:33:30 UTC
The same about =dev-db/libpq-8.3.1.
Comment 16 aditsu 2009-03-17 11:52:30 UTC
Alexander, AFAIK dev-db/postgresql and dev-db/libpq are being deprecated, and replaced by the ebuilds mentioned in this bug's title (dev-db/postgresql-server & co). Those are still masked (for unexplained reasons!!! Tiziano can you comment?) but not hard-masked.
Comment 17 Alexander Bezrukov 2009-03-17 12:13:14 UTC
Adrian, thank you for your input. I am a little confused since I see that virtual/postgresql-server-8.3 pulls dev-db/postgresql-8.3.1 which in turn pulls dev-db/libpq-8.3.1. If these packages are deprecated then the dependencies should be updated.

Can anybody comment on this?

Thanks.
Comment 18 aditsu 2009-03-17 12:35:09 UTC
Again, I'm no expert, but I think virtual/postgresql-server requires either dev-db/postgresql or dev-db/postgresql-server. That's the point of virtual packages, to allow different alternatives to satisfy the same dependency.
dev-db/postgresql is probably still kept for not breaking existing installations, but if you want to upgrade to 8.3 I recommend switching to dev-db/postgresql-server
Comment 19 Deniss Gaplevsky 2009-03-21 12:14:39 UTC
PostgreSQL 8.3.7 is out, please release new ebuild
Comment 20 Caleb Tennis (RETIRED) gentoo-dev 2009-04-09 22:43:16 UTC
8.3.7 is in portage.

Tiziano, any thoughts on stabilizing some of the newer versions?
Comment 21 Nathan 2009-04-21 16:40:24 UTC
Please see my comment 2 on bug #183764.  Comment reproduced below for the convenience of CC recipients...
________________________________

Please stabilize postgresql and libpq 8.1, 8.2, and 8.3.

PostgreSQL 8.1 was released in 2005.
PostgreSQL 8.2 was released in 2006.
PostgreSQL 8.3 was released in 2008.

All the above are still marked "unstable" on all architectures, though I've been using 8.1 and 8.2 through portage on over a dozen x86 and amd64 boxes in production roles (on Gentoo) for years with zero problems, and I'll be moving to 8.3 in production next month.

Additionally, psycopg-2.0.10 (which fixes several threading bugs that affect my organization) depends on >=dev-db/libpq-8.1 (see bug #242336).  As we use psycopg on ALL our Gentoo boxes to access our postgresql databases (remotely, on most of them), it currently requires customization of /etc/portage/package.keywords on all our machines, which seems really odd due to the age and stability of PostgreSQL 8.1.

Comment 22 aditsu 2009-04-27 05:28:04 UTC
I have used postgresql-server 8.3 for several months on several computers and had zero problems with it. The only complaint I have is that there are no ebuilds or flags for contrib modules (such as intarray).
It is ABSOLUTELY RIDICULOUS that the latest stable is still 8.0, and nobody even explained why that is the case.
Comment 23 Michele Beltrame 2009-07-06 13:38:32 UTC
I agree with this request.

I've been using these for ages (on amd64 and x86) and they work great.

It's really time to have 8.3 stable, not just 8.0.15. ;)
Comment 24 Patrick Lauer gentoo-dev 2009-10-22 20:01:52 UTC
Didn't notice this bug initially, all the action is happening in the new one

*** This bug has been marked as a duplicate of bug 285475 ***