Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 229267 - net-print/gnome-cups-manager-0.31-r2 with gcc-4.3.1
Summary: net-print/gnome-cups-manager-0.31-r2 with gcc-4.3.1
Status: RESOLVED DUPLICATE of bug 225501
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-06-24 18:21 UTC by Manfred Knick
Modified: 2008-06-24 19:09 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manfred Knick 2008-06-24 18:21:19 UTC
emerge : compile fails

Reproducible: Always

Steps to Reproduce:
1.emerge
2.
3.

Actual Results:  
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -Wall -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-sign-compare -DORBIT2=1 -pthread -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/cairo -I/usr/include/libpng12 -I/usr/include/pixman-1 -I/usr/include/libglade-2.0 -I/usr/include/libgnomecups-1 -I.. -I.. -DDATADIR=\"/usr/share\" -DGNOME_CUPS_MANAGER_DATADIR=\"/usr/share/gnome-cups-manager\" -DGNOMELOCALEDIR=\"/usr/share/locale\" -march=k8 -O0 -pipe -MT gnome-cups-i18n.lo -MD -MP -MF .deps/gnome-cups-i18n.Tpo -c gnome-cups-i18n.c -o gnome-cups-i18n.o >/dev/null 2>&1
if /bin/sh ../libtool --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -Wall -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-sign-compare  -DORBIT2=1 -pthread -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/cairo -I/usr/include/libpng12 -I/usr/include/pixman-1 -I/usr/include/libglade-2.0 -I/usr/include/libgnomecups-1   -I.. -I.. -DDATADIR=\""/usr/share"\" -DGNOME_CUPS_MANAGER_DATADIR=\""/usr/share/gnome-cups-manager"\" -DGNOMELOCALEDIR=\""/usr/share/locale"\"    -march=k8 -O0 -pipe -MT gnome-cups-ui-util.lo -MD -MP -MF ".deps/gnome-cups-ui-util.Tpo" \
          -c -o gnome-cups-ui-util.lo `test -f 'gnome-cups-ui-util.c' || echo './'`gnome-cups-ui-util.c; \
        then mv -f ".deps/gnome-cups-ui-util.Tpo" ".deps/gnome-cups-ui-util.Plo"; \
        else rm -f ".deps/gnome-cups-ui-util.Tpo"; exit 1; \
        fi
snmpinter.C: In function 'void* do_req(SNMP_session*)':
snmpinter.C:161: error: 'realloc' was not declared in this scope
make[3]: *** [snmpinter.lo] Fehler 1
make[3]: *** Warte auf noch nicht beendete Prozesse...
 x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -Wall -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-sign-compare -DORBIT2=1 -pthread -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/cairo -I/usr/include/libpng12 -I/usr/include/pixman-1 -I/usr/include/libglade-2.0 -I/usr/include/libgnomecups-1 -I.. -I.. -DDATADIR=\"/usr/share\" -DGNOME_CUPS_MANAGER_DATADIR=\"/usr/share/gnome-cups-manager\" -DGNOMELOCALEDIR=\"/usr/share/locale\" -march=k8 -O0 -pipe -MT gnome-cups-ui-util.lo -MD -MP -MF .deps/gnome-cups-ui-util.Tpo -c gnome-cups-ui-util.c  -fPIC -DPIC -o .libs/gnome-cups-ui-util.o
 x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -Wall -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-sign-compare -DORBIT2=1 -pthread -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/cairo -I/usr/include/libpng12 -I/usr/include/pixman-1 -I/usr/include/libglade-2.0 -I/usr/include/libgnomecups-1 -I.. -I.. -DDATADIR=\"/usr/share\" -DGNOME_CUPS_MANAGER_DATADIR=\"/usr/share/gnome-cups-manager\" -DGNOMELOCALEDIR=\"/usr/share/locale\" -march=k8 -O0 -pipe -MT gnome-cups-ui-init.lo -MD -MP -MF .deps/gnome-cups-ui-init.Tpo -c gnome-cups-ui-init.c -o gnome-cups-ui-init.o >/dev/null 2>&1
 x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -Wall -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-sign-compare -DORBIT2=1 -pthread -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/cairo -I/usr/include/libpng12 -I/usr/include/pixman-1 -I/usr/include/libglade-2.0 -I/usr/include/libgnomecups-1 -I.. -I.. -DDATADIR=\"/usr/share\" -DGNOME_CUPS_MANAGER_DATADIR=\"/usr/share/gnome-cups-manager\" -DGNOMELOCALEDIR=\"/usr/share/locale\" -march=k8 -O0 -pipe -MT gnome-cups-ui-util.lo -MD -MP -MF .deps/gnome-cups-ui-util.Tpo -c gnome-cups-ui-util.c -o gnome-cups-ui-util.o >/dev/null 2>&1
make[3]: Leaving directory `/Storage-B/Portage_tmp/portage/net-print/gnome-cups-manager-0.31-r2/work/gnome-cups-manager-0.31/libgnomecups'
make[2]: *** [all-recursive] Fehler 1
make[2]: Leaving directory `/Storage-B/Portage_tmp/portage/net-print/gnome-cups-manager-0.31-r2/work/gnome-cups-manager-0.31/libgnomecups'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/Storage-B/Portage_tmp/portage/net-print/gnome-cups-manager-0.31-r2/work/gnome-cups-manager-0.31'
make: *** [all] Fehler 2
 *
 * ERROR: net-print/gnome-cups-manager-0.31-r2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2941:  Called gnome2_src_compile
 *             environment, line 2170:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure



# emerge --info
 Portage 2.1.4.4 (default-linux/amd64/2007.0/desktop, gcc-4.3.1, glibc-2.7-r2,
2.6.25-gentoo-r5 x86_64)
 =================================================================
 System uname: 2.6.25-gentoo-r5 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor
5200+
 Timestamp of tree: Mon, 23 Jun 2008 22:45:01 +0000
 ccache version 2.4 [disabled]
 app-shells/bash:     3.2_p33
 dev-java/java-config: 1.3.7, 2.1.6
 dev-lang/python:     2.4.4-r13
 dev-python/pycrypto: 2.0.1-r6
 dev-util/ccache:     2.4-r7
 sys-apps/baselayout: 1.12.11.1
 sys-apps/sandbox:    1.2.18.1-r2
 sys-devel/autoconf:  2.13, 2.61-r2
 sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
 sys-devel/binutils:  2.18-r1
 sys-devel/gcc-config: 1.4.0-r4
 sys-devel/libtool:   1.5.26
 virtual/os-headers:  2.6.25-r4
 ACCEPT_KEYWORDS="amd64"
 CBUILD="x86_64-pc-linux-gnu"
 CFLAGS="-march=k8 -O2 -pipe "
 CHOST="x86_64-pc-linux-gnu"
 CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config
/usr/kde/3.5/shutdown /usr/lib/fax /usr/share/config /var/bind /var/lib/hsqldb
/var/spool/fax/etc"
 CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf
/etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/
/etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo
/etc/texmf/web2c /etc/udev/rules.d"
 CXXFLAGS="-march=k8 -O2 -pipe "
 DISTDIR="/usr/portage/distfiles"
 FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict
unmerge-orphans userfetch"
 GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ "
 LANG="de_DE.UTF8"
 LC_ALL="de_DE.UTF8"
 LINGUAS="de"
 MAKEOPTS="-j3"
 PKGDIR="/usr/portage/packages"
 PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times
--compress --force --whole-file --delete --stats --timeout=180
--exclude=/distfiles --exclude=/local --exclude=/packages"
 PORTAGE_TMPDIR="/Storage-B/Portage_tmp"
 PORTDIR="/usr/portage"
 PORTDIR_OVERLAY="/usr/portage/local/local-overlay"
 SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
 USE="X acl acpi alsa amd64 apache2 arts avahi bash-completion berkdb cairo cdr
cli cracklib crypt cups dbus doc dri dvb dvd dvdr dvdread eds emboss encode esd
evo examples fam fax firefox foomaticdb fortran gdbm gif gimp gimpprint gnome
gphoto2 gpm gstreamer gtk hal hbci hvm iconv ioemu ipv6 isdnlog java jce jpeg
kbanking kde kerberos kvm ldap libvirt libwww lirc mad maildir mailwrapper mbox
midi mikmod mmx mp3 mpeg mudflap mysql ncurses nls nptl nptlonly nsplugin ogg
opengl openmp oss pam pcre pdf perl php png ppds pppd python qt qt3 qt3support
qt4 quicktime readline reflection samba scanner screen sdl server session snmp
spell spl sse sse2 ssl svg tcpd tiff truetype unicode usb utempter v4l v4l2
vim-syntax vorbis xml xorg xv zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp
atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801
hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem
ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug
file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate
route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest
authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default
authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs
dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter
headers ident imagemap include info log_config logio mem_cache mime mime_magic
negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite
setenvif so speling status unique_id userdir usertrack vhost_alias"
ELIBC="glibc" FRITZCAPI_CARDS="fcpci" INPUT_DEVICES="keyboard mouse"
KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001
mtxorb ncurses text" LINGUAS="de" MISDN_CARDS="avmfritz" USERLAND="GNU"
VIDEO_CARDS="nv nvidia"
 Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS,
PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Samuli Suominen gentoo-dev 2008-06-24 18:51:44 UTC
0.31-r2 should be fixed, if your portage tree is up to date. anyway, if you plan to use a unstable compiler, try out the latest revisions too before filing bugs.

*gnome-cups-manager-0.33 (10 Jun 2008)

  10 Jun 2008; Daniel Gryniewicz <dang@gentoo.org>
  +gnome-cups-manager-0.33.ebuild:
  Bump to 0.33. Bug #218085 Thanks Peter

  09 Jun 2008; Diego Pettenò <flameeyes@gentoo.org>
  +files/gnome-cups-manager-0.31+gcc-4.3.patch,
  gnome-cups-manager-0.31-r2.ebuild:
  Add patch from upstream to build with GCC 4.3. Thanks to Jose daLuz for
  reporting and Arun Raghavan for providing the patches. Closes s bug
  #225501.


*** This bug has been marked as a duplicate of bug 225501 ***
Comment 2 Manfred Knick 2008-06-24 19:09:01 UTC
(In reply to comment #1)

I'm sorry - I must have missed some latest updates.

I can confirm successful build 
together with =net-print/libgnomecups-0.2.3.