Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 225501 - net-print/gnome-cups-manager-0.31-r2 /w gcc-4.3 : error: iostream.h: No such file or directory
Summary: net-print/gnome-cups-manager-0.31-r2 /w gcc-4.3 : error: iostream.h: No such ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 229267 (view as bug list)
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-06-09 01:59 UTC by Jose daLuz
Modified: 2008-06-24 18:51 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jose daLuz 2008-06-09 01:59:26 UTC
Rebuilding gnome-cups-manager 0.31-r2 after updating glibc from 2.7-r2 to 2.8_p20080602, I get the following error:

 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../.. -march=k8 -O0 -pipe -ggdb -msse3 -MT structfill.lo -MD -MP -MF .deps/structfill.Tpo -c structfill.C  -fPIC -DPIC -o .libs/structfill.o
 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../.. -march=k8 -O0 -pipe -ggdb -msse3 -MT snmpsock.lo -MD -MP -MF .deps/snmpsock.Tpo -c snmpsock.C  -fPIC -DPIC -o .libs/snmpsock.o
structfill.C:31:22: error: iostream.h: No such file or directory
 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../.. -march=k8 -O0 -pipe -ggdb -msse3 -MT snmpsock.lo -MD -MP -MF .deps/snmpsock.Tpo -c snmpsock.C -o snmpsock.o >/dev/null 2>&1
structfill.C: In member function 'int SNMP_structFiller::fillStruct(OidSeq*, void*)':
structfill.C:94: error: 'cerr' was not declared in this scope
structfill.C:98: error: 'cerr' was not declared in this scope
structfill.C:101: error: 'ios' has not been declared
structfill.C:101: error: expected `;' before 'opts'
structfill.C:102: error: 'opts' was not declared in this scope
structfill.C:102: error: 'cerr' was not declared in this scope
structfill.C: In member function 'void* SNMP_structFiller::get(void*)':
structfill.C:180: error: 'cerr' was not declared in this scope
make[3]: *** [structfill.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../.. -march=k8 -O0 -pipe -ggdb -msse3 -MT session.lo -MD -MP -MF .deps/session.Tpo -c session.C  -fPIC -DPIC -o .libs/session.o
 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../.. -march=k8 -O0 -pipe -ggdb -msse3 -MT snmpkit_interface.lo -MD -MP -MF .deps/snmpkit_interface.Tpo -c snmpkit_interface.C  -fPIC -DPIC -o .libs/snmpkit_interface.o
 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../.. -march=k8 -O0 -pipe -ggdb -msse3 -MT session.lo -MD -MP -MF .deps/session.Tpo -c session.C -o session.o >/dev/null 2>&1
snmpkit_interface.C: In function 'void* sk_sfiller_get(SNMPSTRUCTFILLER*, void*)':
snmpkit_interface.C:301: error: 'strdup' was not declared in this scope
snmpkit_interface.C: In function 'void* sk_sfiller_get_next(SNMPSTRUCTFILLER*, void*)':
snmpkit_interface.C:348: error: 'strdup' was not declared in this scope
make[3]: *** [snmpkit_interface.lo] Error 1
make[3]: Leaving directory `/var/tmp/paludis/net-print-gnome-cups-manager-0.31-r2/work/gnome-cups-manager-0.31/libgnomecups/snmpkit'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/paludis/net-print-gnome-cups-manager-0.31-r2/work/gnome-cups-manager-0.31/libgnomecups'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/paludis/net-print-gnome-cups-manager-0.31-r2/work/gnome-cups-manager-0.31'
make: *** [all] Error 2

!!! ERROR in net-print/gnome-cups-manager-0.31-r2:

Portage 2.1.5.4 (default-linux/amd64/2007.0/desktop, gcc-4.3.0, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r4 x86_64)
=================================================================
System uname: 2.6.25-gentoo-r4 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 6000+
Timestamp of tree: Sun, 08 Jun 2008 01:35:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r3
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe -ggdb -msse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe -ggdb -msse3"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch sandbox sfperms splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS=""
LINGUAS="en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays/paludis-extras /usr/local/overlays/sunrise /usr/local/overlays/gnome /usr/local/overlays/mainline /usr/local/overlays/desktop-effects /usr/local/overlays/vmware /usr/local/overlays/berkano /usr/local/overlays/myoverlay"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 amr bash-completion berkdb bluetooth bzip2 cairo cdda cdr cli cracklib crypt css cups dbus dri dts dvd dvdr dvdread eds emboss encode esd evo fam ffmpeg flac fortran gdbm gif glitz gnome gpm gstreamer gtk hal iconv ipv6 isdnlog java jpeg kde kdehiddenvisibility kerberos ldap libnotify mad midi mikmod mmx mono mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl pic png pppd python qt3support qt4 quicktime readline reflection ruby samba sdl session spell spl sqlite sse sse2 ssl svg tcpd theora tiff truetype unicode usb userlocales vcd vorbis x264 xml xorg xulrunner xv xvid zlib" ALSA_CARDS="cmipci hdaintel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 SpanKY gentoo-dev 2008-06-09 08:15:28 UTC
there is no such iostream.h header
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-06-09 12:58:58 UTC
C++ standard library is part of gcc, not glibc. Wrong package.
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-06-09 13:05:26 UTC
Committed, thanks for reporting and for the patch urls.
Comment 5 Jose daLuz 2008-06-10 11:55:44 UTC
Thanks, but even with the patch I am now getting this error:

 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I.. -Wall -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-sign-compare -DORBIT2=1 -pthread -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/cairo -I/usr/include/libpng12 -I/usr/include/pixman-1 -I/usr/include/libglade-2.0 -I/usr/include/libgnomecups-1 -I.. -I.. -DDATADIR=\"/usr/share\" -DGNOME_CUPS_MANAGER_DATADIR=\"/usr/share/gnome-cups-manager\" -DGNOMELOCALEDIR=\"/usr/share/locale\" -march=k8 -O0 -pipe -ggdb -msse3 -MT snmpinter.lo -MD -MP -MF .deps/snmpinter.Tpo -c snmpinter.C  -fPIC -DPIC -o .libs/snmpinter.o
 x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -Wall -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-sign-compare -DORBIT2=1 -pthread -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/cairo -I/usr/include/libpng12 -I/usr/include/pixman-1 -I/usr/include/libglade-2.0 -I/usr/include/libgnomecups-1 -I.. -I.. -DDATADIR=\"/usr/share\" -DGNOME_CUPS_MANAGER_DATADIR=\"/usr/share/gnome-cups-manager\" -DGNOMELOCALEDIR=\"/usr/share/locale\" -march=k8 -O0 -pipe -ggdb -msse3 -MT gnome-cups-i18n.lo -MD -MP -MF .deps/gnome-cups-i18n.Tpo -c gnome-cups-i18n.c -o gnome-cups-i18n.o >/dev/null 2>&1
if /bin/sh ../libtool --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -Wall -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-sign-compare  -DORBIT2=1 -pthread -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/cairo -I/usr/include/libpng12 -I/usr/include/pixman-1 -I/usr/include/libglade-2.0 -I/usr/include/libgnomecups-1   -I.. -I.. -DDATADIR=\""/usr/share"\" -DGNOME_CUPS_MANAGER_DATADIR=\""/usr/share/gnome-cups-manager"\" -DGNOMELOCALEDIR=\""/usr/share/locale"\"    -march=k8 -O0 -pipe -ggdb -msse3 -MT gnome-cups-ui-print.lo -MD -MP -MF ".deps/gnome-cups-ui-print.Tpo" \
	  -c -o gnome-cups-ui-print.lo `test -f 'gnome-cups-ui-print.c' || echo './'`gnome-cups-ui-print.c; \
	then mv -f ".deps/gnome-cups-ui-print.Tpo" ".deps/gnome-cups-ui-print.Plo"; \
	else rm -f ".deps/gnome-cups-ui-print.Tpo"; exit 1; \
	fi
cc1plus: warning: command line option "-Wmissing-prototypes" is valid for Ada/C/ObjC but not for C++
cc1plus: warning: command line option "-Wnested-externs" is valid for C/ObjC but not for C++
snmpinter.C: In function 'void* do_req(SNMP_session*)':
snmpinter.C:161: error: 'realloc' was not declared in this scope
make[3]: *** [snmpinter.lo] Error 1
make[3]: *** Waiting for unfinished jobs....

The patch is applying:

 * Applying ui_tooltip.diff ...                                          [ ok ]
 * Applying gnome-cups-manager-0.31+gcc-4.3.patch ...                    [ ok ]
>>> Done src_unpack

Is the realloc error also related to gcc 4.3? Your blog posting on the subject would seem to indicate that.
Comment 6 Jose daLuz 2008-06-10 23:13:09 UTC
0.33 just hit the tree -- it builds with no problems.
Comment 7 Mart Raudsepp gentoo-dev 2008-06-20 13:49:12 UTC
Closing as fixed then. The blocker tracker bug maintainers will probably notify us when we need to get gnome-cups-manager-0.33 stable before gcc-4.3 goes
Comment 8 Samuli Suominen gentoo-dev 2008-06-24 18:51:44 UTC
*** Bug 229267 has been marked as a duplicate of this bug. ***