Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 229263 - net-misc/hylafax-4.3.1 with gcc-4.3.1
Summary: net-misc/hylafax-4.3.1 with gcc-4.3.1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Steve Arnold (nerdboy) (OBSOLETE)
URL:
Whiteboard:
Keywords:
: 231070 (view as bug list)
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-06-24 18:17 UTC by Manfred Knick
Modified: 2008-07-08 07:41 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manfred Knick 2008-06-24 18:17:08 UTC
emerge : configure fails

Reproducible: Always

Steps to Reproduce:
1.emerge
2.
3.

Actual Results:  

Missing C++ runtime support for g++ (/usr/bin/g++).

Compilation of the following test program failed:

----------------------------------------------------------
#include "iostream.h"
int main(){ cout << "Hello World!" << endl; return 0;}
----------------------------------------------------------



# emerge --info
 Portage 2.1.4.4 (default-linux/amd64/2007.0/desktop, gcc-4.3.1, glibc-2.7-r2,
2.6.25-gentoo-r5 x86_64)
 =================================================================
 System uname: 2.6.25-gentoo-r5 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor
5200+
 Timestamp of tree: Mon, 23 Jun 2008 22:45:01 +0000
 ccache version 2.4 [disabled]
 app-shells/bash:     3.2_p33
 dev-java/java-config: 1.3.7, 2.1.6
 dev-lang/python:     2.4.4-r13
 dev-python/pycrypto: 2.0.1-r6
 dev-util/ccache:     2.4-r7
 sys-apps/baselayout: 1.12.11.1
 sys-apps/sandbox:    1.2.18.1-r2
 sys-devel/autoconf:  2.13, 2.61-r2
 sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
 sys-devel/binutils:  2.18-r1
 sys-devel/gcc-config: 1.4.0-r4
 sys-devel/libtool:   1.5.26
 virtual/os-headers:  2.6.25-r4
 ACCEPT_KEYWORDS="amd64"
 CBUILD="x86_64-pc-linux-gnu"
 CFLAGS="-march=k8 -O2 -pipe "
 CHOST="x86_64-pc-linux-gnu"
 CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config
/usr/kde/3.5/shutdown /usr/lib/fax /usr/share/config /var/bind /var/lib/hsqldb
/var/spool/fax/etc"
 CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf
/etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/
/etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo
/etc/texmf/web2c /etc/udev/rules.d"
 CXXFLAGS="-march=k8 -O2 -pipe "
 DISTDIR="/usr/portage/distfiles"
 FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict
unmerge-orphans userfetch"
 GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ "
 LANG="de_DE.UTF8"
 LC_ALL="de_DE.UTF8"
 LINGUAS="de"
 MAKEOPTS="-j3"
 PKGDIR="/usr/portage/packages"
 PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times
--compress --force --whole-file --delete --stats --timeout=180
--exclude=/distfiles --exclude=/local --exclude=/packages"
 PORTAGE_TMPDIR="/Storage-B/Portage_tmp"
 PORTDIR="/usr/portage"
 PORTDIR_OVERLAY="/usr/portage/local/local-overlay"
 SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
 USE="X acl acpi alsa amd64 apache2 arts avahi bash-completion berkdb cairo cdr
cli cracklib crypt cups dbus doc dri dvb dvd dvdr dvdread eds emboss encode esd
evo examples fam fax firefox foomaticdb fortran gdbm gif gimp gimpprint gnome
gphoto2 gpm gstreamer gtk hal hbci hvm iconv ioemu ipv6 isdnlog java jce jpeg
kbanking kde kerberos kvm ldap libvirt libwww lirc mad maildir mailwrapper mbox
midi mikmod mmx mp3 mpeg mudflap mysql ncurses nls nptl nptlonly nsplugin ogg
opengl openmp oss pam pcre pdf perl php png ppds pppd python qt qt3 qt3support
qt4 quicktime readline reflection samba scanner screen sdl server session snmp
spell spl sse sse2 ssl svg tcpd tiff truetype unicode usb utempter v4l v4l2
vim-syntax vorbis xml xorg xv zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp
atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801
hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem
ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug
file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate
route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest
authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default
authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs
dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter
headers ident imagemap include info log_config logio mem_cache mime mime_magic
negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite
setenvif so speling status unique_id userdir usertrack vhost_alias"
ELIBC="glibc" FRITZCAPI_CARDS="fcpci" INPUT_DEVICES="keyboard mouse"
KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001
mtxorb ncurses text" LINGUAS="de" MISDN_CARDS="avmfritz" USERLAND="GNU"
VIDEO_CARDS="nv nvidia"
 Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS,
PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-06-24 20:03:00 UTC
Please post a build log.
Comment 2 Manfred Knick 2008-06-24 20:13:52 UTC
(In reply to comment #1)
> Please post a build log.
> 

That _IS_ part of the build log:
- as stated, during configure phase -

- snip -

Actual Results:  

Missing C++ runtime support for g++ (/usr/bin/g++).

Compilation of the following test program failed:

----------------------------------------------------------
#include "iostream.h"
int main(){ cout << "Hello World!" << endl; return 0;}
----------------------------------------------------------

Comment 3 Manfred Knick 2008-06-24 20:16:25 UTC
(In reply to comment #1)

More complete quote:

- snip -

Configuring HylaFAX (tm) (aka FlexFAX) 4.3.0.

If configure does the wrong thing, check the file config.log for
information that may help you understand what went wrong.

Reading site-wide parameters from ./config.site.
Hmm, looks like a x86_64-unknown-linux-gnu system.
Using /usr/bin/gcc for a C compiler (set CC to override).
Looks like /usr/bin/gcc supports the -g option.
... but not together with the -O option, not using it.
Looks like /usr/bin/gcc has an ANSI C preprocessor.
... but __ANSI_CPP__ is not automatically defined, will compensate.
Looks like /usr/bin/gcc supports the -M option for generating make dependencies.
Using /usr/bin/g++ for a C++ compiler (set CXX to override).
Looks like /usr/bin/g++ supports the -g option.
Using " -g" for C++ compiler options.
Looks like /usr/bin/g++ has an ANSI C preprocessor.
... but __ANSI_CPP__ is not automatically defined, will compensate.
Using /usr/bin/make to configure the software.
Using "include file" syntax for Makefiles.
Looks like make supports "sinclude" for conditional includes.
Using /bin/bash to process command scripts.

Missing C++ runtime support for g++ (/usr/bin/g++).

Compilation of the following test program failed:

----------------------------------------------------------
#include "iostream.h"
int main(){ cout << "Hello World!" << endl; return 0;}
----------------------------------------------------------

Usually this is because you do not have a standard C++ library
installed on your system or you have installed it in a non-standard
location.  If you do not have a C++ library installed, then you must
install it.  If it is installed in a non-standard location, then you
should configure the compiler so that it will automatically be found.

(For recent gcc releases this is libstdc++, for older gcc - libg++)

Unrecoverable error!  Once you've corrected the problem rerun this script.
 *
 * ERROR: net-misc/hylafax-4.3.0 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2596:  Called die
 * The specific snippet of code:
 *       eval ./configure --nointeractive ${my_conf} || die "./configure failed";
 *  The die message:
 *   ./configure failed
Comment 4 steveb 2008-06-30 15:25:30 UTC
Having the exact same issue with Hylafax 4.3.0 with GCC 4.3.1:
gentoo ~ # cat /var/tmp/portage/net-misc/hylafax-4.3.0/temp/build.log
>>> Unpacking source...
>>> Unpacking hylafax-4.3.0.tar.gz to /var/tmp/portage/net-misc/hylafax-4.3.0/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/net-misc/hylafax-4.3.0/work/hylafax-4.3.0 ...
 * Applying gentoo-gcc-version.patch ...                                                      [ ok ]

Configuring HylaFAX (tm) (aka FlexFAX) 4.3.0.

If configure does the wrong thing, check the file config.log for
information that may help you understand what went wrong.

Reading site-wide parameters from ./config.site.
YOW!!  Did something bad happen or am I on a i686-pc-linux-gnu system?
Using /usr/bin/gcc for a C compiler (set CC to override).
Looks like /usr/bin/gcc supports the -g option.
... but not together with the -O option, not using it.
Looks like /usr/bin/gcc has an ANSI C preprocessor.
... but __ANSI_CPP__ is not automatically defined, will compensate.
Looks like /usr/bin/gcc supports the -M option for generating make dependencies.
Using /usr/bin/g++ for a C++ compiler (set CXX to override).
Looks like /usr/bin/g++ supports the -g option.
Using " -g" for C++ compiler options.
Looks like /usr/bin/g++ has an ANSI C preprocessor.
... but __ANSI_CPP__ is not automatically defined, will compensate.
Using /usr/bin/make to configure the software.
Using "include file" syntax for Makefiles.
Looks like make supports "sinclude" for conditional includes.
Using /bin/bash to process command scripts.

Missing C++ runtime support for g++ (/usr/bin/g++).

Compilation of the following test program failed:

----------------------------------------------------------
#include "iostream.h"
int main(){ cout << "Hello World!" << endl; return 0;}
----------------------------------------------------------

Usually this is because you do not have a standard C++ library
installed on your system or you have installed it in a non-standard
location.  If you do not have a C++ library installed, then you must
install it.  If it is installed in a non-standard location, then you
should configure the compiler so that it will automatically be found.

(For recent gcc releases this is libstdc++, for older gcc - libg++)

Unrecoverable error!  Once you've corrected the problem rerun this script.
 *
 * ERROR: net-misc/hylafax-4.3.0 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2533:  Called die
 * The specific snippet of code:
 *       eval ./configure --nointeractive ${my_conf} || die "./configure failed";
 *  The die message:
 *   ./configure failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-misc/hylafax-4.3.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-misc/hylafax-4.3.0/temp/environment'.
 *
gentoo ~ #




Trying Hylafax 4.3.1 is even worse:
gentoo ~ # emerge hylafax

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] net-misc/hylafax-4.3.1 [4.3.0] USE="faxonly pam -html -jbig -mgetty" 0 kB

Total: 1 package (1 upgrade), Size of downloads: 0 kB

>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) net-misc/hylafax-4.3.1 to /
 * hylafax-4.3.1.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                       [ ok ]
 * checking ebuild checksums ;-) ...                                                          [ ok ]
 * checking auxfile checksums ;-) ...                                                         [ ok ]
 * checking miscfile checksums ;-) ...                                                        [ ok ]
 * checking hylafax-4.3.1.tar.gz ;-) ...                                                      [ ok ]
 *
 * ERROR: net-misc/hylafax-4.3.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called pkg_setup
 *    hylafax-4.3.1.ebuild, line   40:  Called built_with_use 'pkg_setup' 'pkg_setup' 'pkg_setup' '--missing'
 *           eutils.eclass, line 1698:  Called die
 * The specific snippet of code:
 *    [[ -z ${PKG} ]] && die "Unable to resolve $1 to an installed package"
 *  The die message:
 *   Unable to resolve net-dialup/mgetty to an installed package
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-misc/hylafax-4.3.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-misc/hylafax-4.3.1/temp/die.env'.
 *

 * Messages for package net-misc/hylafax-4.3.1:

 *
 * ERROR: net-misc/hylafax-4.3.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called pkg_setup
 *    hylafax-4.3.1.ebuild, line   40:  Called built_with_use 'pkg_setup' 'pkg_setup' 'pkg_setup' '--missing'
 *           eutils.eclass, line 1698:  Called die
 * The specific snippet of code:
 *     [[ -z ${PKG} ]] && die "Unable to resolve $1 to an installed package"
 *  The die message:
 *   Unable to resolve net-dialup/mgetty to an installed package
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-misc/hylafax-4.3.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-misc/hylafax-4.3.1/temp/die.env'.
 *
gentoo ~ # cat /var/tmp/portage/net-misc/hylafax-4.3.1/temp/build.log
 *
 * ERROR: net-misc/hylafax-4.3.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called pkg_setup
 *    hylafax-4.3.1.ebuild, line   40:  Called built_with_use 'pkg_setup' 'pkg_setup' 'pkg_setup' '--missing'
 *           eutils.eclass, line 1698:  Called die
 * The specific snippet of code:
 *    [[ -z ${PKG} ]] && die "Unable to resolve $1 to an installed package"
 *  The die message:
 *   Unable to resolve net-dialup/mgetty to an installed package
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-misc/hylafax-4.3.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-misc/hylafax-4.3.1/temp/die.env'.
 *
gentoo ~ #
Comment 5 Peter Alfredsen (RETIRED) gentoo-dev 2008-07-07 16:31:39 UTC
*** Bug 231070 has been marked as a duplicate of this bug. ***
Comment 6 Steve Arnold gentoo-dev 2008-07-08 07:05:08 UTC
This is fixed in the latest versions; if it tests okay we can add it to stable (although it looks like it's time for a new stable version).  Reopen if it doesn't fix your problem.
Comment 7 Manfred Knick 2008-07-08 07:41:13 UTC
(In reply to comment #6)

I can confirm successful emerge of 4.3.7 here.

Thanks a lot !!

Kind regards
Manfred