Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 227775 - media-libs/libmatroska / gcc-4.3.1 - error: macro "min" passed 3 arguments, but takes just 2
Summary: media-libs/libmatroska / gcc-4.3.1 - error: macro "min" passed 3 arguments, b...
Status: RESOLVED DUPLICATE of bug 213187
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: PPC64 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-17 09:37 UTC by Andrew John Hughes
Modified: 2008-06-17 15:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (build.log,25.69 KB, text/plain)
2008-06-17 09:37 UTC, Andrew John Hughes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew John Hughes 2008-06-17 09:37:18 UTC
Build log attached.

Reproducible: Always




Portage 2.1.4.4 (default-linux/ppc/ppc64/2007.0/64bit-userland/970/pmac, gcc-4.3.1, glibc-2.7-r2, 2.6.23-gentoo-r8.omega ppc64)
=================================================================
System uname: 2.6.23-gentoo-r8.omega ppc64 PPC970MP, altivec supported
Timestamp of tree: Fri, 13 Jun 2008 08:45:01 +0000
distcc 2.18.3 powerpc64-unknown-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.4.4-r13
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="ppc64"
CBUILD="powerpc64-unknown-linux-gnu"
CFLAGS="-O2 -mtune=970 -mcpu=970 -mabi=altivec -pipe -ggdb"
CHOST="powerpc64-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -mtune=970 -mcpu=970 -mabi=altivec -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.blueyonder.co.uk ftp://mirrors.blueyonder.co.uk/mirrors/gentoo http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/ ftp://ftp.mirrorservice.org/sites/www.ibiblio.org/gentoo/ "
LANG="en_GB.UTF-8"
LINGUAS="en_GB"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/java-overlay /home/andrew/projects/libre_java_overlay /home/andrew/projects/andys_overlay"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl addbookmarks alias alsa altivec asf autoreplace bash-completion berkdb bluetooth bzip2 cairo caps cdda cddb cdparanoia cdr cjk cli connectionstatus contactnotes cpudetection cracklib crypt cups curl daap dbus dga dia djvu dri dts dv dvd dvdnav dvdr dvdread dvi effects emacs emf encode examples fame ffmpeg fftw firefox flac fortran fping gcj gdbm gif gmp gnutls gpac gpgme gpm gtk hal hfs highlight history iconv idn ieee1394 imagemagick imap imlib ipod ipv6 irc isdnlog jack javascript jingle jpeg jpeg2k kde ladspa lame lapack latex lcms ldap libnotify live lzo mad matroska mbox midi mjpeg mmap mng mp2 mp3 mpeg mplayer mudflap musepack musicbrainz ncurses netmeeting network nls nntp nowlistening nptl nptlonly nsplugin ogg openal openexr opengl openmp optimisememory oss pam pcre pdf perl plotutils png pnm pop postscript ppc64 ppds pppd python qt qt3 qt4 quicktime readline reflection rtc sasl sdl session shout slp smime smp sms smtp snmp sox speex spell spl sqlite ssl statistics stream subtitles svg syslog t1lib tcpd tetex texteffect tga theora threads tiff translator truetype unicode usb v4l2 vcd visualization vorbis vram webpresence wmf x264 xanim xattr xchattext xcomposite xine xinerama xml xorg xscreensaver xv xvid xvmc yahoo zeroconf zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB" USERLAND="GNU" VIDEO_CARDS="nv fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Andrew John Hughes 2008-06-17 09:37:40 UTC
Created attachment 157235 [details]
Build log
Comment 2 Alexis Ballier gentoo-dev 2008-06-17 15:26:33 UTC
Please *at the very least* try with ~arch version if you have gcc 4.3 failures.
Thanks.

*** This bug has been marked as a duplicate of bug 213187 ***
Comment 3 Andrew John Hughes 2008-06-17 15:30:43 UTC
I planned to anyway, but I'm still in the middle of an emerge -eav world for ~900 packages, rebuilding with gcc 4.3.1.