Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 225405 - sys-auth/consolekit-0.2.3 build failure w/ glibc-2.8: storage size of 'cr' isn't known
Summary: sys-auth/consolekit-0.2.3 build failure w/ glibc-2.8: storage size of 'cr' is...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Project Gentopia
Depends on:
Blocks: glibc-2.8
  Show dependency tree
Reported: 2008-06-08 17:36 UTC by Jose daLuz
Modified: 2008-06-21 20:39 UTC (History)
16 users (show)

See Also:
Package list:
Runtime testing required: ---

folder including updated ebuild, patch and manifest ready for an overlay (sys-auth.tar.gz,3.07 KB, text/plain)
2008-06-15 14:36 UTC, Billy DeVincentis
Billy DeVincentis' package, but attached as binary file (sys-auth.tar.gz,3.07 KB, application/octet-stream)
2008-06-20 20:07 UTC, Christian Schwinn

Note You need to log in before you can comment on or make changes to this bug.
Description Jose daLuz 2008-06-08 17:36:38 UTC
Rebuilding consolekit 0.2.3 (as part of system rebuild) after updating glibc from
2.7-r2 to 2.8_p20080602, I get the following error:

 x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I. -I. -pthread -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DPREFIX=\"/usr\" -DBINDIR=\"/usr/bin\" -DLIBDIR=\"/usr/lib64\" -DLIBEXECDIR=\"/usr/libexec\" -DDATADIR=\"/usr/share\" -DSYSCONFDIR=\"/etc\" -DCONSOLE_KIT_PID_FILE=\"/var/run/\" -Wall -Wmissing-prototypes -DG_DISABLE_ASSERT -DG_DISABLE_CHECKS -DDBUS_VERSION_MAJOR=1 -DDBUS_VERSION_MINOR=2 -DDBUS_VERSION_MICRO=1 -march=k8 -O2 -pipe -ggdb -msse3 -MT ck-sysdeps-unix.lo -MD -MP -MF .deps/ck-sysdeps-unix.Tpo -c ck-sysdeps-unix.c  -fPIC -DPIC -o .libs/ck-sysdeps-unix.o
ck-sysdeps-unix.c: In function 'ck_get_socket_peer_credentials':
ck-sysdeps-unix.c:69: error: storage size of 'cr' isn't known
ck-sysdeps-unix.c:69: warning: unused variable 'cr'
make[4]: *** [ck-sysdeps-unix.lo] Error 1
make[4]: Leaving directory `/var/tmp/paludis/sys-auth-consolekit-0.2.3/work/ConsoleKit-0.2.3/src'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/paludis/sys-auth-consolekit-0.2.3/work/ConsoleKit-0.2.3/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/paludis/sys-auth-consolekit-0.2.3/work/ConsoleKit-0.2.3/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/paludis/sys-auth-consolekit-0.2.3/work/ConsoleKit-0.2.3'
make: *** [all] Error 2

!!! ERROR in sys-auth/consolekit-0.2.3:
!!! In src_compile at line 3934
!!! emake failed

This is the same error as in bug 255403. Perhaps I should be filing these against glibc instead?

Portage (default-linux/amd64/2007.0/desktop, gcc-4.3.0, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r4 x86_64)
System uname: 2.6.25-gentoo-r4 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 6000+
Timestamp of tree: Sun, 08 Jun 2008 01:35:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r3
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=k8 -O2 -pipe -ggdb -msse3"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe -ggdb -msse3"
FEATURES="ccache distlocks fixpackages parallel-fetch sandbox sfperms splitdebug strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/overlays/paludis-extras /usr/local/overlays/sunrise /usr/local/overlays/gnome /usr/local/overlays/mainline /usr/local/overlays/desktop-effects /usr/local/overlays/vmware /usr/local/overlays/berkano /usr/local/overlays/myoverlay"
USE="X a52 aac acl acpi alsa amd64 amr bash-completion berkdb bluetooth bzip2 cairo cdda cdr cli cracklib crypt css cups dbus dri dts dvd dvdr dvdread eds emboss encode esd evo fam ffmpeg flac fortran gdbm gif glitz gnome gpm gstreamer gtk hal iconv ipv6 isdnlog java jpeg kde kdehiddenvisibility kerberos ldap libnotify mad midi mikmod mmx mono mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl pic png pppd python qt3support qt4 quicktime readline reflection ruby samba sdl session spell spl sqlite sse sse2 ssl svg tcpd theora tiff truetype unicode usb userlocales vcd vorbis x264 xml xorg xulrunner xv xvid zlib" ALSA_CARDS="cmipci hdaintel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Comment 1 Rafał Mużyło 2008-06-10 00:37:03 UTC
Consider Bug 225403#c2.
Comment 2 virdiq 2008-06-10 04:11:53 UTC
I'm confirming that adding the flag from bug 225403#c2 does work, as suggested by Rafał Mużyło.

It doesn't seem that this bug has been fixed upstream yet (see;a=history;f=src/ck-sysdeps-unix.c)
Comment 3 virdiq 2008-06-10 05:37:47 UTC
Sorry about the last comment, I was looking in the wrong place.

It looks like they may have patched this problem at the start of 2008 in v0.2.4 as per;a=commitdiff;h=36419b9ca34a89721746950eb78bb78c4bfb6206

The latest version of consolekit is now v0.2.10 and a simple version bump to this version solves the glibc-2.8 build problem.

I also tried doing version bumps from 0.2.4 up to 0.2.10 (latest) and found:
- consolekit-0.2.4 through to consolekit-0.2.6 inclusive can't find polkit >= 0.7 (but I presume the glibc-2.8 problem is fixed in these versions)
- consolekit-0.2.7 and higher build ok without any changes to the current ebuild
Comment 4 virdiq 2008-06-10 05:41:58 UTC
BTW consolekit-0.2.7 makes the polkit >= 0.7 dependency optional (where it was forced for versions 0.2.4-0.2.6), so we'd probably need a new USE flag for polkit support if bumping above consolekit-0.2.3.

See upstream commit;a=commit;h=5895396bc583ae08c5041f5b81f5f9d0a2888e22
Comment 5 Ferenc Erki 2008-06-11 07:47:46 UTC
The solution/workaround mentioned in Bug 225403 works for me for this bug too.

Namely, to add 'inherit flag-o-matic' and 'append-flags -D_GNU_SOURCE' to the ebuild.
Comment 6 Boney McCracker 2008-06-13 02:50:32 UTC
Worked for me also.

Comment 7 Billy DeVincentis 2008-06-15 14:36:53 UTC
Created attachment 156919 [details]
folder including updated ebuild, patch and manifest ready for an overlay
Comment 8 Christian Schwinn 2008-06-20 20:07:02 UTC
Created attachment 157825 [details]
Billy DeVincentis' package, but attached as binary file

Billy DeVincentis' package, but attached as binary file. This way it is possible to download it correctly with links...
Comment 9 Ben de Groot (RETIRED) gentoo-dev 2008-06-21 20:39:37 UTC
Fixed by committing version 0.2.10.