Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 222803 - net-dns/avahi-0.6.22-r1 - configure fails to find qt-mt.pc
Summary: net-dns/avahi-0.6.22-r1 - configure fails to find qt-mt.pc
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Sven Wegener
Depends on:
Reported: 2008-05-19 12:19 UTC by Kristian Niemi
Modified: 2010-01-03 15:21 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

net-dns/avahi-0.6.22-r1/work/avahi-0.6.22/config.log (config.log,151.56 KB, text/plain)
2008-05-19 17:44 UTC, Kristian Niemi

Note You need to log in before you can comment on or make changes to this bug.
Description Kristian Niemi 2008-05-19 12:19:13 UTC
net-dns/avahi-0.6.22-r1: emerge fails at configuration phase because it can't find qt3 (qt-mt, to be exact).

Reproducible: Always

Steps to Reproduce:
1. Make sure qt3 is in USE flags
2. (attempt to) emerge avahi
3. Emerge fails with error (see actual results)

Actual Results:  
Emerge fails with error message: 

configure: error: Package requirements ( qt-mt >= 3.0.0 ) were not met:

No package 'qt-mt' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables QT3_CFLAGS
and QT3_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

!!! ERROR in net-dns/avahi-0.6.22-r1:
!!! In econf at line 1812
!!! econf failed

Expected Results:  
avahi would be compiled.

In some topics I saw suggestions to recompile QT. I tried; it didn not help.

QT:s installed:

~ $ eix -I x11-libs/qt
[I] x11-libs/qt
     Available versions: 
        (3)     3.3.8-r4
        (4)     4.3.3 ~4.3.4-r1 [M]~4.4.0
        {+accessibility +qt3support cups dbus debug doc examples firebird gif glib immqt immqt-bc input_devices_wacom ipv6 jpeg mng mysql nas nis odbc opengl pch png postgres qt3support sqlite sqlite3 ssl tiff xinerama zlib}
     Installed versions:  3.3.8-r4(3)(18.55.52 2008-05-15)(cups gif ipv6 mysql opengl -debug -doc -examples -firebird -immqt -immqt-bc -nas -nis -odbc -postgres -sqlite -xinerama)
                          4.3.3(4)(20.47.00 2008-05-15)(dbus gif jpeg opengl png ssl zlib -+accessibility -+qt3support -cups -debug -doc -examples -firebird -glib -input_devices_wacom -mng -mysql -nas -nis -odbc -pch -postgres -sqlite -sqlite3 -tiff -xinerama)
     Description:         The Qt toolkit is a comprehensive C++ application development framework.

Avahi to be installed:

~ $ paludis -ip avahi
Building target list...
Building dependency list...

These packages will be installed:

* net-dns/avahi::gentoo [R 0.6.22-r1] <target>
    Reasons: net-print/cups-1.3.7-r1:0::installed
    -autoipd -bookmarks dbus -doc gdbm gtk -howl-compat ipv6 mdnsresponder-compat mono python qt3* qt4* -test kernel: (linux)

Total: 1 package (1 rebuild)

paludis --info:
paludis 0.26.1
Paludis build information:
        CXX:                   i686-pc-linux-gnu-g++ 4.1.2 (Gentoo 4.1.2 p1.1)
        CXXFLAGS:              -O2 -mtune=prescott -march=prescott -m32 -pipe
        LDFLAGS:               -Wl,-O1 -Wl,-z,now
        DATE:                  2008-05-06T09:47:33+0200

        C++ Library:           GNU libstdc++ 20070214

    Reduced Privs:
        reduced_uid:           107
        reduced_uid->name:     paludisbuild
        reduced_uid->dir:      /dev/null
        reduced_gid:           444
        reduced_gid->name:     paludisbuild

        DATADIR:               /usr/share
        LIBDIR:                /usr/lib
        LIBEXECDIR:            /usr/libexec
        SYSCONFDIR:            /etc
        PYTHONINSTALLDIR:      /usr/lib/python2.4/site-packages
-- SNIP (only repository info) --
Repository gentoo:
    format:                    ebuild
    location:                  /mnt/portage/portage
    append_repository_name_to_write_cache: true
    binary_destination:        false
    builddir:                  /var/tmp/paludis
    cache:                     /mnt/portage/portage/metadata/cache
    distdir:                   /usr/portage/distfiles
    eapi_when_unknown:         0
    eapi_when_unspecified:     0
    eclassdirs:                /mnt/portage/portage/eclass
    ignore_deprecated_profiles: false
    layout:                    traditional
    names_cache:               /var/empty
    newsdir:                   /mnt/portage/portage/metadata/news
    profile_eapi:              0
    profiles:                  /mnt/portage/portage/profiles/default-linux/x86/2007.0/desktop
    securitydir:               /mnt/portage/portage/metadata/glsa
    setsdir:                   /mnt/portage/portage/sets
   sync:                      rsync://
    use_manifest:              use
    write_cache:               /var/cache/paludis/metadata

    Package information:
        app-admin/eselect-compiler: (none)
        app-shells/bash:       3.2_p33
        dev-java/java-config:  1.3.7 2.1.6
        dev-lang/python:       2.4.4-r9
        dev-python/pycrypto:   2.0.1-r6
        dev-util/ccache:       2.4-r7
        dev-util/confcache:    (none)
        sys-apps/openrc:       (none)
        sys-devel/autoconf:    2.13 2.61-r1
        sys-devel/automake:    1.10.1 1.4_p6 1.5 1.6.3 1.7.9-r1 1.8.5-r3 1.9.6-r2
        sys-devel/binutils:    2.18-r1
        sys-devel/gcc-config:  1.4.0-r4
        sys-devel/libtool:     1.5.26
        virtual/os-headers:    2.6.23-r3 (for sys-kernel/linux-headers::installed)
-- SNIP --

HACKISH SOLUTION: as was suggested in a thread on the forums (, inserting the following in make.conf/bashrc make avahi build:
export PKG_CONFIG_PATH="/usr/qt/3/lib/pkgconfig"

NOTE: After avahi was built successfully, having added the line above, package kdnssd-avahi-0.1.2 also fails, with an error similar even if not identical as the one avahi throws --- if the PKG_CONFIG_PATH isn't set as above. If it is set, on the other hand, kdnssd-avahi also compiles fine.
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2008-05-19 16:54:41 UTC
Please test, if rebuilding Qt 3 fixes the problem for you.
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2008-05-19 16:58:26 UTC
Please provide the config.log from the work directory as well.
Comment 3 Kristian Niemi 2008-05-19 17:38:33 UTC
(In reply to comment #1)
> Please test, if rebuilding Qt 3 fixes the problem for you.

I did mention that I had tried reinstalling QT and that it did not help -- as did another person on the forum thread mentioned as well, so it's not unique for my setup --, though I might have emphasized it more as it's easily overlooked in such a lengthy post as the initial one was.  

But, that said, reinstalling does have a magickal way of sorting things out, so I installed QT (3) again, just for the heck of it.

It did not help. Ended in exactly the same error.
Comment 4 Kristian Niemi 2008-05-19 17:44:21 UTC
Created attachment 153685 [details]

(Was too long to include in message.)
Comment 5 Kristian Niemi 2008-05-19 17:48:06 UTC
As mentioned in the original post (see NOTE), kdnssd-avahi-0.1.2 also fails after avahi has successfully been built (PKG_CONFIG_PATH having been specified in bashrc).

Should a separate bug report be filed for kdnssd-avahi-0.1.2? 

I did not do it originally, as I assumed it might be fixed by getting avahi to compile `the right way'(tm). But on the other hand, it's a separate package, so...? Wait and see, or file and be done with it?-)
Comment 6 Sven Wegener gentoo-dev 2008-05-20 05:27:27 UTC
What's the contents of /etc/env.d/*qt*? There should be one file with PKG_CONFIG_PATH in it, which should end up in /etc/profile.env. You use paludis for building packages?
Comment 7 Kristian Niemi 2008-05-20 08:11:24 UTC
Snippet from /etc/env.d/45qt3: "PKG_CONFIG_PATH=/usr/qt/3/lib/pkgconfig"
Snippet form /etc/profile.env: "export PKG_CONFIG_PATH='/usr/qt/3/lib/pkgconfig'"

Yes, I use paludis. As I've been perfectly capable to compile other packages that depends on QT with paludis, I didn't think it was the culprit. To be able to say as much, I just tried emerging it with portage -- QT3 _was_ found in the configuration phase.

So in short: using emerge solved my problem.

Thanks for your time! I'll post a link about this to the paludis thread so they can take a look.
Comment 8 Ira Snyder 2008-05-23 17:47:07 UTC
I just ran into this problem on a fresh install on a new amd64 system. This is the first time qt was installed, and the first time avahi was installed.

I managed to solve it by running the following commands, in the shell I was installing things with paludis:
source /etc/profile

So, my guess would be that paludis doesn't regenerate the environment after every merge, whereas emerge does. That is just a guess, though.
Comment 9 Morladim 2009-02-17 06:20:57 UTC
Package qt-mt was not found in the pkg-config search path.
Perhaps you should add the directory containing `qt-mt.pc'
For example

gentoo ~ # locate qt-mt.pc

gentoo ~ # export PKG_CONFIG_PATH=/usr/qt/3/lib/pkgconfig/:$PKG_CONFIG_PATH
then reemerge  avahi with USE="qt3" 
All be ok!
Comment 10 Samuli Suominen (RETIRED) gentoo-dev 2010-01-03 15:21:12 UTC
This should be fixed by,

  03 Jan 2010; Samuli Suominen <>
  avahi-0.6.24-r2.ebuild, avahi-0.6.25.ebuild:
  Remove unused USE="qt3" support wrt bug #283429.