Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 220997 - Input-hotplug don't restore mouse/keyboard settings after re/plugging of device
Summary: Input-hotplug don't restore mouse/keyboard settings after re/plugging of device
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 313999
  Show dependency tree
 
Reported: 2008-05-08 20:14 UTC by Miroslaw Mieszczak
Modified: 2010-04-09 05:16 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miroslaw Mieszczak 2008-05-08 20:14:18 UTC
I am using left-handed mouse. If I get the mouse out, and plug it again into the system, when user is logged into kde, the mouse settings will not be restored (mouse buttons will be changed into the right handed mouse).
The same would be happen for keyboard settings.

Of course I could set some udev/hal rules to go around this problem, but the problem is that I am the only left-handed person using the system.


The same problem occure after system suspend.

Reproducible: Always

Steps to Reproduce:
1.start the system
2.login into graphic system
3. replug the mouse

Actual Results:  
After mouse replugging, there are restored system defaults.

Expected Results:  
Mouse should be initialized into user settings
Comment 1 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-04-08 23:14:04 UTC
Could you please try with 4.4.2 and report back?
Comment 2 Miroslaw Mieszczak 2010-04-09 05:16:45 UTC
It seems, that the situation is changed, and now hotplug somehow restore the settings. So I thin, that the bug can be closed now.