Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 220657 - app-misc/workrave-1.8.4 fails w/ gcc-4.3.0 and w/ >=libsigc++-2.1; bump and patch
Summary: app-misc/workrave-1.8.4 fails w/ gcc-4.3.0 and w/ >=libsigc++-2.1; bump and p...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Leonardo Boshell (RETIRED)
URL:
Whiteboard:
Keywords:
: 215435 (view as bug list)
Depends on:
Blocks: gcc-4.3 213430
  Show dependency tree
 
Reported: 2008-05-06 19:07 UTC by Peter Alfredsen (RETIRED)
Modified: 2008-05-07 23:44 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
workrave-1.8.4--1.8.5.ebuild.patch (workrave-1.8.4--1.8.5.ebuild.patch,1.28 KB, patch)
2008-05-06 19:11 UTC, Peter Alfredsen (RETIRED)
Details | Diff
workrave-1.8.5-gcc43.patch (workrave-1.8.5-gcc43.patch,2.95 KB, patch)
2008-05-06 19:12 UTC, Peter Alfredsen (RETIRED)
Details | Diff
workrave-1.8.5-libsigc++-2.2.2.patch (workrave-1.8.5-libsigc++-2.2.2.patch,29.05 KB, patch)
2008-05-06 19:15 UTC, Peter Alfredsen (RETIRED)
Details | Diff
workrave-1.8.4--1.8.5.ebuild.patch (workrave-1.8.4--1.8.5.ebuild.patch,1.96 KB, patch)
2008-05-06 19:40 UTC, Peter Alfredsen (RETIRED)
Details | Diff
workrave-1.8.4--1.8.5.ebuild.patch (workrave-1.8.4--1.8.5.ebuild.patch,1.95 KB, patch)
2008-05-07 09:15 UTC, Peter Alfredsen (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Alfredsen (RETIRED) gentoo-dev 2008-05-06 19:07:38 UTC
if i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I../../intl -I. -I ../include -I. -I. -I../..   -DQT_THREAD_SUPPORT  -D_REENTRANT -W -DWORKRAVE_DATADIR="\"/usr/share/workrave\"" -D_XOPEN_SOURCE=600 -I ../../common/include -I ../../common/include/unix -I ../../backend/include -I ../../backend/src/ -I ../../backend/src/unix -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include -I/usr/include/libgdome -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2  -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DORBIT2=1 -pthread -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include     -O2 -march=i686 -mtune=athlon-xp -msse -mmmx -pipe -ggdb3 -Os -g -DNDEBUG -MT libworkrave_backend_a-BreakControl.o -MD -MP -MF ".deps/libworkrave_backend_a-BreakControl.Tpo" -c -o libworkrave_backend_a-BreakControl.o `test -f 'BreakControl.cc' || echo './'`BreakControl.cc; \
        then mv -f ".deps/libworkrave_backend_a-BreakControl.Tpo" ".deps/libworkrave_backend_a-BreakControl.Po"; else rm -f ".deps/libworkrave_backend_a-BreakControl.Tpo"; exit 1; fi
BreakControl.cc: In member function ‘void BreakControl::send_signal(BreakControl::BreakStage)’:
BreakControl.cc:807: warning: deprecated conversion from string constant to ‘char*’
BreakControl.cc:811: warning: deprecated conversion from string constant to ‘char*’
BreakControl.cc:819: warning: deprecated conversion from string constant to ‘char*’
BreakControl.cc:823: warning: deprecated conversion from string constant to ‘char*’
if i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I../../intl -I. -I ../include -I. -I. -I../..   -DQT_THREAD_SUPPORT  -D_REENTRANT -W -DWORKRAVE_DATADIR="\"/usr/share/workrave\"" -D_XOPEN_SOURCE=600 -I ../../common/include -I ../../common/include/unix -I ../../backend/include -I ../../backend/src/ -I ../../backend/src/unix -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include -I/usr/include/libgdome -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2  -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DORBIT2=1 -pthread -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include     -O2 -march=i686 -mtune=athlon-xp -msse -mmmx -pipe -ggdb3 -Os -g -DNDEBUG -MT libworkrave_backend_a-Configurator.o -MD -MP -MF ".deps/libworkrave_backend_a-Configurator.Tpo" -c -o libworkrave_backend_a-Configurator.o `test -f 'Configurator.cc' || echo './'`Configurator.cc; \
        then mv -f ".deps/libworkrave_backend_a-Configurator.Tpo" ".deps/libworkrave_backend_a-Configurator.Po"; else rm -f ".deps/libworkrave_backend_a-Configurator.Tpo"; exit 1; fi
In file included from Configurator.cc:28:
Configurator.hh:40: warning: ‘typedef’ was ignored in this declaration
Configurator.cc: In static member function ‘static Configurator* Configurator::create(Configurator::Format)’:
Configurator.cc:98: error: ‘exit’ was not declared in this scope
make[5]: *** [libworkrave_backend_a-Configurator.o] Error 1
make[5]: Leaving directory `/var/tmp/portage/app-misc/workrave-1.8.4/work/workrave-1.8.4/backend/src'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/var/tmp/portage/app-misc/workrave-1.8.4/work/workrave-1.8.4/backend/src'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/var/tmp/portage/app-misc/workrave-1.8.4/work/workrave-1.8.4/backend/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-misc/workrave-1.8.4/work/workrave-1.8.4/backend'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-misc/workrave-1.8.4/work/workrave-1.8.4'
make: *** [all] Error 2
Comment 1 Peter Alfredsen (RETIRED) gentoo-dev 2008-05-06 19:11:10 UTC
Created attachment 152143 [details, diff]
workrave-1.8.4--1.8.5.ebuild.patch

Bumps to 1.8.5, fix bug 215435 and bug 213430. 1.8.4 is too far from trunk to be usable for backporting upstream fixes.
Dbus file no longer needed, included upstream. Gnome patch included upstream.
Comment 2 Peter Alfredsen (RETIRED) gentoo-dev 2008-05-06 19:12:41 UTC
Created attachment 152145 [details, diff]
workrave-1.8.5-gcc43.patch

Fixes compilation with GCC-4.3.0. Backported from upstream. Other distro's patches are incomplete.
Comment 3 Peter Alfredsen (RETIRED) gentoo-dev 2008-05-06 19:15:04 UTC
Created attachment 152147 [details, diff]
workrave-1.8.5-libsigc++-2.2.2.patch

Fixes compilation with libsigc++ - backported from upstream and bits added for Dispatcher.{cc,hh}, since those files have been deleted upstream. Builds with  USE="dbus gnome kde nls xml".
Comment 4 Peter Alfredsen (RETIRED) gentoo-dev 2008-05-06 19:40:42 UTC
Created attachment 152153 [details, diff]
workrave-1.8.4--1.8.5.ebuild.patch

Revised slightly with suggestions from Drac wrt bug 220219 .
Comment 5 Peter Alfredsen (RETIRED) gentoo-dev 2008-05-07 09:15:27 UTC
Created attachment 152227 [details, diff]
workrave-1.8.4--1.8.5.ebuild.patch

Use only one epatch.
Comment 6 Ceesjan Luiten 2008-05-07 13:41:59 UTC
workrave-1.8.4-nls_macros.patch
workrave-1.8.5-gcc43.patch
workrave-1.8.5-libsigc++-2.2.2.patch
workrave-1.8.5.ebuild

Thanks Peter - with these files I can successfully build and run workrave 1.8.5 on my ~amd64 system
Comment 7 Samuli Suominen gentoo-dev 2008-05-07 21:19:32 UTC
*** Bug 215435 has been marked as a duplicate of this bug. ***
Comment 8 Gilles Dartiguelongue gentoo-dev 2008-05-07 23:44:41 UTC
commited to the tree. Thanks for the patches.