Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 218982 - sci-astronomy/celestia-1.5.0 fails to compile with >=sys-devel/libtool-2.2
Summary: sci-astronomy/celestia-1.5.0 fails to compile with >=sys-devel/libtool-2.2
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Science Related Packages
URL: https://sourceforge.net/tracker/index...
Whiteboard:
Keywords:
: 229051 (view as bug list)
Depends on:
Blocks: libtool-2.2 228865
  Show dependency tree
 
Reported: 2008-04-23 05:59 UTC by Lars Wendler (Polynomial-C)
Modified: 2008-06-24 17:22 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,105.72 KB, text/plain)
2008-04-23 06:03 UTC, Lars Wendler (Polynomial-C)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2008-04-23 05:59:10 UTC
This happens during compilation of celestia:

i686-pc-linux-gnu-g++ -DCONFIG_DATA_DIR='"/usr/share/celestia"' -DLOCALEDIR='"/u
sr/share/locale"' -DHAVE_CONFIG_H -I. -I../.. -I..  -D_REENTRANT  -Wnon-virtual-
dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align
 -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBU
G -DNO_DEBUG -O2 -march=athlon-xp -mtune=athlon-xp -O2 -pipe -fomit-frame-pointe
r -finline-functions -Wformat-security -Wmissing-format-attribute -fno-exception
s -fno-check-new -fno-common   -Wall      -MT oggtheoracapture.o -MD -MP -MF .de
ps/oggtheoracapture.Tpo -c -o oggtheoracapture.o oggtheoracapture.cpp
mv -f .deps/oggtheoracapture.Tpo .deps/oggtheoracapture.Po
/bin/sh ../../libtool --silent --tag=CXX   --mode=link i686-pc-linux-gnu-g++  -W
non-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE
-Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-str
ings -DNDEBUG -DNO_DEBUG -O2 -march=athlon-xp -mtune=athlon-xp -O2 -pipe -fomit-
frame-pointer -finline-functions -Wformat-security -Wmissing-format-attribute -f
no-exceptions -fno-check-new -fno-common   -Wall      -L/usr/qt/3/lib -L/usr/kde
/3.5/lib  -R /usr/kde/3.5/lib -R /usr/qt/3/lib -Wl,--as-needed -o celestia celes
tiacore.o configfile.o destination.o eclipsefinder.o favorites.o imagecapture.o
url.o   oggtheoracapture.o -lqt  -lz -lpng -lz -lm -lXext -lX11  -lSM -lICE -lkd
ecore -lkdeui -lkio  kde/libkdegui.a  ../celengine/libcelengine.a ../celtxf/libc
eltxf.a ../cel3ds/libcel3ds.a ../celmath/libcelmath.a ../celutil/libcelutil.a  -
lpng -ljpeg -lGLU -lGL -lz  -lSM -lICE  -lm   -lXmu -lXi -lXext -lX11 -lm -lz  -
lGL -ltheora -logg   -lqt  -lz -lpng -lz -lm -lXext -lX11  -lSM -lICE -lkdecore
-lkdeui -lkio
../../libtool: line 451: CDPATH: command not found
../../libtool: line 1287: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.2, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.2
libtool: and run autoconf again.
make[4]: *** [celestia] Error 63
make[4]: Leaving directory `/home/.portage/tmp/portage/sci-astronomy/celestia-1.
5.0/work/celestia-1.5.0/src/celestia'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/.portage/tmp/portage/sci-astronomy/celestia-1.
5.0/work/celestia-1.5.0/src/celestia'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/.portage/tmp/portage/sci-astronomy/celestia-1.
5.0/work/celestia-1.5.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/.portage/tmp/portage/sci-astronomy/celestia-1.                                                                                                                    5.0/work/celestia-1.5.0'
make: *** [all] Error 2
 *
 * ERROR: sci-astronomy/celestia-1.5.0 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3942:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed"
 *  The die message:
 *   emake failed


Reproducible: Always

Steps to Reproduce:
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2008-04-23 06:03:21 UTC
Created attachment 150677 [details]
build.log

Whoops, something went wrong in my previous message. Here's the complete build log in case someone doesn't want to read the mess I posted above...
Comment 2 Rafał Mużyło 2008-04-23 12:17:59 UTC
Upstream bug.
acinclude.m4 should NOT contain libtool.m4.
Actually, after looking briefly at that acinclude.m4, I think it's long overdue for a rewrite.
Comment 3 Markus Dittrich (RETIRED) gentoo-dev 2008-04-25 12:48:02 UTC
Has anybody filed a bug with upstream explaining
the issue?

Thanks,
Markus
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2008-04-28 11:36:03 UTC
(In reply to comment #3)
> Has anybody filed a bug with upstream explaining
> the issue?
> 
> Thanks,
> Markus
> 

filed a bugreport...
Comment 5 Markus Dittrich (RETIRED) gentoo-dev 2008-04-28 12:59:47 UTC
Great, thanks!
Comment 6 Alexey Shvetsov gentoo-dev 2008-06-23 14:23:51 UTC
*** Bug 229051 has been marked as a duplicate of this bug. ***
Comment 7 Aleksandr Yakimov 2008-06-24 09:07:45 UTC
(In reply to comment #2)
> Upstream bug.
> acinclude.m4 should NOT contain libtool.m4.
I've removed anything below 'libtool.m4 - Configure libtool' and program compiles and starts normally. See bug 228865
Comment 8 Markus Dittrich (RETIRED) gentoo-dev 2008-06-24 17:22:07 UTC
The libtool issue should be fixed in the celestia-1.5.1
ebuild I just committed. I'll send the patches upstream.

Best,
Markus