Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 218198 - app-emulation/virtualbox-modules (vboxdrv) doesn't load in 2.6.25 kernel
Summary: app-emulation/virtualbox-modules (vboxdrv) doesn't load in 2.6.25 kernel
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Markus Ullmann (RETIRED)
URL: http://forums.virtualbox.org/viewtopi...
Whiteboard:
Keywords:
: 218935 219061 (view as bug list)
Depends on:
Blocks: kernel-2.6.25
  Show dependency tree
 
Reported: 2008-04-18 02:18 UTC by Aron
Modified: 2008-08-30 16:50 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron 2008-04-18 02:18:29 UTC
The vboxdrv doesn't load for the 2.6.25 kernel.  The emerge completes, but a warning is produced when updating the module dependencies.

innotek has an updated module tarball for this kernel at http://www.virtualbox.de/download/vboxdrv-1.5.7-for-linux.2.6.25.tar.gz

Reproducible: Always

Steps to Reproduce:
1. upgrade to 2.6.25 kernel
2. emerge -1 virtualbox-modules
3. modprobe vboxdrv

Actual Results:  
 * Removing app-emulation/virtualbox-modules-1.5.6 from moduledb.
>>> Original instance of package unmerged safely.
 * Updating module dependencies for 2.6.25-gentoo ...
WARNING: //lib/modules/2.6.25-gentoo/misc/vboxdrv.ko needs unknown symbol change_page_a  [ ok ]
 * Adding module to moduledb.
>>> app-emulation/virtualbox-modules-1.5.6 merged.


Expected Results:  
Module should load fine
Comment 1 amadeus.bit 2008-04-19 13:51:51 UTC
I have the same problem. 

modprobe vboxdrv
FATAL: Error inserting vboxdrv (/lib/modules/2.6.25-gentoo-r1/misc/vboxdrv.ko): Unknown symbol in module, or unknown parameter (see dmesg)

dmesg | grep vboxdrv
vboxdrv: Unknown symbol change_page_attr
Comment 2 Petteri Räty (RETIRED) gentoo-dev 2008-04-19 14:54:37 UTC
Weird it loaded here so there must be a work around:

betelgeuse@pena /usr/portage/app-emulation/virtualbox-modules $ lsmod | grep vbox
vboxdrv                35176  1
betelgeuse@pena /usr/portage/app-emulation/virtualbox-modules $ uname -a
Linux pena 2.6.25-gentoo-r1 #1 SMP Sat Apr 19 13:20:10 EEST 2008 i686 Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz GenuineIntel GNU/Linux
Comment 3 Alessio Cassibba (X-Drum) 2008-04-19 15:45:09 UTC
(In reply to comment #2)
> Weird it loaded here so there must be a work around:
> 
Hi, 

maybe a workaround is possible[1] but unsafe[2], due the API change in kernel 2.6.25 is not a good idea to ignore the set_memory_nx()/set_memory_x() calls.

i just commited an ebuild for the new version of virtualbox-modules on jokey's overlay[3], in version 1.5.7 vboxdrv provides a fix for this problem as described on LKML[4].


[1] http://www.virtualbox.org/attachment/ticket/1263/vbox-r7168-chpgattr-out.patch
[2] http://www.virtualbox.org/ticket/1263
[3] http://overlays.gentoo.org/dev/jokey/browser/trunk/app-emulation/virtualbox-modules
[4] http://lkml.org/lkml/2008/2/17/319
Comment 4 Markus Ullmann (RETIRED) gentoo-dev 2008-04-21 20:26:44 UTC
Added to cvs
Comment 5 Torsten Kurbad 2008-04-22 11:29:52 UTC
(In reply to comment #4)
> Added to cvs

Can you please change the dependency in app-emulation/virtualbox-1.5.6 accordingly?

Thanks in advance,
Torsten

Comment 6 Bernard Cafarelli gentoo-dev 2008-04-23 14:40:12 UTC
*** Bug 218935 has been marked as a duplicate of this bug. ***
Comment 7 Jeroen Roovers gentoo-dev 2008-04-24 03:30:07 UTC
*** Bug 219061 has been marked as a duplicate of this bug. ***
Comment 8 Denilson Sá 2008-06-16 08:11:29 UTC
Huh, I'm not sure if this is really fixed.

We now have virtualbox-modules-1.5.7 in portage, but we don't have 1.5.7 version for other virtualbox packages. Looking at the ebuilds, both virtualbox and virtualbox-bin depend on the exact same version of virtualbox-modules:
~app-emulation/virtualbox-modules-${PV}

So... Am I missing something or this isn't *really* fixed?
Comment 9 Adam Bowers 2008-07-17 15:07:31 UTC
I was doing some searching on a similar problem with the binary nvidia drivers and the SLUB allocator.  It seems that the vboxdrv also has issues when I try to compile the kernel with SLUB.  I thought this may help narrow down the problem.

hpwx070212 linux # make modules_install
  INSTALL drivers/scsi/scsi_wait_scan.ko
  DEPMOD  2.6.25-gentoo-r6
WARNING: /lib/modules/2.6.25-gentoo-r6/video/nvidia.ko needs unknown symbol malloc_sizes
WARNING: /lib/modules/2.6.25-gentoo-r6/misc/vboxdrv.ko needs unknown symbol change_page_attr
Comment 10 @4u 2008-07-17 16:49:52 UTC
This bug has been fixed at least for app-emulation/virtualbox-modules-1.6.2. It works perfectly here for Linux version 2.6.26-rc8 (root@loki) (gcc version 4.1.2 (Gentoo 4.1.2 p1.1)). I had this problem with 2.6.25 and 2.6.26 in earlier versions.
Comment 11 Imre Péntek 2008-07-21 15:51:33 UTC
by the way 1.6.2 still have the ~amd64 flag...
Comment 12 Hamid Ohadi 2008-08-11 13:54:21 UTC
seems like this problem came back again with 1.6.4 with my amd64 machine
Comment 13 Alessio Cassibba (X-Drum) 2008-08-11 19:46:59 UTC
(In reply to comment #12)
> seems like this problem came back again with 1.6.4 with my amd64 machine
> 

Hi
can you please:
- describe exactly what kind of problem you noticed.
- report which kernel are you running/using with vboxdrv.
- report if you are using SLUB with your kernel (zgrep SLUB /proc/config.gz).
Comment 14 Paul Philippov 2008-08-19 20:18:12 UTC
> can you please:
> - describe exactly what kind of problem you noticed.

virtualbox module does not run

# modprobe vboxdrv
FATAL: Error inserting vboxdrv (/lib/modules/2.6.25-gentoo-r7/misc/vboxdrv.ko): Unknown symbol in module, or unknown parameter (see dmesg)

because of

# dmesg | grep vboxdrv
vboxdrv: Unknown symbol change_page_attr

> - report which kernel are you running/using with vboxdrv.

# uname -a
Linux monolith 2.6.25-gentoo-r7 #10 SMP PREEMPT Tue Aug 19 09:33:17 EEST 2008 x86_64 Intel(R) Pentium(R) 4 CPU 3.00GHz GenuineIntel GNU/Linux

> - report if you are using SLUB with your kernel (zgrep SLUB /proc/config.gz).

# zgrep SLUB /proc/config.gz
CONFIG_SLUB_DEBUG=y
CONFIG_SLUB=y
# CONFIG_SLUB_DEBUG_ON is not set
# CONFIG_SLUB_STATS is not set
Comment 15 Patrick Libby 2008-08-22 14:32:55 UTC
I have same kernel version, and the same issue with vboxdrv.

dragonfly@Sakura ~ $ uname -a
Linux Sakura 2.6.25-gentoo-r7.Sakura #1 SMP PREEMPT Fri Aug 1 14:22:35 EDT 2008 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ AuthenticAMD GNU/Linux
dragonfly@Sakura ~ $ zgrep SLUB /proc/config.gz 
# CONFIG_SLUB is not set



(In reply to comment #14)
> > can you please:
> > - describe exactly what kind of problem you noticed.
> 
> virtualbox module does not run
> 
> # modprobe vboxdrv
> FATAL: Error inserting vboxdrv (/lib/modules/2.6.25-gentoo-r7/misc/vboxdrv.ko):
> Unknown symbol in module, or unknown parameter (see dmesg)
> 
> because of
> 
> # dmesg | grep vboxdrv
> vboxdrv: Unknown symbol change_page_attr
> 
> > - report which kernel are you running/using with vboxdrv.
> 
> # uname -a
> Linux monolith 2.6.25-gentoo-r7 #10 SMP PREEMPT Tue Aug 19 09:33:17 EEST 2008
> x86_64 Intel(R) Pentium(R) 4 CPU 3.00GHz GenuineIntel GNU/Linux
> 
> > - report if you are using SLUB with your kernel (zgrep SLUB /proc/config.gz).
> 
> # zgrep SLUB /proc/config.gz
> CONFIG_SLUB_DEBUG=y
> CONFIG_SLUB=y
> # CONFIG_SLUB_DEBUG_ON is not set
> # CONFIG_SLUB_STATS is not set
> 

Comment 16 Paul Philippov 2008-08-22 16:08:31 UTC
VirtualBox 1.6.4 plays perfectly well with both 2.6.25 kernel and SLUB.
Maybe stabilizing to 1.6.x would solve the problem?
Comment 17 Denilson Sá 2008-08-22 20:37:34 UTC
(In reply to comment #16)
> VirtualBox 1.6.4 plays perfectly well with both 2.6.25 kernel and SLUB.
> Maybe stabilizing to 1.6.x would solve the problem?

I think this is a good idea. I've been using 1.6.2 with no problems for about 1 or 2 months.