Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 218178 - nvidia-drivers-169.12 fails to build against 2.6.25 kernel
Summary: nvidia-drivers-169.12 fails to build against 2.6.25 kernel
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Doug Goldstein
URL:
Whiteboard:
Keywords:
: 218180 219686 (view as bug list)
Depends on:
Blocks: kernel-2.6.25
  Show dependency tree
 
Reported: 2008-04-17 21:54 UTC by Roy Marples
Modified: 2008-07-21 13:14 UTC (History)
19 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
71.86.01 won't compile with kernel 2.6.25-gentoo-r6 (x11-drivers:nvidia-drivers-71.86.01:20080719-130833.log,8.48 KB, text/plain)
2008-07-19 14:13 UTC, Mike Hammill
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roy Marples 2008-04-17 21:54:21 UTC
/var/tmp/portage/x11-drivers/nvidia-drivers-169.12/work/NVIDIA-Linux-x86_64-169.12-pkg2/usr/src/nv/nv-vm.c: In function ‘nv_set_page_attrib_uncached’:
/var/tmp/portage/x11-drivers/nvidia-drivers-169.12/work/NVIDIA-Linux-x86_64-169.12-pkg2/usr/src/nv/nv-vm.c:64: warning: ‘change_page_attr’ is deprecated (declared at include/asm/cacheflush.h:28)
/var/tmp/portage/x11-drivers/nvidia-drivers-169.12/work/NVIDIA-Linux-x86_64-169.12-pkg2/usr/src/nv/nv-vm.c: In function ‘nv_set_page_attrib_cached’:
/var/tmp/portage/x11-drivers/nvidia-drivers-169.12/work/NVIDIA-Linux-x86_64-169.12-pkg2/usr/src/nv/nv-vm.c:79: warning: ‘change_page_attr’ is deprecated (declared at include/asm/cacheflush.h:28)
/var/tmp/portage/x11-drivers/nvidia-drivers-169.12/work/NVIDIA-Linux-x86_64-169.12-pkg2/usr/src/nv/nv-vm.c: In function ‘nv_flush_caches’:
/var/tmp/portage/x11-drivers/nvidia-drivers-169.12/work/NVIDIA-Linux-x86_64-169.12-pkg2/usr/src/nv/nv-vm.c:364: error: implicit declaration of function ‘global_flush_tlb’
make[3]: *** [/var/tmp/portage/x11-drivers/nvidia-drivers-169.12/work/NVIDIA-Linux-x86_64-169.12-pkg2/usr/src/nv/nv-vm.o] Error 1
make[2]: *** [_module_/var/tmp/portage/x11-drivers/nvidia-drivers-169.12/work/NVIDIA-Linux-x86_64-169.12-pkg2/usr/src/nv] Error 2
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2008-04-17 22:11:00 UTC
*** Bug 218180 has been marked as a duplicate of this bug. ***
Comment 2 Julien 2008-04-17 23:24:18 UTC
nvidia-drivers-169.12 aren't compatible with 2.6.25 kernels. The discussion is here : http://www.nvnews.net/vbulletin/showthread.php?t=110088

Should apply a patch or upgrade drivers.
Comment 3 SpanKY gentoo-dev 2008-04-18 02:10:05 UTC
ive added the patch from the upstream forum as it works for me ... i'll leave the bug open as the patch is only applied for 2.6.25+ and in case Doug wants to do anything else

http://sources.gentoo.org/x11-drivers/nvidia-drivers/nvidia-drivers-169.12.ebuild?r1=1.1&r2=1.2
http://sources.gentoo.org/x11-drivers/nvidia-drivers/files/NVIDIA_kernel-169.12-2286310.diff?rev=1.1
Comment 4 Roy Marples 2008-04-18 08:12:49 UTC
That patch WFM :)
Comment 5 Guillaume Castagnino 2008-04-18 19:37:50 UTC
Adding the patch for the two legacy version (71.86 and 96.43) should be a good thing ;)

It works for me at least with the 96.43.05 version, using the patch provided on the same nvidia forum thread

Thanks !
Comment 7 Guillaume Castagnino 2008-04-18 21:29:03 UTC
(In reply to comment #6)
> i only added what i could test ... but if 96.43.05 works for you:
> http://sources.gentoo.org/x11-drivers/nvidia-drivers/nvidia-drivers-96.43.05.ebuild?r1=1.2&r2=1.3
> http://sources.gentoo.org/x11-drivers/nvidia-drivers/files/NVIDIA_kernel-96.43.05-2290218.diff?rev=1.1
> 

I just re-synced the tree and build it again with your patch : I confirm it builds and run correctly.

Thanks for your rapidity !
Comment 8 Brian Johnson 2008-04-23 06:42:39 UTC
nvidia-drivers-173.08 (not in portage) builds fine against 2.6.25 without the patch mentioned above...
Comment 9 Alexander Huemer 2008-04-23 15:53:37 UTC
(In reply to comment #8)
> nvidia-drivers-173.08 (not in portage) builds fine against 2.6.25 without the
> patch mentioned above...
> 

this is what i posted on 20080417. but jer@gentoo.org marked my bug https://bugs.gentoo.org/show_bug.cgi?id=218180 as a duplicate of this one, so the information is not easily accessible.
Comment 10 Jeroen Roovers (RETIRED) gentoo-dev 2008-04-29 07:53:49 UTC
*** Bug 219686 has been marked as a duplicate of this bug. ***
Comment 11 Stefan Behte (RETIRED) gentoo-dev Security 2008-05-01 14:06:16 UTC
Hi, x11-drivers/nvidia-drivers-96.43.05 compiles fine on 2.6.25-r1, but doesn't work with some extensions, for example mplayer cries:

Xlib:  extension "XFree86-VidModeExtension" missing on display ":0.0".
Xlib:  extension "XVideo" missing on display ":0.0".

Fullscreen won't work :/

Portage 2.1.4.4 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r1 i686)
=================================================================
System uname: 2.6.25-gentoo-r1 i686 AMD Athlon(tm) XP 2400+
Timestamp of tree: Thu, 01 May 2008 13:34:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.3.5-r3, 2.4.4-r9
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-Os -march=athlon-xp -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://192.168.0.2:66/ http://gentoo.intergenia.de/ ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo/ ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"
LANG="de_DE@euro"
LC_ALL="de_DE@euro"
LINGUAS="de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi aiglx alsa amr apache2 arts asf berkdb bzip2 bzlib cairo cdb cdparanoia cdr cli cracklib crypt css cups curl dbus dga directfb divx4linux dri dts dv dvd dvdr dvdread eds emboss encode ethereal evo extrafilters fbcon ffmpeg firefox flac fortran ftp gcj gdbm gif gpm gstreamer gtk gtk2 hal iconv icq imagemagick isdnlog java jikes jpeg kerberos lame lzo mad midi mikmod mime mjpeg mmx mmxext motif mp3 mpeg mtrr mudflap musepack ncurses network nls nptl nptlonly nsplugin nvidia ogg oggvorbis opengl openmp oss pam pcre pdf perl png pppd print python qt3 qt3support qt4 quicktime readline real reflection samba sdl session snmp sockets spell spl sse ssl svg svga tcpd theora threads tiff truetype unicode usb userlocales vcd vorbis wavpack win32codecs x264 x86 xine xinerama xml xorg xprint xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="nv nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 12 Doug Goldstein gentoo-dev 2008-05-01 14:13:08 UTC
(In reply to comment #11)
> Hi, x11-drivers/nvidia-drivers-96.43.05 compiles fine on 2.6.25-r1, but doesn't
> work with some extensions, for example mplayer cries:
> 
> Xlib:  extension "XFree86-VidModeExtension" missing on display ":0.0".
> Xlib:  extension "XVideo" missing on display ":0.0".
> 
> Fullscreen won't work :/

This is completely unrelated to this bug. Your xorg.conf file is configured wrong. Use the nvidia-xconfig utility to properly configure it.

Additionally, this bug is fixed with the patches that Mike committed while I was gone.
Comment 13 diabelx 2008-05-01 14:15:47 UTC
I tried to patch nvidia drivers, they doesn't compie at kernel (I think but I not remember, I only remember that I can't compie it at kernel 2.6.25-git17), 2.6.25-git15 to git 17, Please test it :), It's for NVIDIA-Linux-x86_64-169.12-pkg2 (broken file of nvidia driver - nv.c path: usr/src/nv/nv.c), I think that will be works
(At my kernel - git-17 - kernel .25, It works, sorry for my english, I'm not good in this language)

--- nv.c        2008-05-01 15:39:30.000000000 +0200
+++ nv2.c       2008-05-01 15:17:10.000000000 +0200
@@ -613,7 +613,7 @@
     nv_state_t *nv;
     nv_linux_state_t *nvl;

-    proc_nvidia = create_proc_entry("nvidia", d_flags, proc_root_driver);
+    proc_nvidia = create_proc_entry("nvidia", d_flags, NULL);
     if (!proc_nvidia)
         goto failed;

@@ -1829,14 +1829,14 @@

     return page;
 #else
-    return NOPAGE_SIGBUS;
+    return VM_FAULT_SIGBUS;
 #endif
 }

 struct vm_operations_struct nv_vm_ops = {
     .open   = nv_kern_vma_open,
     .close  = nv_kern_vma_release,  /* "close" */
-    .nopage = nv_kern_vma_nopage,
+    /*nopage removed*/
 };

 static nv_file_private_t *
Comment 14 Mark Wagner 2008-05-12 04:46:33 UTC
Can somebody (In reply to comment #5)
> Adding the patch for the two legacy version (71.86 and 96.43) should be a good
> thing ;)
> 
> It works for me at least with the 96.43.05 version, using the patch provided on
> the same nvidia forum thread
> 
> Thanks !

I searched for all nvidia bugs and found no resolution for 71.86 in the gentoo bugzilla. Was this bug "resolved fixed" because the summary mentions 169.12 only? If so, does one need to open a bug for 71.86 to get the patches mentioned herein applied to 71.86 or has it been fixed with 71.86 and I surely have no clue what I am doing? Reading the comments for this bug--with my limited reading comprehension skill--I can't figure out what happened.

/var/tmp/portage/x11-drivers/nvidia-drivers-71.86.04/work/NVIDIA-Linux-x86-71.86.04-pkg0/usr/src/nv/nv-vm.c:363: error: implicit declaration of function 'global_flush_tlb'

 * ERROR: x11-drivers/nvidia-drivers-71.86.04 failed.

Comment 15 Johan Hovold 2008-05-29 10:10:03 UTC
(In reply to comment #10)
> *** Bug 219686 has been marked as a duplicate of this bug. ***

Please note that the latest non-~x86 nvidia-drivers-169.09-r1 still does not build against 2.6.25 (so currently one needs to upgrade to the masked 169.12). Should 219686 be reopened?
Comment 16 Doug Goldstein gentoo-dev 2008-05-29 13:27:55 UTC
(In reply to comment #15)
> (In reply to comment #10)
> > *** Bug 219686 has been marked as a duplicate of this bug. ***
> 
> Please note that the latest non-~x86 nvidia-drivers-169.09-r1 still does not
> build against 2.6.25 (so currently one needs to upgrade to the masked 169.12).
> Should 219686 be reopened?
> 

Considering 2.6.25 is not stable, this is a moot point. Additionally, this bug wouldn't be reopened for stabilization.
Comment 17 Antti Mäkelä 2008-07-03 20:19:15 UTC
(In reply to comment #16)
> Considering 2.6.25 is not stable, this is a moot point. Additionally, this bug
> wouldn't be reopened for stabilization.

  Now it *is* stable and ran into this.
Comment 18 Doug Goldstein gentoo-dev 2008-07-03 20:25:14 UTC
(In reply to comment #17)
> (In reply to comment #16)
> > Considering 2.6.25 is not stable, this is a moot point. Additionally, this bug
> > wouldn't be reopened for stabilization.
> 
>   Now it *is* stable and ran into this.
> 

Which is why you use the latest stable version, 173.14.09 which is designed for 2.6.25.
Comment 19 Antti Mäkelä 2008-07-03 20:26:06 UTC
Nvm - apparently x11-drivers/nvidia-drivers-173.14.09 was marked stable at the
same time. Weird part is that this wasn't picked up by "emerge -uvDaN world" -
it's installed as xorg's dependency by VIDEO_CARDS="nvidia" so I thought the
big D would pick it up.
Comment 20 Denilson Sá Maia 2008-07-03 21:15:04 UTC
(In reply to comment #18)
> Which is why you use the latest stable version, 173.14.09 which is designed
> for 2.6.25.

And which breaks on my laptop... I get some weird behavior, basically my 3D desktop becomes unusable.

For me, it is better to stick to 169.12 version.

(I'm just posting this here hoping that it helps someone who stumbles on this bug)
Comment 21 Mike Hammill 2008-07-19 14:13:14 UTC
Created attachment 160846 [details]
71.86.01 won't compile with kernel 2.6.25-gentoo-r6

I just built the now stable linux-2.6.25-gentoo-r6 and then tried rebuilding the  latest stable x11-drivers/nvidia-drivers-71.86.01 for my card (NV20 [GeForce3 Ti 200] (rev a3)) and it bombs.  See included log.  Does that mean one of the currently unstable versions, ~71.86.04 ~71.86.06, has a fix?  If so, when do they become stable?
Comment 22 Doug Goldstein gentoo-dev 2008-07-21 13:14:30 UTC
(In reply to comment #21)
> Created an attachment (id=160846) [edit]
> 71.86.01 won't compile with kernel 2.6.25-gentoo-r6
> pat
> 
> I just built the now stable linux-2.6.25-gentoo-r6 and then tried rebuilding
> the  latest stable x11-drivers/nvidia-drivers-71.86.01 for my card (NV20
> [GeForce3 Ti 200] (rev a3)) and it bombs.  See included log.  Does that mean
> one of the currently unstable versions, ~71.86.04 ~71.86.06, has a fix?  If so,
> when do they become stable?
> 

Open a new bug.