Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 218094 - Please remove all media-video/ffmpeg-0.4.9_p20081014 incompatible plugins.
Summary: Please remove all media-video/ffmpeg-0.4.9_p20081014 incompatible plugins.
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Television related Applications in Gentoo's Portage
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 214740
  Show dependency tree
 
Reported: 2008-04-17 13:01 UTC by Ben de Groot (RETIRED)
Modified: 2008-12-17 06:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben de Groot (RETIRED) gentoo-dev 2008-04-17 13:01:50 UTC
FFmpeg recently changed all the include paths. Every application using it
should update. Make sure the applications build against currently hardmasked media-video/ffmpeg-0.4.9_p20080326.

media-tv herd to do:

media-plugins/mytharchive
media-plugins/vdr-audiorecorder
media-plugins/vdr-softdevice
media-plugins/vdr-softplay
media-tv/nuvexport
Comment 1 Matthias Schwarzott gentoo-dev 2008-04-21 10:57:54 UTC
FIXED:
media-plugins/vdr-audiorecorder
media-plugins/vdr-softdevice
media-plugins/vdr-softplay
Comment 2 Matthias Schwarzott gentoo-dev 2008-04-21 17:52:31 UTC
Not yet listed affected packages:
media-plugins/vdr-dxr3 [fixed now]

Not yet fixed:
media-plugins/vdr-graphtft
Comment 3 Ben de Groot (RETIRED) gentoo-dev 2008-06-22 17:31:48 UTC
vdr-graphtft fixed according to hd_brummy, so unmasked

what about mytharchive and nuvexport?
Comment 4 Samuli Suominen gentoo-dev 2008-12-10 23:37:19 UTC
You have 30 days to fix your packages, ffmpeg is going stable and broken
packages will be masked by treecleaners.
Comment 5 Samuli Suominen gentoo-dev 2008-12-11 10:16:24 UTC
(In reply to comment #3)
> what about mytharchive and nuvexport?

MythTV is entirely broken and won't compile due to multiple different bugs.
It's required to test the packages. This won't be stopping us.
Comment 6 Doug Goldstein gentoo-dev 2008-12-11 18:39:06 UTC
MythTV isn't entire broken... MythTV works perfectly fine for me and a lot of other users thank you very much. It even works great for upstream developers using Gentoo. In fact our MythTV packages work so good that it's one of the more popular platforms for using MythTV.
Comment 7 Samuli Suominen gentoo-dev 2008-12-13 08:43:26 UTC
Then test nuvexport (or remove it, as beandog said) and test stable mytharchive or get it stabilized. Old version will be masked for removal regardless with
the old ffmpeg revisions when we are done.
Comment 8 Samuli Suominen gentoo-dev 2008-12-15 19:22:11 UTC
Since you reopened this, I guess we can use this one. Please remove all plugins that doesn't compile against =media-video/ffmpeg-0.4.9_p20081014, since we need
to package.mask old version soon due to open CVEs. Open stable bugs where needed, remove unused versions where needed, .. you get the drift.

media-plugins/mytharchive-0.20.2_p14807
media-plugins/mytharchive-0.20.2_p14877
media-plugins/mytharchive-0.21_p17105
media-plugins/mytharchive-0.21_p17948
media-plugins/mytharchive-0.21_p18355
media-plugins/vdr-audiorecorder-0.1.0_pre6
media-plugins/vdr-dxr3-0.2.8
media-plugins/vdr-graphtft-0.1.18_alpha
media-plugins/vdr-graphtft-0.1.21_alpha
media-plugins/vdr-image-0.2.7-r1
media-plugins/vdr-image-0.2.7.26
media-plugins/vdr-osdpip-0.0.10
media-plugins/vdr-osdpip-0.0.8-r1
media-plugins/vdr-osdpip-0.0.8-r2
media-plugins/vdr-osdpip-0.0.9
media-plugins/vdr-pcd-0.9
media-plugins/vdr-softdevice-0.4.0
media-plugins/vdr-softdevice-0.4.0.20070711
media-plugins/vdr-softdevice-0.4.0.20070711-r1
media-plugins/vdr-softdevice-0.4.0.20080120
media-plugins/vdr-softdevice-0.5.0
media-plugins/vdr-softdevice-0.5.0-r1
media-plugins/vdr-softdevice-0.5.0.20080922
media-plugins/vdr-softplay-0.0.2.20060815
media-plugins/vdr-softplay-0.0.2.20070730
media-plugins/vdr-softplay-0.0.2.20080421
media-tv/nuvexport (do we need this package? does it work?)
Comment 9 Samuli Suominen gentoo-dev 2008-12-15 19:53:51 UTC
(In reply to comment #8)
> Since you reopened this, I guess we can use this one. Please remove all plugins
> that doesn't compile against =media-video/ffmpeg-0.4.9_p20081014, since we need
> to package.mask old version soon due to open CVEs. Open stable bugs where
> needed, remove unused versions where needed, .. you get the drift.
> 
> media-plugins/mytharchive-0.20.2_p14807
> media-plugins/mytharchive-0.20.2_p14877
> media-plugins/mytharchive-0.21_p17105
> media-plugins/mytharchive-0.21_p17948
> media-plugins/mytharchive-0.21_p18355

Cardoe told me on IRC these are calling ffmpeg from system() and should be compatible with the mentioned ffmpeg versions.

> media-plugins/vdr-audiorecorder-0.1.0_pre6
> media-plugins/vdr-dxr3-0.2.8
> media-plugins/vdr-graphtft-0.1.18_alpha
> media-plugins/vdr-graphtft-0.1.21_alpha
> media-plugins/vdr-image-0.2.7-r1
> media-plugins/vdr-image-0.2.7.26
> media-plugins/vdr-osdpip-0.0.10
> media-plugins/vdr-osdpip-0.0.8-r1
> media-plugins/vdr-osdpip-0.0.8-r2
> media-plugins/vdr-osdpip-0.0.9
> media-plugins/vdr-pcd-0.9
> media-plugins/vdr-softdevice-0.4.0
> media-plugins/vdr-softdevice-0.4.0.20070711
> media-plugins/vdr-softdevice-0.4.0.20070711-r1
> media-plugins/vdr-softdevice-0.4.0.20080120
> media-plugins/vdr-softdevice-0.5.0
> media-plugins/vdr-softdevice-0.5.0-r1
> media-plugins/vdr-softdevice-0.5.0.20080922
> media-plugins/vdr-softplay-0.0.2.20060815
> media-plugins/vdr-softplay-0.0.2.20070730
> media-plugins/vdr-softplay-0.0.2.20080421

What about these? Can't test them myself.

> media-tv/nuvexport (do we need this package? does it work?)

Cardoe told me on IRC this is a perl script..
Comment 10 Samuli Suominen gentoo-dev 2008-12-17 06:58:48 UTC
> media-plugins/vdr-audiorecorder-0.1.0_pre6
> media-plugins/vdr-dxr3-0.2.8
> media-plugins/vdr-graphtft-0.1.18_alpha
> media-plugins/vdr-graphtft-0.1.21_alpha
> media-plugins/vdr-image-0.2.7-r1
> media-plugins/vdr-image-0.2.7.26
> media-plugins/vdr-osdpip-0.0.10
> media-plugins/vdr-osdpip-0.0.8-r1
> media-plugins/vdr-osdpip-0.0.8-r2
> media-plugins/vdr-osdpip-0.0.9
> media-plugins/vdr-pcd-0.9
> media-plugins/vdr-softdevice-0.4.0
> media-plugins/vdr-softdevice-0.4.0.20070711
> media-plugins/vdr-softdevice-0.4.0.20070711-r1
> media-plugins/vdr-softdevice-0.4.0.20080120
> media-plugins/vdr-softdevice-0.5.0
> media-plugins/vdr-softdevice-0.5.0-r1
> media-plugins/vdr-softdevice-0.5.0.20080922
> media-plugins/vdr-softplay-0.0.2.20060815
> media-plugins/vdr-softplay-0.0.2.20070730
> media-plugins/vdr-softplay-0.0.2.20080421

Cleaned up everything that didn't compile and/or link against -lswscale properly. This bug should be fixed now, thank you for the non-cooperation from vdr the maintainers.

Thanks Cardoe for providing the answers :)