Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 214740 - [Tracker] Prepare applications to use newer ffmpeg
Summary: [Tracker] Prepare applications to use newer ffmpeg
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords: Tracker
: 219940 228713 232332 (view as bug list)
Depends on: 215926 218088 218089 218090 218091 218093 218094 218096 218097 218098 218099 218101 218104 218105 228731 229621 230143 231063 245467 245836
Blocks:
  Show dependency tree
 
Reported: 2008-03-25 16:33 UTC by Luca Barbato
Modified: 2008-12-13 07:54 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ffmpeg2theora-newffmpeg.diff (ffmpeg2theora-newffmpeg.diff,505 bytes, patch)
2008-03-25 23:19 UTC, Hanno Böck
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Luca Barbato gentoo-dev 2008-03-25 16:33:58 UTC
FFmpeg recently changed all the include paths. Every application using it should update. I'd like to put a new ffmpeg snapshot in portage, thus I'd update every application to use the new paths.

Reverse dep list:

app-cdr/k3b
app-emulation/vice
app-mobilephone/bitpim
dev-libs/DirectFB-extra
dev-php4/ffmpeg-php
dev-php5/ffmpeg-php
dev-util/bugle
games-arcade/stepmania
games-misc/jugglemaster
media-gfx/album
media-gfx/blender
media-libs/libquicktime
media-libs/mediastreamer
media-libs/mlt
media-libs/swfdec
media-libs/xine-lib
media-plugins/alsa-plugins
media-plugins/mytharchive
media-plugins/vdr-audiorecorder
media-plugins/vdr-graphtft
media-plugins/vdr-image
media-plugins/vdr-osdpip
media-plugins/vdr-pcd
media-plugins/vdr-softdevice
media-plugins/vdr-softplay
media-plugins/xmms-wma
media-sound/cmus
media-sound/gnusound
media-sound/moc
media-sound/mt-daapd
media-sound/picard
media-sound/potamus
media-sound/slimserver
media-sound/soundkonverter
media-sound/sox
media-tv/nuvexport
media-tv/xdtv
media-video/cinelerra-cvs
media-video/coriander
media-video/dvbcut
media-video/dvd-slideshow
media-video/dvdrip
media-video/ffmpeg2theora
media-video/ffmpegthumbnailer
media-video/freej
media-video/gpac
media-video/jubler
media-video/kdenlive
media-video/kino
media-video/lives
media-video/motion
media-video/mpeg4ip
media-video/nemesi
media-video/noad
media-video/tcvp
media-video/tovid
media-video/transcode
media-video/vdr2jpeg
media-video/videotrans
media-video/vlc
media-video/winki
media-video/winki
net-im/wengophone
net-libs/opal
net-libs/openh323
net-misc/linphone
net-voip/linphone
net-www/gnash
sci-geosciences/grass
sci-visualization/paraview
www-apps/gallery
www-misc/zoneminder
x11-misc/xvidcap
Comment 1 Patrizio Bassi 2008-03-25 21:37:19 UTC
just a note:

this is duplicate
media-video/winki
media-video/winki

overlay??
net-misc/linphone
net-voip/linphone
Comment 2 Hanno Böck gentoo-dev 2008-03-25 23:19:20 UTC
Created attachment 147319 [details, diff]
ffmpeg2theora-newffmpeg.diff

This patches ffmpeg2theora (also sent upstream), but it'll let the compile probably fail with older ffmpeg versions. We'll probably have the same issue with all apps.
Comment 3 Luca Barbato gentoo-dev 2008-03-26 00:17:45 UTC
The plan is to push updated version in p.mask and then switch
Comment 4 timofonic 2008-03-26 08:56:27 UTC
(In reply to comment #3)
> The plan is to push updated version in p.mask and then switch
> 

Plan? How many days until this situation gets resolved? Please, this change broke a lot packages.
Comment 5 Luca Barbato gentoo-dev 2008-03-26 09:01:44 UTC
which change? Currently nothing changed, we are pushing in p.mask updates so people willing to early switch can once the applications he is interested it are in the tree.
Comment 6 Joerg Bornkessel gentoo-dev 2008-03-29 17:02:04 UTC
media-plugins/vdr-graphtft
media-plugins/vdr-image
media-plugins/vdr-osdpip
media-plugins/vdr-pcd
( fixed by patch )

media-video/vdr2jpeg-0.1.0 
( version bump, patch, masked by p.mask )

open packages for gentoo-vdr-project:
media-plugins/vdr-audiorecorder
media-plugins/vdr-softdevice
media-plugins/vdr-softplay
Comment 7 Luca Barbato gentoo-dev 2008-03-30 22:49:34 UTC
blender got patched too
Comment 8 Ben de Groot (RETIRED) gentoo-dev 2008-04-13 23:41:25 UTC
xvidcap-1.1.7_rc1 is patched and added to the mask
Comment 9 Ben de Groot (RETIRED) gentoo-dev 2008-04-14 01:17:11 UTC
media-video/gpac is already patched as well
newly added media-video/transcode-1.1.0_alpha7 has patch
Comment 10 Alexis Ballier gentoo-dev 2008-04-14 07:46:05 UTC
(In reply to comment #0)
> media-libs/libquicktime

fixed in their cvs, needs someone to backport it or wait for a new release

> media-libs/mlt
> media-libs/xine-lib
> media-sound/moc
> media-sound/sox
> media-tv/xdtv
> media-video/cinelerra-cvs
> media-video/ffmpegthumbnailer
> media-video/gpac
> media-video/kdenlive

all good now

> media-video/transcode

1.0.6_rc2 fixes it; allowing both old and new layout

> media-video/vlc

0.9.0* good

> media-video/winki

command line only
Comment 11 Ben de Groot (RETIRED) gentoo-dev 2008-04-17 13:20:34 UTC
I have assigned all remaining packages to their respective herds. So if you fix a package or know that a newly committed version fixes the issue, please comment on the specific bug, not on this tracker bug. Thank you all for your cooperation!

Also, the following packages are not in portage:
media-plugins/xmms-wma
media-video/tcvp
net-im/wengophone
Comment 12 Ben de Groot (RETIRED) gentoo-dev 2008-05-01 15:27:47 UTC
*** Bug 219940 has been marked as a duplicate of this bug. ***
Comment 13 Ben de Groot (RETIRED) gentoo-dev 2008-06-13 22:22:14 UTC
The remaining packages at this moment are:

games-arcade/stepmania - needs patch - drac
media-video/jubler  - reported upstream by serkan, has !=ffmpeg-0.4.9_p2008*
media-plugins/vdr-graphtft - zzam?

media-sound/gnusound - needs testing - drac
media-sound/potamus  - needs patch - drac

media-video/motion - works but disables ffmpeg support even with USE=ffmpeg,
                     because headers are not found

voip herd:
media-libs/mediastreamer
net-libs/opal
net-libs/openh323
net-voip/linphone - patch available

no-herd:
media-video/mpeg4ip
net-www/gnash

I have updated all the depending bugs where needed, and asked the maintainers of remaining packages to take action. I propose to unmask newer ffmpeg next week.
Comment 14 Ben de Groot (RETIRED) gentoo-dev 2008-06-20 12:57:55 UTC
ffmpeg-0.4.9_p20080326 is unmasked now, and the remaining incompatible ~arch packages/versions have been masked. Stable versions will build against current stable ffmpeg.
Comment 15 Patrizio Bassi 2008-06-21 08:27:34 UTC
as said in the comment #13

gnash i totally unavailable now and mpeg4ip cannot compile due to --as-needed flag (patch available in next -rX which are masked)...

found reference in http://bugs.gentoo.org/show_bug.cgi?id=218105

Comment 16 Carsten Lohrke (RETIRED) gentoo-dev 2008-06-21 11:22:38 UTC
*** Bug 228713 has been marked as a duplicate of this bug. ***
Comment 17 Beetle B. 2008-07-07 19:02:18 UTC
Current (and only) stable version (x86) for blender (2.43-r2) is *not* patched for ffmpeg.

Current (and only) stable version (x86) for gpac (0.4.2-r1) is *not* patched for ffmpeg.

Also, kino-1.2.0 - the only stable version (x86) dies during compilation. I suspect it is an ffmpeg issue as well. I updated to kino-1.3.0 and it works fine. 
Comment 18 Beetle B. 2008-07-07 19:13:12 UTC
And apparently the latest gpac won't compile for me either (ffmpeg errors). 
Comment 19 Jeroen Roovers (RETIRED) gentoo-dev 2008-07-19 14:24:15 UTC
*** Bug 232332 has been marked as a duplicate of this bug. ***
Comment 20 Samuli Suominen gentoo-dev 2008-12-10 16:56:17 UTC
(In reply to comment #13)
> The remaining packages at this moment are:
> games-arcade/stepmania - needs patch - drac

I believe someone else patched it and f*cked up the patchset by sticking files into ${FILESDIR} so FYI, I won't be touching it because of that anymore.

> media-sound/potamus  - needs patch - drac

Fixed and unmasked.
Comment 21 Samuli Suominen gentoo-dev 2008-12-11 11:10:38 UTC
Unupdated bug, closing. FFMPEG is going stable.