Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 217427 - Stabilize media-video/mjpegtools-1.9.0
Summary: Stabilize media-video/mjpegtools-1.9.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Highest enhancement (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords: STABLEREQ
: 245559 (view as bug list)
Depends on:
Blocks: gcc-4.3-stable
  Show dependency tree
 
Reported: 2008-04-12 16:33 UTC by Arfrever Frehtes Taifersar Arahesis (RETIRED)
Modified: 2011-05-04 22:15 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2008-04-12 16:33:24 UTC
Stabilize media-video/mjpegtools-1.9.0_rc3.
Comment 1 Alexis Ballier gentoo-dev 2008-11-04 19:14:09 UTC
*** Bug 245559 has been marked as a duplicate of this bug. ***
Comment 2 Elias Probst 2008-11-26 09:18:36 UTC
I request to have it stabilized, too, as mjpegtools-1.8* don't compile using gcc-4.3*

I'm running amd64 and it works fine here.
Comment 3 Brian Beardall 2008-12-24 05:59:41 UTC
I request that it not be marked stable yet as I'm experiencing problems with yuvdeinterlace in mjpegtools-1.9.0_rc3. yuvdeinterlace is fixed for me in version 1.9.0_rc4
Comment 4 Steve Dibb (RETIRED) gentoo-dev 2009-01-10 12:20:59 UTC
(In reply to comment #3)
> I request that it not be marked stable yet as I'm experiencing problems with
> yuvdeinterlace in mjpegtools-1.9.0_rc3. yuvdeinterlace is fixed for me in
> version 1.9.0_rc4
> 

I vote we wait for 1.9.0 release.
Comment 5 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-02-06 21:12:20 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > I request that it not be marked stable yet as I'm experiencing problems with
> > yuvdeinterlace in mjpegtools-1.9.0_rc3. yuvdeinterlace is fixed for me in
> > version 1.9.0_rc4
> > 
> 
> I vote we wait for 1.9.0 release.
> 

beandog,
I don't see any bugs on 1.9.0. Let's do it - (needed for gcc-4.3 stab)

Keywords: mjpegtools-1.9.0: ~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 
Comment 6 Ryan Hill (RETIRED) gentoo-dev 2009-02-08 07:27:39 UTC
this is high priority
Comment 7 Peter Alfredsen (RETIRED) gentoo-dev 2009-02-12 05:49:12 UTC
Needed for gcc-4.3 stabilization. Good to go.
Comment 8 Brent Baude (RETIRED) gentoo-dev 2009-02-13 16:31:44 UTC
ppc64 stable
Comment 9 Markus Meier gentoo-dev 2009-02-14 22:00:18 UTC
amd64/x86 stable
Comment 10 Brent Baude (RETIRED) gentoo-dev 2009-02-15 13:53:12 UTC
ppc stable
Comment 11 Stuart Hickinbottom 2009-02-15 14:36:04 UTC
I run a headless (X-less) server that includes mjpegtools and it's trying to update from 1.8.0-r1 to 1.9.0 as a result of stabilisation. I get build errors as a result of the lack of X11:

creating png2yuv
(cd .libs && rm -f liblavrec.la && ln -s ../liblavrec.la liblavrec.la)
/bin/sh ../libtool --tag=CC   --mode=link i686-pc-linux-gnu-gcc  -march=prescott -O2 -pipe -fomit-frame-pointer -fno-strict-aliasing -pthread -Wall -Wunused  -Wl,-O1 -o lav2wav lav2wav.o ../utils/libmjpegutils.la  liblavfile.la -lm
/bin/sh ../libtool --tag=CC   --mode=link i686-pc-linux-gnu-gcc  -march=prescott -O2 -pipe -fomit-frame-pointer -fno-strict-aliasing -pthread -Wall -Wunused  -Wl,-O1 -o lav2yuv lav2yuv-lav2yuv.o lav2yuv-lav_common.o ../utils/libmjpegutils.la  liblavfile.la liblavjpeg.la -lm
i686-pc-linux-gnu-gcc -shared  .libs/liblavplay_la-liblavplay.o .libs/liblavplay_la-audiolib.o  -Wl,--rpath -Wl,/var/tmp/portage/media-video/mjpegtools-1.9.0/work/mjpegtools-1.9.0/lavtools/.libs -Wl,--rpath -Wl,/var/tmp/portage/media-video/mjpegtools-1.9.0/work/mjpegtools-1.9.0/utils/.libs -L/var/tmp/portage/media-video/mjpegtools-1.9.0/work/mjpegtools-1.9.0/utils/.libs ./.libs/liblavfile.so -L/usr/lib /usr/lib/libSDL.so -lpthread ./.libs/liblavjpeg.so ../utils/.libs/libmjpegutils.so -lX11 -lm  -march=prescott -pthread -Wl,-O1 -Wl,-soname -Wl,liblavplay-1.9.so.0 -o .libs/liblavplay-1.9.so.0.0.0
/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lX11
collect2: ld returned 1 exit status
make[2]: *** [liblavplay.la] Error 1

I don't believe it used to require X11, and the RDEPEND still has X as an optional dependency based on USE flags.
Comment 12 Tobias Klausmann gentoo-dev 2009-02-15 15:15:10 UTC
Stable on alpha.
Comment 13 Stuart Hickinbottom 2009-02-17 13:50:45 UTC
(In reply to comment #11)
> I run a headless (X-less) server that includes mjpegtools and it's trying to
> update from 1.8.0-r1 to 1.9.0 as a result of stabilisation. I get build errors
> as a result of the lack of X11:
> ...

Looking into this further I've tracked it down to "lavtools/Makefile.in", which contains the following:
@HAVE_V4L_TRUE@am__append_4 = ${X_LIBS} -lX11

I have V4L enabled (the server does indeed have a USB-connected camera), but the makefile wrongly assumes that means X as well. Removing that "-lX11" makes things work for me, but I'm not sure what the ramifications are for other people's USE flag combinations.
Comment 14 Steve Brudenell 2009-02-19 19:24:57 UTC
(In reply to comment #13)
(In reply to comment #11)

I have the same problem as these two. I have USE=-X and the ebuild correctly configures with --without-x, but the Makefile adds in -lX11 anyway.

This same condition happens with both 1.9.0_rc4 and the "stable" 1.9.0, but doesn't happen with 1.9.0_rc3. I'm not sure what happened here.
Comment 15 Steve Brudenell 2009-02-19 20:07:19 UTC
spoke too soon; actually this bug does also exist in 1.9.0_rc3.
Comment 16 Stuart Hickinbottom 2009-02-19 21:32:54 UTC
To my untrained eye it was this commit made a couple of weeks ago to the upstream source:
http://mjpeg.cvs.sourceforge.net/viewvc/mjpeg/mjpeg_play/lavtools/Makefile.am?r1=1.117&r2=1.118

From their changelog:
 Need to add back, but conditionally, ${X_LIBS} -lX11.  Can't use HAVE_X
 because OSX 10.5 has X but adding extra -lX11 options causes problems.  Use
 HAVE_V4L in hopes that only linux systems will be affected.

I think this is an upstream bug.
Comment 17 Christian Faulhammer (RETIRED) gentoo-dev 2009-02-19 23:33:15 UTC
(In reply to comment #16)

> I think this is an upstream bug.

 Could you please report it or check if the upstream repository has already a fix?
Comment 18 Stuart Hickinbottom 2009-02-20 09:05:43 UTC
(In reply to comment #17)
>  Could you please report it or check if the upstream repository has already a
> fix?
> 

Done:
https://sourceforge.net/mailarchive/forum.php?thread_name=499E6A37.9090209%40hickinbottom.com&forum_name=mjpeg-developer
Comment 19 Raúl Porcel (RETIRED) gentoo-dev 2009-03-03 15:55:23 UTC
sparc stable, closing
Comment 20 damage 2009-07-10 08:57:49 UTC
Hi guys,
I think closing this bug is not what we want.

mjpegtools HAS a bug with the current ebuild (see above, -lX11 problem). So setting this to resolved and adding the stable arch flags to the ebuild while some is posting that he has opened a bug on the upstream looks ugly.

I'm sorry if I have misunderstand something.

This problem still occurs in media-video/mjpegtools-1.9.0 which is current X86 stable.

greez
Damage
Comment 21 Stuart Hickinbottom 2011-05-04 22:15:08 UTC
Note that I've just had an email from the mjpegtools list (following up my report in comment#18):
http://sourceforge.net/mailarchive/message.php?msg_id=27446907

I've tried this version from CVS and it does build on a Gentoo without X11 installed. Either the recent commit could be bundled into a patch for 1.9.0, or else it would be picked up anyway in the next mjpegtools release and ebuild update.

I'm not personally waiting for this (masking 1.9.0 works for me), but wanted to report this update here.