Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 216009 - media-libs/swfdec-0.6.2: Sandbox violations
Summary: media-libs/swfdec-0.6.2: Sandbox violations
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
: 216575 (view as bug list)
Depends on:
Blocks: gnome2.22-tracker
  Show dependency tree
Reported: 2008-04-03 09:22 UTC by Alexander Skwar
Modified: 2008-04-07 02:12 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---

swfdec-0.6.2.ebuild (swfdec-0.6.2.ebuild,2.10 KB, text/plain)
2008-04-05 17:05 UTC, Nguyen Thai Ngoc Duy (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Skwar 2008-04-03 09:22:32 UTC
[ebuild  N    ] media-libs/swfdec-0.6.2  USE="alsa doc -ffmpeg gstreamer gtk mad -oss -pulseaudio" 0 kB 

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-11138.log"

open_wr:   /root/.gconf/.testing.writeability
unlink:    /root/.gconf/.testing.writeability
open_wr:   /root/.gconfd/saved_state
open_wr:   /root/.gconfd/saved_state
open_wr:   /root/.gstreamer-0.10/registry.i686.xml.tmpJ3238T
open_wr:   /root/.gstreamer-0.10/registry.i686.xml.tmpXD338T
open_wr:   /root/.gconfd/saved_state
open_wr:   /root/.gconfd/saved_state
open_wr:   /root/.gconfd/saved_state
open_wr:   /root/.gconfd/saved_state
open_wr:   /root/.gconfd/saved_state.tmp

--($:~)-- emerge --info
Portage (default-linux/x86/2007.0/desktop, gcc-4.2.3, glibc-2.7-r2, i686)
System uname: i686 Genuine Intel(R) CPU T2400 @ 1.83GHz
Timestamp of tree: Thu, 03 Apr 2008 06:15:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.5
dev-lang/python:     2.5.1-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.12
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.24
CFLAGS="-march=pentium-m -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=pentium-m -O2 -pipe -fomit-frame-pointer"
FEATURES="buildpkg ccache collision-protect distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X acpi alsa berkdb bluetooth cairo cdr cli cracklib crypt cups dbus dmi doc dri dvd dvdr dvdread encode fam firefox fortran gdbm gif gnome gnutls gpm gstreamer gtk hal iconv isdnlog jpeg kde kdeenablefinal kdehiddenvisibility keyring ldap libnotify mad midi mmx mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl pam pcmcia pcre pdf perl png pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl sse sse2 ssl svg tcpd tiff truetype unicode vorbis wifi win32codecs x86 xine xinerama xml xorg xv zlib" ALSA_CARDS="hda-intel intel8x0 intel8x0m usb-audio usb-usx3y" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CAMERAS="ptp2 directory" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="nv nvidia vga none"
Comment 1 Alexander Skwar 2008-04-03 09:26:57 UTC
Compiling swfdec with USE=-gstreamer "fixes" the problem.
Comment 2 Ian Abbott 2008-04-03 14:01:27 UTC
Compiling swfdec with USE="-doc" also "fixes" the problem!

Here's a snippet of build output on my system:

creating swfdec-scan
gtk-doc: Running scanner swfdec-scan
ACCESS DENIED  open_wr:   /root/.gstreamer-0.10/registry.x86_64.xml.tmp3PKV8T
ACCESS DENIED  open_wr:   /root/.gstreamer-0.10/registry.x86_64.xml.tmp1JIV8T
touch scan-build.stamp
make[2]: vfork: Invalid argument
make[2]: Leaving directory `/var/tmp/portage/media-libs/swfdec-0.6.2/work/swfdec-0.6.2/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-libs/swfdec-0.6.2/work/swfdec-0.6.2'
make: *** [all] Error 2
Comment 3 Ian Abbott 2008-04-03 14:34:04 UTC
I re-emerged gtk-doc (dev-util/gtk-doc-1.10-r1) and that allowed swfdec to build successfully with both the 'doc' and 'gstreamer' use flags.
Comment 4 Graham Murray 2008-04-03 18:50:44 UTC
(In reply to comment #3)
> I re-emerged gtk-doc (dev-util/gtk-doc-1.10-r1) and that allowed swfdec to
> build successfully with both the 'doc' and 'gstreamer' use flags.

re emerging gtk-doc had no effect for me. It still shows the same sandbox violations.
Comment 5 Ian Abbott 2008-04-04 22:12:19 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > I re-emerged gtk-doc (dev-util/gtk-doc-1.10-r1) and that allowed swfdec to
> > build successfully with both the 'doc' and 'gstreamer' use flags.
> > 
> re emerging gtk-doc had no effect for me. It still shows the same sandbox
> violations.

Sorry, re-emerging gtk-doc tuned out to be a red herring! What actually allowed me to emerge swfdec successfully was running the following commands after it failed:

  cd /var/tmp/portage/media-libs/swfdec-0.6.2/work/swfdec-0.6.2/doc
  make clean

and then emerging swfdec again. This is not a valid fix as it leaves mess behind in the /root directory, and besides, it's easier to emerge with FEATURES="-sandbox" (also not a valid fix of course).
Comment 6 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2008-04-05 16:40:01 UTC
swfdec-scan is linked to libgstreamer and libgconf. As a result, when these libraries are intialized, they try to access /root.

Setting GST_REGISTRY (for example to /tmp/registry.xml) will avoid gstreamer access violation. gconf violation is more difficult though. 
Comment 7 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2008-04-05 17:05:33 UTC
Created attachment 148760 [details]

Please try the attached ebuild. The diff is

diff --git a/media-libs/swfdec/swfdec-0.6.2.ebuild b/media-libs/swfdec/swfdec-0.6.2.ebuild
index 54b3aaf..f5c028b 100644
--- a/media-libs/swfdec/swfdec-0.6.2.ebuild
+++ b/media-libs/swfdec/swfdec-0.6.2.ebuild
@@ -59,6 +59,12 @@ src_compile() {
 	use alsa && myaudio="alsa"
 	myconf=" --with-audio=$myaudio"
+	# bug #216009
+	# avoid writing to /root/.gstreamer-0.10/registry.xml
+	export GST_REGISTRY="${T}"/registry.xml
+	# also avoid loading gconf plugins, which may write to /root/.gconfd
 	econf \
 		$(use_enable doc gtk-doc) \
 		$(use_enable gstreamer) \
Comment 8 Ian Abbott 2008-04-05 20:17:45 UTC
I cleaned out the the files left behind in the /root directory from my earlier experiments (to start with a clean slate) and tried Nguyen Thai Ngoc Duy's patched ebuild. It worked for me!

FTR, here are my USE flags for the ebuild:

[ebuild   R   ] media-libs/swfdec-0.6.2  USE="alsa doc gstreamer gtk mad -ffmpeg -oss -pulseaudio" 0 kB

Thanks for the fix!
Comment 9 Ed Catmur 2008-04-06 12:47:38 UTC
Please mark as blocking bug 214260.
Comment 10 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2008-04-06 13:00:08 UTC
I'm waiting for at least one more user confirming this bug is fixed before I commit it. So please test.
Comment 11 Ed Catmur 2008-04-06 13:59:55 UTC
Confirm ebuild fixes bug here.
Comment 12 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2008-04-06 18:45:53 UTC
Comment 13 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2008-04-07 02:12:42 UTC
*** Bug 216575 has been marked as a duplicate of this bug. ***