Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 215442 - 2.6.24 does not import defconfig unless explicitly told to do [i386/x86_64]
Summary: 2.6.24 does not import defconfig unless explicitly told to do [i386/x86_64]
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
URL: http://bugzilla.kernel.org/show_bug.c...
Whiteboard: linux-2.6.24-regression
Keywords: InVCS
: 220031 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-03-30 15:32 UTC by Kerin Millar
Modified: 2008-05-09 04:40 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kerin Millar 2008-03-30 15:32:44 UTC
As per the summary. Try exporting ARCH to "i386" or "x86_64" then run:

# make mrproper
# make menuconfig

Compare and contrast with:

# make mrproper
# make defconfig
# make menuconfig

This is causing havoc; I've lost count of the number of people who have come into #gentoo complaining that they can't find required options (espsecially due ot CONFIG_PCI  being disabled) and it's causing a significant inflation of other common kernel configuration problems. The worst affected is the new user, who has neither /boot mounted with a prior config or is in a position to run make oldconfig. Not ideal.

I've not yet looked into why this is but assume it has something to do with the x86 architecture merge. Please can we get a fix into genpatches ASAP? In fact, I'd like to see this go into the stable queue - although upstream may not care as kernel configuration is considered to be a matter for distro vendors to consider rather than end-users.
Comment 1 Mike Pagano gentoo-dev 2008-04-05 12:35:03 UTC
A temporary workaround has been committed to the tree. Keeping this bug open until a proper fix exists upstream.
Comment 2 Mike Pagano gentoo-dev 2008-04-07 13:07:07 UTC
releng friends: Please consider including the latest kernel-2.eclass file which contains the temporary workaround that addresses this bug.

Comment 3 Christian Heim (RETIRED) gentoo-dev 2008-04-07 13:19:34 UTC
(In reply to comment #2)
> releng friends: Please consider including the latest kernel-2.eclass file which
> contains the temporary workaround that addresses this bug.

I added it to the snapshot, so someone blame me if stuff breaks ...
Comment 4 Daniel Drake (RETIRED) gentoo-dev 2008-04-17 17:54:42 UTC
will track the upstream bug report now
Comment 5 Daniel Drake (RETIRED) gentoo-dev 2008-04-17 17:55:54 UTC
for reference: the change we made in the tree to work around the issue is just to run "make defconfig" on affected systems after kernel sources have been installed (kernel-2.eclass modification)
Comment 6 Daniel Drake (RETIRED) gentoo-dev 2008-05-02 16:45:56 UTC
upstream patch available
Comment 7 Daniel Drake (RETIRED) gentoo-dev 2008-05-02 16:46:10 UTC
*** Bug 220031 has been marked as a duplicate of this bug. ***
Comment 8 Chris Gianelloni (RETIRED) gentoo-dev 2008-05-02 18:11:10 UTC
OK, should I pull the eclass or will you be rolling another genpatches version with this fixed?
Comment 9 Daniel Drake (RETIRED) gentoo-dev 2008-05-02 18:54:26 UTC
Will do another 2.6.24 release today, mark stable tomorrow, then request that you include the new gentoo-sources/genpatches for 2008.0 (assuming there is still time).

The eclass hack will also be dropped tomorrow, and if possible it would be good to get that removed from the snapshot too. It had some undesirable side effects (although only minor)
Comment 10 Chris Gianelloni (RETIRED) gentoo-dev 2008-05-03 00:52:29 UTC
Sounds good.  Just add release to CC on the stabilization bug.
Comment 11 Daniel Drake (RETIRED) gentoo-dev 2008-05-04 09:43:57 UTC
fixed in gentoo-sources-2.6.24-r7 and gentoo-sources-2.6.25-r2. eclass hack removed.

Chris, 2.6.24-r7 has been marked stable, there is no stabilisation bug because I do it myself. Please add 2.6.24-r7 to the snapshot and revert the eclass change you made earlier. Do you want a new bug for this request?
Comment 12 Chris Gianelloni (RETIRED) gentoo-dev 2008-05-09 04:40:20 UTC
Updated in the release snapshot...