Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 213361 - www-client/epiphany fails to compile with net-libs/xulrunner-1.9
Summary: www-client/epiphany fails to compile with net-libs/xulrunner-1.9
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 217257 (view as bug list)
Depends on:
Blocks: xul-1.9
  Show dependency tree
 
Reported: 2008-03-14 09:29 UTC by Nirbheek Chauhan (RETIRED)
Modified: 2008-06-20 07:54 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
epiphany-xulrunner19.patch (epiphany-xulrunner19.patch,20.75 KB, patch)
2008-03-14 20:55 UTC, Pacho Ramos
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nirbheek Chauhan (RETIRED) gentoo-dev 2008-03-14 09:29:41 UTC
Compilation error for www-client/epiphany-{2.22.0,2.20.3} USE=xulrunner (same error for both versions) :

mv -f .deps/libephymozillaembed_la-EphyContentPolicy.Tpo .deps/libephymozillaembed_la-EphyContentPolicy.Plo
EphyAboutModule.cpp: In member function ‘nsresult EphyAboutModule::GetErrorMessage(nsIURI*, const char*, char**, char**, char**, char**, char**, char**)’:
EphyAboutModule.cpp:232: warning: deprecated conversion from string constant to ‘char*’
EphyAboutModule.cpp:433: warning: deprecated conversion from string constant to ‘char*’
mv -f .deps/libephymozillaembed_la-EphyAboutModule.Tpo .deps/libephymozillaembed_la-EphyAboutModule.Plo
mv -f .deps/libephymozillaembed_la-EphyDirectoryProvider.Tpo .deps/libephymozillaembed_la-EphyDirectoryProvider.Plo
make[4]: Leaving directory `/var/tmp/portage/www-client/epiphany-2.22.0/work/epiphany-2.22.0/embed/mozilla'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/www-client/epiphany-2.22.0/work/epiphany-2.22.0/embed'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/www-client/epiphany-2.22.0/work/epiphany-2.22.0/embed'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/www-client/epiphany-2.22.0/work/epiphany-2.22.0'
make: *** [all] Error 2
 * 
 * ERROR: www-client/epiphany-2.22.0 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2606:  Called gnome2_src_compile
 *             environment, line 1970:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/www-client/epiphany-2.22.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/www-client/epiphany-2.22.0/temp/environment'.
 *
Comment 1 Pacho Ramos gentoo-dev 2008-03-14 20:55:17 UTC
Created attachment 146158 [details, diff]
epiphany-xulrunner19.patch

This is the patch used by fedora
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-04-10 22:09:57 UTC
epiphany 2.22.1 is supposed to have fixes to build against xulrunner 1.9. Please test.
Comment 3 Mark Loeser (RETIRED) gentoo-dev 2008-04-11 15:12:28 UTC
*** Bug 217257 has been marked as a duplicate of this bug. ***
Comment 4 Boney McCracker 2008-05-03 20:19:34 UTC
(In reply to comment #2)
> epiphany 2.22.1 is supposed to have fixes to build against xulrunner 1.9.
> Please test.
> 

2.22.1 builds and runs fine for me:
    net-libs/xulrunner-1.9_beta5-r1
    www-client/epiphany-2.22.1.1
Comment 5 Mart Raudsepp gentoo-dev 2008-06-20 07:54:20 UTC
I have added epiphany-2.22.2-r10 to the tree, that builds against xulrunner-1.9 final (since xul-1.9_rc1 a patch was needed). So we can probably consider this bug fixed then