Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 217257 - www-client/epiphany-2.22.1.1 refuses to build with xulrunner-1.9_beta5 - fix
Summary: www-client/epiphany-2.22.1.1 refuses to build with xulrunner-1.9_beta5 - fix
Status: RESOLVED DUPLICATE of bug 213361
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-11 09:02 UTC by Grzegorz A. Daszuta
Modified: 2008-04-11 15:12 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Grzegorz A. Daszuta 2008-04-11 09:02:27 UTC
www-client/epiphany-2.22.1.1 refuses to build with xulrunner-1.9_beta5, there's a problem like:

> checking which gecko to use... xulrunner
> checking manual gecko home set... Package xulrunner was not found in the 
> pkg-config search path.
> Perhaps you should add the directory containing `xulrunner.pc'
> to the PKG_CONFIG_PATH environment variable
> No package 'xulrunner' found
> Package xulrunner-unstable was not found in the pkg-config search path.
> Perhaps you should add the directory containing `xulrunner-unstable.pc'
> to the PKG_CONFIG_PATH environment variable
> No package 'xulrunner-unstable' found
> checking for compiler -fshort-wchar option... yes
> checking whether to enable C++ RTTI... no
> checking whether we have a gtk 2 gecko build... configure: error: This 
> program needs a gtk 2 gecko build

quick look into xulrunner-1.9_beta5 package contents revealed that some minor mod on epiphany ebuild should do, it goes like:
 	if use xulrunner; then
-		G2CONF="${G2CONF} --with-gecko=xulrunner"
+		G2CONF="${G2CONF} --with-gecko=libxul-embedding"
 	else

voila! ephy runs and scores 71 in acid3, just like ff3

I wonder why --with-gecko=libxul won't act instead --with-gecko=libxul-embedding, it's probably due to some pkgconfig issues, but have no time at the moment to track it.

sincerely,
Grzesiek

Reproducible: Always

Steps to Reproduce:
Comment 1 Mark Loeser (RETIRED) gentoo-dev 2008-04-11 15:12:28 UTC
Not the same exact failure, but still related.  Please add your failure information to the other bug.

Thanks

*** This bug has been marked as a duplicate of bug 213361 ***