Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 21310 - a standard way to install includes (doinclude/doheader)
Summary: a standard way to install includes (doinclude/doheader)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Hosted Projects
Classification: Unclassified
Component: PMS/EAPI (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: PMS/EAPI
URL:
Whiteboard: in-eapi-5
Keywords:
Depends on:
Blocks: future-eapi
  Show dependency tree
 
Reported: 2003-05-19 22:33 UTC by Jason Toffaletti
Modified: 2012-09-23 06:46 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Toffaletti 2003-05-19 22:33:37 UTC
there should be a standard way (doinclude? doheader?) to install library include files 
from ebuild scripts, similar to dolib, doman, doinfo, etc... 

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Jason Stubbs (RETIRED) gentoo-dev 2005-07-28 07:26:09 UTC
Putting a hold on feature requests for portage as they are drowning out the 
bugs. Most of these features should be available in the next major version of 
portage. But for the time being, they are just drowning out the major bugs and 
delaying the next version's progress. 
 
Any bugs that contain patches and any bugs for etc-update or dispatch-conf can 
be reopened. Sorry, I'm just not good enough with bugzilla. ;) 
Comment 2 Marius Mauch (RETIRED) gentoo-dev 2007-01-11 12:07:32 UTC
Reopen for consideration.
Comment 3 Marius Mauch (RETIRED) gentoo-dev 2007-01-11 12:07:52 UTC
And now really reopening.
Comment 5 Zac Medico gentoo-dev 2012-09-15 20:19:25 UTC
Do we intend to support the -r option? The pms patch does not document it, but the portage patch supports -r since the arguments are passed to doins.
Comment 6 Zac Medico gentoo-dev 2012-09-15 20:24:37 UTC
Or maybe -r should be implied?
Comment 7 Ulrich Müller gentoo-dev 2012-09-15 20:44:26 UTC
The code for doheader was copied from doconfd and doenvd. Is it intentional that these support -r?
Comment 8 Zac Medico gentoo-dev 2012-09-15 20:46:19 UTC
(In reply to comment #7)
> The code for doheader was copied from doconfd and doenvd. Is it intentional
> that these support -r?

Probably not. I think recursion is desirable for doheader though, since feedback on the gentoo-dev ml specifically included recursive cases.