Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 213001 - libcaca-0.99_beta13 missing cstring header in cxx/cxxtest.cpp
Summary: libcaca-0.99_beta13 missing cstring header in cxx/cxxtest.cpp
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 214219 (view as bug list)
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-03-11 03:11 UTC by Alexandre Borges Marcelo
Modified: 2008-03-22 10:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Simple patch adding cstring to cxx/cxxtest.cpp (libcaca-0.99_beta13-gcc-4.3.patch,227 bytes, patch)
2008-03-11 03:13 UTC, Alexandre Borges Marcelo
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Borges Marcelo 2008-03-11 03:11:04 UTC
libcaca fails to compile with gcc-4.3 with the strlen function in cxx/cxxtest.cpp not defined. Simply adding #include <cstring> solves the problem.

Reproducible: Always
Comment 1 Alexandre Borges Marcelo 2008-03-11 03:13:07 UTC
Created attachment 145790 [details, diff]
Simple patch adding cstring to cxx/cxxtest.cpp
Comment 2 Alexandre Borges Marcelo 2008-03-12 15:44:11 UTC
Already fixed in the svn version.
Comment 3 Alexis Ballier gentoo-dev 2008-03-22 09:50:24 UTC
*** Bug 214219 has been marked as a duplicate of this bug. ***
Comment 4 Alexis Ballier gentoo-dev 2008-03-22 10:29:26 UTC
applied, thanks!