Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 212267 - compiz-start script hardcodes which window decorator to run.
Summary: compiz-start script hardcodes which window decorator to run.
Status: RESOLVED DUPLICATE of bug 197455
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Hanno Boeck
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-04 11:47 UTC by Richard Connon
Modified: 2008-11-02 04:03 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Connon 2008-03-04 11:47:06 UTC
The compiz-start script decides which window decorator to use based on whether or not KDE is running rather than being customisable.
Surely this should respect the window decorator command set in CCSM?

Reproducible: Always

Steps to Reproduce:
1. emerge compiz-fusion
2. set a non-default window decorator command in CCSM
3. start compiz with compiz-start

Actual Results:  
Compiz runs with kde-window-decorator (or gtk-window-decorator).

Expected Results:  
Compiz should run the decorator specified in CCSM.
Comment 1 Anton Bolshakov 2008-04-23 01:24:49 UTC
sounds like the bug #197455
Comment 2 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2008-11-02 04:03:24 UTC

*** This bug has been marked as a duplicate of bug 197455 ***