Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 197455 - x11-wm/compiz-0.6.2 hard codes incorrect plug-in list via compiz-start script
Summary: x11-wm/compiz-0.6.2 hard codes incorrect plug-in list via compiz-start script
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: Desktop-Effects herd
URL:
Whiteboard:
Keywords:
: 212267 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-10-29 19:51 UTC by Greg Watson (linuxkrn)
Modified: 2008-11-02 04:03 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
compiz-start changes (compiz-start.patch,1.12 KB, patch)
2008-02-03 05:04 UTC, Paul
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Watson (linuxkrn) 2007-10-29 19:51:52 UTC
The start script for compiz (compiz-start) hard codes the list of plug-ins to run.  When in fact it, should use the ccsm/gconf backend and only run one.  If options are set via ccsm compiz will crash with random segfaults.  Replacing one line fixes this problem.

The fix:  Change line 41 of compiz-start

compiz $COMPIZ_OPTIONS gconf move resize minimize place decoration wobbly fa   de cube rotate scale switcher zoom dbus

to:

compiz $COMPIZ_OPTIONS ccp

Reference: http://wiki.zenwalk.org/index.php?title=Compiz_Fusion Item #6 bottom of page.

As another note, this was tested on both ~amd64 and ~x86.  Not sure if you wanted to modify the keywords for amd64.
Comment 1 Anton Bolshakov 2007-10-31 03:00:23 UTC
I agree. The default compiz-start doesn't work for me and destroys KDE decoration.
There are two more recommended options:

compiz $COMPIZ_OPTIONS --sm-disable --ignore-desktop-hints ccp

ps. I guess the script will be replaced with fusion-icon in future.
Comment 2 Anton Bolshakov 2007-11-01 01:47:47 UTC
btw, it would be logical to have compiz-fusion-stop script as well.
It should do something like that:
kwin --replace &
Comment 3 Petteri Räty (RETIRED) gentoo-dev 2007-11-24 23:27:51 UTC
from #compiz-fusion

01:24 < Betelgeuse> crdlb: Well do you think we should fix it?
01:24 < crdlb> yes :)
01:24 < crdlb> although there is a small problem in that ccp is provided by libcompizconfig
Comment 4 Denilson Sá 2007-12-07 05:13:40 UTC
The current compiz-start script is simply broken. It does not work. So... Why still install it with the ebuild? Or, even better, why not just fix the script? So simple to do! And yet haven't been done in more then one month...
Comment 5 Paul 2008-02-03 05:04:26 UTC
Created attachment 142574 [details, diff]
compiz-start changes

This patch changes compiz-start to accept an argument regarding which window decorator to start. Lacking an argument, it will try to start a decorator that looks like your current one.
Comment 6 Richard Connon 2008-04-23 09:21:59 UTC
Surely compiz-config settings should be used not arguments to the script. If it requires libcompizconfig you should just add that as a dependancy. 90% of compiz users must have it installed anyway.
Comment 7 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2008-11-02 04:01:31 UTC
The updated compiz-0.7.8 uses the new compiz-manager startup script and fusion-icon has been added to the tree as a better replacement to start compiz.
Comment 8 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2008-11-02 04:03:24 UTC
*** Bug 212267 has been marked as a duplicate of this bug. ***