Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 204681 - dev-cpp/glibmm-2.14.2 GCC 4.3 build failure
Summary: dev-cpp/glibmm-2.14.2 GCC 4.3 build failure
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: GNOME C++ Bindings Maintainers (OBSOLETE)
URL:
Whiteboard:
Keywords:
: 207350 (view as bug list)
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-01-06 23:16 UTC by Ryan Hill (RETIRED)
Modified: 2008-03-22 22:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Hill (RETIRED) gentoo-dev 2008-01-06 23:16:01 UTC
Just missing an #include <cstring> in object.cc.  Fixed upstream, so a 2.14.3 release will fix this as well.

http://bugzilla.gnome.org/show_bug.cgi?id=498438

 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -DG_LOG_DOMAIN=\"glibmm\" -I../../glib -I../../glib -I/usr/include/sigc++-2.0 -I/usr/lib64/sigc++-2.0/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -O3 -g -march=native -fomit-frame-pointer -pipe -Wall -Wno-long-long -MT object.lo -MD -MP -MF .deps/object.Tpo -c object.cc  -fPIC -DPIC -o .libs/object.o
mv -f .deps/miscutils.Tpo .deps/miscutils.Plo
/bin/sh ../../libtool --tag=CXX   --mode=compile x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -DG_LOG_DOMAIN=\"glibmm\"  -I../../glib -I../../glib -I/usr/include/sigc++-2.0 -I/usr/lib64/sigc++-2.0/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include    -O3 -g -march=native -fomit-frame-pointer -pipe -Wall -Wno-long-long -MT objectbase.lo -MD -MP -MF .deps/objectbase.Tpo -c -o objectbase.lo objectbase.cc
 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -DG_LOG_DOMAIN=\"glibmm\" -I../../glib -I../../glib -I/usr/include/sigc++-2.0 -I/usr/lib64/sigc++-2.0/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -O3 -g -march=native -fomit-frame-pointer -pipe -Wall -Wno-long-long -MT objectbase.lo -MD -MP -MF .deps/objectbase.Tpo -c objectbase.cc  -fPIC -DPIC -o .libs/objectbase.o
object.cc: In constructor 'Glib::ConstructParams::ConstructParams(const Glib::Class&, const char*, ...)':
object.cc:110: error: 'memset' was not declared in this scope
make[5]: *** [object.lo] Error 1
make[5]: *** Waiting for unfinished jobs....
mv -f .deps/main.Tpo .deps/main.Plo
mv -f .deps/objectbase.Tpo .deps/objectbase.Plo
make[5]: Leaving directory `/var/tmp/portage/dev-cpp/glibmm-2.14.2/work/glibmm-2.14.2/glib/glibmm'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/var/tmp/portage/dev-cpp/glibmm-2.14.2/work/glibmm-2.14.2/glib/glibmm'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/dev-cpp/glibmm-2.14.2/work/glibmm-2.14.2/glib'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/dev-cpp/glibmm-2.14.2/work/glibmm-2.14.2/glib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-cpp/glibmm-2.14.2/work/glibmm-2.14.2'
make: *** [all] Error 2
 *
 * ERROR: dev-cpp/glibmm-2.14.2 failed.
Comment 1 Ryan Hill (RETIRED) gentoo-dev 2008-01-06 23:16:42 UTC
sorry, wrong herd.
Comment 2 milan hodoscek 2008-01-25 08:52:48 UTC
*** Bug 207350 has been marked as a duplicate of this bug. ***
Comment 3 Dennis Schridde 2008-03-12 13:40:46 UTC
On my system it is also blocked by bug #206063
Comment 4 Neil Cathey 2008-03-17 21:24:41 UTC
This is fixed in glibmm-2.16.0
Comment 5 Ryan Hill (RETIRED) gentoo-dev 2008-03-22 22:02:29 UTC
Fixed.