Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 206063 - dev-libs/libsigc++-2.0.18 GCC 4.3 patch
Summary: dev-libs/libsigc++-2.0.18 GCC 4.3 patch
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: x86 Linux
: High enhancement (vote)
Assignee: GNOME C++ Bindings Maintainers (OBSOLETE)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-01-16 09:52 UTC by Devils-Hawk
Modified: 2008-06-23 08:45 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gcc-4.3.0 fix for libsigc++-2.0.18 (libsigcxx-gcc43.patch,1.15 KB, patch)
2008-01-16 09:54 UTC, Devils-Hawk
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Devils-Hawk 2008-01-16 09:52:31 UTC
Fails to build because of typedef redefinitions. Upstream already fixed the bug in 2.1.1, see bump request for 2.1.1. Attached patch #undef's a compatibility layer but only for gcc >= 4.3.0 ( 2.1.1 removes it entirely, so its probably safe to do).

Reproducible: Always
Comment 1 Devils-Hawk 2008-01-16 09:54:37 UTC
Created attachment 141031 [details, diff]
gcc-4.3.0 fix for libsigc++-2.0.18
Comment 2 Ryan Hill (RETIRED) gentoo-dev 2008-01-17 01:05:01 UTC
see also bug #203931.
Comment 3 Rémi Cardona gentoo-dev 2008-03-18 06:47:31 UTC
Hum, forgot to close this one too. libsigc++ is in Gnome overlay, and shortly to package.mask.

Closing
Comment 4 Eric Thibodeau 2008-05-14 16:49:35 UTC
(In reply to comment #3)
> Hum, forgot to close this one too. libsigc++ is in Gnome overlay, and shortly
> to package.mask.
> 
> Closing
> 

I'm attempting to build the LiveDVD with gcc-4.3 and dev-libs/libsigc++ fails (obviously). It is not clear where I can find the "fixed" version of this package (the gnome overlay only seems to have ~2.1.1 and ~2.2.2 versions, not 2.0.18-r? )
Comment 5 Daniel Gryniewicz (RETIRED) gentoo-dev 2008-05-19 18:30:20 UTC
2.1.x and 2.2.x are not slotted with 2.0.18, they replace it, so just use either of those.
Comment 6 Rémi Cardona gentoo-dev 2008-05-19 22:55:57 UTC
2.2.2 is on my list of gnome-mm stabilization. Please try whatever package you need with that version of libsigc++. If it breaks, please file a bug.

Thanks
Comment 7 Andrew John Hughes 2008-06-23 08:42:53 UTC
Why has 2.0.18 not been patched?
Comment 8 Rémi Cardona gentoo-dev 2008-06-23 08:45:39 UTC
Because 2.2.2 is stable on most arches, and is asked for stabilization on the remaining arches.

Please update to 2.2.2