Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 196991 - media-tv/me-tv - a digital television (DVB) viewer for GNOME (new ebuild)
Summary: media-tv/me-tv - a digital television (DVB) viewer for GNOME (new ebuild)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: Low enhancement (vote)
Assignee: Thomas Raschbacher
URL: https://launchpad.net/me-tv
Whiteboard:
Keywords: EBUILD, InOverlay
: 197124 (view as bug list)
Depends on: 396175
Blocks:
  Show dependency tree
 
Reported: 2007-10-25 02:14 UTC by unnamedrambler
Modified: 2012-10-21 15:30 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Proposed ebuild submission. (me-tv-0.3.3.ebuild,663 bytes, text/plain)
2007-10-25 02:17 UTC, unnamedrambler
Details
Updated ebuild for 0.5.22 (me-tv-0.5.22.ebuild,769 bytes, text/plain)
2008-02-27 21:45 UTC, Schrangl Lukas
Details
Ebuild for 0.5.23 (me-tv-0.5.23.ebuild,760 bytes, text/plain)
2008-03-02 14:59 UTC, Schrangl Lukas
Details
Ebuild for 0.5.27 (me-tv-0.5.27.ebuild,760 bytes, text/plain)
2008-05-09 16:33 UTC, Henry Nnamfoh
Details
Ebuild for 0.5.29 (me-tv-0.5.29.ebuild,760 bytes, text/plain)
2008-05-09 18:17 UTC, Henry Nnamfoh
Details
Ebuild fixed for 0.5.29 (me-tv-0.5.29.ebuild,768 bytes, text/plain)
2008-05-10 13:42 UTC, Henry Nnamfoh
Details
Ebuild for O.5.30 (me-tv-0.5.30.ebuild,768 bytes, text/plain)
2008-05-18 18:50 UTC, Henry Nnamfoh
Details
Ebuild for 0.5.31 (me-tv-0.5.31.ebuild,760 bytes, text/plain)
2008-07-09 23:15 UTC, Henry Nnamfoh
Details
Ebuild for 0.6.0 (me-tv-0.6.0.ebuild,814 bytes, text/plain)
2008-09-14 13:44 UTC, jacopo lamanna
Details
Ebuild for 0.6.0 fixed (me-tv-0.6.0.ebuild,814 bytes, text/plain)
2008-09-14 13:50 UTC, jacopo lamanna
Details
Ebuild for 0.6.2 (me-tv-0.6.2.ebuild,854 bytes, text/plain)
2008-09-19 20:41 UTC, Henry Nnamfoh
Details
Ebuild for 0.6.3 (me-tv-0.6.3.ebuild,861 bytes, text/plain)
2008-10-15 22:07 UTC, Manuel Wiesinger
Details
Ebuild for 0.7.0 (me-tv-0.7.0.ebuild,890 bytes, text/plain)
2008-10-18 07:48 UTC, Henry Nnamfoh
Details
ebuild for the new stable 1.4 series (me-tv-1.4.0.6.ebuild,1.46 KB, application/octet-stream)
2012-03-07 22:48 UTC, Mario Kicherer
Details
test ebuild for 1.4.0.9 (file_196991.txt,367 bytes, text/plain)
2012-04-01 21:25 UTC, Mario Kicherer
Details
testing 1.4.0.9 (me-tv-1.4.0.9.ebuild,1.47 KB, text/plain)
2012-04-01 21:29 UTC, Mario Kicherer
Details
Me-Tv 1.4.0.9 ebuild with fixed libunique dependency (me-tv-1.4.0.9-r1.ebuild,1.47 KB, text/plain)
2012-04-20 12:33 UTC, Samuel Robyr
Details
me-tv-1.4.0.9.ebuild which applies path for sqlite/ext4 problem (me-tv-1.4.0.9.ebuild,1.17 KB, text/plain)
2012-06-10 02:33 UTC, Sven
Details
me-tv-sqlite-fix.patch for my ebuild (me-tv-sqlite-fix.patch,1.63 KB, patch)
2012-06-10 02:33 UTC, Sven
Details | Diff
me-tv-1.4.0.9.ebuild which applies path for sqlite/ext4 problem (me-tv-1.4.0.9.ebuild,1.14 KB, text/plain)
2012-06-10 02:42 UTC, Sven
Details
Version bump to 1.4.0.10 (me-tv-1.4.0.10.ebuild,1.10 KB, text/plain)
2012-07-25 21:20 UTC, Mario Kicherer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description unnamedrambler 2007-10-25 02:14:39 UTC
Me TV was developed for the modern digital lounge room with a PC for a media centre that is capable of normal PC tasks (web surfing, word processing and watching TV). It is not designed to be a full-blown media centre, such as MythTV, but will integrate well with an existing GNOME desktop.

I suggest media-tv/me-tv. 

I've attached an ebuild that merges correctly on my x86 system, however I cannot test the functionality because I do not have a tuner card. 

I pulled dependencies from this page http://gnomefiles.org/app.php/Me_TV (Requirements heading). Also, I fudged the dep versions.. how should I have done this?

The source package filename is has a strange naming convention:
me-tv-version-2.tar.gz. However it unpacks to me-tv-version/  I handled this by using a MV_P variable in the ebuild, and adding a hardcoded "cd .." in the src_unpack routine.

Any comments on the ebuild would be fantastic. I need to know what I am doing wrong before I can get better at writing ebuilds.

Casey

Reproducible: Always
Comment 1 unnamedrambler 2007-10-25 02:17:44 UTC
Created attachment 134292 [details]
Proposed ebuild submission.

In my initial report I mentioned I hard coded a cd.. I removed that as the unpack routine was able to figure it out without any help.
Comment 2 unnamedrambler 2007-10-25 02:23:57 UTC
RESTRICT="nomirror" should probably be added to the ebuild too.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-10-26 12:05:04 UTC
*** Bug 197124 has been marked as a duplicate of this bug. ***
Comment 4 Mark Somerville 2007-10-29 13:48:49 UTC
This works on my amd64 system (with media-tv/me-tv ** in /etc/portage/package.keywords, of course).

The application does require xine-lib to be compiled with the correct use flags.

Version 0.4.0 has been released. This requires gtk+ 2.12, which is currently masked by keyword.
Comment 5 unnamedrambler 2007-10-29 19:22:36 UTC
Do you know which use flags xine-lib needs to have? I'm creating an updated ebuild.
Comment 6 Robert Golding 2008-02-04 08:45:20 UTC
This is an excellent program, however the only problem I had with it was obtaining a proper channels file.  Once that was found (I think the newer version has auto search on iniitial start) it installed and worked straight out of the box.
I had tried various other apps including ktv, xine, tvtime and others, however was unable to get them up a running for the DVB card.

I think an ebuild of ME-TV would be very handy for those, like myself, who are not good a chasing down dep problems or finding the little extra thing that makes it all work.  The very reason I used Tvtime for my older analogue card.
Comment 7 Schrangl Lukas 2008-02-27 21:45:58 UTC
Created attachment 144783 [details]
Updated ebuild for 0.5.22

Here is an updated ebuild for 0.5.22. It is based on the old one I found here, just added a few deps. It compiles and runs fine on my system, but I haven't had much time for testing yet.
Comment 8 Schrangl Lukas 2008-03-02 14:59:53 UTC
Created attachment 145090 [details]
Ebuild for 0.5.23
Comment 9 Henry Nnamfoh 2008-05-09 16:33:03 UTC
Created attachment 152635 [details]
Ebuild for 0.5.27
Comment 10 Henry Nnamfoh 2008-05-09 18:17:41 UTC
Created attachment 152665 [details]
Ebuild for 0.5.29
Comment 11 Robert Golding 2008-05-10 04:03:58 UTC
The last few ebuilds have the same error, which will give you a "file not found"
The file name "${P}.tar.gz" should be "me-tv_${MV_P}.tar.gz"

Wi9th that minor error fixed it worked perfectly on my machine.
Comment 12 Henry Nnamfoh 2008-05-10 13:42:01 UTC
Created attachment 152739 [details]
Ebuild fixed for 0.5.29
Comment 13 Henry Nnamfoh 2008-05-18 18:50:18 UTC
Created attachment 153579 [details]
Ebuild for O.5.30
Comment 14 Henry Nnamfoh 2008-07-09 23:15:17 UTC
Created attachment 159992 [details]
Ebuild for 0.5.31

Ebuild for 0.5.31
Comment 15 jacopo lamanna 2008-09-14 12:34:27 UTC
Thanks for the ebuild, great software...I'm trying to make the 6.0.0 but no results. 
Comment 16 jacopo lamanna 2008-09-14 13:20:55 UTC
ebuild for 6.0.0

it needs dev-cpp/libgnomemm-2.6.0 
         dev-cpp/libgnomeuim-2.6.0

(booth added to the DEPEND var)

I made the ebuilds just by changing the version numbers (they aren't in portage or layman/gnome repo). 

me-tv-6.0.0 now compiles but the binary gives the error:

Gnome-ERROR **: Module 'libgnomeuimm_cpp_only' requires version '2.20.1' of module 'libgnomemm_cpp_only' to be installed, and you only have version '2.6.0' of 'libgnomemm_cpp_only'. Aborting application.
aborting...
Comment 17 jacopo lamanna 2008-09-14 13:44:01 UTC
Created attachment 165398 [details]
Ebuild for 0.6.0

solved (my mistake)...

ebuild for 0.6.0
Comment 18 jacopo lamanna 2008-09-14 13:47:17 UTC
Comment on attachment 165398 [details]
Ebuild for 0.6.0

><HTML><HEAD/><BODY><PRE># Copyright 1999-2008 Gentoo Foundation
># Distributed under the terms of the GNU General Public License v2
># $Header: $
>
>DESCRIPTION="Me TV is a digital television (DVB) viewer for GNOME."
>HOMEPAGE="https://launchpad.net/me-tv"
>MY_P="me-tv-${PV}"
>SRC_URI="https://code.launchpad.net/me-tv/stable/0.6/+download/${MY_P}.tar.gz"
>LICENSE="GPL-3"
>SLOT="0"
>KEYWORDS="~x86"
>IUSE=""
>
>DEPEND="&gt;=dev-cpp/libgnomemm-2.6
>	&gt;=dev-cpp/libgnomeuimm-2.6
>	&gt;=gnome-base/libgnome-2.14
>	&gt;=gnome-base/libgnomeui-2.14
>	&gt;=gnome-base/libglade-2.6
>	dev-libs/libxml2
>	media-libs/xine-lib
>	=net-libs/gnet-2.0*
>	x11-libs/libXtst
>	&gt;=x11-libs/gtk+-2.12"
>RDEPEND=""
>
>src_unpack() {
>	unpack ${A}
>}
>src_compile() {
>	econf || die "econf failed"
>	emake || die "emake failed"
>}
>
>src_install() {
>	emake DESTDIR="${D}" install || die "install failed"
>}
></PRE></BODY></HTML>
Comment 19 jacopo lamanna 2008-09-14 13:50:31 UTC
Created attachment 165400 [details]
Ebuild for 0.6.0 fixed
Comment 20 Henry Nnamfoh 2008-09-19 20:41:47 UTC
Created attachment 165868 [details]
Ebuild for 0.6.2

Version bump, update dependencies.
Comment 21 Manuel Wiesinger 2008-10-15 22:07:51 UTC
Created attachment 168616 [details]
Ebuild for 0.6.3
Comment 22 Henry Nnamfoh 2008-10-18 07:48:38 UTC
Created attachment 168886 [details]
Ebuild for 0.7.0
Comment 23 Gilles Dartiguelongue gentoo-dev 2008-11-30 11:15:41 UTC
align ebuild requests to same values
Comment 24 Thomas Raschbacher gentoo-dev 2009-01-02 13:44:44 UTC
I've added my own ebuild to my dev overlay (layman -a lordvan) for 0.7.7

can someone please test it? unfortunately I can't run it withouth a dvb-t or dvd-c card and i only got dvb-s.

I do have different dependencies, but I'll chekc that out later
Comment 25 James Wells 2009-01-21 15:28:35 UTC
I bumped the 0.7.0 ebuild to 0.7.9 and was able to get me-tv installed and run.

One warning though, it appears that the DVB ABI change in the 2.6.28 kernel can cause me-tv to fail when connecting to frontend0.  Now sure how widespread the issue is as I only have a Hauppauge 950Q to test with.
Comment 26 James Wells 2009-01-21 19:20:51 UTC
They just released 0.7.10, and again I was able to bump the 0.7.0 ebuild and emerge it.  It runs correctly but still appears to suffer from the 2.6.28 ABI change.  Will downgrade my kernel later today to 2.6.27 and try to see if my theory is correct.
Comment 27 Robert Golding 2009-01-22 03:55:37 UTC
(In reply to comment #26)
> They just released 0.7.10, and again I was able to bump the 0.7.0 ebuild and
> emerge it.  It runs correctly but still appears to suffer from the 2.6.28 ABI
> change.  Will downgrade my kernel later today to 2.6.27 and try to see if my
> theory is correct.
> 
I am having the same trouble here.  I have also tried to use the 'hg' version and install as third party, but still have me-tv not being able to lock channel/frontend.  

Perhaps a different version of the frontends?
If so, where would I get them/it?

I use the same frontends dir in 2.6.27 and 2.6.28, so am not sure what is causing this prob.
Comment 28 Robert Golding 2009-01-22 03:59:25 UTC
Forgot to mention,

metv working very well in 2.6.27 (gentoo sources) up to 'r5', the later 2.6.28-rx kernel is also gentoo-sources.  I'm lazy and find using gentoo-sources easier than patching vanilla for squash-fs and uvesa-decor, not too mention many other patches I would need to do.
Comment 29 James Wells 2009-01-22 15:57:07 UTC
Okay, had a chance to play around a bit more with this last night.  It is definately not a kernel issue.  I emerged me-tv-0.5.33 and I was able to connect to my tuner correctly.  Did some more research based on this and found that support for ATSC tuners was dropped in the 0.6.X+ versions of me-tv.  Unfortunately, in my case, I have a Hauppauge 950Q, which uses the ATSC frontend.  Apparently there is a developer's version of 0.7.10 that supports ATSC but I have only seen the Debian package for it so far.
Comment 30 Robert Golding 2009-01-23 04:24:59 UTC
I have gone back to 0.6.2.  The 0.7.x versions were not buffering enough for HD, and was causing it to continually stop and start, plus dozens of artifacts across the screen. I was only able to watch the standard digital channels.
The older versions of me-tv seem to have no probs with buffering for HD

Here in Australia there is different programming between SD & HD.

Also the frontend (Zarlink) probs I have are with the 2.6.28 kernel and dvb4l.  Not with me-tv.
Comment 31 Robert Golding 2009-01-31 20:17:25 UTC
Whatever was wrong with the EPG (it was sporadic at best) and the buffering for HD has been fixed in 7.11.
I just renamed the 7.10.ebuild to me-tv-0.7.11.ebuild.

I have, however, lost one of my HD channels with pop-up error message;
"Failed to find PMT ID for service"

Can somebody tell what that means?
Comment 32 Thomas Raschbacher gentoo-dev 2009-02-12 08:35:30 UTC
i'll prolly add the newest one to the tree and / or my dev overlay soonish
Comment 33 James Wells 2009-02-17 16:10:56 UTC
Had a chance to play with 0.7.14, the latest version, and it now has preliminary support for ATSC, better buffering, and a working channels.conf import.   I am still seeing issues with the Electronic Programming Guide (EPG), but they seem to be related to ATSC only.
Comment 34 Thomas Raschbacher gentoo-dev 2009-03-06 08:14:59 UTC
added 0.7.16 to my overlay .
Comment 35 Robert Golding 2009-03-09 00:54:50 UTC
(In reply to comment #34)
> added 0.7.16 to my overlay .
> 

Failed to build
----->
>>> Verifying ebuild manifests

!!! Digest verification failed:
!!! /usr/portage/local/layman/lordvan/media-tv/me-tv/ChangeLog
!!! Reason: Filesize does not match recorded size
!!! Got: 422
!!! Expected: 227
----->
Comment 36 Thomas Raschbacher gentoo-dev 2009-03-17 13:41:02 UTC
sorry for that .. fixed it.

I'll add 0.8.0 as soon as it's out (which according to the author is going to be soon _and_ include DVB-s support .. so I can actually use this .. 
So i might even add it to the main portage tree once I can use it as well and make sure everything works
Comment 37 Thomas Raschbacher gentoo-dev 2009-03-20 14:07:42 UTC
added improved 0.8.0_rc1 provided to me by lamothe (from me-tv project)
CC'd lamothe
Comment 38 Thomas Raschbacher gentoo-dev 2009-03-20 14:08:19 UTC
please test it and provide feedback (to lamothe please) so we get a 0.8.0 final soon ;)
Comment 39 Robert Golding 2009-03-23 02:04:01 UTC
(In reply to comment #38)
> please test it and provide feedback (to lamothe please) so we get a 0.8.0 final
> soon ;)
> 

Only one little annoying thing, epg is across 2 pages, yet page 1 is scrolled and page 2 has only three items, why not just scroll the entire epg?

Otherwise works very well, no problems, found all channels correctly, tried it from location xml and from existing channels.conf. I also wiped the entire .me-tv sub-dir and it came up asking which location and gave full channels for my area (Adelaide, South Aus) It is also, finally, giving me full epg text, not truncated or blank anymore.

emerge --info  --->
Portage 2.2_rc26 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.28-gentoo-r2 i686)
=================================================================
System uname: Linux-2.6.28-gentoo-r2-i686-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5600+-with-glibc2.0
Timestamp of tree: Sat, 21 Mar 2009 07:00:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.2-r7
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer -falign-functions=64"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer -falign-functions=64"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.isp.net.au/ftp/pub/gentoo http://ftp.swin.edu.au/gentoo http://distfiles.gentoo.org http://gentoo.osuosl.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_AU.UTF-8"
LC_ALL="en_AU.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_AU"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/voyageur /usr/portage/local/layman/sunrise /usr/portage/local/layman/desktop-effects /usr/portage/local/robert /usr/portage/local/layman/lordvan"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aalib acl acpi additions aften aim akamaru alsa arts asf audacious audiofile auto-completion automount avi bash-completion bashlogger berkdb bitmap-fonts bittorrent bluetooth bonobo branding browserplugin bzip2 bzlib cairo cdparanoia cdr cli corba cracklib crypt cups dbus dca directfb directv disk-partition dlloader dri dv dvd dvdr dvdread eds elf emboss encode epson esd evdev fam fbcon ffmpeg firefox flac fontconfig fortran freetype games gdbm gif gimp glitz gnome gphoto2 gpm grub gstreamer gtk gtk2 hal iconv icq imlib imlib2 inotify ipfilter iproute2 isdnlog java javascript jpeg kde4 kernel-linux ldap libg++ lm_sensors mad midi mikmod mjpeg mmx mmxext mp3 mpeg mpg mplayer mudflap ncurses nls nptl nptlonly nsplugin nvidia offensive ogg opengl openmp oss pam pcre pdf pdflib perl png ppds pppd print python qt3support qt4 quicktime readline reflection remote sane scanner sdl session smp spell spl sse ssl svg svga sysfs tcpd tga tiff totem truetype truetype-fonts type1-fonts udev unicode usb v4l v4l2 vcd vorbis win32codecs wmf wmv x86 xine xml xorg xsane xulrunner xv xvid zlib" ALSA_CARDS="ac97 hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_AU" LIRC_DEVICES="usb" USERLAND="GNU" VIDEO_CARDS="nvidia nv v4l vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 40 Thomas Raschbacher gentoo-dev 2009-04-01 12:58:42 UTC
0.8.0 has been released.
please note that the only officially supported  engine is xine-ui as mentioned in the ebuild anyway
Comment 41 Peter Scum 2009-04-06 20:31:35 UTC
The build of 0.8.0 crashes on my amd64-machine with this message:

mv -f .deps/me_tv-lib_gstreamer_engine.Tpo .deps/me_tv-lib_gstreamer_engine.Po
mv -f .deps/me_tv-devices_dialog.Tpo .deps/me_tv-devices_dialog.Po
mv -f .deps/me_tv-xine_lib_engine.Tpo .deps/me_tv-xine_lib_engine.Po
mv -f .deps/me_tv-channel_manager.Tpo .deps/me_tv-channel_manager.Po
mv -f .deps/me_tv-scheduled_recording_manager.Tpo .deps/me_tv-scheduled_recording_manager.Po
x86_64-pc-linux-gnu-g++  -march=nocona -O2 -pipe -Wl,--as-needed `getconf LFS_LDFLAGS` `getconf LFS64_LDFLAGS` -Wl,-O1 -o me-tv me_tv-main.o me_tv-stream_thread.o me_tv-application.o me_tv-dvb_frontend.o me_tv-dvb_scanner.o me_tv-dvb_demuxer.o me_tv-dvb_si.o me_tv-dvb_service.o me_tv-dvb_transponder.o me_tv-atsc_text.o me_tv-channels_dialog.o me_tv-thread.o me_tv-main_window.o me_tv-gtk_epg_widget.o me_tv-me-tv-ui.o me_tv-device_manager.o me_tv-meters_dialog.o me_tv-engine.o me_tv-data.o me_tv-epg_event.o me_tv-me-tv.o me_tv-channel.o me_tv-scheduled_recording_dialog.o me_tv-scheduled_recordings_dialog.o me_tv-preferences_dialog.o me_tv-status_icon.o me_tv-scheduled_recording.o me_tv-epg_thread.o me_tv-xine_engine.o me_tv-mplayer_engine.o me_tv-exception.o me_tv-scan_window.o me_tv-string_splitter.o me_tv-channels_conf_line.o me_tv-initial_scan_line.o me_tv-lib_vlc_engine.o me_tv-epg_events.o me_tv-lib_gstreamer_engine.o me_tv-xine_lib_engine.o me_tv-devices_dialog.o me_tv-channel_manager.o me_tv-scheduled_recording_manager.o -pthread -lgnomeuimm-2.6 -lgnomemm-2.6 -lgnomecanvasmm-2.6 -lglademm-2.4 -lgnomeui-2 -lSM -lICE -lgnomevfsmm-2.6 -lgtkmm-2.4 -lglade-2.0 -lgdkmm-2.4 -latkmm-1.6 -lpangomm-1.4 -lcairomm-1.0 -lxml2 -lbonoboui-2 -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation -lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lz -lfontconfig -lgnomevfs-2 -lgiomm-2.4 -lgio-2.0 -lgmodule-2.0 -lgconfmm-2.6 -lglibmm-2.4 -lgconf-2 -lgobject-2.0 -lsigc-2.0 -lXtst -lgnet-2.0 -lgthread-2.0 -lrt -lglib-2.0   -lsqlite3   -lxine    -pthread -lgstinterfaces-0.10 -lgstreamer-0.10 -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lxml2 -lglib-2.0
me_tv-main_window.o:(.rodata._ZTC10MainWindow0_N5Gnome2UI3AppE[vtable for MainWindow]+0x2a8): undefined reference to `non-virtual thunk to Gnome::UI::App::~App()'
me_tv-main_window.o:(.rodata._ZTC10MainWindow0_N5Gnome2UI3AppE[vtable for MainWindow]+0x2b0): undefined reference to `non-virtual thunk to Gnome::UI::App::~App()'
collect2: ld returned 1 exit status
make[2]: *** [me-tv] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-tv/me-tv-0.8.0/work/me-tv-0.8.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-tv/me-tv-0.8.0/work/me-tv-0.8.0'
make: *** [all] Error 2

The Full message is here: http://nopaste.org/p/aWRoQxL8x

emerge --info:

Portage 2.2_rc28 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.27-gentoo-r8 x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-glibc2.2.5
Timestamp of tree: Mon, 06 Apr 2009 12:45:02 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.2-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.3.9
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="rsync://ftp-stud.fht-esslingen.de/gentoo/ ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ rsync://ftp.join.uni-muenster.de/gentoo/ "
LANG="C"
LC_ALL="C"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/portage/local/layman/science /usr/portage/local/layman/lordvan /usr/portage/local/layman/kde-testing"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnowext 7zip X a52 aac acct acl acpi additions alias alsa amd64 amr amrnb autoipd automount avahi bash-completion berkdb bluetooth bogofilter bonjour bookmarks branding bzip2 cairo captury cdaudio cdda cddb cdio cdparanoia cdr cli consolekit cpp cracklib crypt css cups daap dbus device-mapper dirac directfb divx dri dts dvb dvd dvdr dvdread embedded emboss encode eu_epg evo exif fam fame fat fbcon fbcondecor ffmpeg fftw firefox flac flash fortran fuse gdbm gif gimp glib gnutls gpg gphoto2 gpm grammar gstreamer gtk hal hddtemp highlight history howl-compat htmlhandbook iconv id3tag idle ifp imagemagick imap imlib inotify ipod ipv6 irc isdnlog jabber java jingle jpeg kde kdeprefix lame lastfm latex libgcrypt libnotify libsamplerate libsexy lirc live livebuffer lm_sensors logrotate loop-aes lua lzo mad matroska mdnsresponder-compat midi mikmod mixer mjpeg mms mmx mmxext mng modplug mp3 mp3tunes mp4 mpd mpeg mplayer mtp mudflapmultilib musepack musicbrainz ncurses network njb nls nophonehome normalize nptl nptlonly nsplugin ntfs nvidia ogg openal opengl openmp oscar otr pam pcre pdf perl phonon png ppds pppd pvr python qt3support qt4 quicktime rar raw readline redland reflection reiserfs rss rtsp ruby samba sdl sdl-image semantic-desktop session shout skins slang slp smp sndfile snes speex spell spl sqlite sqlite3 srv sse sse2 ssl startup-notification stream subtitles svg swat swig sysfs syslog taglib tcpd teletext theora thesaurus threads tiff tordns trayicon truetype tv tvtime twolame unicode usb v4l v4l2 vcd vcdinfo vcdx vdr vim-syntax vim-with-x visualization vlm vnc vorbis webdav webinterface webkit wma wmf wxwindows x264 xcomposite xhtml xine xinerama xml xorg xosd xpm xscreensaver xulrunner xv xvid xvmc zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate routeshare shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="directory sony_dscf1sony_dscf55 ptp2" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" LIRC_DEVICES="devinput" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 42 Thomas Raschbacher gentoo-dev 2009-04-08 09:02:32 UTC
Comment on attachment 168886 [details]
Ebuild for 0.7.0

marked all old ebuilds obsolete
Comment 43 Thomas Raschbacher gentoo-dev 2009-04-08 09:05:13 UTC
(In reply to comment #41)
> The build of 0.8.0 crashes on my amd64-machine with this message:
> me_tv-main_window.o:(.rodata._ZTC10MainWindow0_N5Gnome2UI3AppE[vtable for
> MainWindow]+0x2a8): undefined reference to `non-virtual thunk to
> Gnome::UI::App::~App()'
> me_tv-main_window.o:(.rodata._ZTC10MainWindow0_N5Gnome2UI3AppE[vtable for
> MainWindow]+0x2b0): undefined reference to `non-virtual thunk to
> Gnome::UI::App::~App()'
> collect2: ld returned 1 exit status
> make[2]: *** [me-tv] Error 1
> make[2]: Leaving directory
> `/var/tmp/portage/media-tv/me-tv-0.8.0/work/me-tv-0.8.0/src'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory
> `/var/tmp/portage/media-tv/me-tv-0.8.0/work/me-tv-0.8.0'
> make: *** [all] Error 2
> 
> The Full message is here: http://nopaste.org/p/aWRoQxL8x
> 
peter, can you just post the versions for the gtk/gnomemm deps too?:

dev-cpp/libgnomemm
gnome-base/libgnome
dev-cpp/libgnomeuimm
gnome-base/libgnomeui
dev-cpp/glibmm
gnome-base/gconf
dev-cpp/gconfmm
dev-libs/glib
Comment 44 Peter Scum 2009-04-08 11:07:48 UTC
(In reply to comment #43)
> peter, can you just post the versions for the gtk/gnomemm deps too?:
> 
> dev-cpp/libgnomemm
2.22.0

> gnome-base/libgnome
2.24.1

> dev-cpp/libgnomeuimm
2.22.0

> gnome-base/libgnomeui
2.24.1

> dev-cpp/glibmm
2.16.4

> gnome-base/gconf
2.24.0

> dev-cpp/gconfmm
2.22.0

> dev-libs/glib
2.18.4-r1

Comment 45 Thomas Raschbacher gentoo-dev 2009-04-08 13:21:59 UTC
0.8.2 is released and in my git overlay.

@Peter: could it be you changed C++ compiler version recently (or at least since emerging those) if so please re-emerge all the gtk/gnomemm libs and try again (i know it'll take a while .. blame C++ ;))
Comment 46 Robert Golding 2009-04-08 14:17:22 UTC
(In reply to comment #45)
> 0.8.2 is released and in my git overlay.
> 

overlay sunrise keeps asking for root password, I will ask on forums as well
Comment 47 Thomas Raschbacher gentoo-dev 2009-04-08 14:28:58 UTC
(In reply to comment #46)
> (In reply to comment #45)
> > 0.8.2 is released and in my git overlay.
> > 
> 
> overlay sunrise keeps asking for root password, I will ask on forums as well
> 
yeah i had same thing with sunrise today but i just was like .. WTF .. <enter>,<enter>,<enter>,<enter>
-> goes to next one
:D
Comment 48 Robert Golding 2009-04-08 14:32:52 UTC
(In reply to comment #47)
> yeah i had same thing with sunrise today but i just was like .. WTF ..
> <enter>,<enter>,<enter>,<enter>
> -> goes to next one
> :D
> 

Ta, thanks  .. at least I got my me-tv goodness :-)
Comment 49 Peter Scum 2009-04-08 14:36:22 UTC
(In reply to comment #46)
> (In reply to comment #45)
> > 0.8.2 is released and in my git overlay.
> > 
> 
> overlay sunrise keeps asking for root password, I will ask on forums as well
> 

See here: https://bugs.gentoo.org/265423

(In reply to comment #45)
Thanks for the hint, but I don't think, i changed my c++-compiler recently. 
Anyway: dev-cpp/libgnomeuimm fails to build as well. I try to rebuild @world now... this may take a while.
Comment 50 Thomas Raschbacher gentoo-dev 2009-04-09 11:50:33 UTC
0.8.3 added to my overlay which has a recording fix.
Comment 51 Peter Scum 2009-04-10 19:57:47 UTC
Ok, emerge -e me-tv worked for me. It took hours, but it worked ;)

But when I try to emerge it with the vlc-useflag, it fails with this message:
!!! Invalid or corrupt dependency specification:

invalid atom: '>=media-video/vlc/vlc-0.9[dvb]'

('ebuild', '/', 'media-tv/me-tv-0.8.3', 'merge')

>=dev-cpp/libgnomemm-2.20.0 >=dev-cpp/libgnomecanvasmm-2.20.0 >=dev-cpp/libgnomeuimm-2.20.0 >=dev-cpp/gconfmm-2.20.0 =dev-db/sqlite-3* >=net-libs/gnet-2.0.0 >=x11-libs/libXtst-1.0.0 doc? ( >=dev-util/gtk-doc-1.0 ) mplayer? ( media-video/mplayer[dvb] ) xine? ( >=media-libs/xine-lib-1.1.7 media-video/xine-ui ) vlc? ( >=media-video/vlc/vlc-0.9[dvb] ) gstreamer? ( >=media-libs/gst-plugins-bad-0.10 ) >=sys-apps/sed-4

This package can not be installed. Please notify the 'media-tv/me-
tv-0.8.3' package maintainer about this problem.                                                ... done!
Comment 52 Juergen Rose 2009-04-13 17:01:50 UTC
'emerge =me-tv-0.8.3' fails for me with:
...
x86_64-pc-linux-gnu-g++  -march=nocona -O2 -pipe -Wl,--as-needed `getconf LFS_LDFLAGS` `getconf LFS64_LDFLAGS` -Wl,-O1 -o me-tv me_tv-main.o me_tv-stream_thread.o me_tv-application.o me_tv-dvb_frontend.o me_tv-dvb_scanner.o me_tv-dvb_demuxer.o me_tv-dvb_si.o me_tv-dvb_service.o me_tv-dvb_transponder.o me_tv-atsc_text.o me_tv-channels_dialog.o me_tv-thread.o me_tv-main_window.o me_tv-gtk_epg_widget.o me_tv-me-tv-ui.o me_tv-device_manager.o me_tv-meters_dialog.o me_tv-engine.o me_tv-data.o me_tv-epg_event.o me_tv-me-tv.o me_tv-channel.o me_tv-scheduled_recording_dialog.o me_tv-scheduled_recordings_dialog.o me_tv-preferences_dialog.o me_tv-status_icon.o me_tv-scheduled_recording.o me_tv-epg_thread.o me_tv-xine_engine.o me_tv-mplayer_engine.o me_tv-exception.o me_tv-scan_window.o me_tv-string_splitter.o me_tv-channels_conf_line.o me_tv-initial_scan_line.o me_tv-lib_vlc_engine.o me_tv-epg_events.o me_tv-lib_gstreamer_engine.o me_tv-xine_lib_engine.o me_tv-devices_dialog.o me_tv-channel_manager.o me_tv-scheduled_recording_manager.o -pthread -lgnomeuimm-2.6 -lgnomemm-2.6 -lgnomecanvasmm-2.6 -lglademm-2.4 -lgnomeui-2 -lSM -lICE -lgnomevfsmm-2.6 -lgtkmm-2.4 -lglade-2.0 -lgdkmm-2.4 -latkmm-1.6 -lpangomm-1.4 -lcairomm-1.0 -lxml2 -lbonoboui-2 -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation -lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgnomevfs-2 -lgiomm-2.4 -lgio-2.0 -lgmodule-2.0 -lgconfmm-2.6 -lglibmm-2.4 -lgconf-2 -lgobject-2.0 -lsigc-2.0 -lXtst -lgnet-2.0 -lgthread-2.0 -lrt -lglib-2.0   -lsqlite3      
me_tv-main_window.o:(.rodata._ZTC10MainWindow0_N5Gnome2UI3AppE[vtable for MainWindow]+0x2a8): undefined reference to `non-virtual thunk to Gnome::UI::App::~App()'
me_tv-main_window.o:(.rodata._ZTC10MainWindow0_N5Gnome2UI3AppE[vtable for MainWindow]+0x2b0): undefined reference to `non-virtual thunk to Gnome::UI::App::~App()'
collect2: ld returned 1 exit status
make[2]: *** [me-tv] Error 1
Comment 53 Juergen Rose 2009-04-13 17:03:52 UTC
'emerge -vD me-tv' (me-tv-0.8.4) fails for me with:
...
x86_64-pc-linux-gnu-g++  -march=nocona -O2 -pipe -Wl,--as-needed `getconf LFS_LDFLAGS` `getconf LFS64_LDFLAGS` -Wl,-O1 -o me-tv me_tv-main.o me_tv-stream_thread.o me_tv-application.o me_tv-dvb_frontend.o me_tv-dvb_scanner.o me_tv-dvb_demuxer.o me_tv-dvb_si.o me_tv-dvb_service.o me_tv-dvb_transponder.o me_tv-atsc_text.o me_tv-channels_dialog.o me_tv-thread.o me_tv-main_window.o me_tv-gtk_epg_widget.o me_tv-me-tv-ui.o me_tv-device_manager.o me_tv-meters_dialog.o me_tv-engine.o me_tv-data.o me_tv-epg_event.o me_tv-me-tv.o me_tv-channel.o me_tv-scheduled_recording_dialog.o me_tv-scheduled_recordings_dialog.o me_tv-preferences_dialog.o me_tv-status_icon.o me_tv-scheduled_recording.o me_tv-epg_thread.o me_tv-xine_engine.o me_tv-mplayer_engine.o me_tv-exception.o me_tv-scan_window.o me_tv-string_splitter.o me_tv-channels_conf_line.o me_tv-initial_scan_line.o me_tv-lib_vlc_engine.o me_tv-epg_events.o me_tv-lib_gstreamer_engine.o me_tv-xine_lib_engine.o me_tv-devices_dialog.o me_tv-channel_manager.o me_tv-scheduled_recording_manager.o -pthread -lgnomeuimm-2.6 -lgnomemm-2.6 -lgnomecanvasmm-2.6 -lglademm-2.4 -lgnomeui-2 -lSM -lICE -lgnomevfsmm-2.6 -lgtkmm-2.4 -lglade-2.0 -lgdkmm-2.4 -latkmm-1.6 -lpangomm-1.4 -lcairomm-1.0 -lxml2 -lbonoboui-2 -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation -lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgnomevfs-2 -lgiomm-2.4 -lgio-2.0 -lgmodule-2.0 -lgconfmm-2.6 -lglibmm-2.4 -lgconf-2 -lgobject-2.0 -lsigc-2.0 -lXtst -lgnet-2.0 -lgthread-2.0 -lrt -lglib-2.0   -lsqlite3      
me_tv-main_window.o:(.rodata._ZTC10MainWindow0_N5Gnome2UI3AppE[vtable for MainWindow]+0x2a8): undefined reference to `non-virtual thunk to Gnome::UI::App::~App()'
me_tv-main_window.o:(.rodata._ZTC10MainWindow0_N5Gnome2UI3AppE[vtable for MainWindow]+0x2b0): undefined reference to `non-virtual thunk to Gnome::UI::App::~App()'
collect2: ld returned 1 exit status
make[2]: *** [me-tv] Error 1
Comment 54 Juergen Rose 2009-04-13 17:04:16 UTC
root@condor:/usr/local/portage/media-video/me-tv(151)# emerge --info
Portage 2.1.6.11 (default/linux/amd64/2008.0/desktop, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.29 x86_64)
=================================================================
System uname: Linux-2.6.29-x86_64-Intel-R-_Core-TM-2_CPU_6600_@_2.40GHz-with-gentoo-2.0.0
Timestamp of tree: Mon, 13 Apr 2009 05:30:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:     4.0_p17
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.4-r15, 2.5.4-r2, 2.6.1-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.3-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/share/config /
var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-p
hp5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language
.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
FFLAGS="-march=nocona -O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
LINGUAS="de fr"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages/"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local 
--exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/java-overlay /usr/local/portage/layman/zugaina /usr/local/portage/layman/dotnet /usr/local/portage/layman/science /usr/local/po
rtage/layman/jokey /usr/local/portage/layman/lordvan /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac acl acpi administrator afs aiglx alsa amd64 amrr ao aotuv apache2 asf atlas auctex audacious audiofile automount bash-completion beagle berkdb bjam b
las bluetooth bonobo boo boost branding bzip2 c++ cairo cdda cddb cdf cdio cdparanoia cdr cgi chm cli corba cracklib cran crypt cups curl cxx daap dbus device-mapper dga 
dia divx djvu dlloader dmi doc dri ds3490 dv dvb dvd dvdr dvdread dvi dxr3 dynagraph eds effects elf emacs emboss encode epiphany esd evo examples exif expat extra fam fa
me ffmpeg fftw firefox fits flac fltk foomaticdb fortran fpx galago gd gdal gdbm geos gif gimp gimpprint ginac glade glib glitz gml gmp gnokii gnome gnuplot gnutls gphoto
2 gpm graphics graphviz gs gsl gsm gstreamer gtk guile hal hardened harness hddtemp hdf hdf5 hlapi http hvm iconv icq icu id3 ide imagemagick imap innodb ipod ipv6 irda i
rmc isdnlog ithreads jabber java jbig john jpeg jpeg2k kde kde4 kdeprefix kerberos kexi keyring kvm ladspa lame lapack latex lcms ldap libffi libgda libnotify libsamplera
te lirc lm_sensors lua lzo lzw mad maildir mailwrapper math matroska midi mikmod mmx mmxext mng mod mono motif mozdevelop mozilla mozsvg mozxmlterm mp3 mp4 mp4live mpeg m
peg2 mplayer mudflap multilib musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networkmanager nfs nls nntp nptl nptlonly nsplugin ntfs numarray numeri
c nvidia obex ocaml octave odbc ogdi ogg ole opengl openmp pae pam pcre pda pdf perl plotutils plugins png posix postgres postscript ppds pppd preview-latex proj projectx
 pstricks python qhull qt3 qt3support qt4 quicktime readline reflection reiserfs rhythmbox rle rpc rrdcgi rrdtool samba sasl science sdl session slang slp smp sndfile snm
p soup sox speex spell spl sqlite sse sse2 ssl startup-notification stlport subtitles subversion suexec svg sysfs t1lib tcl tcpd tex theora threads thunderbird tidy tiff 
tk truetype unicode usb userlocales utempter v4l2 vorbis webkit wmf wxwindows xattr xcb xemacs xext xine xml xmlreader xmlrpc xorg xpm xulrunner xv xvid xvmc zlib zvbi" A
LSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi nul
l plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default
 authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident i
magemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status uni
que_id userdir usertrack vhost_alias" DVB_CARDS="cx8800 cx88xx tda1004x saa713" ELIBC="glibc" INPUT_DEVICES="keyboard mouse                " KERNEL="linux" LCD_DEVICES="b
ayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de fr" NETBEANS_MODULES="ide websvccommon nb harness apisupport groovy gsf j2ee java xml" U
SERLAND="GNU" VIDEO_CARDS="nv nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 55 Thomas Raschbacher gentoo-dev 2009-04-14 13:45:51 UTC
0.8.4 is in my overlay .. 

@Juergen: see above regarding Peters problem .. (gtk/gnomemm being broken ..)
@Peter: the 0.8.4 version in my overlay should have this fixed .. 
Comment 56 Thomas Raschbacher gentoo-dev 2009-04-15 13:04:15 UTC
0.8.5 wiht channel editor fix in my overlay now
Comment 57 Robert Golding 2009-04-15 19:00:16 UTC
(In reply to comment #56)
> 0.8.5 wiht channel editor fix in my overlay now
> 

#--->
one rob # emerge -auv me-tv

These are the packages that would be merged, in order:

Calculating dependencies - * Missing digest for '/usr/portage/local/layman/lordvan/media-tv/me-tv/me-tv-0.8.5.ebuild'                                        ... done!

Total: 0 packages, Size of downloads: 0 kB
#--->

Just so you know, I fixed it on mine.
Comment 58 Juergen Rose 2009-04-16 05:58:03 UTC
Hi Thomas,

how can I access your overlay?

Regards Juergen
Comment 59 Thomas Raschbacher gentoo-dev 2009-04-16 12:57:26 UTC
@juergen:
USE="git" emerge --ask layman; layman -a lordvan; emerge --ask me-tv  ;)

@peter: sorry forgot to push the repo after commit (relatively new to git ;))
Comment 60 Robert Golding 2009-05-10 23:21:38 UTC
Hi Thomas,
I have a problem and I don't know how to fix it.  I removed all KDE packages from my system then did a --depclean to find any leftovers from kde-base and unmerged them by hand.  

Since then I have been unable to use Me-Tv (everything is exactly the same for OpenOfficeOrg, including messages). The error message is as follows;

--start-->
one rob # me-tv
me-tv: Symbol `_ZTIN3Gtk6WidgetE' has different size in shared object, consider re-linking
Me TV 0.8.7

(me-tv:23946): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.
11/05/09 08:40:05: Me TV terminated
--end-->

I tried to re-emerge it, it failed to compile, so I then retried using gcc-4.1.2 and it still failed to compile, after which, with gcc-4.1.2, the error message changed to;

--start-->
one rob #  me-tv 
me-tv: /usr/lib/gcc/i686-pc-linux-gnu/4.1.2/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by me-tv)
--end-->

I have re-merged libstdc++ and libstdc++v3 to no avail.

The emerge fail message is as follows;

--start-->
i686-pc-linux-gnu-g++  -march=athlon64 -O2 -pipe -fomit-frame-pointer -falign-functions=64 -Wl,--as-needed `getconf LFS_LDFLAGS` `getconf LFS64_LDFLAGS` -Wl,-O1 -o me-tv me_tv-main.o me_tv-stream_thread.o me_tv-application.o me_tv-dvb_frontend.o me_tv-dvb_scanner.o me_tv-dvb_demuxer.o me_tv-dvb_si.o me_tv-dvb_service.o me_tv-dvb_transponder.o me_tv-atsc_text.o me_tv-channels_dialog.o me_tv-thread.o me_tv-main_window.o me_tv-gtk_epg_widget.o me_tv-me-tv-ui.o me_tv-device_manager.o me_tv-meters_dialog.o me_tv-engine.o me_tv-data.o me_tv-epg_event.o me_tv-me-tv.o me_tv-channel.o me_tv-scheduled_recording_dialog.o me_tv-scheduled_recordings_dialog.o me_tv-preferences_dialog.o me_tv-status_icon.o me_tv-scheduled_recording.o me_tv-epg_thread.o me_tv-xine_engine.o me_tv-mplayer_engine.o me_tv-exception.o me_tv-scan_window.o me_tv-string_splitter.o me_tv-channels_conf_line.o me_tv-initial_scan_line.o me_tv-lib_vlc_engine.o me_tv-epg_events.o me_tv-lib_gstreamer_engine.o me_tv-xine_lib_engine.o me_tv-devices_dialog.o me_tv-channel_manager.o me_tv-scheduled_recording_manager.o -pthread -lgnomeuimm-2.6 -lgnomemm-2.6 -lgnomecanvasmm-2.6 -lglademm-2.4 -lgnomeui-2 -lSM -lICE -lgnomevfsmm-2.6 -lgtkmm-2.4 -lglade-2.0 -lgdkmm-2.4 -latkmm-1.6 -lpangomm-1.4 -lcairomm-1.0 -lxml2 -lbonoboui-2 -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation -lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgnomevfs-2 -lgiomm-2.4 -lgio-2.0 -lgmodule-2.0 -lgconfmm-2.6 -lglibmm-2.4 -lgconf-2 -lgobject-2.0 -lsigc-2.0 -lgnet-2.0 -lgthread-2.0 -lrt -lglib-2.0   -lsqlite3   -lxine   -lvlc   -pthread -lgstinterfaces-0.10 -lgstreamer-0.10 -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lxml2 -lglib-2.0   
me_tv-main_window.o:(.rodata._ZTC10MainWindow0_N5Gnome2UI3AppE[vtable for MainWindow]+0x154): undefined reference to `non-virtual thunk to Gnome::UI::App::~App()'
me_tv-main_window.o:(.rodata._ZTC10MainWindow0_N5Gnome2UI3AppE[vtable for MainWindow]+0x158): undefined reference to `non-virtual thunk to Gnome::UI::App::~App()'
collect2: ld returned 1 exit status
make[2]: *** [me-tv] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-tv/me-tv-0.8.7/work/me-tv-0.8.7/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-tv/me-tv-0.8.7/work/me-tv-0.8.7'
make: *** [all] Error 2
 * 
 * ERROR: media-tv/me-tv-0.8.7 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2973:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed"
 *  The die message:
 *   emake failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-tv/me-tv-0.8.7/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-tv/me-tv-0.8.7/temp/environment'.
 * This ebuild is from a repository named 'lordvan'
 * 

>>> Failed to emerge media-tv/me-tv-0.8.7, Log file:

>>>  '/var/tmp/portage/media-tv/me-tv-0.8.7/temp/build.log'
--end-->

Any ideas?
Comment 61 Thomas Raschbacher gentoo-dev 2009-05-11 06:46:59 UTC
Added 0.8.11

(In reply to comment #60)
> Hi Thomas,
> I have a problem and I don't know how to fix it.  I removed all KDE packages
> from my system then did a --depclean to find any leftovers from kde-base and
> unmerged them by hand.  
> 
> Since then I have been unable to use Me-Tv (everything is exactly the same for
> OpenOfficeOrg, including messages). The error message is as follows;
> 
me-tv is a gtkmm application not qt/kde so that has nothing to do with that.
what u could try to do is run revdep-rebuild and see if anything comes up .. if not then recompile gtkmm and then me-tv
Comment 62 Gilles Dartiguelongue gentoo-dev 2009-05-11 08:36:26 UTC
me-tv: Symbol `_ZTIN3Gtk6WidgetE' has different size in shared object, consider
-> rebuild gtkmm

me_tv-main_window.o:(.rodata._ZTC10MainWindow0_N5Gnome2UI3AppE[vtable for
-> rebuild libgnomeuimm
Comment 63 Robert Golding 2009-05-11 14:45:35 UTC
Thankyou, though I had to remerge the entire gtk/gnomemm series to get there.
I still don't understand what happened, but I also don't know why revdep didn't find any probs either.  
Have to put it down to coincidence and lack of experience I reckon.
Comment 64 Gilles Dartiguelongue gentoo-dev 2009-05-11 14:56:40 UTC
(In reply to comment #63)
> Thankyou, though I had to remerge the entire gtk/gnomemm series to get there.
> I still don't understand what happened, but I also don't know why revdep didn't
> find any probs either.  
> Have to put it down to coincidence and lack of experience I reckon.
> 

some c++  lib changes, some g++ changes, whatever not sure myself. revdep-rebuild can't find about this stuff because it doesn't know how to check for that. It would need to start every binary using C++ and catch symbol mismatch somehow but I'm not really qualified to speak about it really, C++ runtime is mistery to me.
Comment 65 Thomas Raschbacher gentoo-dev 2009-05-14 11:31:00 UTC
try running fix_libtool_files.sh for your old gcc versions maybe it helps

(In reply to comment #64)
> (In reply to comment #63)
> > Thankyou, though I had to remerge the entire gtk/gnomemm series to get there.
> > I still don't understand what happened, but I also don't know why revdep didn't
> > find any probs either.  
> > Have to put it down to coincidence and lack of experience I reckon.
> > 
> 
> some c++  lib changes, some g++ changes, whatever not sure myself.
> revdep-rebuild can't find about this stuff because it doesn't know how to check
> for that. It would need to start every binary using C++ and catch symbol
> mismatch somehow but I'm not really qualified to speak about it really, C++
> runtime is mistery to me.
> 

Comment 66 Thomas Raschbacher gentoo-dev 2009-05-25 12:09:14 UTC
FYI 0.8.13 added -- i know 0.8.14 beta is out but i decided to not add betas anymore for the time being due to lack of time to keep up with fast releases :D
Comment 67 Robert Golding 2009-05-29 09:31:59 UTC
Hi Thomas,
There is a problem with your overlay;
---->start
one rob # layman -s lordvan
* Running command "cd "/usr/portage/local/layman/lordvan" && /usr/bin/git pull"...
remote: Counting objects: 21, done.
remote: Compressing objects: 100% (13/13), done.
remote: Total 15 (delta 5), reused 0 (delta 0)
Unpacking objects: 100% (15/15), done.
From git://git.overlays.gentoo.org/dev/lordvan
   6b9e1d3..8d7c76a  master     -> origin/master
Updating 6b9e1d3..8d7c76a
error: Entry 'media-tv/me-tv/Manifest' not uptodate. Cannot merge.
* 
* Errors:
* ------
* 
* Failed to sync overlay "lordvan".
* Error was: Syncing overlay "lordvan" returned status 256!
* 
----->end
Comment 68 Robert Golding 2009-05-29 15:50:42 UTC
Thankyou Thomas for fixing that :-)
Comment 69 Thomas Raschbacher gentoo-dev 2009-06-09 07:47:14 UTC
0.9.1 added.
I think i might add it to main tree instead of my overlay at some point soon.
Comment 70 Thomas Raschbacher gentoo-dev 2009-06-17 11:46:42 UTC
added 0.9.2 which has bugfixes to my overlay.

One other thing .. the program works fine for me - apart from some improvements i'd like to see.
I intend to add it to the main tree soon. Please let me know if you think there is some issue that needs resolving first
Comment 71 Thomas Raschbacher gentoo-dev 2009-08-17 12:02:26 UTC
intend to add 1.0.0 soon - and if that works ok for a couple of days i intend to add the ebuild to main portage tree.
Comment 72 Thomas Raschbacher gentoo-dev 2009-08-27 06:10:53 UTC
added 1.0.0 now .. 
Comment 73 jacopo lamanna 2009-09-02 16:03:42 UTC
checking for ME_TV_XINE... configure: error: Package requirements (libxine >= 1.1.7) were not met:

No package 'libxine' found


Is xine-lib essential? I'd like to  use mplayer only (as with the much older versions):

Calculating dependencies... done!
[ebuild  N    ] media-tv/me-tv-1.0.0  USE="mplayer nls -debug -doc -gstreamer -static -vlc -xine" 0 kB 
Comment 74 Thomas Raschbacher gentoo-dev 2009-09-07 12:05:49 UTC
as the postinst message says xine-lib is the default backend therefore it could be that it is required in 1.0.0 despite configure flags .. i'll have a look.
thanks for reporting it. -- i'll also fix the wrong dep ;)
Comment 75 Robert Golding 2009-09-21 02:45:25 UTC
I updated my system to xcb-1.4 and all the rebuilds and revdeps it required and since then Me-tv refuses to start.
It brings up a box labelled "Me TV" and the following message within;

Duplicate object id 'hbox1' on line 1220 (previously on line 535)

and this on the cli;

one ~ # me-tv
Me TV 1.0.0
21/09/09 12:13:54: Me TV terminated

I have removed it, reinstalled it, tried it with various options and even gone in and deleted every file that is in .gnome2 .gconf for it, then rebuilt the 'mm'libs, but to no avail.

Any ideas?
Comment 76 Robert Golding 2009-09-21 05:26:14 UTC
See launchpad bugs;
https://bugs.launchpad.net/me-tv/+bug/422126

There is a patch to fix it I just don't know how to apply it in an ebuild.

---->
--- me-tv-1.0.0.orig/src/me-tv.ui
+++ me-tv-1.0.0/src/me-tv.ui
@@ -1216,7 +1216,7 @@
               </packing>
             </child>
             <child>
-              <object class="GtkHBox" id="hbox1">
+              <object class="GtkHBox" id="hbox9">
                 <property name="visible">True</property>
                 <child>
                   <object class="GtkComboBox" id="combo_box_deinterlace_type">
@@ -1866,7 +1866,7 @@
         <property name="visible">True</property>
         <property name="spacing">2</property>
         <child>
-          <object class="GtkVBox" id="vbox2">
+          <object class="GtkVBox" id="vbox8">
             <property name="visible">True</property>
             <child>
               <object class="GtkLabel" id="label_select_devic">
----->
Comment 77 Robert Golding 2009-09-21 09:12:59 UTC
Have run the patch by hand, digested and emerged, now me-tv works OK.
That patch is the fix, hope it helps
Comment 78 Thomas Raschbacher gentoo-dev 2009-10-26 19:38:33 UTC
heh nice one there researching it ;) i'll apply it as soon as i bought a new PSU for my dev - pc .. ;)
Comment 79 Thomas Raschbacher gentoo-dev 2009-11-28 18:42:07 UTC
yep thanks for the patch .. will incorporate it into the ebuild as soon as i got my ssh key issues sorted ;)
Comment 80 Thomas Raschbacher gentoo-dev 2010-01-20 21:16:07 UTC
right .. sorted out my ssh key issues .. ;)

there's the newest and greatest version 1.1.5 for you to try out
Comment 81 Robert Golding 2010-02-01 01:35:21 UTC
FYI to Lordvan

--->
one ~ # emerge -auv me-tv

These are the packages that would be merged, in order:

Calculating dependencies \ * Missing digest for '/usr/portage/local/layman/lordvan/media-tv/me-tv/me-tv-1.1.5.ebuild'                                        ... done!
[ebuild     UD] media-tv/me-tv-1.0.0 [1.1.5] USE="doc gstreamer mplayer nls xine -debug -static -vlc" 0 kB [1=>2]

Total: 1 package (1 downgrade), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/portage/local/layman/lordvan
 [2] /usr/portage/local/robert

Would you like to merge these packages? [Yes/No] 
--->

I ran ebuild/digest to fix, just bringing it to your attention.
Comment 82 Robert Golding 2010-02-11 12:05:17 UTC
FYI to Lordvan

--->
one ~ # layman -s lordvan
* Running command "cd "/usr/portage/local/layman/lordvan" && /usr/bin/git pull"...
Updating 72bc04e..c771be8
error: Entry 'media-tv/me-tv/Manifest' not uptodate. Cannot merge.
* 
* Errors:
* ------
* 
* Failed to sync overlay "lordvan".
* Error was: Syncing overlay "lordvan" returned status 256!
* 
--->

I ran ebuild/digest to fix this one as well, just bringing it to your attention again. 

Have installed to version 1.1.6. I hope it was you who put it there  :-)
Comment 83 Thomas Raschbacher gentoo-dev 2010-03-25 21:30:34 UTC
I blame the guy who talked me into making my overlay git .. ^^
having a look now but i was sure i had it sorted - updated it on one pc and then sync'd on another one .. odd thing is i didn'T get that error .. if you remove the overlay and re-add it does it work then?
if not please stick the contents of <layman-dir>/lordvan/media-tv/me-tv into some archive and send it to me - or attach it here. thanks
Comment 84 Robert Golding 2010-03-26 07:42:51 UTC
(In reply to comment #83)
>  .. if you
> remove the overlay and re-add it does it work then?
>

Yep, that fixed it, ta.
Comment 85 Thomas Raschbacher gentoo-dev 2010-04-13 20:47:48 UTC
enjoy version 1.2.0 

p.s.: prolly will add it to the main tree soonisch
Comment 86 Thomas Raschbacher gentoo-dev 2010-05-03 06:05:22 UTC
1.2.1 now
Comment 87 Thomas Raschbacher gentoo-dev 2010-07-18 07:38:22 UTC
1.3.1 in overlay now
Comment 88 Sven 2010-08-08 21:35:18 UTC
@lordvan:

please clean up the ebuild for me-tv 1.3.1.
portage reports many QA issues. Among them, a message that me-tv's configure doesn't support many of the enable/disable options that the ebuilds passes to configure. Also, support for any other backend than xine seems to have been removed. Yet the ebuilds still has the use-flags for gstreamer, mplayer, etc.

Please fix.
Comment 89 Thomas Raschbacher gentoo-dev 2010-08-24 06:02:25 UTC
@sven: I know the ebuild will need some cleaning up - which is partially why it is not in the official tree yet but my dev overlay. since it seems to be working though it has a bit lower priority for me atm (also due to RL reasons) but I'll try to sort it out ;)
Comment 90 Thomas Raschbacher gentoo-dev 2010-09-20 14:49:28 UTC
new - cleaned up version in my overlay. please test.

One thing: does anyone except me have a problem with recording where me-tv creates lots of small files instead of one big recording? (like 30MB each or sth)
Comment 91 Thomas Raschbacher gentoo-dev 2011-04-23 11:30:21 UTC
1.3.6 in my overlay. will add 2.0.1 soon
Comment 92 Thomas Raschbacher gentoo-dev 2011-04-23 11:52:12 UTC
2.0.1 in there package.mask'd
Comment 93 roxxo 2011-06-04 01:00:30 UTC
I recently found Me TV and this nice ebuild. However, I use OSSv4 instead of ALSA (and USE="-alsa") and had to comment line 45 in client/vlc_engine.cc, to avoid a segfault. 

//vlc_argv[i++] = "--alsa-caching=2000";
Comment 94 Thomas Raschbacher gentoo-dev 2011-08-31 13:24:43 UTC
roxxo Could you please report this with upstream as a bug? I'D rather not patch it here only.

On another note the original author has stopped working on me-tv and it is being continued by someone else, so I do not know if they got the launchpad tracker back up yet.
Comment 95 Thomas Raschbacher gentoo-dev 2011-10-03 08:51:32 UTC
Bug report I got via Email - will try to look into it later

> Hello,
> 
> i just tried me-tv-2.0.1.ebuild. On my KDE-System it fails with
> =========
> configure: error: Package requirements (
> [...]
>         gstreamer-0.10 gstreamer-interfaces-0.10
> ) were not met:
> 
> No package 'gstreamer-interfaces-0.10' found
> =========
> 
> Installing dev-perl/GStreamer-Interfaces fixed the problem for me.
> 
> With regards,
> Michael Klapproth
> -- 
> Security is like an onion - the more you dig in the more you want to cry
> 
>
Comment 96 Robert Golding 2012-01-01 08:30:36 UTC
As Me-tv is the only stand alone digital(DVB) television viewing client I know of, any reason it hasn't been put into the official tree yet?
Comment 97 Robert Golding 2012-01-01 09:18:35 UTC
Could someone who already has the source for 2.0.1 in #distfiles, attach it here please, it is only 266kB, the downloads area for Me-Tv is missing that source at the moment, and I would like to try it, thanks Rob.
Comment 98 Thomas Raschbacher gentoo-dev 2012-01-29 19:25:59 UTC
hi.

sorry for the delay. I must've missed the bugzie mails.

The problem with upstream is that
1) the original maintainer lost interest
2) the current maintainer has no interest in 2.x version but instead wants to continue the 1.x branch (2.x is a complete rewrite, which he doesn't seem to like)

I am trying to get into contact with him about at least putting the file up on launchpad again.

In the meantime I uploaded the tarball to my server, since I'm not sure about putting it on the official mirrors, since the ebuild is only in my dev-overlay and not in the official tree (this also means I won't be putting me-tv in the official tree before I have talked to the new maintainer).

just update your layman repo. 

In case you have some problems I uploaded it to http://www.lordvan.com/mirror/me-tv/me-tv-2.0.1.tar.gz
Comment 99 Mario Kicherer 2012-03-07 22:48:07 UTC
Created attachment 304567 [details]
ebuild for the new stable 1.4 series

I took the 2.0.1 ebuild from the overlay and adapted it to the latest version (1.4.0.6) from the new 1.4 stable series.

I had problems with installing the gconf schemes, so i disabled it. Me-tv works nonetheless without problems.

Works for me on AMD64.
Comment 100 Thomas Raschbacher gentoo-dev 2012-03-08 07:16:15 UTC
yeah I might just add the current "stable" 1.4 version to the tree instead of the 2.x and leave that one on my overlay for now. unfortunately I did not get an answer from the maintainer. Maybe he did not see it i will try to contact him again ;)
Comment 101 Mario Kicherer 2012-03-08 11:01:31 UTC
On launchpad he seems quite active and supportive. :)

I also saw that there is a console and http server interface in the tarball. When I find some time, I will take a closer look at it and the ebuild.
Comment 102 Mario Kicherer 2012-04-01 21:25:05 UTC
Created attachment 307413 [details]
test ebuild for 1.4.0.9
Comment 103 Mario Kicherer 2012-04-01 21:26:18 UTC
Comment on attachment 307413 [details]
test ebuild for 1.4.0.9

Version bump, updated the dependencies and use flags. Haven't figured out yet why the build script does not allow do en/disable the modules. So the use flags are not really functional right now.

The new version demands to reinitialize channels list (?) and it stresses my hard disk. Maybe it's not ready for daily use. I'll take a look when I have some time again.
Comment 104 Mario Kicherer 2012-04-01 21:29:12 UTC
Created attachment 307415 [details]
testing 1.4.0.9

Sorry, something went wrong. Should get some sleep.
Comment 105 Samuel Robyr 2012-04-20 12:33:31 UTC
Created attachment 309617 [details]
Me-Tv 1.4.0.9 ebuild with fixed libunique dependency

Me-Tv depends on libunique-1.0. I modified your ebuild to depend on libunique:1 instead of >=libunique-1.0, otherwise the ebuild will install libunique-3.x...
Comment 106 Thomas Raschbacher gentoo-dev 2012-06-09 22:37:57 UTC
Thanks for the updates I really need to get around to look at this just a bit busy in RL at the moment :(
Comment 107 Sven 2012-06-09 23:38:40 UTC
That me-tv 1.4.0.9 ebuild is pretty bad. Plenty of QA issues:
 * The autotools-utils_autoreconf() function was deprecated.
 * Please call autotools-utils_src_prepare()
 * with AUTOTOOLS_AUTORECONF set instead.
Or:
configure: WARNING: unrecognized options: --disable-client, --disable-server, --disable-console

Is the me-tv branch even divided into server/client like the 2.0 branch was?
Isn't 1.4 actually based on 1.3 and probably still comes as a single application?
Did you take a 2.0 ebuild as a template for the 1.4 ebuild?
Comment 108 Sven 2012-06-10 00:24:27 UTC
I took Mario's ebuild dated March 7th, fixed the libunique depencency, and renamed it to me-tv-1.4.0.9.ebuild. I had to manually delete the old me-tv the directory ~/.local/share/me-tv/ or otherwise me-tv wouldn't start.

However, me-tv 1.4.0.9 is almost unusable. The me-tv-server tortures my harddisk when importing channels.conf (I actually thought it had locked cause the import took about 20 seconds) and also does heavy disc I/O occurs when switching channels. I'm almost certain, me-tv-server is busy writing/reading from some sqlite databases probably related to the EPG data.

I will not update to 1.4 as it has serious issues. Any ideas what might cause the issues?
Comment 109 Sven 2012-06-10 02:33:12 UTC
Created attachment 314841 [details]
me-tv-1.4.0.9.ebuild which applies path for sqlite/ext4 problem
Comment 110 Sven 2012-06-10 02:33:34 UTC
Created attachment 314843 [details, diff]
me-tv-sqlite-fix.patch for my ebuild
Comment 111 Sven 2012-06-10 02:34:36 UTC
The patch was taken from here: https://bugs.launchpad.net/me-tv/+bug/982421/
It fixes the heavy disk I/O problem for me, which I would otherwise have to fix with the barriers=0 mount option for ext4.
Comment 112 Sven 2012-06-10 02:42:38 UTC
Created attachment 314845 [details]
me-tv-1.4.0.9.ebuild which applies path for sqlite/ext4 problem

removed xine-lib dependency
Comment 113 Mario Kicherer 2012-06-10 09:56:09 UTC
Yes, as I wrote, 1.4.0.9 is buggy on my PC as well. I still use my first ebuild on daily basis. Works fine for me. ("ebuild for the new stable 1.4 series")

The code is still divided into server and several clients. I tried to seperate them with the use-flags, but I had no success so far. I think the build environment does not allow this yet.

Unfortunately, the last code commit was also over 2 months ago. So I would recommend using 1.4.0.6. Haven't tested 1.4.0.7 yet.
Comment 114 Olliver Schinagl 2012-07-17 14:45:29 UTC
dev-libs/libunique:1 needs to be added to the 1.3.6 ebuild as well. I guess the 2.0.1 one too as it can't find the installed libunique which in my case is 3.*
Comment 115 Mario Kicherer 2012-07-25 21:20:36 UTC
Created attachment 319248 [details]
Version bump to 1.4.0.10

Version bump to 1.4.0.10
Seems like the patch is not needed anymore. After a short check, everything looks good so far.
Comment 116 Sven 2012-09-13 14:31:15 UTC
(In reply to comment #115)
> Created attachment 319248 [details]
> Version bump to 1.4.0.10

Is this the ebuild that ended up in lordvan's overlay?

Well, the ebuild for 1.4.0.10 which is currently in lordvan's overlay lacks the dependency on media-video/vlc (which is used by me-tv for playback) and a dependency on dev-cpp/libxmlpp.
Comment 117 Mario Kicherer 2012-09-13 15:09:48 UTC
(In reply to comment #116)
> Is this the ebuild that ended up in lordvan's overlay?
> 
> Well, the ebuild for 1.4.0.10 which is currently in lordvan's overlay lacks
> the dependency on media-video/vlc (which is used by me-tv for playback) and
> a dependency on dev-cpp/libxmlpp.

As he made commits to his overlay recently, it seems, he is developing the ebuild separately from this bug. We have both dependencies in our version and I can confirm that it works on my machine (amd64).
Comment 118 Thomas Raschbacher gentoo-dev 2012-09-14 11:35:26 UTC
I completely missed those last comments here. I apologize.
I will have a look later (now that I am using me-tv myself again as well that will serve as a reminder !)

I'm gonna check what needs fixing/changing in the ebuild to include the deps. Thanks for your efforts!

anyway I plan to add 1.4.0.10 to the official tree - if I get time to then this weekend.
Also i did mask 2.x since it is not being maintaned - and also 1.4.10 works just fine :)
Comment 119 Thomas Raschbacher gentoo-dev 2012-09-21 15:32:23 UTC
quick update. I did incorporate all your changes - and even remove the dep on gtk-doc too since afaik it doesn't call it (gonna make sure about that if possible though).

Anyway I want to see about somehow installing the http server too (maybe just in the docs directory) + maybe adding a use flag. will update my overlay first and let you know so you can test it as well if you get a chance ;)
Comment 120 Thomas Raschbacher gentoo-dev 2012-09-21 15:38:26 UTC
quick question: why did you disable the schema installation?
Comment 121 Sven 2012-09-23 17:41:54 UTC
A dependency on dev-libs/libunique-1.1.6 should also be added.
Comment 122 Thomas Raschbacher gentoo-dev 2012-09-24 07:15:31 UTC
yes that dep is added, but I didn'T commit it yet.
although the http interface will require some coding/patching so i will just commit it in a bit i guess
Comment 123 Thomas Raschbacher gentoo-dev 2012-09-24 07:38:31 UTC
so anyway my dev-box happened to be on.
Commited the latest changes + a basic install of http server into /usr/share/doc

please let me know if I overlooked anything (I don't think so)

also regarding the QA issue about the desktop file I will let the author know as well ;)
Comment 124 Sven 2012-09-24 18:29:52 UTC
@lordvan:
!!! A file listed in the Manifest could not be found: /var/lib/layman/lordvan/media-tv/me-tv/me-tv-2.0.1.ebuild
Comment 125 Ulenrich 2012-09-24 20:05:30 UTC
Me wonder:
I have compiled me-tv from sabayon-for-gentoo overlay, because when I use lordvan I get all this gnomish - but I don't want. Despite of a working me-tv overlay lordvan wants:
---

These are the packages that would be merged, in order:

Calculating dependencies  . ... done!
[ebuild  N     ] sys-apps/sdparm-1.07  0 kB
[ebuild  N     ] app-crypt/p11-kit-0.14  USE="-debug" 534 kB
[ebuild  N     ] gnome-base/orbit-2.14.19-r1  USE="-debug -doc -test" 747 kB
[ebuild  N     ] sys-apps/sg3_utils-1.33  USE="-static-libs" 0 kB
[ebuild  N     ] sys-apps/rescan-scsi-bus-1.56  0 kB
[ebuild  N     ] x11-themes/sound-theme-freedesktop-0.7  404 kB
[ebuild  N     ] gnome-base/gnome-mime-data-2.18.0  USE="-debug" 593 kB
[ebuild  N     ] x11-themes/gnome-icon-theme-3.4.0  USE="-branding" 0 kB
[ebuild  N     ] x11-libs/libnotify-0.7.5  USE="introspection (symlink) -doc -test" 0 kB
[ebuild  N     ] virtual/notification-daemon-0  USE="-gnome" 0 kB
[ebuild  N     ] gnome-base/libbonobo-2.24.3  USE="-debug -doc -examples -test" 1,324 kB
[ebuild  NS    ] sys-fs/udisks-1.0.4-r3 [1.99.0-r1] USE="nls -debug -remote-access" 0 kB
[ebuild  N     ] gnome-base/libgnomecanvas-2.30.3  USE="glade -doc -test" 561 kB
[ebuild  N     ] media-libs/libcanberra-0.29  USE="alsa gstreamer gtk gtk3 sound udev -gnome -oss -pulseaudio -tdb" 309 kB
[ebuild  N     ] gnome-base/libgdu-3.0.2  USE="-avahi -doc -gnome-keyring" 0 kB
[ebuild  N     ] gnome-base/gnome-vfs-2.24.4-r1  USE="acl ssl -avahi -doc -fam -gnutls -ipv6 -kerberos -samba -test" 1,847 kB
[ebuild  N     ] app-crypt/gcr-3.4.1-r2  USE="introspection -debug -doc -test" 1,304 kB
[ebuild  N     ] gnome-base/gvfs-1.12.3  USE="archive cdda fuse gdu gphoto2 udev udisks -afp -avahi -bluetooth -bluray -doc -gnome-keyring -http -ios -samba" 0 kB
[ebuild  N     ] gnome-base/libgnome-2.32.1-r1  USE="-branding -debug -doc" 1,735 kB
[ebuild  N     ] dev-cpp/libgnomecanvasmm-2.26.0  USE="-debug -doc -examples" 320 kB
[ebuild  N     ] dev-cpp/gnome-vfsmm-2.26.0  USE="-debug -doc -examples" 614 kB
[ebuild  N     ] dev-cpp/libglademm-2.6.7  USE="-doc -examples" 319 kB
[ebuild  N     ] dev-cpp/libgnomemm-2.28.0  USE="-debug" 354 kB
[ebuild  N     ] gnome-base/libbonoboui-2.24.5  USE="-doc -examples -test" 954 kB
[ebuild  N     ] gnome-base/gnome-keyring-3.4.1  USE="caps pam -debug -doc (-selinux) -test" 1,082 kB
[ebuild  N     ] gnome-base/libgnome-keyring-3.4.1  USE="introspection -debug -doc -test" 408 kB
[ebuild  N     ] gnome-base/libgnomeui-2.24.5  USE="-doc -test" 1,407 kB
[ebuild  N     ] dev-cpp/libgnomeuimm-2.28.0  USE="-debug" 374 kB
[ebuild   R    ] media-tv/me-tv-1.4.0.10::lordvan [1.4.0.10::saba] USE="nls -debug -http%" 0 kB

Total: 29 packages (27 new, 1 in new slot, 1 reinstall), Size of downloads: 15,182 kB
Comment 126 Thomas Raschbacher gentoo-dev 2012-09-24 22:57:20 UTC
ah sorry about the missing file i forgot to delete the old ebuild ..

hmm interesting about the deps. Maybe they changed them more than I was aware. I will have a look at the sabayan-for-gentoo one - I assume you mean https://git.sabayon.org/overlays/for-gentoo.git/tree/media-tv/me-tv/me-tv-1.4.0.10.ebuild

I will try to confirm that later (i have all the gnome stuff installed on my machines anyway for other programs so I didn't really notice). It would be good to get rid of unneeded deps of course!
Comment 127 Ulenrich 2012-09-25 00:05:13 UTC
@Thomas, a diff sabayon lordvan 
shows:
---
< RDEPEND=">=dev-cpp/gconfmm-.20.0
<       dev-cpp/gtkmm:2.4      
---
> IUSE="debug http nls"
> RDEPEND=">=dev-cpp/libgnomemm-2.20.0
>       >=dev-cpp/libgnomecanvasmm-2.20.0
>       >=dev-cpp/libgnomeuimm-2.20.0
>       >=dev-cpp/gconfmm-2.20.0
>       >=dev-cpp/gtkmm-2.16.0
37,38c40,56
<               $(use_enable nls) \
<               --disable-schemas-install

probably interesting --disable-schemas-install. But this would surely be desired unsing gnome DE ...
Comment 128 Ulenrich 2012-09-25 00:24:59 UTC
As of gnome-3 also sloted<gtkmm:3.0 could be needed? 
(not yet an expert though)
Comment 129 Mart Raudsepp gentoo-dev 2012-09-25 01:58:54 UTC
(In reply to comment #127)
> 37,38c40,56
> <               $(use_enable nls) \
> <               --disable-schemas-install
> 
> probably interesting --disable-schemas-install. But this would surely be
> desired unsing gnome DE ...

Schemas install must be disabled and done in pkg_postinst instead with gnome2_scrollkeeper_update (found in gnome2-utils.eclass).
gnome2.eclass handles it with an environment variable instead, and also takes care of a lot of other things. As lordvan's ebuild uses gnome2.eclass, this should be fine without passing --disable-schemas-install I believe.
All the other things, like icon cache updates, and so on should also be taken care of by gnome2.eclass already, provided that the phase functions aren't overridden and the eclass one not called.

In lordvan overlay you shouldn't be calling econf in src_prepare:
a) Overriding some things done in gnome2_src_prepare (though probably not necessary things for me-tv)
b) It must be done in src_configure, which it is re-done in from gnome2_src_configure, so your econf call in src_prepare actually does nothing effective, just runs configure only to be re-ran with different options in src_configure phase by the eclass one.

But when using gnome2.eclass, the best way is instead to set the G2CONF variable in pkg_setup instead. This would also take care of gtk-doc and debug options for you, but with some gotchas due to how things are handled in official gnome packages usually:

1) Only --enable-debug is passed with USE=debug, nothing in case of USE=-debug - that's because generally --disable-debug would disable API usage safeties as well in many gnome packages, while --enable-debug=minimum is the default and wanted one (--enable-debug=yes adding library internal debugging not needed for usages). For me-tv case, probably no difference as long as the default isn't --enable-debug for some reason. IUSE=debug is added for you unless GCONF_DEBUG=no isn't set before inheriting gnome2 eclass. Safest to set GCONF_DEBUG=yes if you want the eclass to handle it (as we may change the default to "no" at some point in the future); if you want to handle it yourself, no must be passed or you are handling it in both places, which is not good.

2) use_enable doc gtk-doc is also handled automatically, but for this IUSE must contain "doc", afterwards everything is handled for you by gnome2.eclass. Note that to get gtk-doc documentation, you generally don't need USE=doc, but this only makes the documentation already shipped in the tarball regenerated, making cross-referencing to other libraries documentation work offline. However these days there's also a cross-reference fixer available that can fix it in the pre-generated documentation, so you may want to always depend on gtk-doc-am package instead, which should include that utility split out of the full gtk-doc package. You also would probably need gtk-doc-am if you ever eautoreconf, as it contains necessary .m4 files from gtk-doc. These are of course all build-time deps only. If the upstream tarball does ship with pre-generated tarballs, consider if you want USE=doc at all, or can just rely on the pre-generated ones (possibly with always build-depending on gtk-doc-am). In GNOME we always install them, and tell users to use INSTALL_MASK if they don't want it.

Other notes:

a) You probably more than likely missing a virtual/pkgconfig build dependency.
b) No documentation is installed like NEWS, ChangeLog or so. I don't know what exists in the tarball, but this can be achieved by setting DOCS variable in pkg_setup (alongside G2CONF). If documentation is installed by the package itself, probably would need to set the docdir to /usr/share/doc/$PF in G2CONF unless portage sets that itself these days (also unsure if it'd get properly compressed then).
c) You must depend on a specific SLOT of gstreamer, in preparation of gstreamer-1.0. So media-libs/gstreamer:0.10 in this case
d) You probably miss quite a few gstreamer dependencies, as gstreamer alone is media-agnostic and doesn't do anything audio/video specific. If playbin2 is used by upstream, then perhaps a gst-plugins-meta rdependency would suffice.
e) SLOT deps on deps for everything else not from SLOT=0 as well - probably primarily matters for gtkmm and libunique.
f) Useless src_compile declaration if it just calls eclass one only.
g) What is IUSE=static supposed to be doing?
Comment 130 Thomas Raschbacher gentoo-dev 2012-09-25 09:25:48 UTC
Wow thanks for the explaination. I have to admit I am not too familiar with current gnome2 eclass.
I will have a look at what you mentioned - probably after work today

the IUSE static is actually just a leftover that I forgot to remove it seems.
Comment 131 Mario Kicherer 2012-09-25 10:11:59 UTC
I've added "--disable-schemas-install" as I didn't manage to get the ebuild to work without throwing errors/warnings and the app did work for me without (but I'm also not a gnome user).

Besides http, afair it also has a CLI interface. I tried to build both conditional with use flags but the build system is not prepared for this and needs patching. As I'm not familiar with the gnome-specific build stuff, I gave up quite soon.
Comment 132 Thomas Raschbacher gentoo-dev 2012-09-28 09:27:19 UTC
just an update:

I am currently fiddling with this stuff and prolly going to also send some patches to the author (for one for installing the http stuff) - it might take me a bit though since I am quite busy with work as well at the moment. - guess I will update the deps in my overlay when I get a chance later
Comment 133 Thomas Raschbacher gentoo-dev 2012-10-02 07:30:40 UTC
I did update the deps. also removed libXtst dep as they don't seem to be used as far as I can tell (no linkage,..)

Ulenrich, Mario could you check if this works out for you now? I have all the gnome stuff installed so it is a bit of a pain to make sure

gnet is not used either, but the build system still checks, so added it again to make sure. also reporting it as a bug upstream

linking some bugs here I reported:

https://bugs.launchpad.net/me-tv/+bug/1060020
https://bugs.launchpad.net/me-tv/+bug/1055345
Comment 134 Mario Kicherer 2012-10-04 19:19:44 UTC
On my local machine, it compiles fine. Unfortunately, I don't have access to my DVB machine right now. But I never had problems with deps anyway.
Comment 135 Thomas Raschbacher gentoo-dev 2012-10-07 12:15:12 UTC
If noone has any issues with deps and stuff anymore I will add this to the tree soon.
So please let me know if there's anything that is still a problem
Comment 136 Thomas Raschbacher gentoo-dev 2012-10-21 15:30:37 UTC
committed