Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 196549 - >=gnome-base/gdm-2.20 - user list is blank
Summary: >=gnome-base/gdm-2.20 - user list is blank
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 197269 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-10-20 20:02 UTC by Balint Dobai-Pataky
Modified: 2008-09-08 16:44 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Balint Dobai-Pataky 2007-10-20 20:02:33 UTC
the list did not even appear in gdm - no matter what settings i applied.
now in 2.20.1 the list appears, but no user is in it. - i have explicitly set some users to appear in the list.


Reproducible: Always
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-10-20 20:07:16 UTC
gdm != games (yet :P)
Comment 2 Balint Dobai-Pataky 2007-10-20 20:14:04 UTC
sorry :-D

i see this in my messages log:
gdm[8490]: pam_nologin(gdm:auth): cannot determine username
Comment 3 Marc Geerlings 2007-10-21 10:52:10 UTC
Same problem on also a amd64
Comment 4 Víctor Enríquez 2007-10-22 00:25:14 UTC
Same problem here too, I can't see the user list, the "faces" of the users are gone,using gdm-2.20.1, it doesn't seem related to any theme or setting.
Comment 5 Víctor Enríquez 2007-10-24 16:39:18 UTC
I can see the list, if I put the option Browser=true in the file /usr/share/gdm/default.conf, I think this is not a bug, it's only disabled.
Maybe you can put a message at the end of the ebuild, saying how to enable the Browser.
Comment 6 Balint Dobai-Pataky 2007-10-24 16:59:57 UTC
if i enter the Browser=true in the custom.conf i see the listbox, but nothing in it
Comment 7 Balint Dobai-Pataky 2007-10-24 19:54:56 UTC
i tested it yesterday, and didn't work
now it does. i mean if i add the Browser=true setting, so it's cool than,
sorry
Comment 8 Gilles Dartiguelongue gentoo-dev 2007-11-18 11:55:55 UTC
*** Bug 197269 has been marked as a duplicate of this bug. ***
Comment 9 Pacho Ramos gentoo-dev 2007-11-22 00:02:39 UTC
I have the same problem, maybe this bug should be reopened
Comment 10 Fabio Bonfante 2007-11-23 01:30:50 UTC
same problem, solved editing (i think better place)
/etc/X11/gdm/custom.conf
(it overrides /usr/share/gdm/default.conf)
---------------------
[greeter]
Browser=true
---------------------

Anyway looking at the comments in default.conf seems that the "browser component" had to be showed (by gdm obviously) with themes using it... are we really sure that it's not an upstream "bug" or a not well documented behavior's change?
Comment 11 Pacho Ramos gentoo-dev 2007-11-23 08:46:09 UTC
The problem is fixed adding "Browser=true"m but this line should be added by gdmsetup when needed :-/
Comment 12 Pacho Ramos gentoo-dev 2007-11-23 08:46:45 UTC
(In reply to comment #11)
> The problem is fixed adding "Browser=true"m but this line should be added by
> gdmsetup when needed :-/
> 

when needed :-/ -> when user configures gdm for showing users list
Comment 13 Gilles Dartiguelongue gentoo-dev 2008-01-16 22:23:40 UTC
In order to make it clear for everybody, I hit this on a 2.16 -> 2.20 transition. The solution is simply to check the damn checkbox in gdm. Do not trust the preview of the gdm theme, there is now a checkbox to activate the user list on themes supporting it and it is disable by default. Thanks for your attention.
Comment 14 Olexandr Shalakhin 2008-09-07 13:10:56 UTC
(In reply to comment #13)
> In order to make it clear for everybody, I hit this on a 2.16 -> 2.20
> transition. The solution is simply to check the damn checkbox in gdm. Do not
> trust the preview of the gdm theme, there is now a checkbox to activate the
> user list on themes supporting it and it is disable by default. Thanks for your
> attention.
> 

Does it means that gdm would not support user list? I have changed 
[greeter]
Browser=true
at /etc/X11/gdm/custom.conf and /usr/share/gdm/default.conf. As the result user lists are still empty :'(
Comment 15 Pacho Ramos gentoo-dev 2008-09-07 15:36:26 UTC
Simply open "gdmsetup" and go to "Local" tab, then, use "Style:" for configuring it

This should work
Comment 16 Olexandr Shalakhin 2008-09-08 16:44:04 UTC
(In reply to comment #15)
> Simply open "gdmsetup" and go to "Local" tab, then, use "Style:" for
> configuring it
> 
> This should work
> 

Thanks :)