Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 194681 - app-emulation/qemu-softmmu-0.9.0 fails to compile with gcc-3.4.6
Summary: app-emulation/qemu-softmmu-0.9.0 fails to compile with gcc-3.4.6
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Luca Barbato
URL:
Whiteboard:
Keywords:
: 196614 Pryan 212195 212513 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-10-04 07:25 UTC by Aniruddha
Modified: 2008-05-20 23:11 UTC (History)
18 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,102.06 KB, text/plain)
2007-10-04 07:27 UTC, Aniruddha
Details
Accept HACK_CFLAGS variable (hack_cflags.patch,958 bytes, patch)
2008-05-12 14:57 UTC, Martin von Gagern
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Aniruddha 2007-10-04 07:25:04 UTC
Qemu fails to compile. I get this error message:

.9.0/work/qemu-0.9.0/slirp  -c -o helper.o /var/tmp/portage/app-emulation/qemu-s
oftmmu-0.9.0/work/qemu-0.9.0/target-ppc/helper.c
../softmmu_template.h: In function `__stq_mmu':
../softmmu_template.h:260: error: unable to find a register to spill in class `G
ENERAL_REGS'
../softmmu_template.h:260: error: this is the insn:
(insn:HI 337 317 338 13 ../softmmu_template.h:287 (parallel [
            (set (reg:DI 0 ax [214])
                (lshiftrt:DI (reg/v:DI 59 [ val ])
                    (subreg:QI (reg:SI 235) 0)))
            (clobber (scratch:SI))
            (clobber (reg:CC 17 flags))
        ]) 309 {lshrdi3_1} (nil)
    (expr_list:REG_UNUSED (reg:CC 17 flags)
        (expr_list:REG_UNUSED (scratch:SI)
            (nil))))
../softmmu_template.h:260: confused by earlier errors, bailing out
make[1]: *** [op_helper.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0/wo
rk/qemu-0.9.0/ppc-softmmu'
make: *** [subdir-ppc-softmmu] Error 2
 *
 * ERROR: app-emulation/qemu-softmmu-0.9.0 failed.
 * Call stack:
 *   ebuild.sh, line 1654:   Called dyn_compile
 *   ebuild.sh, line 990:   Called qa_call 'src_compile'
 *   ebuild.sh, line 44:   Called src_compile
 *   qemu-softmmu-0.9.0.ebuild, line 98:   Called die
 *
 * make failed
 * If you need support, post the topmost build error, and the call stack if rele                                                                           vant.
 * A complete build log is located at '/var/tmp/portage/app-emulation/qemu-softm                                                                           mu-0.9.0/temp/build.log'.
 *


# gcc-config -l
 [1] i686-pc-linux-gnu-3.4.6 *


Reproducible: Always

Steps to Reproduce:
1.Set gcc to 3.4.6
2.emerge qemu
3.
Comment 1 Aniruddha 2007-10-04 07:27:09 UTC
Created attachment 132525 [details]
build.log
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-10-04 07:40:39 UTC
emerge --info please.
Comment 3 Aniruddha 2007-10-04 08:16:59 UTC
Should I add emerge --info to each bugreport?

# emerge --info
--- Invalid atom in /etc/portage/package.mask: =sys-devel/gcc-3.4.6 ~x86
Portage 2.1.3.9 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.5-r4, 2.6.21-gentoo-r4 i686)
=================================================================
System uname: 2.6.21-gentoo-r4 i686 AMD Athlon(tm) 64 Processor 4000+
Timestamp of tree: Sun, 23 Sep 2007 09:00:09 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe -msse3"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=athlon64 -O2 -pipe -msse3"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.tiscali.nl/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/ftd4linux /usr/portage/local/layman/sunrise /usr/portage/local/layman/portato /usr/portage/local/layman/secondlife /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X Xaw3d a52 aac acl acpi alsa apache2 arts bash-completion berkdb bitmap-fonts bluetooth branding cairo cdinstall cdparanoia cdr cli cracklib crypt cups dbus dedicated dga doc dri dvd dvdr dvdread eds emboss encode esd evo exif fam ffmpeg firefox flac foomaticdb fortran gdbm gif gpm gstreamer gtk gtk2 hal iconv imagemagick imap imlib ipv6 isdnlog java jikes joystick jpeg jpeg2k kde kerberos ldap libnotify mad maildir matroska midi mikmod mmx mp3 mpeg mplayer mudflap musepack mysql ncurses nls nocd nptl nptlonly nsplugin offensive ofx ogg openal opengl openmp oss pam pcmcia pcre pda pdf perl php png pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl sqlite sse sse2 ssl svg svga tcpd tiff tk truetype truetype-fonts type1-fonts unicode usb vcd videos vorbis wifi win32codecs wxwindows x86 xface xine xinerama xml xorg xprint xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev joystick keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia vesa nv"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-10-04 11:24:09 UTC
(In reply to comment #3)
> Should I add emerge --info to each bugreport?

Yes please.
Comment 5 Luca Barbato gentoo-dev 2007-10-04 12:27:23 UTC
gcc bug/architecture limit reached?
Comment 6 Auke Booij (tulcod) 2007-10-15 19:10:14 UTC
same here, i'm sure that i'm using gcc 3.4.6-r2. same output, no significant differences in emerge --info
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2007-10-21 14:39:41 UTC
*** Bug 196614 has been marked as a duplicate of this bug. ***
Comment 8 Florian Knodt 2007-10-25 09:24:48 UTC
Same here with gcc-3.4.6-r2 and 3.4.5 (x86, USE="-*") - GCC 3.3.6 works
Comment 9 Carlo Marcelo Arenas Belon 2007-11-22 18:36:37 UTC
this problem seems to be specific to gentoo x86 because :

gcc-3.4.6 as provided by Ubuntu Gutsy (gcc-3.4) or Fedora 8 (compat-gcc-34) in x86 work.
gcc-3.4.6-r2 as provided by Gentoo 2007.0 in amd64 works too
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2007-12-22 19:17:24 UTC
*** Bug 203055 has been marked as a duplicate of this bug. ***
Comment 11 GNUtoo 2008-01-26 21:25:46 UTC
i have the same bug compiling gcc for openmoko...
they have a bugreport here:
http://bugzilla.openmoko.org/cgi-bin/bugzilla/show_bug.cgi?id=1093

and here's my compilation output:
gcc-3.4.6 -Wall -O2 -g -fno-strict-aliasing -I. -I.. -I/home/gentux/dev/embedded/openmoko/qemu-neo1973/target-arm -I/home/gentux/dev/embedded/openmoko/qemu-neo1973 -MMD -MP -ome/gentux/dev/embedded/openmoko/qemu-neo1973/gnokiigsm -I/home/gentux/dev/embedded/openmoko/qemu-neo1973/slirp    -c -o gdbstub.o /home/gentux/dev/embedded/openmoko/qemu-neo
gcc-3.4.6 -Wall -O2 -g -fno-strict-aliasing -I. -I.. -I/home/gentux/dev/embedded/openmoko/qemu-neo1973/target-arm -I/home/gentux/dev/embedded/openmoko/qemu-neo1973 -MMD -MP -ome/gentux/dev/embedded/openmoko/qemu-neo1973/gnokiigsm -I/home/gentux/dev/embedded/openmoko/qemu-neo1973/slirp    -c -o exec.o /home/gentux/dev/embedded/openmoko/qemu-neo197
gcc-3.4.6 -Wall -O2 -g -fno-strict-aliasing -I. -I.. -I/home/gentux/dev/embedded/openmoko/qemu-neo1973/target-arm -I/home/gentux/dev/embedded/openmoko/qemu-neo1973 -MMD -MP -ome/gentux/dev/embedded/openmoko/qemu-neo1973/gnokiigsm -I/home/gentux/dev/embedded/openmoko/qemu-neo1973/slirp    -c -o kqemu.o /home/gentux/dev/embedded/openmoko/qemu-neo19
gcc-3.4.6 -Wall -O2 -g -fno-strict-aliasing  -fno-reorder-blocks  -fno-gcse    -fno-optimize-sibling-calls  -fno-crossjumping  -fno-align-labels  -fno-align-jumps  -fno-alignme/gentux/dev/embedded/openmoko/qemu-neo1973 -MMD -MP -DNEED_CPU_H -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/home/gentux/dev/embedded/openmoko/qemu-neo1973/p.o /home/gentux/dev/embedded/openmoko/qemu-neo1973/target-arm/op.c
/home/gentux/dev/embedded/openmoko/qemu-neo1973/target-arm/op_neon.h: In function `op_neon_shl_u64':
/home/gentux/dev/embedded/openmoko/qemu-neo1973/target-arm/op_neon.h:412: error: unable to find a register to spill in class `GENERAL_REGS'
/home/gentux/dev/embedded/openmoko/qemu-neo1973/target-arm/op_neon.h:412: error: this is the insn:
(insn:HI 26 25 27 1 /home/gentux/dev/embedded/openmoko/qemu-neo1973/target-arm/op_neon.h:405 (parallel [
            (set (reg/v:DI 60 [ val ])
                (lshiftrt:DI (reg/v:DI 60 [ val ])
                    (subreg:QI (reg:SI 64 [ shift ]) 0)))
            (clobber (scratch:SI))
            (clobber (reg:CC 17 flags))
        ]) 309 {lshrdi3_1} (insn_list 25 (nil))
    (expr_list:REG_DEAD (reg:SI 64 [ shift ])
        (expr_list:REG_UNUSED (reg:CC 17 flags)
            (expr_list:REG_UNUSED (scratch:SI)
                (nil)))))
/home/gentux/dev/embedded/openmoko/qemu-neo1973/target-arm/op_neon.h:412: confused by earlier errors, bailing out
make[1]: *** [op.o] Error 1
make[1]: Leaving directory `/home/gentux/dev/embedded/openmoko/qemu-neo1973/arm-softmmu'
make: *** [subdir-arm-softmmu] Error 2
Comment 12 letrec@gmail.com 2008-01-30 17:58:45 UTC
bug confirmed. 

Reproducible: Always.

I thought this bug may be specific to hardened. 


Anniruda, you may want to remove the trailing '~x86' from your /etc/portage/package.mask on the line with '=sys-devel/gcc-3.4.6' as this is invalid formatting. 


../softmmu_template.h: In function `__stq_mmu':
../softmmu_template.h:260: error: unable to find a register to spill in class `GENERAL_REGS'
../softmmu_template.h:260: error: this is the insn:
(insn:HI 352 332 353 13 ../softmmu_template.h:287 (parallel [
            (set (reg:DI 0 ax [214])
                (lshiftrt:DI (reg/v:DI 59 [ val ])
                    (subreg:QI (reg:SI 238) 0)))
            (clobber (scratch:SI))
            (clobber (reg:CC 17 flags))
        ]) 309 {lshrdi3_1} (nil)
    (expr_list:REG_UNUSED (reg:CC 17 flags)
        (expr_list:REG_UNUSED (scratch:SI)
            (nil))))
../softmmu_template.h:260: confused by earlier errors, bailing out
make[1]: *** [op_helper.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/mips-softmmu'
make: *** [subdir-mips-softmmu] Error 2
 * 
 * ERROR: app-emulation/qemu-softmmu-0.9.0-r1 failed.
 * Call stack:
 *                      ebuild.sh, line 1701:  Called dyn_compile
 *                      ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *                      ebuild.sh, line   44:  Called src_compile
 *   qemu-softmmu-0.9.0-r1.ebuild, line   99:  Called die
 * The specific snippet of code:
 *      emake || die "make failed"
 *  The die message:
 *   make failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/temp/build.log'.
 * 

 * Messages for package app-emulation/qemu-softmmu-0.9.0-r1:

 * 
 * ERROR: app-emulation/qemu-softmmu-0.9.0-r1 failed.
 * Call stack:
 *                      ebuild.sh, line 1701:  Called dyn_compile
 *                      ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *                      ebuild.sh, line   44:  Called src_compile
 *   qemu-softmmu-0.9.0-r1.ebuild, line   99:  Called die
 * The specific snippet of code:
 *      emake || die "make failed"
 *  The die message:
 *   make failed
 * 

Comment 13 Carlo Marcelo Arenas Belon 2008-01-30 22:15:56 UTC
(In reply to comment #12)
> bug confirmed. 
> 
> Reproducible: Always.
> 
> I thought this bug may be specific to hardened. 

you can't compile qemu with a hardened compiler but that is documented and a set of workarounds are proposed and tracked in BUG166392.

this bug is aboug not being to compile qemu with gcc-3.4.6 as provided by gentoo in x86.
Comment 14 Kevin F. Quinn (RETIRED) gentoo-dev 2008-02-10 15:31:43 UTC
I get something similar with gcc-3.4.6-r2:

i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing  -fno-reorder-blocks  -fno-gcse    -fno-optimize-sibling-calls  -fno-crossjumping  -fno-align-labels  -fno-align-jumps  -fno-align-functions   -mpreferred-stack-boundary=2 -fomit-frame-pointer   -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.1/work/qemu-0.9.1/target-i386 -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.1/work/qemu-0.9.1 -MMD -MP -DNEED_CPU_H -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.1/work/qemu-0.9.1/fpu  -DHAS_AUDIO -DHAS_AUDIO_CHOICE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.1/work/qemu-0.9.1/slirp -c -o op.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.1/work/qemu-0.9.1/target-i386/op.c
/var/tmp/portage/app-emulation/qemu-softmmu-0.9.1/work/qemu-0.9.1/target-i386/ops_sse.h: In function `op_psrlq_mmx':
/var/tmp/portage/app-emulation/qemu-softmmu-0.9.1/work/qemu-0.9.1/target-i386/ops_sse.h:213: error: unable to find a register to spill in class `GENERAL_REGS'
/var/tmp/portage/app-emulation/qemu-softmmu-0.9.1/work/qemu-0.9.1/target-i386/ops_sse.h:213: error: this is the insn:
(insn:HI 36 35 37 3 /var/tmp/portage/app-emulation/qemu-softmmu-0.9.1/work/qemu-0.9.1/target-i386/ops_sse.h:207 (parallel [
            (set (reg:DI 63 [ <variable>.q ])
                (lshiftrt:DI (reg:DI 63 [ <variable>.q ])
                    (subreg:QI (reg/v:SI 60 [ shift ]) 0)))
            (clobber (scratch:SI))
            (clobber (reg:CC 17 flags))
        ]) 309 {lshrdi3_1} (insn_list 33 (insn_list 35 (nil)))
    (expr_list:REG_DEAD (reg/v:SI 60 [ shift ])
        (expr_list:REG_UNUSED (reg:CC 17 flags)
            (expr_list:REG_UNUSED (scratch:SI)
                (nil)))))

I tried a vanilla build of gcc-3.4.6-r2 (i.e. without any patches to gcc; means tweaking toolchain.eclass slightly to get that to work) and it fails the same way, so it's not the Gentoo patches that cause the problem.  Using gcc-3.3.6-r1 builds without errors (which could mean there's no problem when building with 3.3.6 - or it could mean there is a problem, just 3.3.6 doesn't notice the problem).



# emerge --info
Portage 2.1.4.1 (default-linux/x86/2006.1, gcc-3.3.6, glibc-2.6.1-r0, 2.6.23-gentoo-r6 i686)
=================================================================
System uname: 2.6.23-gentoo-r6 i686 AMD Athlon(tm) XP 2500+
Timestamp of tree: Sun, 03 Feb 2008 10:00:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe -ggdb2"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe -ggdb2"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs collision-protect cvs distlocks fixpackages installsources metadata-transfer pax sandbox sfperms sign splitdebug strict test unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="ftp://ibiblio.org/pub/linux/distributions/gentoo/ http://gentoo.virginmedia.com/ http://mirror.qubenet.net/mirror/gentoo/"
LDFLAGS="-Wl,-O1"
LINGUAS="en_GB en it de es fr"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays/tree"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi ada alsa apache2 arts audiofile berkdb bitmap-fonts bzip2 cairo caps cdparanoia cdr cli cracklib crypt cups cvs dbus dri dts dv dvb dvd dvdr dvdread encode fam fax ffmpeg firefox flac flash foomaticdb fortran gcj gdbm gif gnutls gpm gs gstreamer gtk gtk2 hal iconv imagemagick imap imlib ipod ipv6 isdnlog jack java javascript jbig jpeg jpeg2k kde ldap lesstif mad mbrola midi mime ming mmap mmx mmxext mng mp3 mpeg mplayer mudflap nas ncurses nls nptl nptlonly nsplugin offensive ogg opengl openmp pam pcre pda pdf perl png ppds pppd pygtk python qt3 qt4 quicktime readline reflection rle ruby samba sdl session speex spell spl sse sse2 ssl subversion svg tcl tcltk tcpd test tetex theora threads tidy tiff tk truetype truetype-fonts type1-fonts unicode usb v4l v4l2 vcd vdr vim-syntax vorbis wifi win32codecs wmf x264 x86 xine xinerama xml xmlrpc xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en it de es fr" USERLAND="GNU" VIDEO_CARDS="radeon vesa vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2008-03-03 15:34:27 UTC
*** Bug 212195 has been marked as a duplicate of this bug. ***
Comment 16 Tim Redman 2008-03-07 14:40:03 UTC
*** Bug 212513 has been marked as a duplicate of this bug. ***
Comment 17 Stefano Takekawa 2008-03-13 15:53:04 UTC
Same error here.

i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing -mpreferred-stack-boundary=2 -fomit-frame-pointer -falign-functions=0 -fno-gcse -fno-reorder-blocks -fno-optimize-sibling-calls  -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-i386 -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/fpu -DHAS_AUDIO -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp -c -o op.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-i386/op.c
/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-i386/ops_sse.h: In function `op_psrlq_mmx':
/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-i386/ops_sse.h:213: error: unable to find a register to spill in class `GENERAL_REGS'
/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-i386/ops_sse.h:213: error: this is the insn:
(insn:HI 36 35 37 3 /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-i386/ops_sse.h:207 (parallel [
            (set (reg:DI 63 [ <variable>.q ])
                (lshiftrt:DI (reg:DI 63 [ <variable>.q ])
                    (subreg:QI (reg/v:SI 60 [ shift ]) 0)))
            (clobber (scratch:SI))
            (clobber (reg:CC 17 flags))
        ]) 309 {lshrdi3_1} (insn_list 33 (insn_list 35 (nil)))
    (expr_list:REG_DEAD (reg/v:SI 60 [ shift ])
        (expr_list:REG_UNUSED (reg:CC 17 flags)
            (expr_list:REG_UNUSED (scratch:SI)
                (nil)))))
/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-i386/ops_sse.h:213: confused by earlier errors, bailing out
make[1]: *** [op.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/i386-softmmu'
make: *** [subdir-i386-softmmu] Error 2


compass04al ~ # emerge --info
Portage 2.1.4.4 (default-linux/x86/2007.0/desktop, gcc-3.4.6, glibc-2.5-r4, 2.6.23-gentoo-r8 i686)
=================================================================
System uname: 2.6.23-gentoo-r8 i686 Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Timestamp of tree: Thu, 13 Mar 2008 05:00:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.4.4-r9
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
DISTDIR="/mnt/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
FEATURES="buildpkg candy distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.oregonstate.edu http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="it_IT.utf8"
LC_ALL="it_IT.utf8"
LINGUAS="it en"
MAKEOPTS="-j1"
PKGDIR="/mnt/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays/my_portage"
SYNC="rsync://compasstore01/gentoo-portage"
USE="X a52 aac acl acpi alsa arts asf audiofile avi berkdb browserplugin bzip2 bzlib cairo cdr cli cracklib crypt cups dbus divx4linux djvu dmi dri dvd dvdr dvdread dvi eds emacs emboss encode evo extensions fam fame fbcon fbcondecor ffmpeg fftw firefox flac foomaticdb fortran gdbm gif gimp glibc-compat20 glitz gnome gpm gs gstreamer gtk gtk2 hal i8x0 iconv id3tag imagemagick imlib intel isdnlog ithreads java javascript jpeg kde kdeenablefinal latex libnotify lm_sensors logrotate lzo mad midi mikmod mjpeg mmx mmxext mng motif mp3 mpeg mudflap musicbrainz mysql nautilus ncurses network nis nls nopie nossp nptl nptlonly nsplugin ogg oggvorbis opengl openmp pam pch pcre pdf pdflib perl pic png ppds pppd python qt qt3 qt3support qt4 quicktime quota rdesktop readline real reflection samba sane sdl session smp sndfile spell spl sse sse2 ssl ssse3 startup-notification svg svga syslog tcl tetex theora threads tiff tk truetype twolame unicode usb userlocales utempter vcd vorbis win32codecs wma wmf wxwindows x86 xcomposite xemacs xforms xine xml xorg xpm xscreensaver xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it en" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa fbdev"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 18 Andreas Thalhammer 2008-04-12 20:32:10 UTC
And also here, the same error.

...SNIP...
i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/fpu -DHAS_AUDIO -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp  -c -o slirp/socket.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp/socket.c
/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-i386/ops_sse.h: In function `op_psrlq_mmx':
/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-i386/ops_sse.h:213: error: unable to find a register to spill in class `GENERAL_REGS'
/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-i386/ops_sse.h:213: error: this is the insn:
(insn:HI 36 35 37 3 /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-i386/ops_sse.h:207 (parallel [
            (set (reg:DI 63 [ <variable>.q ])
                (lshiftrt:DI (reg:DI 63 [ <variable>.q ])
                    (subreg:QI (reg/v:SI 60 [ shift ]) 0)))
            (clobber (scratch:SI))
            (clobber (reg:CC 17 flags))
        ]) 309 {lshrdi3_1} (insn_list 33 (insn_list 35 (nil)))
    (expr_list:REG_DEAD (reg/v:SI 60 [ shift ])
        (expr_list:REG_UNUSED (reg:CC 17 flags)
            (expr_list:REG_UNUSED (scratch:SI)
                (nil)))))
/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-i386/ops_sse.h:213: confused by earlier errors, bailing out
make[1]: *** [op.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/i386-softmmu'
make: *** [subdir-i386-softmmu] Error 2
make: *** Waiting for unfinished jobs....
i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/fpu -DHAS_AUDIO -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp  -c -o slirp/tcp_input.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp/tcp_input.c
i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/fpu -DHAS_AUDIO -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp  -c -o slirp/tcp_output.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp/tcp_output.c
i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/fpu -DHAS_AUDIO -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp  -c -o slirp/tcp_subr.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp/tcp_subr.c
i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/fpu -DHAS_AUDIO -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp  -c -o slirp/tcp_timer.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp/tcp_timer.c
i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/fpu -DHAS_AUDIO -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp  -c -o slirp/udp.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp/udp.c
i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/fpu -DHAS_AUDIO -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp  -c -o slirp/bootp.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp/bootp.c
i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/fpu -DHAS_AUDIO -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp  -c -o slirp/debug.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp/debug.c
i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/fpu -DHAS_AUDIO -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp  -c -o slirp/tftp.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp/tftp.c
i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/fpu -DHAS_AUDIO -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp  -c -o exec.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/exec.c
i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/fpu -DHAS_AUDIO -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp  -c -o kqemu.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/kqemu.c
i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing -mpreferred-stack-boundary=2 -fomit-frame-pointer -falign-functions=0 -fno-gcse -fno-reorder-blocks -fno-optimize-sibling-calls  -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/fpu -DHAS_AUDIO -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp -c -o op.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc/op.c
i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing -fomit-frame-pointer -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/fpu -DHAS_AUDIO -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp  -c -o cpu-exec.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/cpu-exec.c
i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/fpu -DHAS_AUDIO -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp  -c -o fpu/softfloat-native.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/fpu/softfloat-native.c
i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing -fomit-frame-pointer -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/fpu -DHAS_AUDIO -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp  -c -o op_helper.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc/op_helper.c
i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/fpu -DHAS_AUDIO -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/slirp  -c -o helper.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/target-ppc/helper.c
../softmmu_template.h: In function `__stq_mmu':
../softmmu_template.h:260: error: unable to find a register to spill in class `GENERAL_REGS'
../softmmu_template.h:260: error: this is the insn:
(insn:HI 337 317 338 13 ../softmmu_template.h:287 (parallel [
            (set (reg:DI 0 ax [214])
                (lshiftrt:DI (reg/v:DI 59 [ val ])
                    (subreg:QI (reg:SI 235) 0)))
            (clobber (scratch:SI))
            (clobber (reg:CC 17 flags))
        ]) 309 {lshrdi3_1} (nil)
    (expr_list:REG_UNUSED (reg:CC 17 flags)
        (expr_list:REG_UNUSED (scratch:SI)
            (nil))))
../softmmu_template.h:260: confused by earlier errors, bailing out
make[1]: *** [op_helper.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0-r1/work/qemu-0.9.0/ppc-softmmu'
make: *** [subdir-ppc-softmmu] Error 2
...SNIP...

The GCC is also 3.4.6:
# emerge -pv =sys-devel/gcc-3.4.6-r2
[ebuild   R   ] sys-devel/gcc-3.4.6-r2  USE="d fortran gcj gtk nls objc (-altivec) -bootstrap -boundschecking -build -doc (-hardened) -ip28 -ip32r10k -libffi (-multilib) -multislot (-n32) (-n64) -nocxx -nopie -nossp -test -vanilla" 0 kB 

# emerge --info
Portage 2.1.4.4 (default-linux/x86/2007.0/desktop, gcc-3.4.6, glibc-2.6.1-r0, 2.6.24-gentoo-r4 i686)
=================================================================
System uname: 2.6.24-gentoo-r4 i686 Intel(R) Pentium(R) M processor 1700MHz
...SNIP...

BTW, the problem does NOT occur on a Power PC "ppc" of mine (Power Mac G4, Motorola Dual-PPC 7455 32-bit processor), QEMU build fine there.

Andreas.
Comment 19 Carlo Marcelo Arenas Belon 2008-05-11 23:59:26 UTC
a workaround as proposed by upstream is to use a CPU optimization which won't clobber the few available registers in x86.

CFLAGS="-march=i486" should work in all cases
Comment 20 Luca Barbato gentoo-dev 2008-05-12 05:22:16 UTC
anybody with an x86 could test it?
Comment 21 Martin von Gagern 2008-05-12 14:57:42 UTC
Created attachment 152953 [details, diff]
Accept HACK_CFLAGS variable

I tried the qemu-softmmu-0.9.1-r1.ebuild, and -march=i486 indeed did work for me, but I had a hard time getting that integrated into the proper variables, especially OP_CFLAGS. The sed command in the ebuild won't match correctly, and if it is changed to match, it will cause some kind of endless variable recursion.

So I modified the ebuild according to attached file and set HACK_CFLAGS=-march=i486 on the emerge command line, along with CC=gcc-3.4.6. As a result, the package did at least emerge.

As a next step, I guess these modifications should be restricted so that they will only affect people on x86, maybe only with gcc-3.4.6.
Comment 22 David Williams 2008-05-12 15:03:15 UTC
Just tried on my Athlon64 running as x86 - Sorry didn't work.

gcc-config

export PATH="/usr/i686-pc-linux-gnu/gcc-bin/3.4.6:/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/sbin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/3.4.6:/opt/sun-jdk-1.4.2.17/bin:/opt/sun-jdk-1.4.2.17/jre/bin:/opt/sun-jdk-1.4.2.17/jre/javaws"
g

emerge --info

Portage 2.1.4.4 (default-linux/x86/2007.0, gcc-3.4.6, glibc-2.6.1-r0, 2.6.24-gentoo-r7 i686)
=================================================================
System uname: 2.6.24-gentoo-r7 i686 AMD Athlon(tm) 64 Processor 3200+
Timestamp of tree: Fri, 09 May 2008 18:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r9
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.7.9-r1, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=-i486"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=-i486"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.blueyonder.co.uk/"
LINGUAS="en_GB en uk"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.uk.gentoo.org/gentoo-portage"
USE="X acl acpi alsa berkdb bzip2 cli cracklib crypt cups dbus dri fam fat foomaticdb fortran gdbm gpm gtk hal iconv isdnlog java kqemu midi mudflap ncurses nls nptl nptlonly nsplugin ntfs openmp pam pcre perl ppds pppd python readline reflection reiserfs sdl session spl ssl startup-notification tcpd unicode x86 xorg zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en uk" USERLAND="GNU" VIDEO_CARDS="vesa fbdev nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

Comment 23 RonnyPeine 2008-05-20 18:51:43 UTC
Could this bugreport be closed? qemu-softmmu is working like a charm since 0.9.1-r3 even on hardened-x86. Compiled and tested with sys-devel/gcc-3.4.6-r2 on i686-pc-linux-gnu (hardened).
Comment 24 Andreas Thalhammer 2008-05-20 21:01:54 UTC
(In reply to comment #23)
> qemu-softmmu is working like a charm since
> 0.9.1-r3 ... Compiled and tested with sys-devel/gcc-3.4.6-r2
> on i686-pc-linux-gnu.

I can confirm that on a non-hardened system.
Comment 25 Luca Barbato gentoo-dev 2008-05-20 23:11:04 UTC
good to know,