Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 191186 - media-video/xvattr-1.3-r2 fails if gtk use flag not set
Summary: media-video/xvattr-1.3-r2 fails if gtk use flag not set
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 191588 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-09-03 21:33 UTC by DeKay
Modified: 2007-09-07 13:02 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DeKay 2007-09-03 21:33:47 UTC
Did an emerge sync just prior to this, then emerge -vauND world.  The emerge failed when it got to xvattr.

mythbox ~ # emerge -pv xvattr
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] media-video/xvattr-1.3-r2 [1.3-r1] USE="-gtk" 0 kB

Total: 1 package (1 upgrade), Size of downloads: 0 kB

mythbox ~ # emerge xvattr
Calculating dependencies... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) media-video/xvattr-1.3-r2 to /
<snip checksums>
>>> Unpacking source...
>>> Unpacking xvattr-1.3.tar.gz to /var/tmp/portage/media-video/xvattr-1.3-r2/work
 * Applying xvattr-1.3-gtk.patch ...   [ ok ]
 * Running eautoreconf in '/var/tmp/portage/media-video/xvattr-1.3-r2/work/xvattr-1.3' ...
 * Running aclocal ...                 [ ok ]
 * Running autoconf ...                [ !! ]

 * Failed Running autoconf !
 * Include in your bugreport the contents of:
 *   /var/tmp/portage/media-video/xvattr-1.3-r2/temp/autoconf-3421.out

!!! ERROR: media-video/xvattr-1.3-r2 failed.
Call stack:
  ebuild.sh, line 1638:   Called dyn_unpack
  ebuild.sh, line 763:   Called qa_call 'src_unpack'
  ebuild.sh, line 44:   Called src_unpack
  xvattr-1.3-r2.ebuild, line 27:   Called eautoreconf
  autotools.eclass, line 95:   Called eautoconf
  autotools.eclass, line 165:   Called autotools_run_tool 'autoconf'
  autotools.eclass, line 218:   Called die

!!! Failed Running autoconf !
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/media-video/xvattr-1.3-r2/temp/build.log'.

mythbox ~ # less /var/tmp/portage/media-video/xvattr-1.3-r2/temp/build.log
>>> Unpacking source...
>>> Unpacking xvattr-1.3.tar.gz to /var/tmp/portage/media-video/xvattr-1.3-r2/work
 * Applying xvattr-1.3-gtk.patch ...  [ ok ]
 * Running eautoreconf in '/var/tmp/portage/media-video/xvattr-1.3-r2/work/xvattr-1.3' ...
 * Running aclocal ...  [ ok ]
 * Running autoconf ... [ !! ]

 * Failed Running autoconf !
 * Include in your bugreport the contents of:
 *   /var/tmp/portage/media-video/xvattr-1.3-r2/temp/autoconf-3421.out

!!! ERROR: media-video/xvattr-1.3-r2 failed.
Call stack:
  ebuild.sh, line 1638:   Called dyn_unpack
  ebuild.sh, line 763:   Called qa_call 'src_unpack'
  ebuild.sh, line 44:   Called src_unpack
  xvattr-1.3-r2.ebuild, line 27:   Called eautoreconf
  autotools.eclass, line 95:   Called eautoconf
  autotools.eclass, line 165:   Called autotools_run_tool 'autoconf'
  autotools.eclass, line 218:   Called die

!!! Failed Running autoconf !
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/media-video/xvattr-1.3-r2/temp/build.log'.


mythbox ~ # less /var/tmp/portage/media-video/xvattr-1.3-r2/temp/autoconf-3421.out
***** autoconf *****

configure.in:23: error: possibly undefined macro: AM_PATH_GTK_2_0
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.


And just for grins:
mythbox ~ # emerge --info
Portage 2.1.2.12 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.4-r3, 2.6.19-gentoo-r5 i686)
=================================================================
System uname: 2.6.19-gentoo-r5 i686 Intel(R) Pentium(R) 4 CPU 2.60GHz
Gentoo Base System version 1.12.1
Timestamp of tree: Mon, 03 Sep 2007 18:30:01 +0000
app-shells/bash:     3.2_p17
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium4 -Os -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-march=pentium4 -Os -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--alphabetical"
FEATURES="confcache distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.mirrors.tera-byte.com/ http://gentoo.osuosl.org/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://www.gtlib.gatech.edu/pub/gentoo http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ http://gentoo.chem.wisc.edu/gentoo/ http://gentoo.mirrors.pair.com/ http://gentoo.mirrors.tds.net/gentoo http://mirrors.acm.cs.rpi.edu/gentoo/ http://gentoo.llarian.net/ http://gentoo.binarycompass.org http://mirror.datapipe.net/gentoo http://prometheus.cs.wmich.edu/gentoo http://mirror.usu.edu/mirrors/gentoo/ http://mirror.phy.olemiss.edu/mirror/gentoo http://mirror.mcs.anl.gov/pub/gentoo/ http://gentoo.mirrors.easynews.com/linux/gentoo/ http://gentoo.cites.uiuc.edu/pub/gentoo/ http://mirror.utdlug.org/linux/distributions/gentoo/ "
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aa52 aac acpi alsa aotuv apache2 audiophile bash-completion berkdb bitmap-fonts bzip2 cddb cdinstall cdparanoia cdr cli cracklib crypt dbus dts dv dvb dvd dvdr dvdread encode exif ffmpeg fftw firefox flac fortran gdbm gif gphoto2 gpm hal iconv imlib isdnlog ivtv joystick jpeg jpeg2k lcms libnotify libsamplerate lirc lm_sensors mad midi mmap mmx mp3 mpeg mudflap mysql mysqli na_dd na_icons ncurses nls nptl nptlonly nsplugin odbc ogg openal openexr opengl openmp pam pcre png ppds pppd python qt3 readline reflection session sndfile spl sse2 ssl svg tcpd theora truetype truetype-fonts type1-fonts unicode usb v4l vcd vim-pager vim-syntax vim-with-x vorbis wifi win32codecs wmf x86 xine xml xorg xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIRC_DEVICES="mceusb2" USERLAND="GNU" VIDEO_CARDS="fbdev i810 nvidia vesa"
Unset:  CTARGET, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Samuli Suominen gentoo-dev 2007-09-04 11:12:21 UTC
oops.. yeah.. AM_PATH_GTK_2_0 won't work without gtk-2.0.m4, I bet you don't have GTK+ installed at all?

Anyway, fixed by replacing it with pkg-config check. Sync in hour or so, and retry.
Comment 2 DeKay 2007-09-05 00:50:43 UTC
> I bet you don't have GTK+ installed at all?

You'd win that bet!  I try to keep my mythbox with a minimal number of packages installed.  Anyway, just re-synced and it compiles cleanly. Thanks!
Comment 3 Samuli Suominen gentoo-dev 2007-09-07 13:02:05 UTC
*** Bug 191588 has been marked as a duplicate of this bug. ***