Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 188943 - net-wireless/iwlwifi-1.0.0_p1 on sys-kernel/gentoo-sources-2.6.22-r2 kernel panics
Summary: net-wireless/iwlwifi-1.0.0_p1 on sys-kernel/gentoo-sources-2.6.22-r2 kernel p...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Saleem Abdulrasool (RETIRED)
Depends on:
Reported: 2007-08-15 06:28 UTC by Paul Gratz
Modified: 2007-08-29 03:25 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Paul Gratz 2007-08-15 06:28:54 UTC
Basically similar behavior to

IE. if I boot up w/ the wifi switch on and it tries to associate w/ my base station (using WPA w/ wpa_supplicant) I get a kernel panic.  It doesn't always happen immediately  but it always does eventually.  If I switch off wifi, everything is rock solid...

I also have gotting this in dmesg:

------------[ cut here ]------------
kernel BUG at mm/slab.c:1673!
invalid opcode: 0000 [#1]
Modules linked in: i915 drm snd_pcm_oss snd_mixer_oss snd_seq_oss snd_seq_midi_e
vent snd_seq snd_seq_device rtc usbhid hci_usb bluetooth i2c_i801 i2c_core ohci1
394 ieee1394 generic ide_core yenta_socket rsrc_nonstatic pcmcia_core iwl4965 sn
d_hda_intel snd_pcm snd_timer snd soundcore snd_page_alloc ehci_hcd intel_agp ag
pgart uhci_hcd usbcore evdev
CPU:    1
EIP:    0060:[<c0156638>]    Not tainted VLI
EFLAGS: 00010206   (2.6.22-gentoo-r2test #4)
EIP is at kmem_freepages+0x6b/0x9c
eax: 80000060   ebx: c16602a0   ecx: ffffffff   edx: 00000000
esi: c17df8c0   edi: 00000001   ebp: f3015000   esp: f7c4ff40
ds: 007b   es: 007b   fs: 00d8  gs: 0000  ss: 0068
Process events/1 (pid: 8, ti=f7c4e000 task=f7c2c030 task.ti=f7c4e000)
Stack: c17df8c0 f37c1ac0 c17e14c0 c17e14d0 c01568f8 f37c1ac0 c17e14e4 c0156b24
       00000005 c17df8c0 00000002 c17e14c0 c17df8c0 c17159a0 c0157786 c015782b
       00000000 00000000 c17159a4 c17f0200 c17159a0 c0127d25 ffff98cc 000000ff
Call Trace:
 [<c01568f8>] slab_destroy+0x2b/0x40
 [<c0156b24>] drain_freelist+0x67/0x88
 [<c0157786>] cache_reap+0x0/0xe5
 [<c015782b>] cache_reap+0xa5/0xe5
 [<c0127d25>] run_workqueue+0x77/0x10a
 [<c01284b2>] worker_thread+0x0/0xc6
 [<c012856c>] worker_thread+0xba/0xc6
 [<c012ab04>] autoremove_wake_function+0x0/0x35
 [<c012aa37>] kthread+0x38/0x5d
 [<c012a9ff>] kthread+0x0/0x5d
 [<c010318f>] kernel_thread_helper+0x7/0x10
Code: 53 43 c0 e8 fd 23 ff ff 89 fa eb 2a c1 e8 1f 89 f9 69 c0 c0 03 00 00 f7 d9                                                                           
ba 09 00 00 00 05 40 53 43 c0 eb de 8b 03 84 c0 78 04 <0f> 0b eb fe 0f ba 33 07                                                                            
83 c3 20 4a 83 fa ff 75 e9 64 a1 00 10
EIP: [<c0156638>] kmem_freepages+0x6b/0x9c SS:ESP 0068:f7c4ff40

Not sure if it is related...

Reproducible: Always

Steps to Reproduce:
1.Boot w/ wifi switch on
2.restart the net.wlan0 service a couple times

Actual Results:  
kernel panic, screen freeze blinking caps lock and scroll lock lights

Expected Results:  
Happy wireless connection
Comment 1 Paul Gratz 2007-08-17 19:00:21 UTC
I just wanted to add that I have tried this with the older version of iwlwifi on gentoo 2.6.22-r2 with the same results.  I also tried gentoo-sources-2.6.22-r3 with the same results and iwlwifi-1.0.0-p1.  

Finally I tried vanilla kernel w/ iwlwifi-1.0.0-p1 and there I do not get kernel panics.  Wifi does not work very well and I still get the kernel bugs in dmesg but it does not panic. 
Comment 2 Andrey A. Ugolnik 2007-08-27 13:43:02 UTC
Latest iwlwifi module version is 0.1.12, not 1.0.x. iwlwifi-0.1.12 more recent.
Comment 3 Saleem Abdulrasool (RETIRED) gentoo-dev 2007-08-29 01:52:33 UTC
I am unable to actually reproduce this locally, however, I am not using gentoo-sources (Im using a vanilla kernel).  Could you please provide the output of the kernel bug messages?  Seems like something is not dealing well with memory causing the slab allocator to die.
Comment 4 Paul Gratz 2007-08-29 03:25:54 UTC
Sorry, I should have closed this. I found that when I went to the mac80211 instead of the ieee80211 the bugs and kernel panics go away.  It still does not work very well, very poor performance, but I'm following up on that with an open bug w/ the upstream iwlwifi development team.

PS. we might want to add a check for MAC80211 and not IEEE80211 in the ebuild so other people don't run into this.