Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 182860 - remove sys-apps/hal-0.5.11
Summary: remove sys-apps/hal-0.5.11
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard:
Keywords:
: 190484 190506 284185 (view as bug list)
Depends on: 313389
Blocks:
  Show dependency tree
 
Reported: 2007-06-22 02:36 UTC by bunkacid
Modified: 2011-05-10 14:37 UTC (History)
14 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log from emerge (config.log,51.98 KB, text/plain)
2007-06-22 02:37 UTC, bunkacid
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bunkacid 2007-06-22 02:36:28 UTC
While updating my system today, sys-apps/hal failed to emerge.


Reproducible: Always

Steps to Reproduce:
1. emerge -tav1 =sys-apps/hal-0.5.9.1
2. 
3.

Actual Results:  
...
checking for VOLUME_ID... configure: error: Package requirements (libvolume_id >= 0.61) were not met:

No package 'libvolume_id' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables VOLUME_ID_CFLAGS
and VOLUME_ID_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/sys-apps/hal-0.5.9.1/work/hal-0.5.9.1/config.log

!!! ERROR: sys-apps/hal-0.5.9.1 failed.
Call stack:
  ebuild.sh, line 1629:   Called dyn_compile
  ebuild.sh, line 975:   Called qa_call 'src_compile'
  ebuild.sh, line 44:   Called src_compile
  hal-0.5.9.1.ebuild, line 144:   Called econf '--disable-policy-kit' '--docdir=/usr/share/doc/hal-0.5.9.1' '--with-os-type=gentoo' '--with-pid-file=/var/run/hald.pid' '--with-socket-dir=/var/run/hald' '--with-hwdata=/usr/share/misc' '--enable-hotplug-map' '--enable-man-pages' '--with-backend=linux' '--disable-verbose-mode' '--without-dell-backlight' '--disable-parted' '--enable-pcmcia-support' '--disable-docbook-docs' '--disable-doxygen-docs' '--disable-selinux' '--disable-console-kit' '--enable-acpi-toshiba' '--enable-acpi-ibm'
  ebuild.sh, line 578:   Called die

!!! econf failed


Expected Results:  
success


$ emerge --info
Portage 2.1.3_rc4 (default-linux/x86/2006.1/desktop, gcc-4.1.2, glibc-2.5-r3, 2.6.19-gentoo-r5 i686)
=================================================================
System uname: 2.6.19-gentoo-r5 i686 Intel(R) Pentium(R) 4 CPU 2.53GHz
Gentoo Base System release 1.12.9
Timestamp of tree: Fri, 22 Jun 2007 00:50:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r7
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.15.92.0.2-r10, 2.16.1-r3
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium4 -O2 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=pentium4 -O2 -fomit-frame-pointer -pipe -fvisibility-inlines-hidden"
DISTDIR="/var/portage/distfiles"
EMERGE_DEFAULT_OPTS="--alphabetical"
FEATURES="candy ccache digest distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://gentoo.llarian.net/ http://gentoo.chem.wisc.edu/gentoo/ http://gentoo.mirrors.pair.com/ http://mirrors.acm.cs.rpi.edu/gentoo/ http://mirror.datapipe.net/gentoo http://www.gigaload.org/gentoo.org/"
MAKEOPTS="-j2"
PKGDIR="/var/portage/packages"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=180 --exclude-from=/etc/portage/rsync_excludes"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/portage/local/layman/toolchain /var/portage/local/layman/initng /var/portage/local/layman/ns1-overlay /var/portage/local/layman/sunrise /var/portage/local/layman/einit"
SYNC="rsync://portageproxy.home.ns1.net/gentoo-portage"
USE="X accessibility alsa bash-completion berkdb bitmap-fonts cairo cdr cli cracklib crypt cups dbus dri dts dvd dvdr emboss encode esd fam firefox flac fortran gdbm gif gnome gpm gstreamer gtk hal iconv ipv6 isdnlog jikes jpeg kdeenablefinal ldap libg++ logrotate mad midi mikmod mmx mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre perl png ppds pppd python qt4 quicktime readline reflection sdl session spell spl sse sse2 ssl tcpd truetype truetype-fonts type1-fonts unicode vorbis win32codecs x86 xinerama xml xorg xv zlib" ALSA_CARDS="intel8x0 intel8x0m usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INITNG_PLUGINS="also bash_launcher chdir chroot conflict cpout critical ctrlaltdel daemon_clean dbus_event debug_commands envparser find fstat history idleprobe initctl interactive iparser last limit logfile netdev netprobe ngc4 pause provide reload renice rlparser simple_launcher stcmd stdout suid syncron syslog sysreq unneeded" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIRC_DEVICES="all" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev"
Unset:  CTARGET, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 bunkacid 2007-06-22 02:37:37 UTC
Created attachment 122775 [details]
config.log from emerge
Comment 2 bunkacid 2007-06-22 03:28:46 UTC
sys-apps/hal-0.5.9.1.ebuild is missing the dependency for dev-libs/libvolume_id which is keyworded ~*  

$ eix libvolume
[I] dev-libs/libvolume_id
     Available versions:  (~*)0.71.0 {static}
     Installed versions:  0.71.0(19:45:24 06/21/07)(-static)
     Homepage:            http://www.marcuscom.com
     Description:         Library to provide file system information


Comment 3 Doug Goldstein gentoo-dev 2007-06-22 13:51:47 UTC
The depends in the HAL ebuild are 100% correct. On an x86 system, libvolume_id is provided by udev. Which is properly depended on in the HAL ebuild.

Unless you've done something screwy with your system, this may be a portage bug.

Please provide info on which version of udev you have installed and provide the output of the following:

pkg-config libvolume_id --modversion
Comment 4 Petteri Räty (RETIRED) gentoo-dev 2007-06-22 14:41:21 UTC
Do you have anything in /etc/portage/profile/package.provided?
Comment 5 Doug Goldstein gentoo-dev 2007-06-22 14:46:07 UTC
Your installation of dev-libs/libvolume_id is wrong. It it not keyworded ~* since technically that means ~ on all arches. Which it is not. It is keyworded as follows:

Keywords for dev-libs/libvolume_id:

       | a a a h i m m p p p s s s s x x 
       | l m r p a 6 i p p p 3 h p p 8 8 
       | p d m p 6 8 p c c c 9   a a 6 6 
       | h 6   a 4 k s   6 - 0   r r   - 
       | a 4             4 m     c c   f 
       |                   a       -   b 
       |                   c       f   s 
       |                   o       b   d 
       |                   s       s     
       |                           d     
-------+--------------------------------
0.71.0 |                               ~ 

So you can see it's only keyworded on FreeBSD and should only be used on FreeBSD. You're on Linux.
Comment 6 bunkacid 2007-06-22 22:52:12 UTC
(In reply to comment #3)
I am using sys-fs/udev-112-r1
OK.  I saw the depend for FreeBSD in the ebuild so I tried it, and it worked for me.  ~* is what I had to add in order for the emerge to work.
 
> Please provide info on which version of udev you have installed and provide the
> output of the following:
> 
> pkg-config libvolume_id --modversion
> 
$ pkg-config libvolume_id --modversion
0.71.0

(In reply to comment #4)
Nothing that I'm aware is related.
$ cat /etc/portage/package.provided 
mail-client/evolution-2.4.2.1
mail-filter/spamassassin-3.1.0

www-client/epiphany
www-client/epiphany-1.8.4.1
www-client/epiphany-2.16.1

(In reply to comment #5)
OK, so I removed libvolume_id  and downgraded to sys-apps/hal-0.5.9-r1

Hope this all helps.
Comment 7 bunkacid 2007-06-22 23:16:59 UTC
Here is the output after downgrading.

px@pmobilex ~ $ pkg-config libvolume_id --modversion
0.75.0
px@pmobilex ~ $ eix -I udev
[I] sys-fs/udev
     Available versions:  104-r12 ~111 ~111-r1 ~111-r3 ~112 ~112-r1 {selinux}
     Installed versions:  104-r12(16:12:47 06/22/07)(-selinux)
     Homepage:            http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
     Description:         Linux dynamic and persistent device naming support (aka userspace devfs)

Comment 8 Doug Goldstein gentoo-dev 2007-06-29 16:13:02 UTC
re-emerge udev. emerge HAL. That will fix your issue.
Comment 9 bunkacid 2007-06-30 00:45:24 UTC
(In reply to comment #8)
> re-emerge udev. emerge HAL. That will fix your issue.
> 

Thanks. :)
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2007-08-28 09:50:30 UTC
*** Bug 190484 has been marked as a duplicate of this bug. ***
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2007-08-28 13:52:53 UTC
*** Bug 190506 has been marked as a duplicate of this bug. ***
Comment 12 Pablo Montepagano 2007-09-01 17:54:28 UTC
re-emerging udev followed by HAL did not solve the problem. In the compiler output of udev I saw this:

!!! dolib: extras/volume_id/lib/*.so* does not exist
!!! dolib: extras/volume_id/lib/*.a does not exist

What's up with that?

udev-114
hal-0.5.9-r1

Portage 2.1.2.12 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.5-r4, 2.6.21-gentoo-r4 i686)
=================================================================
System uname: 2.6.21-gentoo-r4 i686 AMD Duron(tm) processor
Gentoo Base System release 1.12.9
Timestamp of tree: Wed, 29 Aug 2007 20:00:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="ftp://mirrors.localhost.net.ar/pub/mirrors/gentoo http://gentoo.localhost.net.ar/ http://las.ic.unicamp.br/pub/gentoo ftp://ftp.las.ic.unicamp.ber/pub/gentoo ftp://distro.ibiblo.org/pub/linux/distributions/gentoo"
LANG="es_AR"
LC_ALL="es_AR"
LINGUAS="es"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage/"
USE="3dnow 3dnowext X aac acl acpi alsa apm bash-completion berkdb bitmap-fonts bzip2 cairo cdb cdparanoia cdr cli cracklib crypt cscope cups curl curlwrappers dbase dbus dri dvd dvdr dvdread eds emboss encode evo exif fam fastcgi fdftk ffmpeg firefox flac fortran freetds ftp gdbm ggi gif gphoto2 gpm gstreamer hal iconv imagemagick imlib ipv6 isdnlog javascript jpeg kde kdexdeltas kerberos ldap libwww mad maildir mailwrapper mbox midi mikmod mime mmx mng mono mp3 mpeg msn mudflap ncurses nls nptl nptlonly nsplugin ogg oggvorbis openal opengl openmp oss pam pcre pdf pdflib perl php png pppd python qt qt3 qt3support qt4 quicktime readline reflection samba sdl session sndfile speex spell spl ssl svg szip tcpd tiff truetype truetype-fonts type1-fonts unicode utempter vorbis win32codecs x86 xine xml xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es" USERLAND="GNU" VIDEO_CARDS="trident vesa fbdev"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2007-09-01 19:06:14 UTC
*** Bug 190994 has been marked as a duplicate of this bug. ***
Comment 14 Vasilis Lourdas 2009-08-15 22:09:56 UTC
I experience the same problem with hal-0.5.11-r9:

checking for usb.h... yes
checking for usb_find_devices in -lusb... yes
checking for SMBIOSFreeMemory in -lsmbios... no
checking pci/pci.h usability... yes
checking pci/pci.h presence... yes
checking for pci/pci.h... yes
checking for pci_init in -lpci... yes
checking for gperf... /usr/bin/gperf
checking whether to rebuild gperf header files... checking for DBUS... yes
checking for GLIB... yes
checking if GLib is version 2.14.0 or newer... yes
checking for VOLUME_ID... configure: error: Package requirements (libvolume_id >= 0.77) were not met:

No package 'libvolume_id' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables VOLUME_ID_CFLAGS
and VOLUME_ID_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-apps/hal-0.5.11-r9/work/hal-0.5.11/config.log
 * 
 * ERROR: sys-apps/hal-0.5.11-r9 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3931:  Called econf '--with-backend=linux' '--with-os-type=gentoo' '--with-pid-file=/var/run/hald.pid' '--with-hwdata=/usr/share/misc' '--with-socket-dir=/var/run/hald' '--enable-umount-helper' '--enable-man-pages' '--disable-policy-kit' '--disable-console-kit' '--disable-acl-management' '--enable-pci' '--disable-apm' '--disable-verbose-mode' '--disable-parted' '--disable-docbook-docs' '--disable-gtk-doc' '--docdir=/usr/share/doc/hal-0.5.11-r9' '--localstatedir=/var' '--enable-acpi' '--disable-acpi-ibm' '--disable-acpi-toshiba' '--enable-acpi-proc' '--enable-acpi-acpid' '--with-cpufreq' '--with-usb-csr' '--with-keymaps' '--with-macbook' '--with-macbookpro' '--without-dell-backlight' '--enable-sonypic'
 *               ebuild.sh, line  534:  Called die
 * The specific snippet of code:
 *   			die "econf failed"
 *  The die message:
 *   econf failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-apps/hal-0.5.11-r9/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/hal-0.5.11-r9/temp/environment'.
 * 

>>> Failed to emerge sys-apps/hal-0.5.11-r9, Log file:
Comment 15 Arne Babenhauserheide 2009-09-08 15:43:03 UTC
*** Bug 284185 has been marked as a duplicate of this bug. ***
Comment 16 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-09-09 14:46:31 UTC
*** Bug 284268 has been marked as a duplicate of this bug. ***
Comment 17 Arne Babenhauserheide 2009-09-09 17:17:24 UTC
This is the core of my problem: The gnome overlay has udev-145-r1 which is blocked by device mapper. 

[ebuild     U ] sys-fs/udev-145-r1 [145]                                                   
[blocks B     ] sys-fs/device-mapper ("sys-fs/device-mapper" is blocking sys-fs/udev-145-r1)

But this is *no* problem of the portage tree. 
Comment 18 Arne Babenhauserheide 2009-09-09 18:11:36 UTC
Correction: It seems like a problem of the portage tree, since after rebuilding udev-145 hal still doesn't build. 
Comment 19 Arne Babenhauserheide 2009-09-09 18:12:04 UTC
checking for GLIB... yes                                                                               
checking if GLib is version 2.14.0 or newer... yes                                                     
checking for VOLUME_ID... configure: error: Package requirements (libvolume_id >= 0.77) were not met:  

No package 'libvolume_id' found
Comment 20 Markus Peloquin 2009-09-11 05:43:22 UTC
Had the same problem.  I updated hal-0.5.11-r? to -0.5.13.  I still cannot get my @preserved-rebuild list to clear out.
Comment 21 Peter J. de Vrijer 2009-09-14 08:00:06 UTC
Why is this bug in status Resolved? I still have the problem.
Tried sugestion to re-emerge udev (145-r1), but that did nog help.

What do I have to do to get hal emerged?


Comment 22 chemist 2009-09-14 15:17:51 UTC
Try this.
chemist@limbo ~ $ echo "dev-libs/libvolume_id ~*" >> /etc/portage/package.keywords
chemist@limbo ~ $ echo ">=dev-libs/libvolume_id-0.81.0" >> /etc/portage/package.unmask
chemist@limbo ~ $ emerge libvolume_id
chemist@limbo ~ $ emerge hal

version libvolume_id may be other.

Language is not good. 
Comment 23 Olivier Crete (RETIRED) gentoo-dev 2009-09-16 16:41:51 UTC
libvolume_id was removed from udev in version 142

from the NEWS file:
"The program vol_id and the library libvolume_id are removed from the
repository. Libvolume_id is merged with libblkid from the util-linux-ng
package. Persistent disk links for label and uuid depend on the
util-linux-ng version (2.15) of blkid now. Older versions of blkid
can not be used with udev."

I guess the dep on hal 0.5.11 needs to be <udev-142 and possibly newer hal for newer udev ?
Comment 24 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-09-18 10:03:28 UTC
Official workaround looks to be: use hal-0.5.13 instead of 0.5.11.
I hope <udev-145 can be added to hal-0.5.11 to prevent issues when mixing arch.
Comment 25 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-09-18 15:57:29 UTC
0.5.11 is going away soon.  In the meantime, don't mix arches without knowing the consequences.
Comment 26 Arne Babenhauserheide 2009-09-18 17:59:53 UTC
Isn't Gentoo partly about being able to select what I want stable and what testing? 

At least that's one of its major strengths and distinguishing points for me! 

...for example using KDE 4.3 on a otherwise stable amd64 system. 
Comment 27 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-09-18 20:52:55 UTC
(In reply to comment #25)
> 0.5.11 is going away soon.  In the meantime, don't mix arches without knowing
> the consequences.
> 

Just about "don't mix arches without knowing the consequences". As I said to
Eva, I agree users doing that (ie. I do that) should know it can leads to
issues but I'm used to do that and I never got any issues since a long time. In
most cases you can easily mix both keywords without going in deep issues. I'm
not saying there is a trivial fix for this bug but I think mixing keywords
shouldn't be considered as the -only- reason for these types of bugs.
Comment 28 Alexander Bezrukov 2009-09-20 00:58:49 UTC
Bug #285511 can be an additional reason to get rid of ~hal-0.5.11.
Comment 29 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2010-04-12 12:41:12 UTC
It looks like hal-0.5..11 has been removed from the tree a month ago.
I think this is resolving this bug.