Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 181435 - =dev-lang/perl-5.*: Ignored LDFLAGS: Many files
Summary: =dev-lang/perl-5.*: Ignored LDFLAGS: Many files
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
: 209799 (view as bug list)
Depends on:
Blocks: perl-5.10.1
  Show dependency tree
 
Reported: 2007-06-09 16:59 UTC by Arfrever Frehtes Taifersar Arahesis (RETIRED)
Modified: 2010-09-21 14:31 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch (perl-LDFLAGS.patch,28.75 KB, patch)
2007-06-10 16:53 UTC, Arfrever Frehtes Taifersar Arahesis (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2007-06-09 16:59:47 UTC
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Fcntl/Fcntl.so
  [ 1] .hash            HASH           000000f4 0000f4 0000c4 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/File/Glob/Glob.so
  [ 1] .hash            HASH           000000f4 0000f4 000180 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Opcode/Opcode.so
  [ 1] .hash            HASH           000000f4 0000f4 000260 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Time/HiRes/HiRes.so
  [ 1] .hash            HASH           000000f4 0000f4 000194 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/B/C/C.so
  [ 1] .hash            HASH           000000f4 0000f4 0000c4 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/B/B.so
  [ 1] .hash            HASH           000000f4 0000f4 000734 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/IPC/SysV/SysV.so
  [ 1] .hash            HASH           000000f4 0000f4 000138 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Data/Dumper/Dumper.so
  [ 1] .hash            HASH           000000f4 0000f4 000270 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Socket/Socket.so
  [ 1] .hash            HASH           000000f4 0000f4 00016c 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/attrs/attrs.so
  [ 1] .hash            HASH           000000f4 0000f4 0000c0 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Unicode/Normalize/Normalize.so
  [ 1] .hash            HASH           000000f4 0000f4 001200 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/List/Util/Util.so
  [ 1] .hash            HASH           000000f4 0000f4 000344 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Cwd/Cwd.so
  [ 1] .hash            HASH           000000f4 0000f4 000148 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/I18N/Langinfo/Langinfo.so
  [ 1] .hash            HASH           000000f4 0000f4 0000dc 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/SDBM_File/SDBM_File.so
  [ 1] .hash            HASH           000000f4 0000f4 000294 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/NDBM_File/NDBM_File.so
  [ 1] .hash            HASH           000000f4 0000f4 00022c 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Filter/Util/Call/Call.so
  [ 1] .hash            HASH           000000f4 0000f4 000184 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Digest/MD5/MD5.so
  [ 1] .hash            HASH           000000f4 0000f4 00013c 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/MIME/Base64/Base64.so
  [ 1] .hash            HASH           000000f4 0000f4 0000d8 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/IO/IO.so
  [ 1] .hash            HASH           000000f4 0000f4 000224 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Devel/DProf/DProf.so
  [ 1] .hash            HASH           000000f4 0000f4 0001a4 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Devel/Peek/Peek.so
  [ 1] .hash            HASH           000000f4 0000f4 000188 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Devel/PPPort/PPPort.so
  [ 1] .hash            HASH           000000f4 0000f4 0004e0 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/GDBM_File/GDBM_File.so
  [ 1] .hash            HASH           000000f4 0000f4 00025c 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Encode/Byte/Byte.so
  [ 1] .hash            HASH           000000f4 0000f4 000294 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Encode/JP/JP.so
  [ 1] .hash            HASH           000000f4 0000f4 000134 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Encode/KR/KR.so
  [ 1] .hash            HASH           000000f4 0000f4 0000dc 04   A  3   0  4
Comment 1 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2007-06-09 17:00:09 UTC
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Encode/Encode.so
  [ 1] .hash            HASH           000000f4 0000f4 00034c 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Encode/EBCDIC/EBCDIC.so
  [ 1] .hash            HASH           000000f4 0000f4 0000e0 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Encode/Unicode/Unicode.so
  [ 1] .hash            HASH           000000f4 0000f4 000138 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Encode/TW/TW.so
  [ 1] .hash            HASH           000000f4 0000f4 0000d8 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Encode/Symbol/Symbol.so
  [ 1] .hash            HASH           000000f4 0000f4 0000e0 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Encode/CN/CN.so
  [ 1] .hash            HASH           000000f4 0000f4 0000e0 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Storable/Storable.so
  [ 1] .hash            HASH           000000f4 0000f4 000430 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/PerlIO/encoding/encoding.so
  [ 1] .hash            HASH           000000f4 0000f4 000328 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/PerlIO/scalar/scalar.so
  [ 1] .hash            HASH           000000f4 0000f4 000184 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/PerlIO/via/via.so
  [ 1] .hash            HASH           000000f4 0000f4 00031c 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/ByteLoader/ByteLoader.so
  [ 1] .hash            HASH           000000f4 0000f4 00031c 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/POSIX/POSIX.so
  [ 1] .hash            HASH           000000f4 0000f4 00088c 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/re/re.so
  [ 1] .hash            HASH           000000f4 0000f4 0006a0 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Sys/Hostname/Hostname.so
  [ 1] .hash            HASH           000000f4 0000f4 0000b4 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/Sys/Syslog/Syslog.so
  [ 1] .hash            HASH           000000f4 0000f4 0000e0 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/threads/threads.so
  [ 1] .hash            HASH           000000f4 0000f4 000094 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/threads/shared/shared.so
  [ 1] .hash            HASH           000000f4 0000f4 000094 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/DB_File/DB_File.so
  [ 1] .hash            HASH           000000f4 0000f4 00027c 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/XS/Typemap/Typemap.so
  [ 1] .hash            HASH           000000f4 0000f4 000324 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/lib/perl5/5.8.8/i686-linux/auto/XS/APItest/APItest.so
  [ 1] .hash            HASH           000000f4 0000f4 000298 04   A  3   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/bin/perl5.8.8
  [ 3] .hash            HASH           080481a8 0001a8 004154 04   A  5   0  4
/var/tmp/portage/dev-lang/perl-5.8.8-r2/image/usr/bin/a2p
  [ 3] .hash            HASH           08048188 000188 0000d4 04   A  5   0  4
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-06-09 17:04:31 UTC
Maybe you could elaborate on how did you come to the conclusion that your LDFLAGS are ignored, which ones are ignored and where's the problem. The above cryptic stuff unfortunately doesn't explain anything.
Comment 3 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2007-06-09 17:27:14 UTC
(In reply to comment #2)
> Maybe you could elaborate on how did you come to the conclusion that your
> LDFLAGS are ignored

Some LDFLAGS can change existence of some sections in ELF files. I have such (at least) 2 flags in my LDFLAGS and one of them always change existence of some sections when isn't ignored.
I changed /usr/lib/portage/bin/prepstrip, so that it now additionally runs readelf and grep and copy the output to the log file.
I perform some tests (reading emerge logs) and >99,5% of results are correct.

> which ones are ignored

All.

> and where's the problem.

Ignoring LDLFAGS increases files sizes and decreases performance.
Comment 4 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2007-06-10 16:53:45 UTC
Created attachment 121674 [details, diff]
Patch
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2008-02-27 18:50:12 UTC
*** Bug 209799 has been marked as a duplicate of this bug. ***
Comment 6 Robert Wohlrab 2008-12-12 18:47:32 UTC
Have exactly the same problem here. I checked perl and inserted my own gcc_specs file with "--no-add-needed --no-undefined -O1 --as-needed" in link (!static) to test the package. I noticed that different parts doesn't link against needed libs.... should be fixed by upstream and gentoo


make[2]: Entering directory `/var/tmp/portage/dev-lang/perl-5.8.8-r5/work/perl-5.8.8/ext/B/C'
../../../miniperl "-I../../../lib" "-I../../../lib" ../../../lib/ExtUtils/xsubpp  -typemap ../../../lib/ExtUtils/typemap  C.xs > C.xsc && mv C.xsc C.c
x86_64-pc-linux-gnu-gcc -c   -fno-strict-aliasing -pipe -Wdeclaration-after-statement -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2 -pipe -march=athlon64   -DVERSION=\"1.04_01\" -DXS_VERSION=\"1.04_01\" -fPIC "-I../../.."   C.c                                                                                                                                                              
Running Mkbootstrap for B::C ()                                                                                                                                                                            
chmod 644 C.bs                                                                                                                                                                                             
rm -f ../../../lib/auto/B/C/C.so                                                                                                                                                                           
x86_64-pc-linux-gnu-gcc  -shared -L/usr/local/lib64 C.o  -o ../../../lib/auto/B/C/C.so  \                                                                                                                  
                \                                                                                                                                                                                          
                                                                                                                                                                                                           
C.o: In function `boot_B(void) const':                                                                                                                                                                     
C.c:(.text+0x25): undefined reference to `PL_stack_sp'                                                                                                                                                     
C.c:(.text+0x2c): undefined reference to `PL_stack_base'                                                                                                                                                   
C.c:(.text+0x36): undefined reference to `PL_markstack_ptr'                                                                                                                                                
C.c:(.text+0xf5): undefined reference to `Perl_croak'                                                                                                                                                      
C.c:(.text+0x103): undefined reference to `PL_runops'                                                                                                                                                      
C.c:(.text+0x117): undefined reference to `PL_sv_yes'                                                                                                                                                      
C.c:(.text+0x12d): undefined reference to `PL_stack_sp'                                                                                                                                                    
C.c:(.text+0x160): undefined reference to `Perl_sv_2pv_flags'                                                                                                                                              
C.c:(.text+0x17b): undefined reference to `Perl_sv_2pv_flags'                                                                                                                                              
C.c:(.text+0x19c): undefined reference to `Perl_form'                                                                                                                                                      
C.c:(.text+0x1a6): undefined reference to `Perl_get_sv'                                                                                                                                                    
C.c:(.text+0x1e2): undefined reference to `Perl_form'                                                                                                                                                      
C.c:(.text+0x1ec): undefined reference to `Perl_get_sv'                                                                                                                                                    
C.o: In function `my_runops':                                                                                                                                                                              
C.c:(.text+0x23e): undefined reference to `Perl_get_hv'                                                                                                                                                    
C.c:(.text+0x249): undefined reference to `Perl_newSViv'                                                                                                                                                   
C.c:(.text+0x250): undefined reference to `PL_op'                                                                                                                                                          
C.c:(.text+0x282): undefined reference to `PL_sig_pending'                                                                                                                                                 
C.c:(.text+0x28d): undefined reference to `Perl_despatch_signals'                                                                                                                                          
C.c:(.text+0x2a3): undefined reference to `Perl_newSViv'                                                                                                                                                   
C.c:(.text+0x2b0): undefined reference to `Perl_safesysmalloc'                                                                                                                                             
C.c:(.text+0x30a): undefined reference to `Perl_sv_setiv'                                                                                                                                                  
C.c:(.text+0x31c): undefined reference to `Perl_sv_setref_iv'                                                                                                                                              
C.c:(.text+0x32d): undefined reference to `Perl_hv_store_ent'                                                                                                                                              
C.c:(.text+0x33c): undefined reference to `Perl_sv_free'                                                                                                                                                   
C.c:(.text+0x343): undefined reference to `PL_tainted'                                                                                                                                                     
collect2: ld returned 1 exit status                                                                                                                                                                        
make[2]: *** [../../../lib/auto/B/C/C.so] Error 1                                                                                                                                                          
make[2]: Leaving directory `/var/tmp/portage/dev-lang/perl-5.8.8-r5/work/perl-5.8.8/ext/B/C'                                                                                                               
make[1]: *** [subdirs] Error 2                                                                                                                                                                             
make[1]: Leaving directory `/var/tmp/portage/dev-lang/perl-5.8.8-r5/work/perl-5.8.8/ext/B'                                                                                                                 
make: *** [lib/auto/B/B.so] Error 2                                                                                                                                                                        
 *                                                                                                                                                                                                         
 * ERROR: dev-lang/perl-5.8.8-r5 failed.                                                                                                                                                                   
 * Call stack:                                                                                                                                                                                             
 *               ebuild.sh, line   49:  Called src_compile                                                                                                                                                 
 *             environment, line 2500:  Called die                                                                                                                                                         
 * The specific snippet of code:                                                                                                                                                                           
 *       emake -j1 || die "Unable to make"                                                                                                                                                                 
 *  The die message:                                                                                                                                                                                       
 *   Unable to make
Comment 7 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2008-12-12 20:38:50 UTC
(In reply to comment #6)

C.so etc. are modules which are loaded by Perl, so they don't have to be linked against Perl libraries.
Comment 8 Davide Pesavento gentoo-dev 2009-04-05 15:19:04 UTC
Still not fixed in 5.8.8-r5

QA Notice: Files built without respecting LDFLAGS have been detected              
 Please include the following list of files in your report:                       
/usr/bin/a2p                                                                      
/usr/bin/perl5.8.8                                                                
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/B/C/C.so                                 
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/B/B.so                                   
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/IO/IO.so                                 
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/XS/APItest/APItest.so                    
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/XS/Typemap/Typemap.so                    
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/re/re.so                                 
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Cwd/Cwd.so                               
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/IPC/SysV/SysV.so                         
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Sys/Hostname/Hostname.so                 
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Sys/Syslog/Syslog.so                     
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Data/Dumper/Dumper.so                    
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/I18N/Langinfo/Langinfo.so                
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/File/Glob/Glob.so                        
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/MIME/Base64/Base64.so                    
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/List/Util/Util.so                        
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Time/HiRes/HiRes.so                      
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Digest/MD5/MD5.so                        
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Encode/CN/CN.so                          
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Encode/JP/JP.so                          
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Encode/KR/KR.so                          
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Encode/TW/TW.so                          
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Encode/EBCDIC/EBCDIC.so                  
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Encode/Byte/Byte.so                      
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Encode/Symbol/Symbol.so                  
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Encode/Encode.so                         
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Encode/Unicode/Unicode.so                
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Filter/Util/Call/Call.so                 
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Devel/Peek/Peek.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Devel/DProf/DProf.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Devel/PPPort/PPPort.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Fcntl/Fcntl.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/POSIX/POSIX.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/attrs/attrs.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Opcode/Opcode.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/PerlIO/via/via.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/PerlIO/encoding/encoding.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/PerlIO/scalar/scalar.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Socket/Socket.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/SDBM_File/SDBM_File.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/threads/shared/shared.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/threads/threads.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/NDBM_File/NDBM_File.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/GDBM_File/GDBM_File.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Storable/Storable.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/DB_File/DB_File.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/Unicode/Normalize/Normalize.so
/usr/lib64/perl5/5.8.8/x86_64-linux/auto/ByteLoader/ByteLoader.so
Comment 9 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-09-28 19:14:26 UTC
Comment on attachment 121674 [details, diff]
Patch

More generic patch should be created.
Comment 10 Davide Pesavento gentoo-dev 2010-03-27 13:59:17 UTC
More or less the same for perl-5.10.1

QA Notice: Files built without respecting LDFLAGS have been detected
 Please include the following list of files in your report:
/usr/bin/a2p
/usr/bin/perl5.10.1
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/B/B.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/IO/IO.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/re/re.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Cwd/Cwd.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/IPC/SysV/SysV.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Sys/Hostname/Hostname.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Sys/Syslog/Syslog.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/mro/mro.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Data/Dumper/Dumper.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/I18N/Langinfo/Langinfo.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/File/Glob/Glob.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Hash/Util/Util.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Hash/Util/FieldHash/FieldHash.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/MIME/Base64/Base64.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/List/Util/Util.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Math/BigInt/FastCalc/FastCalc.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Text/Soundex/Soundex.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Time/HiRes/HiRes.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Time/Piece/Piece.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Digest/MD5/MD5.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Digest/SHA/SHA.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Encode/CN/CN.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Encode/JP/JP.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Encode/KR/KR.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Encode/TW/TW.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Encode/EBCDIC/EBCDIC.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Encode/Byte/Byte.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Encode/Symbol/Symbol.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Encode/Encode.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Encode/Unicode/Unicode.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Filter/Util/Call/Call.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Devel/Peek/Peek.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Devel/DProf/DProf.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Devel/PPPort/PPPort.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Fcntl/Fcntl.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/POSIX/POSIX.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/attrs/attrs.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Compress/Raw/Zlib/Zlib.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Compress/Raw/Bzip2/Bzip2.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Opcode/Opcode.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/PerlIO/via/via.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/PerlIO/encoding/encoding.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/PerlIO/scalar/scalar.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Socket/Socket.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/SDBM_File/SDBM_File.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/threads/shared/shared.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/threads/threads.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/NDBM_File/NDBM_File.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Storable/Storable.so
/usr/lib64/perl5/5.10.1/x86_64-linux/auto/Unicode/Normalize/Normalize.so
/usr/lib64/libperl.so.5.10.1
Comment 11 Torsten Veller (RETIRED) gentoo-dev 2010-09-21 14:31:46 UTC
Fixed for perl-5.12.2-r1.