Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 160857 (ff-bin-wont-work) - I have www-client/mozilla-firefox-bin installed, but $ebuild still pulls in www-client/mozilla-firefox
Summary: I have www-client/mozilla-firefox-bin installed, but $ebuild still pulls in w...
Status: VERIFIED INVALID
Alias: ff-bin-wont-work
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 108015 113094 122325 136852 163599 163890 163945 168377 180403 181119 183026 187715 190876 196228 209687 281805 281807 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-01-08 10:40 UTC by Denilson Sá Maia
Modified: 2009-08-17 17:30 UTC (History)
14 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denilson Sá Maia 2007-01-08 10:40:19 UTC
media-video/vlc-0.8.6-r1 is now stable, and I was really surprised it tried to install www-client/mozilla-firefox. I have www-client/mozilla-firefox and www-client/opera installed, I have nsplugin useflag enabled, and no other package that installs plugin has ever depended on firefox or seamonkey.

Looking at ebuild, I found:
	nsplugin? (
		!seamonkey? ( www-client/mozilla-firefox )
		seamonkey? ( www-client/seamonkey )
	)

The big question is: Does vlc really need mozilla-firefox or seamonkey (instead of mozilla-firefox-bin or any other browser)?

Reproducible: Always

Steps to Reproduce:
1. eix-sync -v && emerge -auDNtv world
or
1. eix-sync -v && emerge -av media-video/vlc
Actual Results:  
Portage tries to install www-client/mozilla-firefox, in addition to the already installed www-client/mozilla-firefox-bin

Expected Results:  
vlc should have been emerged without asking for a browser.

Some related (but not duplicate) bug reports:
bug 139317 - VLC-0.8.5-r4 with USE="nsplugin -seamonkey" places nsplugins in wrong dir
bug 137665 - Packages with rdepend on mozilla to convert to seamonkey/firefox useflags

I've looked also at media-video/totem ebuild, and found it also depends on either firefox or seamonkey (but with different conditional deps).
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-01-08 11:15:10 UTC
You can't built anythining agains -bin; simply won't work due to missing headers and other stuff.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-01-24 19:21:21 UTC
*** Bug 163599 has been marked as a duplicate of this bug. ***
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-01-26 12:23:21 UTC
*** Bug 163890 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-01-26 18:13:24 UTC
*** Bug 163945 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-02-25 20:57:18 UTC
*** Bug 168377 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-02-25 21:01:46 UTC
*** Bug 136852 has been marked as a duplicate of this bug. ***
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2007-02-25 21:03:36 UTC
*** Bug 122325 has been marked as a duplicate of this bug. ***
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2007-02-25 21:05:13 UTC
*** Bug 108015 has been marked as a duplicate of this bug. ***
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2007-02-25 21:05:52 UTC
*** Bug 113094 has been marked as a duplicate of this bug. ***
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2007-02-26 17:14:51 UTC
*** Bug 168474 has been marked as a duplicate of this bug. ***
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2007-05-31 11:25:24 UTC
*** Bug 180403 has been marked as a duplicate of this bug. ***
Comment 12 Maxi Combina 2007-05-31 11:44:20 UTC
(In reply to comment #1)
> You can't built anythining agains -bin; simply won't work due to missing
> headers and other stuff.
> 

Yes, I know that I can't compile against -bin.
The question remains: why does vlc wants to compile seamonkey/firefox? If it *really* needs a browser, isn't the -bin version enough?
It's the exact same problem as in bug 180403: emerging quodlibet wanted to install mozilla-firefox. I traced the dependencies until I found that dev-python/gnome-python-extras is the atom that wants to pull mozilla-firefox. I edited the ebuild (and the Manifest) of gnome-python-extras and I could install quodlibet without mozilla-firefox, and it works OK.
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2007-05-31 12:12:05 UTC
(In reply to comment #12)
> Yes, I know that I can't compile against -bin.
> The question remains: why does vlc wants to compile seamonkey/firefox? If it
> *really* needs a browser, isn't the -bin version enough?

vlc (or whatever else) doesn't want to compile firefox, it needs files provided by firefox *only* (not by -bin) to compile *itself*, it doesn't want it as a *browser*. What's so hard to understand here?

CLOSED.
Comment 14 Maxi Combina 2007-05-31 12:28:13 UTC
> vlc (or whatever else) doesn't want to compile firefox, it needs files provided
> by firefox *only* (not by -bin) to compile *itself*, it doesn't want it as a
> *browser*. What's so hard to understand here?
> 
> CLOSED.
Ok, I see what you say now, thanks for the clarification.
What is so hard to undestand is: why the heck does a media player (such as vlc or quodlibet) needs files provided by a browser?
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2007-05-31 12:30:01 UTC
(In reply to comment #14)
> What is so hard to undestand is: why the heck does a media player (such as vlc
> or quodlibet) needs files provided by a browser?

Because it provides a browser plugin?
 

Comment 16 Jakub Moc (RETIRED) gentoo-dev 2007-06-06 19:48:38 UTC
*** Bug 181119 has been marked as a duplicate of this bug. ***
Comment 17 Jakub Moc (RETIRED) gentoo-dev 2007-06-24 09:27:13 UTC
*** Bug 183026 has been marked as a duplicate of this bug. ***
Comment 18 Jakub Moc (RETIRED) gentoo-dev 2007-08-04 11:54:58 UTC
*** Bug 187715 has been marked as a duplicate of this bug. ***
Comment 19 Jakub Moc (RETIRED) gentoo-dev 2007-08-31 13:03:38 UTC
*** Bug 190876 has been marked as a duplicate of this bug. ***
Comment 20 Jakub Moc (RETIRED) gentoo-dev 2007-10-17 22:55:50 UTC
*** Bug 196228 has been marked as a duplicate of this bug. ***
Comment 21 Jakub Moc (RETIRED) gentoo-dev 2007-10-20 10:34:42 UTC
*** Bug 196228 has been marked as a duplicate of this bug. ***
Comment 22 Jakub Moc (RETIRED) gentoo-dev 2008-02-11 18:07:51 UTC
*** Bug 209687 has been marked as a duplicate of this bug. ***
Comment 23 Gilles Dartiguelongue gentoo-dev 2009-08-17 16:56:01 UTC
*** Bug 281805 has been marked as a duplicate of this bug. ***
Comment 24 Gilles Dartiguelongue gentoo-dev 2009-08-17 16:56:10 UTC
*** Bug 281807 has been marked as a duplicate of this bug. ***