Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 159922 - sys-apps/coreutils-6.7-r1 has no /bin/install and breaks ruby extconf.rb. See commen #2
Summary: sys-apps/coreutils-6.7-r1 has no /bin/install and breaks ruby extconf.rb. See...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: Nguyen Thai Ngoc Duy (RETIRED)
URL:
Whiteboard:
Keywords:
: 159928 160054 160269 160311 160312 160717 162663 162869 163510 163939 164093 164267 164349 164376 164378 164392 164637 164658 164725 164900 164931 164964 165112 165162 165171 165295 165653 165988 166012 166714 166716 167161 167966 173956 174797 175507 175991 176696 177358 178228 178440 178462 178486 199189 209016 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-01-03 21:35 UTC by Alexandre Rostovtsev (RETIRED)
Modified: 2008-02-05 16:36 UTC (History)
46 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ruby eclasses patch (ruby-eclasses.patch,1.92 KB, patch)
2007-01-22 15:26 UTC, Nguyen Thai Ngoc Duy (RETIRED)
Details | Diff
rubygems patch (rubygems.patch,2.29 KB, patch)
2007-01-22 15:27 UTC, Nguyen Thai Ngoc Duy (RETIRED)
Details | Diff
eclass patch (eclass.patch,3.07 KB, patch)
2007-01-31 15:04 UTC, Nguyen Thai Ngoc Duy (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Rostovtsev (RETIRED) gentoo-dev 2007-01-03 21:35:57 UTC
sys-apps/coreutils-6.7-r1 moved /bin/install to /usr/bin/install. For one thing, this change appears to break some ruby packages that use the extconf.rb system:

# emerge ruby-libglade2
[...]
>>> Install ruby-libglade2-0.16.0-r1 into /var/tmp/portage/dev-ruby/ruby-libglade2-0.16.0-r1/image/ category dev-ruby
/bin/install -c -m 0755 libglade2.so /var/tmp/portage/dev-ruby/ruby-libglade2-0.16.0-r1/image//usr/lib/ruby/site_ruby/1.8/i686-linux
make: /bin/install: Command not found
make: *** [/var/tmp/portage/dev-ruby/ruby-libglade2-0.16.0-r1/image//usr/lib/ruby/site_ruby/1.8/i686-linux/libglade2.so] Error 127

!!! ERROR: dev-ruby/ruby-libglade2-0.16.0-r1 failed.

One solution would be to symlink /bin/install to /usr/bin/install. However, the ancient bug #39648 suggests some other reasons why install should be in /bin.

Perhaps simply installing install into /bin is the best idea.
Comment 1 SpanKY gentoo-dev 2007-01-03 22:02:48 UTC
apps shouldnt be hard coding paths
Comment 2 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2007-01-04 00:49:26 UTC
install path is unfortunately hard-coded when installing ruby. A workaround is reemerge ruby
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-01-04 01:06:33 UTC
*** Bug 159928 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-01-04 10:55:07 UTC
*** Bug 160054 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-01-05 09:34:00 UTC
*** Bug 160269 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-01-05 14:14:47 UTC
*** Bug 160311 has been marked as a duplicate of this bug. ***
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2007-01-05 14:15:20 UTC
*** Bug 160312 has been marked as a duplicate of this bug. ***
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2007-01-07 17:25:45 UTC
*** Bug 160717 has been marked as a duplicate of this bug. ***
Comment 9 Moshe Kamensky 2007-01-11 20:22:38 UTC
I have a similar problem with pppoe-start. It is looking for /bin/id, which moved into /usr/bin
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2007-01-18 14:45:01 UTC
*** Bug 162663 has been marked as a duplicate of this bug. ***
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2007-01-20 08:22:07 UTC
*** Bug 162869 has been marked as a duplicate of this bug. ***
Comment 12 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2007-01-22 15:08:01 UTC
(In reply to comment #9)
> I have a similar problem with pppoe-start. It is looking for /bin/id, which
> moved into /usr/bin
> 

Moshe, pppoe-start doesn't relate to this bug really. Please open another bug for it.
Comment 13 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2007-01-22 15:26:10 UTC
Created attachment 107797 [details, diff]
ruby eclasses patch

This patch was inspired by Eric Hodel (override mkmf.rb)
Comment 14 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2007-01-22 15:27:22 UTC
Created attachment 107798 [details, diff]
rubygems patch

The previous patch touches RUBYOPT so rubygems ebuilds need to be adjusted.
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2007-01-23 22:57:30 UTC
*** Bug 163510 has been marked as a duplicate of this bug. ***
Comment 16 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2007-01-26 15:54:12 UTC
A slightly different patch was committed (stricter condition, not polute stdin)
Comment 17 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2007-01-27 05:29:41 UTC
*** Bug 163939 has been marked as a duplicate of this bug. ***
Comment 18 Jakub Moc (RETIRED) gentoo-dev 2007-01-27 19:23:15 UTC
*** Bug 164093 has been marked as a duplicate of this bug. ***
Comment 19 Jakub Moc (RETIRED) gentoo-dev 2007-01-28 19:20:09 UTC
*** Bug 164267 has been marked as a duplicate of this bug. ***
Comment 20 Botykai Zsolt 2007-01-29 07:22:18 UTC
IMHO Then this workaround should have been mentioned in ewarn. 
Comment 21 Jakub Moc (RETIRED) gentoo-dev 2007-01-29 09:17:03 UTC
*** Bug 164349 has been marked as a duplicate of this bug. ***
Comment 22 Jakub Moc (RETIRED) gentoo-dev 2007-01-29 10:41:46 UTC
*** Bug 164376 has been marked as a duplicate of this bug. ***
Comment 23 Jakub Moc (RETIRED) gentoo-dev 2007-01-29 11:20:45 UTC
*** Bug 164378 has been marked as a duplicate of this bug. ***
Comment 24 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2007-01-29 12:19:30 UTC
gems packages were _not_ fixed (I thought it would use ruby_src_unpack but it in fact did not). gems.eclass is fixed now (revision 1.15). Everybody whose bugs are marked duplicated please test and feedback.
Thank you.
Comment 25 Jakub Moc (RETIRED) gentoo-dev 2007-01-29 12:57:09 UTC
*** Bug 164392 has been marked as a duplicate of this bug. ***
Comment 26 Jakub Moc (RETIRED) gentoo-dev 2007-01-29 12:58:12 UTC
Sorry, have I missed something here? Given the flood of dupes, this doesn't appear to be fixed at all...
Comment 27 Bernard Cafarelli gentoo-dev 2007-01-29 13:18:07 UTC
Will we call this an "amarok effect"? ;) (which now pulls in mongrel ruby server)
Comment 28 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2007-01-29 15:10:24 UTC
Oh I forgot another thing :( I focused on ebuild installation only. This bug still remains if you install things by hand (even via rubygems)
Maybe it's time to make a version bump for dev-lang/ruby
Comment 29 Hans de Graaff gentoo-dev 2007-01-29 19:27:33 UTC
Bumping dev-lang/ruby may cause people to run into bug 161566 now that autoconf 2.61 is stable. If possible I think it would be good to have a resolution on this first, although I don't know how many people still use glibc 2.3.x
Comment 30 Jason Wever (RETIRED) gentoo-dev 2007-01-29 19:44:02 UTC
Every normal sparc user still uses glibc-2.3.x (only place it is unmasked is in an experimental gcc-4.1.x profile at the moment)
Comment 31 Jakub Moc (RETIRED) gentoo-dev 2007-01-31 00:49:48 UTC
*** Bug 164637 has been marked as a duplicate of this bug. ***
Comment 32 Jakub Moc (RETIRED) gentoo-dev 2007-01-31 08:09:38 UTC
*** Bug 164658 has been marked as a duplicate of this bug. ***
Comment 33 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2007-01-31 13:46:12 UTC
Attempt to fix this bug is the reason of bug 164525 :( I reverted changes I made for this bug.
Comment 34 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2007-01-31 15:04:10 UTC
Created attachment 108755 [details, diff]
eclass patch

A less intrusive approach (overload rbconfig.rb)
Comment 35 Jakub Moc (RETIRED) gentoo-dev 2007-01-31 18:11:01 UTC
*** Bug 164725 has been marked as a duplicate of this bug. ***
Comment 36 nobrow 2007-01-31 18:53:55 UTC
The "Amarok Effect" ...

Can confirm that remerging Ruby fixed the problem with installing Fastthread (Bug 164725).
Comment 37 Jakub Moc (RETIRED) gentoo-dev 2007-02-01 20:39:58 UTC
*** Bug 164900 has been marked as a duplicate of this bug. ***
Comment 38 Jakub Moc (RETIRED) gentoo-dev 2007-02-02 08:24:43 UTC
*** Bug 164931 has been marked as a duplicate of this bug. ***
Comment 39 Jakub Moc (RETIRED) gentoo-dev 2007-02-02 10:34:33 UTC
*** Bug 164964 has been marked as a duplicate of this bug. ***
Comment 40 Alan McKinnon 2007-02-02 13:03:08 UTC
Can confirm too that remerging ruby-1.8.5-p12 allows fastthread-0.6.3 to merge and install.
Using glibc-2.5 on ~x86
Comment 41 Jakub Moc (RETIRED) gentoo-dev 2007-02-03 12:03:15 UTC
*** Bug 165112 has been marked as a duplicate of this bug. ***
Comment 42 Jakub Moc (RETIRED) gentoo-dev 2007-02-03 19:49:40 UTC
*** Bug 165162 has been marked as a duplicate of this bug. ***
Comment 43 Jakub Moc (RETIRED) gentoo-dev 2007-02-03 21:37:27 UTC
*** Bug 165171 has been marked as a duplicate of this bug. ***
Comment 44 Ian P. Christian 2007-02-04 00:34:09 UTC
also can confirm re-emerging ruby fixes this.
Comment 45 Dennis Schridde 2007-02-04 09:54:56 UTC
confirming, that re-emerging ruby fixes this
Maybe those who upgrade amaroK should be notified that this might be necessary.
Comment 46 Jakub Moc (RETIRED) gentoo-dev 2007-02-04 13:24:35 UTC
People stop confirming the issue, this bug is already noisy enough as it is due to users that don't bother themselves with searching for duplicates. :(
Comment 47 Jakub Moc (RETIRED) gentoo-dev 2007-02-04 16:55:45 UTC
*** Bug 165295 has been marked as a duplicate of this bug. ***
Comment 48 Jakub Moc (RETIRED) gentoo-dev 2007-02-06 21:10:58 UTC
*** Bug 165653 has been marked as a duplicate of this bug. ***
Comment 49 Erik Zeek 2007-02-07 04:21:38 UTC
(In reply to comment #34)
> Created an attachment (id=108755) [edit]
> eclass patch
> 
> A less intrusive approach (overload rbconfig.rb)
> 

I can confirm that this patch allows fastthread to install.

Thanks.
Comment 50 Jakub Moc (RETIRED) gentoo-dev 2007-02-08 21:09:42 UTC
*** Bug 165988 has been marked as a duplicate of this bug. ***
Comment 51 Jakub Moc (RETIRED) gentoo-dev 2007-02-08 22:37:41 UTC
*** Bug 166012 has been marked as a duplicate of this bug. ***
Comment 52 Jakub Moc (RETIRED) gentoo-dev 2007-02-13 20:08:44 UTC
*** Bug 166714 has been marked as a duplicate of this bug. ***
Comment 53 Jakub Moc (RETIRED) gentoo-dev 2007-02-13 20:10:01 UTC
*** Bug 166716 has been marked as a duplicate of this bug. ***
Comment 54 Jakub Moc (RETIRED) gentoo-dev 2007-02-16 09:47:24 UTC
*** Bug 167161 has been marked as a duplicate of this bug. ***
Comment 55 Jakub Moc (RETIRED) gentoo-dev 2007-02-22 08:26:05 UTC
*** Bug 167966 has been marked as a duplicate of this bug. ***
Comment 56 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2007-03-31 18:19:13 UTC
I'm tempted to close this bug as CANTFIX. This bug is unlikely to happen again in the near future. And no report for two months. Any other ideas?
Comment 57 Hans de Graaff gentoo-dev 2007-04-07 07:24:14 UTC
Perhaps it is a good idea to leave the bug open for some time, because coreutils-6.7 is now being marked stable on several arches (I noticed it on amd64 this morning). So many people will only run into this now, and if we close the bug less people will find it leading to many duplicates.
Comment 58 Maciej Piechotka 2007-04-07 12:35:18 UTC
Or give warning in preinst/postinst
Comment 59 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2007-04-07 16:24:50 UTC
(In reply to comment #58)
> Or give warning in preinst/postinst
> 
Although I doubt this, I have modified all dev-lang/ruby ebuilds and hoped somebody would notice the message.
Comment 60 Joe Harvell 2007-04-09 18:43:02 UTC
(In reply to comment #9)
> I have a similar problem with pppoe-start. It is looking for /bin/id, which
> moved into /usr/bin
> 

Did you open a bug for this?
Comment 61 Jakub Moc (RETIRED) gentoo-dev 2007-04-09 20:55:16 UTC
*** Bug 173956 has been marked as a duplicate of this bug. ***
Comment 62 Jakub Moc (RETIRED) gentoo-dev 2007-04-09 20:56:53 UTC
(In reply to comment #60)
> (In reply to comment #9)
> > I have a similar problem with pppoe-start. It is looking for /bin/id, which
> > moved into /usr/bin
> Did you open a bug for this?

Please don't; there's already one with zillion of duplicates; plus you shouldn't be using this stuff at all.
Comment 63 Joe Harvell 2007-04-09 22:01:41 UTC
(In reply to comment #62)
> (In reply to comment #60)
> > (In reply to comment #9)
> > > I have a similar problem with pppoe-start. It is looking for /bin/id, which
> > > moved into /usr/bin
> > Did you open a bug for this?
> 
> Please don't; there's already one with zillion of duplicates; plus you
> shouldn't be using this stuff at all.
> 

Jakub:

Could you give me a reference to this bug?  Also, I don't understand your last comment.  Who shouldn't be using what?
Comment 64 Jakub Moc (RETIRED) gentoo-dev 2007-04-10 07:55:49 UTC
(In reply to comment #63)
> Could you give me a reference to this bug?  

Maybe you could just use search and find Bug 159747 and loads of duplicates? 

> Also, I don't understand your last comment.  Who shouldn't be using what?

You shouldn't use pppoe-start at all.
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=4&chap=3#doc_chap4

</end of completely OT debate>


Comment 65 Jakub Moc (RETIRED) gentoo-dev 2007-04-16 14:35:00 UTC
*** Bug 174797 has been marked as a duplicate of this bug. ***
Comment 66 Daevid Vincent 2007-04-20 22:59:56 UTC
I just tried to emerge ruby-mysql and got the /bin/install error.

I then tried to "emerge -av dev-lang/ruby dev-ruby/mysql-ruby" and got the same error...

Then I realized that you all are talking about 1.8.5_p12, which is masked and _p2 is the one that I remerged. Ironic that mysql-ruby is marked stable though?

Can you please mark 1.8.5_p35 (or _p12) as stable then?

locutus ~ # eix dev-lang/ruby
[I] dev-lang/ruby
     Available versions:  (1.8)  1.8.4-r3 1.8.5_p2 ~1.8.5_p12 ~1.8.5_p35 ~1.8.6_pre1 ~1.8.6_pre3 ~1.8.6
     Installed versions:  1.8.5_p2(1.8)(15:52:03 04/20/07)(-cjk -debug doc examples ipv6 -socks5 threads -tk)
     Homepage:            http://www.ruby-lang.org/
     Description:         An object-oriented scripting language
Comment 67 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2007-04-22 08:30:46 UTC
*** Bug 175507 has been marked as a duplicate of this bug. ***
Comment 68 Jeff Mitchell 2007-04-25 17:34:19 UTC
*** Bug 175991 has been marked as a duplicate of this bug. ***
Comment 69 Łukasz Damentko (RETIRED) gentoo-dev 2007-05-01 16:33:59 UTC
*** Bug 176696 has been marked as a duplicate of this bug. ***
Comment 70 Jakub Moc (RETIRED) gentoo-dev 2007-05-06 20:02:02 UTC
*** Bug 177358 has been marked as a duplicate of this bug. ***
Comment 71 Jakub Moc (RETIRED) gentoo-dev 2007-05-06 20:03:41 UTC
Closing this bug; re-emerge ruby if you hit this issue.
Comment 72 Jakub Moc (RETIRED) gentoo-dev 2007-05-12 20:57:09 UTC
*** Bug 178228 has been marked as a duplicate of this bug. ***
Comment 73 Hans de Graaff gentoo-dev 2007-05-13 14:37:30 UTC
I've bumped the currently stable ruby-1.8.5_p2 to ruby-1.8.5_p2-r1 and filed bug 178346 to stabilize this as soon as possible. This will cause ruby users to recompile their ruby and thus solve the issue.

I have not added a dependency on coreutils-6.7-r1 because this would cause problems stabling this ebuild for some profiles (mostly the selinux versions). These profiles will have to deal with the issue at a later date.
Comment 74 Jakub Moc (RETIRED) gentoo-dev 2007-05-13 21:35:30 UTC
*** Bug 178440 has been marked as a duplicate of this bug. ***
Comment 75 Bonne Eggleston 2007-05-13 21:47:25 UTC
How about a warning when coreutils is upgraded?
Comment 76 Ferris McCormick (RETIRED) gentoo-dev 2007-05-13 22:58:58 UTC
Fixed on sparc by ruby-1.8.5_p2-r1 (Bug 178346).
Comment 77 Jakub Moc (RETIRED) gentoo-dev 2007-05-14 08:26:58 UTC
*** Bug 178462 has been marked as a duplicate of this bug. ***
Comment 78 Jakub Moc (RETIRED) gentoo-dev 2007-05-14 09:58:46 UTC
*** Bug 178486 has been marked as a duplicate of this bug. ***
Comment 79 Jakub Moc (RETIRED) gentoo-dev 2007-11-14 23:03:33 UTC
*** Bug 199189 has been marked as a duplicate of this bug. ***
Comment 80 Jakub Moc (RETIRED) gentoo-dev 2008-02-05 16:36:54 UTC
*** Bug 209016 has been marked as a duplicate of this bug. ***