Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 158335 - gnome-extra/gucharmap-1.8.0 access violations
Summary: gnome-extra/gucharmap-1.8.0 access violations
Status: RESOLVED DUPLICATE of bug 118699
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-16 17:09 UTC by Wojciech Milkowski
Modified: 2006-12-16 17:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wojciech Milkowski 2006-12-16 17:09:49 UTC
gnome-extra/gucharmap-1.8.0 is trying to unlink files in main fs tree during sandbox installation:

`/var/tmp/portage/gnome-extra/gucharmap-1.8.0/work/gucharmap-1.8.0/help'
if ! test -d es/; then mkdir es/; fi
case "." in /*) sd=".";; *) sd="../.";; esac; \
        if [ -f "C/gucharmap.xml" ]; then d="../"; else d="$sd/"; fi; \
        (cd es/ && \
          `which xml2po` -e -p \
            "${d}es/es.po" \
            "${d}C/gucharmap.xml" > gucharmap.xml.tmp && \
            cp gucharmap.xml.tmp gucharmap.xml && rm -f gucharmap.xml.tmp)
if ! test -d fr/; then mkdir fr/; fi
case "." in /*) sd=".";; *) sd="../.";; esac; \
        if [ -f "C/gucharmap.xml" ]; then d="../"; else d="$sd/"; fi; \
        (cd fr/ && \
          `which xml2po` -e -p \
            "${d}fr/fr.po" \
            "${d}C/gucharmap.xml" > gucharmap.xml.tmp && \
            cp gucharmap.xml.tmp gucharmap.xml && rm -f gucharmap.xml.tmp)
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
if ! test -d fi/; then mkdir fi/; fi
case "." in /*) sd=".";; *) sd="../.";; esac; \
        if [ -f "C/gucharmap.xml" ]; then d="../"; else d="$sd/"; fi; \
        (cd fi/ && \
          `which xml2po` -e -p \
            "${d}fi/fi.po" \
            "${d}C/gucharmap.xml" > gucharmap.xml.tmp && \
            cp gucharmap.xml.tmp gucharmap.xml && rm -f gucharmap.xml.tmp)
if ! test -d sv/; then mkdir sv/; fi
case "." in /*) sd=".";; *) sd="../.";; esac; \
        if [ -f "C/gucharmap.xml" ]; then d="../"; else d="$sd/"; fi; \
        (cd sv/ && \
          `which xml2po` -e -p \
            "${d}sv/sv.po" \
            "${d}C/gucharmap.xml" > gucharmap.xml.tmp && \
            cp gucharmap.xml.tmp gucharmap.xml && rm -f gucharmap.xml.tmp)
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
if ! test -d ru/; then mkdir ru/; fi
case "." in /*) sd=".";; *) sd="../.";; esac; \
        if [ -f "C/gucharmap.xml" ]; then d="../"; else d="$sd/"; fi; \
        (cd ru/ && \
          `which xml2po` -e -p \
            "${d}ru/ru.po" \
            "${d}C/gucharmap.xml" > gucharmap.xml.tmp && \
            cp gucharmap.xml.tmp gucharmap.xml && rm -f gucharmap.xml.tmp)
xsltproc -o gucharmap-C.omf --stringparam db2omf.basename gucharmap --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//EN" --stringparam db2omf.lang C --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir "/usr/share/gnome/help" --stringparam db2omf.omf_in "`pwd`/./gucharmap.omf.in" `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` C/gucharmap.xml
db2omf: Missing element with role maintainer
ACCESS DENIED  unlink:    /usr/share/xml2po/docbook.pyc
xsltproc -o gucharmap-bg.omf --stringparam db2omf.basename gucharmap --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//EN" --stringparam db2omf.lang bg --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir "/usr/share/gnome/help" --stringparam db2omf.omf_in "`pwd`/./gucharmap.omf.in" `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` bg/gucharmap.xml
db2omf: Missing element with role maintainer
xsltproc -o gucharmap-es.omf --stringparam db2omf.basename gucharmap --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//EN" --stringparam db2omf.lang es --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir "/usr/share/gnome/help" --stringparam db2omf.omf_in "`pwd`/./gucharmap.omf.in" `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` es/gucharmap.xml
db2omf: Missing element with role maintainer
xsltproc -o gucharmap-fr.omf --stringparam db2omf.basename gucharmap --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//EN" --stringparam db2omf.lang fr --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir "/usr/share/gnome/help" --stringparam db2omf.omf_in "`pwd`/./gucharmap.omf.in" `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` fr/gucharmap.xml
db2omf: Missing element with role maintainer
xsltproc -o gucharmap-fi.omf --stringparam db2omf.basename gucharmap --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//EN" --stringparam db2omf.lang fi --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir "/usr/share/gnome/help" --stringparam db2omf.omf_in "`pwd`/./gucharmap.omf.in" `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` fi/gucharmap.xml
db2omf: Missing element with role maintainer
xsltproc -o gucharmap-sv.omf --stringparam db2omf.basename gucharmap --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//EN" --stringparam db2omf.lang sv --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir "/usr/share/gnome/help" --stringparam db2omf.omf_in "`pwd`/./gucharmap.omf.in" `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` sv/gucharmap.xml
db2omf: Missing element with role maintainer
xsltproc -o gucharmap-ru.omf --stringparam db2omf.basename gucharmap --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//EN" --stringparam db2omf.lang ru --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir "/usr/share/gnome/help" --stringparam db2omf.omf_in "`pwd`/./gucharmap.omf.in" `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` ru/gucharmap.xml
db2omf: Missing element with role maintainer
make[2]: Opuszczenie katalogu `/var/tmp/portage/gnome-extra/gucharmap-1.8.0/work/gucharmap-1.8.0/help'
make[2]: Wejście do katalogu `/var/tmp/portage/gnome-extra/gucharmap-1.8.0/work/gucharmap-1.8.0'
LC_ALL=C ./intltool-merge -d -u -c ./po/.intltool-merge-cache ./po gucharmap.desktop.in gucharmap.desktop
Generating and caching the translation database
Merging translations into gucharmap.desktop.
make[2]: Opuszczenie katalogu `/var/tmp/portage/gnome-extra/gucharmap-1.8.0/work/gucharmap-1.8.0'
make[1]: Opuszczenie katalogu `/var/tmp/portage/gnome-extra/gucharmap-1.8.0/work/gucharmap-1.8.0'
>>> Source compiled.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-gnome-extra_-_gucharmap-1.8.0-14223.log"

unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
unlink:    /usr/share/xml2po/docbook.pyc
--------------------------------------------------------------------------------
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-12-16 17:20:05 UTC
Please, search...


*** This bug has been marked as a duplicate of 118699 ***