Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 156446 - net-misc/dhcpcd-3.0.0 keywords dropped, please re-add
Summary: net-misc/dhcpcd-3.0.0 keywords dropped, please re-add
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Roy Marples (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on: 156515
Blocks: 166921
  Show dependency tree
 
Reported: 2006-11-27 13:24 UTC by Roy Marples (RETIRED)
Modified: 2007-02-22 05:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roy Marples (RETIRED) gentoo-dev 2006-11-27 13:24:42 UTC
dhcpcd-3.0.0
A complete rewrite by Roy Marples <uberlord@gentoo.org>

Functional changes since version 2:
We now support FreeBSD as well as Linux.
RFC 3004 User Class support has been added.
RFC 3442 Classless Static Routes support has been added
(thanks to apexman for helping).
Options -r, -e, -v, -w, -B, -C, -D, -L, -S have been dropped.
-a now means "do arp" instead of "don't arp".
-o has been dropped, but we never bring down the interface anymore.
IP address is now required for the -s option.
-G no longer takes an IP address as an replacement gateway.
The .cache file is no longer created or used.
Default script is now /etc/dhcpcd.sh instead of /etc/dhcpc/dhcpcd.exe.
The .info file has changed slightly to better support mulitple entries with
more than one entity, such as route now having network,genmask and gateway.
We no longer create and restore .sv files as it's up to the interface
manager to restore them correctly as >1 dhcp client may be running.

As such, please re-keyword your ARCH. It works fine on Linux (x86,amd64) and FreeBSD (x86,sparc64) so should hopefully be trouble free.

Thanks
Comment 1 Roy Marples (RETIRED) gentoo-dev 2006-11-27 13:26:16 UTC
All arches should now be added.
Comment 2 Jeroen Roovers gentoo-dev 2006-11-27 16:34:49 UTC
It works! Marked ~hppa.
Comment 3 Joe Jezak (RETIRED) gentoo-dev 2006-11-28 07:14:44 UTC
Works here too, marked ~ppc.
Comment 4 Markus Ullmann (RETIRED) gentoo-dev 2006-11-29 10:09:40 UTC
masked until dependent bug is solved
Comment 5 Roy Marples (RETIRED) gentoo-dev 2006-11-30 10:03:51 UTC
Bug is solved.
Comment 6 Gustavo Zacarias (RETIRED) gentoo-dev 2006-11-30 10:17:46 UTC
3.0.1 ~sparc blessed.
Comment 7 Markus Rothe (RETIRED) gentoo-dev 2006-12-01 08:36:12 UTC
added ~ppc64
Comment 8 Stefaan De Roeck (RETIRED) gentoo-dev 2006-12-17 11:28:24 UTC
added ~alpha
Comment 9 Stuart Longland (RETIRED) gentoo-dev 2007-02-22 05:07:55 UTC
Tested on mips successfully... keyworded ~mips.