Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 156515 - net-misc/dhcpcd-3.0.0 fails to get a request
Summary: net-misc/dhcpcd-3.0.0 fails to get a request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Roy Marples (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 156446
  Show dependency tree
 
Reported: 2006-11-28 07:37 UTC by Mike McQuaid
Modified: 2006-12-02 13:47 UTC (History)
16 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
tcpdump output for dhcpcd-2.0.8 (tcpdump-dhcpcd-2.out,720 bytes, text/plain)
2006-11-28 09:37 UTC, Mike McQuaid
Details
tcpdump output for dhcpcd-3.0.0 (tcpdump-dhcpcd-3.out,1.74 KB, text/plain)
2006-11-28 09:38 UTC, Mike McQuaid
Details
dhcpcd 3.0.0 output (failure) (dhcpcd3-dhcpcd-log,758 bytes, text/plain)
2006-11-28 14:33 UTC, Colin Bennett
Details
dhcpcd 3.0.0 wireshark log (failure) (dhcpcd3-wireshark-log,4.83 KB, application/octet-stream)
2006-11-28 14:34 UTC, Colin Bennett
Details
dhcpcd 2.0.8 output (success) (dhcpcd2-dhcpcd-log,703 bytes, text/plain)
2006-11-28 14:37 UTC, Colin Bennett
Details
dhcpcd 2.0.8 wireshark log (success) (dhcpcd2-wireshark-log,1.65 KB, application/octet-stream)
2006-11-28 14:38 UTC, Colin Bennett
Details
dhcpcd-3.0.0-byte-ordering.patch (dhcpcd-3.0.0-byte-ordering.patch,553 bytes, patch)
2006-11-28 17:29 UTC, TGL
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mike McQuaid 2006-11-28 07:37:03 UTC
m249 ~ # dhcpcd -d eth0
Info, eth0: dhcpcd 3.0.0 starting
Info, eth0: ethernet address = 0:50:8d:e5:c7:9e
Info, eth0: broadcasting for lease
Debug, eth0: Sending DHCP_DISCOVER with xid 790950117
Debug, eth0: waiting on select for 10 seconds
Debug, eth0: Sending DHCP_DISCOVER with xid 790950117
Debug, eth0: Sending DHCP_DISCOVER with xid 790950117
Debug, eth0: Sending DHCP_DISCOVER with xid 790950117
Debug, eth0: Sending DHCP_DISCOVER with xid 790950117
Error, eth0: timed out
Info, eth0: exiting


compared with the old version
m249 ~ # dhcpcd -d eth0
Info, MAC address = 00:50:8d:e5:c7:9e
Debug, broadcasting DHCP_DISCOVER
Debug, dhcpIPaddrLeaseTime=4294967295 in DHCP server response.
Debug, dhcpT1value is missing in DHCP server response. Assuming 2147483647 sec
Debug, dhcpT2value is missing in DHCP server response. Assuming 3758096383 sec
Debug, DHCP_OFFER received from  (192.168.0.1)
Debug, broadcasting DHCP_REQUEST for 192.168.0.3
Debug, dhcpIPaddrLeaseTime=4294967295 in DHCP server response.
Debug, dhcpT1value is missing in DHCP server response. Assuming 2147483647 sec
Debug, dhcpT2value is missing in DHCP server response. Assuming 3758096383 sec
Debug, DHCP_ACK received from  (192.168.0.1)
Debug, broadcasting ARPOP_REQUEST for 192.168.0.3
Info, verified 192.168.0.3 address is not in use
Info, your IP address = 192.168.0.3
Debug, orig hostname = m249
Debug, about to exec "/etc/dhcpc/dhcpcd.exe /var/lib/dhcpc/dhcpcd-eth0.info new"
Comment 1 Roy Marples (RETIRED) gentoo-dev 2006-11-28 08:00:48 UTC
Could you attach a wireshark capture or a tcpdump please?
Comment 2 Roy Marples (RETIRED) gentoo-dev 2006-11-28 08:41:44 UTC
Also, please attach your emerge --info and state what dhcp server and version you're using.
Comment 3 Mike McQuaid 2006-11-28 09:25:36 UTC
emerge --info

Portage 2.1.2_rc2-r2 (default-linux/amd64/2006.1, gcc-4.1.1, glibc-2.5-r0, 2.6.18-suspend2-m249 x86_64)
=================================================================
System uname: 2.6.18-suspend2-m249 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
Gentoo Base System version 1.12.6
Last Sync: Tue, 28 Nov 2006 02:50:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
dev-util/confcache:  0.4.2-r1
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -msse3 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=athlon64 -msse3 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache confcache distlocks metadata-transfer parallel-fetch sandbox sfperms strict userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://gentoo.blueyonder.co.uk"
LANG="en_GB.UTF-8"
LC_ALL="en_GB.UTF-8"
LINGUAS="en en_GB"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://mp5/gentoo-portage"
USE="amd64 7zip X a52 aac acpi aiglx alias alsa amarok amazon amr aoss asf bash-completion bitmap-fonts bluetooth branding browserplugin bzip2 cairo ccache cdda cddb cdinstall cdio cdparanoia cdr cdrom cdsound cli commercial connectionstatus contactnotes cracklib crypt cscope css cups custom-cflags cvs dbus divx dlloader dri dts dvb dvd dvdr dvdread effects elibc_glibc emoticon emul-linux-x86 encode exif extraicons extras fam fbcon fbsplash festival ffmpeg firefox flac flash frontendonly ftp fuse gdbm geoip gif gimp gimpprint glibc-omitfp glitz gmail gmailtimestamps gphoto2 gpm grammar graphviz gtk gtk2 gvim gzip hal hddtemp highlight history html iconv id3 inotify input_devices_evdev input_devices_keyboard input_devices_mouse ipod irc jabber jack java java5 javascript joystick jpeg kcal kde kdepim kdgraphics kdm kernel_linux kqemu ladspa lame largeterminal latex lcd linguas_en linguas_en_GB lirc lirc_devices_livedrive_midi live lm_sensors logitech-mouse logrotate mad mailwrapper mjpeg mmap mozbranding mp3 mp4 mp4live mpeg mpeg2 mplayer msn msnextras mysql mythtv ncurses net network nls nntp no-old-linux nocardbus nocd nowlistening nptl nptlonly nsplugin ntlm nvidia ogg openal opengl oss pam pcre pdf perl php png print python qemu-fast qt3 quicktime rdesktop readline rss rtc samba sasl screen sdl session smp sound spell sql sse-filters ssl subversion svg svgz svn-mirror tcpd threads threadsafe tidy truetype truetype-fonts type1-fonts udev uk_bleb uk_rt unicode unzip usb userland_GNU vfat video_cards_nv video_cards_nvidia vim vnc vncviewer vorbis widescreen wifi wma wmp x264 xcomposite xine xinerama xorg xscreensaver xv xvid xvmc zip zlib zpack"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 Mike McQuaid 2006-11-28 09:27:52 UTC
Server is Dnsmasq version 2.33.
Getting tcpdump now.
Comment 5 Roy Marples (RETIRED) gentoo-dev 2006-11-28 09:32:02 UTC
I'd prefer a wireshark/ethereal trace as I've never used tcpdump, but I'll see if I can use yours. Traffic of it working and it not working is what's needed.

Also, what arch is the dnsmasq server running on?
Comment 6 Mike McQuaid 2006-11-28 09:37:46 UTC
Created attachment 102928 [details]
tcpdump output for dhcpcd-2.0.8
Comment 7 Mike McQuaid 2006-11-28 09:38:00 UTC
Created attachment 102929 [details]
tcpdump output for dhcpcd-3.0.0
Comment 8 Mike McQuaid 2006-11-28 09:39:20 UTC
If you need wireshark, let me know. 
dnsmasq is being run on a DD-WRT Linksys WRT54G linux router, architecture is MIPS iirc.
Comment 9 Roy Marples (RETIRED) gentoo-dev 2006-11-28 11:40:45 UTC
I'm afraid I'll need the wireshark captures please, as those dumps don't contain the frames I need.

BTW, I've just tested against dnsmasq-2.34 on a x86 server and that works from a x86 dhcpcd-3 client. Any chance you can upgrade dnsmasq on your router?
Comment 10 Thomas Scheiblauer 2006-11-28 11:44:55 UTC
bringing the interface up (eg. 'ip link set eth0 up' or 'ifconfig eth0 up' and after that 'dhcpcd eth0')  before calling dhcpcd on it helps (this is of course not the behaviour we are used to)
Comment 11 Renato Caldas 2006-11-28 13:20:26 UTC
I confirm this problem. The server in my case is a Window$ XP machine.
Comment 12 Morten O. Hansen 2006-11-28 13:33:36 UTC
Same problem here. Downgrading to 2.0.8-r3 fixes it.
Comment 13 Colin Bennett 2006-11-28 14:33:25 UTC
Created attachment 102944 [details]
dhcpcd 3.0.0 output (failure)

I have the same problem. I am attaching my dhcpcd logs for both success (2.0.8-r3) and failure (3.0.0). I have a Linksys WRT54G, and suddenly since dhcpcd got upgraded, my networking, both wired and wireless can't get dhcp responses.
Comment 14 Colin Bennett 2006-11-28 14:34:19 UTC
Created attachment 102945 [details]
dhcpcd 3.0.0 wireshark log (failure)

Here is my wireshark log from dhcpcd 3.0.0 trying to get a DHCP address.
Comment 15 Colin Bennett 2006-11-28 14:37:05 UTC
Created attachment 102946 [details]
dhcpcd 2.0.8 output (success)
Comment 16 Colin Bennett 2006-11-28 14:38:03 UTC
Created attachment 102947 [details]
dhcpcd 2.0.8 wireshark log (success)
Comment 17 Mike Auty gentoo-dev 2006-11-28 14:40:37 UTC
I had a mid-air collision with the following comment I was posting.  Luckily Colin's captures demonstrate the issue perfectly.  He's also sending packets from the reversed address of the one he received...

Original post:
I'm afraid I didn't record my wireshark results, but if it helps offer an area to investigate I noticed that after doing a discover on my wireless connection, I received an offer of 192.168.0.4.  My machine then appeared to send out several DHCP request packets (which included correctly had the requested address option set as 192.168.0.4), but all of these packets had a source IP address of 4.0.168.192, suggesting there's been some sort of byte ordering issue as the packets are sent.  If I can recreate the situation tomorrow I'll try to post the pcap files...
Comment 18 TGL 2006-11-28 17:28:48 UTC
(In reply to comment #17)
> but all of these packets had a source IP address of 4.0.168.192, suggesting 
> there's been some sort of byte ordering issue as the packets are sent.

Seems that make_dhcp_packet() in socket.c applies htonl() on some addresses which were already in network byte order. The following patch fixed that here (not much tested, but at least now i get a correct IP adress).
Comment 19 TGL 2006-11-28 17:29:13 UTC
Created attachment 102961 [details, diff]
dhcpcd-3.0.0-byte-ordering.patch
Comment 20 Roy Marples (RETIRED) gentoo-dev 2006-11-29 05:54:50 UTC
(In reply to comment #19)
> Created an attachment (id=102961) [edit]
> dhcpcd-3.0.0-byte-ordering.patch

Thanks for the patch - that is indeed an error!

OK people, I've put up a beta tarball with this fix and a few others rolled in.
http://dev.gentoo.org/~uberlord/dhcpcd-3.0.1_pre1.tar.bz2

If everyone CC'ed on this bug could download and test that tarball and then report back if it fixes it for them or not I'd appreciate it.

The more people who say it's working, the faster I can put it into portage.

Thanks
Comment 21 Mike McQuaid 2006-11-29 06:22:36 UTC
Fixes it for me.
Good work!
Comment 22 Mike Auty gentoo-dev 2006-11-29 06:30:21 UTC
I'll test it this evening once I get back to the hotel, and let you know...
Comment 23 Mike Auty gentoo-dev 2006-11-29 08:47:33 UTC
Yep, all seems to be working fine from here...
Comment 24 Wilbur Pan 2006-11-29 09:10:27 UTC
I didn't try the tarball, but dhcpcd-3.0.0-byte-ordering.patch fixed this issue for me.
Comment 25 Frank Russo 2006-11-29 09:26:54 UTC
Confirmed on ~amd64.  Patch works.

Frank Russo
Comment 26 Lasse Bigum 2006-11-29 10:02:04 UTC
Tested here as well on ~x86, works for me.
Comment 27 Morten O. Hansen 2006-11-29 10:41:52 UTC
Works here to now. ~x86.
Comment 28 John Hanson 2006-11-29 12:50:34 UTC
Had the same issue on a fresh ~x86 install. Fix worked for me (though I had to repack the tarball as the folder name inside it didn't match the tarball name).

Comment 29 Justin Blanchard 2006-11-29 14:38:10 UTC
Thanks! It helped here too. ~x86. I imagine sparc-fbsd/ppc/hppa won't mind the change... =) Are more reports still helpful, or have there been enough? Maybe from x86-fbsd?
Comment 30 bunkacid 2006-11-29 16:30:38 UTC
dhcpcd-3.0.1_pre1.tar.bz2 works great for me on x86

here is the configuration options I use in /etc/conf.d/net

dhcpcd_ath0="-a -d -t 13 -m 1 -h hostname-ath0"

Comment 31 hiyuh 2006-11-29 16:58:40 UTC
FYI, I've tested 3.0.0 w/ the byte-ordering patch on ~ppc.
And IT JUST WORKS(tm) for me. :)
Comment 32 Jacob Braun 2006-11-29 18:21:11 UTC
Works for me on ~x86.
Comment 33 Florian Manschwetus 2006-11-29 22:59:29 UTC
curious from time to time it has worked here, but often it has needed 2 or 3 tries
(~x86 wpa_supplicant ipw3945) without the patch i downgraded (I think enough ~x86 confirmes)
Comment 34 Federico Cuello 2006-11-30 08:20:55 UTC
Hello everybody,

Version 3.0 (unpatched) worked but only after an "ifconfig eth0 up", and waiting a couple of seconds until I got "eth0: Media Link On 100mbps full-duplex eth0: no IPv6 routers present" in the logs. Then I could run dhcpcd with no problems.

Comment 35 Roy Marples (RETIRED) gentoo-dev 2006-11-30 10:00:40 UTC
Fixed in dhcpcd-3.0.1
Comment 36 Scott M. Likens 2006-11-30 21:32:52 UTC
desolation ~ # dhcpcd --version
dhcpcd 3.0.1

Error, eth0: ignoring packet with xid -1429161163 as it's not ours
(465612271)
Error, eth0: ignoring packet with xid 595488122 as it's not ours
(465612271)
Error, eth0: ignoring packet with xid 605093888 as it's not ours
(465612271)
Error, eth0: ignoring packet with xid 605093888 as it's not ours
(465612271)
Error, eth0: ignoring packet with xid 1066559027 as it's not ours
(465612271)
Error, eth0: ignoring packet with xid -501499551 as it's not ours
(465612271)
Error, eth0: ignoring packet with xid 595488122 as it's not ours
(465612271)
Error, eth0: ignoring packet with xid -948754339 as it's not ours
(465612271)
Error, eth0: timed out

Resolved with ifconfig eth0 up

I did capture it with wireshark, however there really wasn't anything useful in it.

Replace dhcpcd with udhcpc, and it works with success.  No reboot required.
Comment 37 Michiel de Bruijne 2006-12-01 07:19:17 UTC
(In reply to comment #36)
> desolation ~ # dhcpcd --version
> dhcpcd 3.0.1

> I did capture it with wireshark, however there really wasn't anything useful in
> it.
> 
> Replace dhcpcd with udhcpc, and it works with success.  No reboot required.
> 

(In reply to comment #0)
> m249 ~ # dhcpcd -d eth0
> Info, eth0: dhcpcd 3.0.0 starting
> Info, eth0: ethernet address = 0:50:8d:e5:c7:9e
> Info, eth0: broadcasting for lease
> Debug, eth0: Sending DHCP_DISCOVER with xid 790950117
> Debug, eth0: waiting on select for 10 seconds
> Debug, eth0: Sending DHCP_DISCOVER with xid 790950117
> Debug, eth0: Sending DHCP_DISCOVER with xid 790950117
> Debug, eth0: Sending DHCP_DISCOVER with xid 790950117
> Debug, eth0: Sending DHCP_DISCOVER with xid 790950117
> Error, eth0: timed out
> Info, eth0: exiting
> 
> 
> compared with the old version
> m249 ~ # dhcpcd -d eth0
> Info, MAC address = 00:50:8d:e5:c7:9e
> Debug, broadcasting DHCP_DISCOVER
> Debug, dhcpIPaddrLeaseTime=4294967295 in DHCP server response.
> Debug, dhcpT1value is missing in DHCP server response. Assuming 2147483647 sec
> Debug, dhcpT2value is missing in DHCP server response. Assuming 3758096383 sec
> Debug, DHCP_OFFER received from  (192.168.0.1)
> Debug, broadcasting DHCP_REQUEST for 192.168.0.3
> Debug, dhcpIPaddrLeaseTime=4294967295 in DHCP server response.
> Debug, dhcpT1value is missing in DHCP server response. Assuming 2147483647 sec
> Debug, dhcpT2value is missing in DHCP server response. Assuming 3758096383 sec
> Debug, DHCP_ACK received from  (192.168.0.1)
> Debug, broadcasting ARPOP_REQUEST for 192.168.0.3
> Info, verified 192.168.0.3 address is not in use
> Info, your IP address = 192.168.0.3
> Debug, orig hostname = m249
> Debug, about to exec "/etc/dhcpc/dhcpcd.exe /var/lib/dhcpc/dhcpcd-eth0.info
> new"
> 

Same over here, still problems with net-misc/dhcpcd-3.0.1, <net-misc/dhcpcd-3 works fine, net-misc/pump-0.8.24 works fine as well.

Could somebody who is able to reopen this bug?

emerge --info
Portage 2.1.2_rc2-r3 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.5-r0, 2.6.18-gentoo-r1 i686)
=================================================================
System uname: 2.6.18-gentoo-r1 i686 AMD Athlon(tm) XP 2600+
Gentoo Base System version 1.12.6
Last Sync: Fri, 01 Dec 2006 11:30:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.3.6, 2.4.4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
dev-util/confcache:  0.4.2-r1
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--noconfmem"
FEATURES="autoconfig ccache distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp.snt.utwente.nl/pub/os/linux/gentoo"
LANG="en_US.ISO-8859-1"
LC_ALL="en_US.ISO-8859-1"
LINGUAS="en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow X a52 aac acpi alsa arts artswrappersuid asf bash-completion bzip2 cairo cddb cdinstall cjk connectionstatus crypt css cups dbus directfb dri dts dvd dvdr dvdread elibc_glibc encode exif ffmpeg firefox flac foomaticdb fortran gif gphoto2 gtk hal history hpn imagemagick imlib input_devices_keyboard input_devices_mouse irc java jpeg kde kdeenablefinal kdehiddenvisibility kernel_linux lcms linguas_en logitech-mouse mad mikmod mmx mp3 mp4 mpeg musicbrainz nfs nls nptl nptlonly nsplugin nxclient ogg opengl pdf png portaudio ppds python qt3 qt4 quicktime rdesktop readline real ruby samba speex spell sqlite sse ssl statistics svg sysfs theora threads tiff truetype unicode usb userland_GNU vcd video_cards_nvidia vorbis win32codecs x264 xcomposite xforms xft xine xorg xv xvid xvmc zlib"
Unset:  CTARGET, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 38 Roy Marples (RETIRED) gentoo-dev 2006-12-01 07:31:55 UTC
(In reply to comment #37)
> Same over here, still problems with net-misc/dhcpcd-3.0.1, <net-misc/dhcpcd-3
> works fine, net-misc/pump-0.8.24 works fine as well.
> 
> Could somebody who is able to reopen this bug?

It's not the same bug. This is a new one, and it's already fixed - or I think it is.
You can test  a new tarball by grabbing 3.0.2_pre1
http://dev.gentoo.org/~uberlord/dhcpcd-3.0.2_pre1.tar.bz2
Comment 39 Michiel de Bruijne 2006-12-02 13:47:24 UTC
(In reply to comment #38)
> (In reply to comment #37)
> > Same over here, still problems with net-misc/dhcpcd-3.0.1, <net-misc/dhcpcd-3
> > works fine, net-misc/pump-0.8.24 works fine as well.
> > 
> > Could somebody who is able to reopen this bug?
> 
> It's not the same bug. This is a new one, and it's already fixed - or I think
> it is.
> You can test  a new tarball by grabbing 3.0.2_pre1
> http://dev.gentoo.org/~uberlord/dhcpcd-3.0.2_pre1.tar.bz2
> 

ok, thanks for the info, I will test/confirm this when 3.0.2 is in the tree.