Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 15175 - baselayout-1.8.6.2 is broken (?!)
Summary: baselayout-1.8.6.2 is broken (?!)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High blocker (vote)
Assignee: Martin Schlemmer (RETIRED)
URL:
Whiteboard:
Keywords:
: 15185 15281 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-02-05 14:13 UTC by Quequero
Modified: 2006-03-04 07:19 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Quequero 2003-02-05 14:13:10 UTC
I've just emerged the new baselayout (version 1.8.6.2) as usual, i've upgraded 
all 27 files with etc-update, updated env vars with env-update ;p... The day 
after i turn on my pc and i can't boot... Seems strange but i get a bunch of 
errors like:

Feb  5 17:36:35 tiger rc-scripts: ERROR: "/var/state/init.d/started/checkfs" 
has syntax errors in it; not executing...
Feb  5 17:36:35 tiger rc-scripts: 
ERROR: "/var/state/init.d/need/checkroot/checkfs" has syntax errors in it; not 
executing...

These are the only two that my syslog registered but there are pages and pages 
of these errors (also complaining about the non-existance of softscript.new and 
softscript.old... but during the emerge i've got no errors)... Have i done some 
mistakes of is there a problem with this new package? I've updated baselayout 
also on another machine but i think that i won't reboot for now ;p...
Thanx a lot
Que

Reproducible: Always
Steps to Reproduce:
1. emerge -u baselayout
2. etc-update 
3. reboot
4. urgh :))

Actual Results:  
after all it crashes :)
Comment 1 Chuck Brewer 2003-02-05 16:32:30 UTC
I had the problem where when I rebooted, I got the missing link from /var/state to /mnt/.init.d, because I had not done the etc-update (emerged overnite and forgot).
not it boots fine with just a couple minor flaws..
1) starting devfsd gives output, which it never did before(e.g. starting devfsd management daemon 1.3.x blah blah..) my guess is it isnt pointing at /dev/null
2)I know devfsd is supposedly started and ps shows it, but now all my filesystem output is showing the newstyle names even though devfsd is running and the symlinks are there.
when I do mount I see stuff like :
rootfs on / type rootfs (rw)
/dev/root on / type ext3 (rw) and so on when I should see for those two entries:
/dev/hdb2 on / type ext3 (rw)
the other curious thing is since the move to /var/state/init.d I dont have tmpfs mounted on /mnt/.init.d anymore...will explore that to see if it helps.
Comment 2 Martin Schlemmer (RETIRED) gentoo-dev 2003-02-05 17:52:35 UTC
when I do mount I see stuff like :
rootfs on / type rootfs (rw)
/dev/root on / type ext3 (rw) and so on when I should see for those two entries:
/dev/hdb2 on / type ext3 (rw)
----------------------------------

I decided to just cp /proc/mounts to /etc/mtab, as its less prone to fail
than the "try to recreate all /etc/mtab entries with fake mounts".  It does
not do any harm, but if it really bothers that much ...
Comment 3 Chuck Brewer 2003-02-05 18:54:29 UTC
Well, I realize that its probably more foolproof that way, and I realize that I may be alone in this, but I'm not a big fan of devfs on the desktop, so I like to see the old names. Plus if it was just that one partition I could probably get over it,but I have 6 partitions on my Gentoo install, and mount another 5 on the other disk and /dev/ide/host0/bus0/target*/lun0/part* 15 times looks crazy when doing mount or df.
Also, could you point me at where I can > /dev/null the starting devfsd output in init? I can see the vesion in dmesg when it rolls by and the output spoils the pretty green messages:)
Comment 4 Quequero 2003-02-05 19:16:34 UTC
Uhm, i've just noticed that my reiserfs is mounted readonly with this version of baselayout... Anyway fstab is ok... Dunno why.

Que
Comment 5 Matt Taylor 2003-02-05 20:42:54 UTC
I just emerged the this baselayout and rebooted and I get a ton of messeges on the console inbetween initscripts like:

modprobe: Can't locate module /dev/parallel
modprobe: Can't locate module /dev/parallel
modprobe: Can't locate module /dev/lp1
modprobe: Can't locate module /dev/par1
modprobe: Can't locate module /dev/printers/1
modprobe: Can't locate module /dev/parallel
modprobe: Can't locate module /dev/lp2
modprobe: Can't locate module /dev/par2
modprobe: Can't locate module /dev/printers/2
modprobe: Can't locate module /dev/parallel
modprobe: Can't locate module /dev/lp3
modprobe: Can't locate module /dev/par3
modprobe: Can't locate module /dev/printers/3
modprobe: Can't locate module /dev/ttyS2
modprobe: Can't locate module /dev/ttyS3
modprobe: Can't locate module /dev/ttyS4
modprobe: Can't locate module /dev/ttyS5
modprobe: Can't locate module /dev/ttyS6
modprobe: Can't locate module /dev/ttyS7
modprobe: Can't locate module /dev/ttyS8
modprobe: Can't locate module /dev/ttyS9
modprobe: Can't locate module /dev/ttyS10
modprobe: Can't locate module /dev/ttyS11
modprobe: Can't locate module /dev/ttyS12
modprobe: Can't locate module /dev/ttyS13
modprobe: Can't locate module /dev/ttyS14

theres about 3-4 times that many but thats all I grabed before it went by and it doesnt show up in dmesg or the syslog.
Comment 6 Matt Taylor 2003-02-05 20:55:49 UTC
and the output of df is really ugly...what happend to the old setup?

Filesystem            Size  Used Avail Use% Mounted on
/dev/root              14G   12G  1.5G  89% /
/dev/ide/host0/bus0/target1/lun0/part2
                      9.2G  8.7G   13M 100% /mnt/linuxback
/dev/ide/host0/bus0/target1/lun0/part1
                      4.7G  4.7G   40M 100% /mnt/winback
/dev/ataraid/disc0/part1
                       86G   54G   33G  62% /mnt/raid
/dev/ide/host0/bus1/target1/lun0/part1
                       75G   74G  634M 100% /mnt/anime
/dev/ide/host2/bus1/target0/lun0/part1
                      112G  109G  3.2G  98% /mnt/stuff
/dev/ide/host2/bus1/target1/lun0/part1
                       75G   74G  1.3G  99% /mnt/tv

I know previous comments mentioned this but I didnt know it was this bad until I ran it.
Comment 7 Matt Taylor 2003-02-05 21:26:53 UTC
Oh and another thing...after emerging this baselayout and doing etc-update, mozilla stoped working.  I run it and it doesnt do any disk access and it uses 95% cpu and a ever increasing amount of ram until I kill it.  I searched for mozilla but all the bugs were about crashes or compile problems.  I emerged a few other packages before baselayout, but there not anything that I could see effecting mozilla.  I tried remerging mozilla to no effect.

Galeon runs but keeps opening more and more windows and doesnt load any pages.  I'm stuck using pheonix-bin which renders ugly compared to mozilla.
Comment 8 Matt Taylor 2003-02-05 21:29:06 UTC
and apperently pheonix doesn't do line wraps when posting the comments.

sorry about that.
Comment 9 Jon Portnoy (RETIRED) gentoo-dev 2003-02-06 01:01:56 UTC
This one is biting a lot of people. Perhaps baselayout should display a big red 'YOU MUST RUN etc-update' notice and kill portage so people notice it? 
Comment 10 Quequero 2003-02-06 07:21:30 UTC
I think that pkg_postinfo should have to be displayed after the clean phase, btw i've done etc-update as usual but now my fs is mounted readonly, the only thing i can do is to pass "linux rw" to lilo, then i can enter in management-mode but still i can't boot and i get a bunch of errors in the proc fs... What should i do? :) thanx a lot again :)
Comment 11 Guy 2003-02-06 07:37:54 UTC
My opinion regarding comment #9: YES!!!!!

I haven't run into any problems with the new baselayout (4 machines) so far - but, having been burned once before I take the following steps:

# emerge rsync
# emerge -pu world

- notice new baselayout update -

BY ITSELF!!!

# emerge baselayout
# etc-update

This works, provided you make good choices during etc-update. The phrase 'good choices' is critical to a successful result. I've had as many as 58 config files to be updated. And it's easy to make a mistake. Also, during 'etc-update' if you're thinking of using option 2 (keep current config and abandon new config), you should regard this as a mistake. You should be using either options 1 or 3 only for each changed config file. I've noticed that some of the changes are very subtle but important.

After (and ONLY after) the emerge of baselayout and running of etc-update are complete do I continue with the rest of the emerges.
Comment 12 Matt Taylor 2003-02-06 08:39:00 UTC
I also did etc-update and I took all the new configs except one, and I mereged the changes of that one, so I doubt my problems are becaue of not doing or doing etc-update imporperly.  I also merged baselayout by itself and ran etc-update imideatly after emerge.
Comment 13 Voicu Liviu 2003-02-06 11:10:15 UTC
I get ReadOnly system, can't create symbolic linca bla bla...and hangs
500 lines like this
/sbin/rc: line 275: /var/state/init.d/softlevel: Read-only file system

bla bla
Comment 14 Quequero 2003-02-06 13:28:52 UTC
The same here, azarah is this an ebuild problem or we are doing some kind of mistakes? thanx a lot
Que
Comment 15 Richard Gibert 2003-02-07 03:22:17 UTC
There also seems to be an problem with the /etc/init.d/net.eth0 script for some people after upgrading to this baselayout version.  Having net.eth0 added to the default run level causes

* Bringing eth0 up... [ ok ]
* Setting default gateway...
SIOCADDRT: File exists
* Failed to bring eth0 up [ !! ] 

for some of us as discussed at http://forums.gentoo.org/viewtopic.php?t=33962

Removing net.eth0 from the default runlevel seems to fix this issue, and eth0 seems to be brought up all on its own.
Comment 16 Quinn Harris 2003-02-07 13:26:18 UTC
I agree with Comment #9

I usually don't update my inittab file because I change the tty to vc/ as I don't use compatability mode with devfs.

Because I didn't update inittab, my system was broken after upgrading to baselayout-1.8.6.2.

I question if every Gentoo always updates thier etc files after an upgrade.  Most of the time not updating etc files isn't a big deal.
Comment 17 Jon Portnoy (RETIRED) gentoo-dev 2003-02-07 22:00:40 UTC
The issue with ugly `df` output is unrelated to baselayout. This is from util-linux - in z, util-linux does #define resolve_symlinks at the beginning of mount/realpath.c - in y, util-linux undefs it. Easy enough to fix...
Comment 18 Jon Portnoy (RETIRED) gentoo-dev 2003-02-07 22:58:32 UTC
Just committed util-linux-2.11z-r1, which should fix the ugly df output.
Comment 19 Chuck Brewer 2003-02-08 00:27:33 UTC
I dont suppose util-linux is gifted enough to fix the duplicate rootfs entries and 
point {mount|df} at the compat symlinks? This would work exceedingly well with azarah's choice to cp /proc/mounts to /etc/mtab.

rootfs on / type rootfs     \____/dev/hdb2 on / type ext3
/dev/root on / type ext3    /

Heres to hoping!BTW nice job avenj!
Comment 20 Martin Schlemmer (RETIRED) gentoo-dev 2003-02-09 04:36:36 UTC
Seth, sorry to pin this on you, but you unmasked baselayout-1.8.6.2 by mistake :(
It was still very experimental, as users usually do not etc-update, or read
post messages :/

  http://cvs.gentoo.org/cgi-bin/viewcvs.cgi/gentoo-x86/profiles/package.mask.diff?r1=1.2007&r2=1.2008
Comment 21 Seth Chandler 2003-02-09 16:15:38 UTC
yeah i'll have to take credit for this problem
you want to remask it?  i think we probably need to automate
some of the processes before we can unmask it again...

seth
Comment 22 Jon Portnoy (RETIRED) gentoo-dev 2003-02-09 16:17:41 UTC
If you remask it, the same thing happens again (in terms of people not running etc-update and having an unbootable system) - but it's probably a good idea anyway...
Comment 23 Martin Schlemmer (RETIRED) gentoo-dev 2003-02-16 16:57:56 UTC
*** Bug 15281 has been marked as a duplicate of this bug. ***
Comment 24 Martin Schlemmer (RETIRED) gentoo-dev 2003-02-16 17:27:31 UTC
*** Bug 15185 has been marked as a duplicate of this bug. ***
Comment 25 Martin Schlemmer (RETIRED) gentoo-dev 2003-04-06 11:05:54 UTC
baselayout-1.8.6.4 has been out a while, and all issues addressed.