Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 148878 - "emerge -e system" fails at gettext after activating gcc-4.1.1
Summary: "emerge -e system" fails at gettext after activating gcc-4.1.1
Status: VERIFIED DUPLICATE of bug 142893
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2006-09-23 19:02 UTC by Mark Dominik Bürkle
Modified: 2006-09-25 01:48 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Mark Dominik Bürkle 2006-09-23 19:02:52 UTC

I emerged "eselect-compiler" and did "eselect compiler <number-of-4.1.1>" some time ago. I did not notice that gcc-config still listed 3.4.6 as default compiler.

Some two, three days ago I did "gcc-config <numer-of-4.1.1>" and followed - without deleting /etc/env.d/05compiler.

Is that killing me, despite the fact that its values only point to 4.1.1-versions of INFOPATH/LDPATH/MANPATH and are the same in /lib/ and /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/ (since gcc-config switching to 4.1.1)?

The current symptom is that "emerge -e system" fails at building gettext:

eix-sync @ Sat Sep 23 21:53:58 CEST 2006

pcnocmdb2 ~ # emerge -1av gettext

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] sys-devel/gettext-0.15  USE="nls -doc -emacs -nocxx" 0 kB

Total size of downloads: 0 kB

Would you like to merge these packages? [Yes/No]

>>> Emerging (1 of 1) sys-devel/gettext-0.15 to /
 * gettext-0.15.tar.gz MD5 ;-) ...                                                                                                                                                                                                                                                                                                                                                                                             [ ok ]

/bin/sh ../libtool --tag=CC --mode=link i686-pc-linux-gnu-gcc  -march=pentium4 -mmmx -msse -msse2 -mfpmath=sse -O3 -fomit-frame-pointer -ffast-math -pipe   -o msgfmt  msgfmt-msgfmt.o msgfmt-write-mo.o msgfmt-write-java.o msgfmt-write-csharp.o msgfmt-write-resources.o msgfmt-write-tcl.o msgfmt-write-qt.o msgfmt-hash-string.o
(cd .libs && rm -f && ln -s
(cd .libs && rm -f && ln -s
i686-pc-linux-gnu-ar cru .libs/libgettextpo.a  gettext-po.o
i686-pc-linux-gnu-ranlib .libs/libgettextpo.a
(cd .libs && rm -f && ln -s ../
/bin/sh ../libtool --tag=CC --mode=link i686-pc-linux-gnu-gcc  -march=pentium4 -mmmx -msse -msse2 -mfpmath=sse -O3 -fomit-frame-pointer -ffast-math -pipe   -o msgmerge  msgmerge-msgmerge.o msgmerge-msgl-fsearch.o msgmerge-plural-count.o
i686-pc-linux-gnu-gcc -march=pentium4 -mmmx -msse -msse2 -mfpmath=sse -O3 -fomit-frame-pointer -ffast-math -pipe -o .libs/msgfmt msgfmt-msgfmt.o msgfmt-write-mo.o msgfmt-write-java.o msgfmt-write-csharp.o msgfmt-write-resources.o msgfmt-write-tcl.o msgfmt-write-qt.o msgfmt-hash-string.o  ./.libs/ /var/tmp/portage/gettext-0.15/work/gettext-0.15/gettext-tools/lib/.libs/ -lc
creating msgfmt
/bin/sh ../libtool --tag=CC --mode=link i686-pc-linux-gnu-gcc  -march=pentium4 -mmmx -msse -msse2 -mfpmath=sse -O3 -fomit-frame-pointer -ffast-math -pipe   -o msgunfmt  msgunfmt-msgunfmt.o msgunfmt-read-mo.o msgunfmt-read-java.o msgunfmt-read-csharp.o msgunfmt-read-resources.o msgunfmt-read-tcl.o
i686-pc-linux-gnu-gcc -march=pentium4 -mmmx -msse -msse2 -mfpmath=sse -O3 -fomit-frame-pointer -ffast-math -pipe -o .libs/msgmerge msgmerge-msgmerge.o msgmerge-msgl-fsearch.o msgmerge-plural-count.o  ./.libs/ /var/tmp/portage/gettext-0.15/work/gettext-0.15/gettext-tools/lib/.libs/ -lc
msgmerge-msgl-fsearch.o: In function `message_fuzzy_index_search':
msgl-fsearch.c:(.text+0x149): undefined reference to `ceil'
collect2: ld returned 1 exit status
make[4]: *** [msgmerge] Error 1
make[4]: *** Waiting for unfinished jobs....
i686-pc-linux-gnu-gcc -march=pentium4 -mmmx -msse -msse2 -mfpmath=sse -O3 -fomit-frame-pointer -ffast-math -pipe -o .libs/msgunfmt msgunfmt-msgunfmt.o msgunfmt-read-mo.o msgunfmt-read-java.o msgunfmt-read-csharp.o msgunfmt-read-resources.o msgunfmt-read-tcl.o  ./.libs/ /var/tmp/portage/gettext-0.15/work/gettext-0.15/gettext-tools/lib/.libs/ -lc
creating msgunfmt
make[4]: Leaving directory `/var/tmp/portage/gettext-0.15/work/gettext-0.15/gettext-tools/src'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/var/tmp/portage/gettext-0.15/work/gettext-0.15/gettext-tools/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gettext-0.15/work/gettext-0.15/gettext-tools'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/var/tmp/portage/gettext-0.15/work/gettext-0.15/gettext-tools'
make: *** [all-recursive] Error 1

!!! ERROR: sys-devel/gettext-0.15 failed.
Call stack:, line 1546:   Called dyn_compile, line 937:   Called src_compile
  gettext-0.15.ebuild, line 64:   Called die

!!! (no error message)
!!! If you need support, post the topmost build error, and the call stack if relevant.

emerge gcc, again
emerge gettext, again - same result
emerge -e system, again - same result

Kind regards,
Comment 1 Mark Dominik Bürkle 2006-09-23 19:04:55 UTC
Portage 2.1.2_pre1 (default-linux/x86/2006.0, gcc-4.1.1/vanilla, glibc-2.4-r3, 2.6.17-suspend2-r4 i686)
System uname: 2.6.17-suspend2-r4 i686 Intel(R) Pentium(R) 4 CPU 2.80GHz
Gentoo Base System version 1.12.4
Last Sync: Sat, 23 Sep 2006 19:20:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [disabled]
app-admin/eselect-compiler: 2.0.0_rc2-r1
dev-java/java-config: 1.3.5-r1, 2.0.27-r1
dev-lang/python:     2.3.5, 2.4.3-r3
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r2
dev-util/confcache:  [Not Present]
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17
CFLAGS="-march=pentium4 -mmmx -msse -msse2 -mfpmath=sse -O3 -fomit-frame-pointer -ffast-math -pipe"
CONFIG_PROTECT="/etc /lib/rcscripts /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/eselect/compiler /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=pentium4 -mmmx -msse -msse2 -mfpmath=sse -O3 -fomit-frame-pointer -ffast-math -pipe"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
LINGUAS="de en fr"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="x86 X acpi alsa apache2 arts bash-completion berkdb bitmap-fonts cli crypt cups curl dlloader dri dvd eds elibc_glibc emboss encode esd foomaticdb gdbm gif gpm gstreamer gtk gtk2 imap imlib input_devices_evdev input_devices_joystick input_devices_keyboard input_devices_mouse input_devices_vmmouse input_devices_void ipv6 isdnlog jpeg kde kernel_linux ldap libg++ libwww linguas_de linguas_en linguas_fr lirc_devices_com1 mad mikmod mmap mmx mmx2 motif mozilla mp3 mpeg ncurses nls nptl nptlonly nsplugin ogg oggvorbis openal opengl openssh pam pcre perl png pppd python qt3 qt4 quicktime readline reflection sdl session spl sse sse2 ssl tcpd theora truetype truetype-fonts type1-fonts udev unicode userland_GNU video_cards_dummy video_cards_fbdev video_cards_mga video_cards_nv video_cards_nvidia video_cards_radeon video_cards_v4l video_cards_vesa video_cards_vmware vorbis xinerama xml xml2 xmlrpc xorg xv zlib"
Comment 2 Joe Kappus 2006-09-23 19:34:59 UTC
simple workaround, take out -ffast-math from CFLAGS when building gettext, this is a very rare case that this CFLAG breaks a package.  
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-09-24 00:16:44 UTC
--ffast-math is a stupid flag to use globally.

*** This bug has been marked as a duplicate of 142893 ***
Comment 4 Mark Dominik Bürkle 2006-09-25 01:03:12 UTC
can't set bug#142893 to test-request -- see patch in bug#142893, worked for me (simple build check only, though).

Reopen here to set test-request.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-09-25 01:06:02 UTC
Please, leave duplicate bugs alone.

*** This bug has been marked as a duplicate of 142893 ***
Comment 6 Mark Dominik Bürkle 2006-09-25 01:06:22 UTC
See patch in bug#142893 (attachment#97998 [details, diff] or -- builds with my -mpfmath=sse + -ffast-math CFLAGS.

No tests with other CFLAGS; now emerging -ev system (and expecting it to continue past gettext:).
Comment 7 Mark Dominik Bürkle 2006-09-25 01:16:26 UTC
"emerge -ev system" already continued past gettext - without modifying my globcal CFLAGS in make.conf -- -ffast-math and -mfpmath=sse are still in there. *g*
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2006-09-25 01:47:54 UTC
Please, stop messing with duplicate bugs.
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2006-09-25 01:48:09 UTC

*** This bug has been marked as a duplicate of 142893 ***
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2006-09-25 01:48:30 UTC
Closed duplicate, don't touch.