Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 141383 - media-gfx/blender openal/freealut dependencies
Summary: media-gfx/blender openal/freealut dependencies
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: Highest major (vote)
Assignee: Luca Barbato
: 143550 143852 143931 (view as bug list)
Depends on:
Reported: 2006-07-22 07:20 UTC by Mike Nelson
Modified: 2008-05-19 14:02 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---

proposed patch for installing with openal-20050504 (blender-2.42-openal-freealut.patch,5.87 KB, patch)
2006-07-22 07:23 UTC, Mike Nelson
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Nelson 2006-07-22 07:20:14 UTC
blender-2.42 requires openal and freealut, which was a problem for me with ~media-libs/openal-20050504 installed since this cant have freealut installed at the same time. I found a fix for this for me by changing blender-2.42 to require either openal or freealut, but maybe this should just require openal and not freealut, since freealut requires openal. freealut specifically disallows openal-20050504 (!~media-libs/openal-20050504), and opeanl-20050504 disallows freealut (!media-libs/freealut).

I'm sure this was because blender doesn't compile right with this configuration. I also made a simple patch in order to compile with openal-20050504. This might make sense to go upstream. I don't remember ever hearing sounds in blender before so I'm not sure how to test this.

I'll attach a patch of my changes.
Comment 1 Mike Nelson 2006-07-22 07:23:29 UTC
Created attachment 92495 [details, diff]
proposed patch for installing with openal-20050504

Here's the patch that I talked about in the opening comment.
Comment 2 Luca Barbato gentoo-dev 2006-07-22 07:45:14 UTC
I hope those ebuilds will be removed soon since there is a release eventually
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-08-11 04:14:19 UTC
*** Bug 143550 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-08-13 23:17:43 UTC
*** Bug 143852 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-08-13 23:43:33 UTC
@amd64 - can you stabilize 2.41-r1 at least? You current stable version is not useful, it blocks the only available media-libs/openal version in portage.
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-08-14 12:57:40 UTC
*** Bug 143931 has been marked as a duplicate of this bug. ***
Comment 7 Simon Stelling (RETIRED) gentoo-dev 2006-08-16 03:58:19 UTC
marked stable
Comment 8 Dan Beavers 2006-08-19 20:43:33 UTC
I am confused.  My platform is amd64 and I can not update blender.  Should the resolved status be changed?

bireme ~ # emerge -avt media-gfx/blender

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[blocks B     ] ~media-libs/openal-20050504 (is blocking media-libs/freealut-1.0.1)
[ebuild  N    ] media-gfx/blender-2.41-r1  USE="nls" 0 kB
[ebuild  N    ]  media-libs/freealut-1.0.1  444 kB
[ebuild     UD]   media-libs/openal-0.0.8 [20050504-r1] USE="alsa arts mp3% sdl -debug -esd -vorbis" 850 kB

Total size of downloads: 1,295 kB

!!! Error: The above package list contains packages which cannot be installed
!!!        at the same time on the same system.
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2006-08-20 00:21:37 UTC
(In reply to comment #8)
> I am confused.  My platform is amd64 and I can not update blender.  Should the
> resolved status be changed?

No. You need to unmerge old openal first. 

emerge -C \<media-libs/openal-0.0.8
Comment 10 Dan Beavers 2006-08-20 18:28:37 UTC
(In reply to comment #9)
> emerge -C \<media-libs/openal-0.0.8
Thanks, that worked.
Comment 11 Mike Nelson 2008-05-19 14:02:39 UTC
Just, I found that this issue was originally caused by some installed openal stuff into /usr/local/{include,lib} on my system (from outside of portage). See my forum post, , for details.

Finally solved for me without my funky patch.