Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 137562 - portage selects the temporarily best version instead of the overall best
Summary: portage selects the temporarily best version instead of the overall best
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
: 137564 (view as bug list)
Depends on:
Blocks: 155723 autouse 284934 300071 288499
  Show dependency tree
 
Reported: 2006-06-22 04:44 UTC by Simon Stelling (RETIRED)
Modified: 2010-09-04 07:55 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Stelling (RETIRED) gentoo-dev 2006-06-22 04:44:24 UTC
(this is a follow-up to bug 136638 comment #27)

assume the following setup:

a-0: depends on >=b-0
a-1: depends on >=b-1
a-2: depends on c

a-2 and b-1 are package.masked.

now try to emerge =a-0:

# emerge -p =app-misc/a-0

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] app-misc/b-0
[ebuild  N    ] app-misc/a-0

this is all fine. but now try to emerge a:

 # emerge -p app-misc/a

These are the packages that would be merged, in order:

Calculating dependencies -
!!! All ebuilds that could satisfy ">=app-misc/b-1" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-misc/b-1 (masked by: package.mask)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "app-misc/a-1" [ebuild])

this obviously shouldn't happen.
Comment 1 Simon Stelling (RETIRED) gentoo-dev 2006-06-22 04:53:50 UTC
*** Bug 137564 has been marked as a duplicate of this bug. ***
Comment 2 Petteri Räty (RETIRED) gentoo-dev 2006-06-24 01:40:19 UTC
This is especially annoying with the xorg 7.1 because you need to package.mask all the drivers individually because of this. 
Comment 3 Jason Stubbs (RETIRED) gentoo-dev 2006-06-24 02:53:34 UTC
"Me toos" won't help or this bug will just end up like the other one. As I said on the other bug, it's something that (at least some of us) know needs to be handled but is not going to happen overnight. Is there anybody working on it right now? Probably not.
Comment 4 Simon Stelling (RETIRED) gentoo-dev 2006-06-24 04:02:05 UTC
might be worth asking Brian's SoCer, IIRC it is about dependency tracking, in pkgcore though
Comment 5 Simon Stelling (RETIRED) gentoo-dev 2006-11-17 01:07:40 UTC
I see this is still a problem with the new dep resolver, but could it be that it became easier to fix this issue now?
Comment 6 Zac Medico gentoo-dev 2006-11-17 21:16:12 UTC
Recent improvements haven't made this any easier to fix as far as I can see.  To fix this bug, the resolver needs to be able to backtrack and try alternative paths after it goes down an unsatisfiable path.  That puts this bug roughly on par with bug 1343.
Comment 7 Zac Medico gentoo-dev 2009-07-11 21:18:21 UTC
This is fixed in svn r13816 with patch by Sebastian Mingramm (few) <s.mingramm@gmx.de>.
Comment 8 Zac Medico gentoo-dev 2009-08-03 23:00:10 UTC
This is fixed in 2.2_rc34.
Comment 9 Zac Medico gentoo-dev 2009-10-11 00:44:10 UTC
This is fixed in 2.1.7.