Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 119722 - Stabilize PEAR ebuilds needed for dev-lang/php
Summary: Stabilize PEAR ebuilds needed for dev-lang/php
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: Highest normal (vote)
Assignee: PHP Bugs
URL:
Whiteboard:
Keywords:
: 119712 (view as bug list)
Depends on: 119461
Blocks:
  Show dependency tree
 
Reported: 2006-01-20 11:46 UTC by Jakub Moc (RETIRED)
Modified: 2006-04-28 21:17 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jakub Moc (RETIRED) gentoo-dev 2006-01-20 11:46:08 UTC
Please, test and mark stable the following PEAR ebuilds:

dev-php/PEAR-Auth-1.2.3-r1
dev-php/PEAR-Auth_SASL-1.0.1-r1
dev-php/PEAR-Benchmark-1.2.4
dev-php/PEAR-Cache-1.5.4-r1
dev-php/PEAR-Cache_Lite-1.6.0
dev-php/PEAR-Console_Table-1.0.2-r1
dev-php/PEAR-Crypt_RC4-1.0.2-r1
dev-php/PEAR-DB-1.7.6-r1
dev-php/PEAR-DB_DataObject-1.8.0
dev-php/PEAR-DB_Table-0.21.2-r1
dev-php/PEAR-Date-1.4.6
dev-php/PEAR-File-1.2.2
dev-php/PEAR-File_Find-1.2.0
dev-php/PEAR-HTML_Common-1.2.2
dev-php/PEAR-HTML_Javascript-1.1.1
dev-php/PEAR-HTML_QuickForm-3.2.5-r1
dev-php/PEAR-HTML_Select_Common-1.1-r2
dev-php/PEAR-HTML_Table-1.6.1
dev-php/PEAR-HTML_Table_Matrix-1.0.9
dev-php/PEAR-HTML_Template_Flexy-1.2.3
dev-php/PEAR-HTML_Template_IT-1.1.3
dev-php/PEAR-HTML_Template_Sigma-1.1.4
dev-php/PEAR-HTML_TreeMenu-1.2.0-r1
dev-php/PEAR-HTTP-1.4.0
dev-php/PEAR-HTTP_Request-1.3.0
dev-php/PEAR-HTTP_WebDAV_Server-0.99.1-r1
dev-php/PEAR-I18N-0.8.6-r2
dev-php/PEAR-Image_IPTC-1.0.2-r1
dev-php/PEAR-Log-1.9.3
dev-php/PEAR-MDB-1.3.0-r1
dev-php/PEAR-Mail-1.1.9
dev-php/PEAR-Mail_Mime-1.3.1-r1
dev-php/PEAR-Math_Stats-0.9.0_beta3-r1
dev-php/PEAR-Net_CheckIP-1.1-r1
dev-php/PEAR-Net_DIME-0.3-r1
dev-php/PEAR-Net_DNS-0.03-r1
dev-php/PEAR-Net_DNSBL-1.0.0-r1
dev-php/PEAR-Net_IMAP-1.0.3-r1
dev-php/PEAR-Net_LMTP-1.0.1-r1
dev-php/PEAR-Net_POP3-1.3.6-r1
dev-php/PEAR-Net_SMTP-1.2.7
dev-php/PEAR-Net_Server-0.12.0-r1
dev-php/PEAR-Net_Sieve-1.1.1-r1
dev-php/PEAR-Net_SmartIRC-1.0.0
dev-php/PEAR-Net_Socket-1.0.6-r1
dev-php/PEAR-Net_URL-1.0.14-r1
dev-php/PEAR-Net_UserAgent_Detect-2.1.0-r1
dev-php/PEAR-Numbers_Words-0.14.0
dev-php/PEAR-OLE-0.5-r1
dev-php/PEAR-PEAR_Info-1.6.0
dev-php/PEAR-PHPUnit-1.3.0-r1
dev-php/PEAR-Pager-2.3.4
dev-php/PEAR-PhpDocumentor-1.3.0_rc5
dev-php/PEAR-SOAP-0.9.1
dev-php/PEAR-Services_Weather-1.3.2-r1
dev-php/PEAR-Spreadsheet_Excel_Writer-0.9.0
dev-php/PEAR-Structures_DataGrid-0.6.3
dev-php/PEAR-System_Command-1.0.3
dev-php/PEAR-Text_Diff-0.2.0
dev-php/PEAR-Text_Password-1.1.0
dev-php/PEAR-Text_Wiki-1.0.3
dev-php/PEAR-Tree-0.2.4-r1
dev-php/PEAR-Validate-0.6.2
dev-php/PEAR-VersionControl_SVN-0.3.0_alpha1-r1
dev-php/PEAR-XML_Beautifier-1.1-r1
dev-php4/PEAR-XML_CSSML-1.1.1
dev-php/PEAR-XML_RSS-0.9.2-r1
dev-php/PEAR-XML_Serializer-0.18.0
dev-php/PEAR-XML_Tree-2.0.0_rc2-r1
dev-php/PEAR-XML_Util-1.1.1-r1
dev-php4/PEAR-XML_XPath-1.2.2

Thanks.
Comment 1 Jonathan Pappworth 2006-01-21 01:44:44 UTC
add the following to the list
dev-php/PEAR-XML_Parser-1.2.7
Comment 2 Andy Wang 2006-01-21 02:10:49 UTC
It looks like php-pear.eclass defines:
DEPEND="$DEPEND virtual/php dev-php/php"

Why would it depend on both virtual-php and dev-php/php?

Also, wouldn't it have made sense to actually resolve this bug before making the dev-lang/php stuff stable?
Comment 3 Sebastian Bergmann (RETIRED) gentoo-dev 2006-01-21 02:16:34 UTC
1. php-pear.eclass is the PEAR eclass for the old-style PHP packages. The new-style PHP packages use php-pear-r1.eclass.

2. How could packages (like dev-php*/PEAR-*) that depend on the new-style PHP packages be stabilized before the the new-style PHP packages were stabilized?
Comment 4 Andy Wang 2006-01-21 02:36:16 UTC
"Please, test and mark stable the following PEAR ebuilds:"

My point is, shouldn't they have been tested before dev-lang/php went stable, and marked stable in sync with dev-lang/php?

It makes upgrading to the new php stuff rather tricky as an emerge update is causing blocks if any of the PEAR packages are depended upon by something.  It also makes scripting updates rather difficult as an emerge -NDuav world won't complete and one has to manually update packages until the blocks are taken care of.
Comment 5 Sebastian Bergmann (RETIRED) gentoo-dev 2006-01-21 02:38:52 UTC
The "test and mark stable" is directed at the architecture teams.

The packages have been tested by the PHP Herd and quite a few early adopters of the new-style PHP packages.
Comment 6 Andy Wang 2006-01-21 02:47:30 UTC
I'm just a little frustrated I guess.
I saw php-5 went stable.  Read the documentation on upgrading php, unmerged all the php packages, upgraded php, then find out the fast majority of the php packages I need won't merge because of this problem.  So i had to backtrack and and redo all of this.
Comment 7 Sebastian Bergmann (RETIRED) gentoo-dev 2006-01-21 02:58:39 UTC
*** Bug 119712 has been marked as a duplicate of this bug. ***
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2006-01-21 03:03:23 UTC
Stop this ranting on keywording bugs, please. It's causing just *tons* of bugspam for all concerned arches and serves no good purpose.
Comment 9 Nicola 2006-01-21 08:46:03 UTC
things such as this simply kill who wants to use gentoo for servers... in my opinion a gentoo stable portage tree is needeed, I hope glep 19 will be a reality soon...
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2006-01-21 08:57:41 UTC
(In reply to comment #9)
> things such as this simply kill who wants to use gentoo for servers... in my
> opinion a gentoo stable portage tree is needeed, I hope glep 19 will be a
> reality soon...

Which part of my previous comment have you missed? Go rant elsewhere, not on keywording bugs. Things like keywording bugs don't kill anything, don't clutter this with off-topic comments.


Comment 11 Markus Rothe (RETIRED) gentoo-dev 2006-01-21 12:35:11 UTC
I've marked most packages stable on ppc64, but I couldn't mark this packages stable on ppc64, because they missed ~ppc64 due to *bad version bumping* (keyword was just dropped):

dev-php/PEAR-Benchmark-1.2.4
dev-php/PEAR-DB_Table-0.21.2-r1
dev-php/PEAR-PHPUnit-1.3.0-r1

I'm unsure how to handle this. Should I wait another 4 weeks or bump directly to stable?
Comment 12 Sebastian Bergmann (RETIRED) gentoo-dev 2006-01-21 12:44:12 UTC
Please bump to stable directly. Thanks.
Comment 13 Markus Rothe (RETIRED) gentoo-dev 2006-01-21 12:59:28 UTC
stable on ppc64
Comment 14 Mark Loeser (RETIRED) gentoo-dev 2006-01-21 23:55:34 UTC
x86 done, readd us if we missed anything.
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2006-01-22 05:01:08 UTC
alpha, ia64: Please, keyword this ~arch and stabilize when you are ready. Thanks.
Comment 16 Jason Wever (RETIRED) gentoo-dev 2006-01-22 09:34:07 UTC
SPARC'd them all (I hope)
Comment 17 Simon Stelling (RETIRED) gentoo-dev 2006-01-22 14:16:25 UTC
amd64 stable
Comment 18 Bryan Østergaard (RETIRED) gentoo-dev 2006-01-23 10:07:06 UTC
~ia64 keyworded all of it - keeping ia64 cc'ed so we don't forget to stable later.
Comment 19 Chris Gianelloni (RETIRED) gentoo-dev 2006-01-23 13:44:26 UTC
Since alpha and ppc never started bug #119461, I amd removing bug #119737 from this list.
Comment 20 Jan Hrabe 2006-01-24 10:11:22 UTC
(In reply to comment #7)
> *** Bug 119712 has been marked as a duplicate of this bug. ***
> 

I reported the 119712 bug.  This is an update:

> Please, emerge dev-lang/php first or put dev-php/php and dev-php/mod_php into
> /etc/portage/package.mask and it should be OK then (issue with default
> virtuals, it seems). Dunno if horde works with php-5.0.5, you might want to
> emerge =dev-lang/php-4* instead.

I tried that and I was ultimately able to emerge all pieces without portage
complaining.  Unfortunately, the installed combination does not lead to
working horde/imp/turba.  The PEAR modules are now marked stable and so is
php 5 but neither the stable version of imp nor its ~x86 marked version seem
to work.  I suppose php 5 was perhaps made stable without regard to these
php applications.  I'll try to downgrade back to php 4 as my company server
cannot be down much longer.  Thanks for trying to help.
Comment 21 Jakub Moc (RETIRED) gentoo-dev 2006-01-24 11:02:09 UTC
(In reply to comment #20)
> I tried that and I was ultimately able to emerge all pieces without portage
> complaining.  Unfortunately, the installed combination does not lead to
> working horde/imp/turba.  The PEAR modules are now marked stable and so is
> php 5 but neither the stable version of imp nor its ~x86 marked version seem
> to work. 

Completely unrelated to this bug, see Bug 120047 (and there's a couple of others). Your complaints need to be directed upstream, the horde code is broken. You can use 4.3.11 meanwhile, we won't be fixing horde. You can have both 4.3.11 and 5.0.5 installed at the same time - read out docs: http://www.gentoo.org/proj/en/php/php4-php5-configuration.xml
Comment 22 Jan Hrabe 2006-01-25 08:17:30 UTC
> Completely unrelated to this bug, see Bug 120047 (and there's a couple of
> others). Your complaints need to be directed upstream, the horde code is
> broken. You can use 4.3.11 meanwhile, we won't be fixing horde. You can have
> both 4.3.11 and 5.0.5 installed at the same time - read out docs:
> http://www.gentoo.org/proj/en/php/php4-php5-configuration.xml

You are right it's not entirely related but someone marked the original bug
as a duplicate this one.  

I am happy to report that PHP 4.3.11 works with horde.  Thanks for your advice.
PHP had to be emerged a few times because it complains about various USE  variables in a one-by-one fashion.  It may therefore be useful for others to list the combination that worked for me:

1. packages.keywords file:
>=www-apps/horde-3.0.7          ~x86
>=www-apps/horde-imp-4.0.4      ~x86
>=www-apps/horde-turba-2.0.4    ~x86

2. packages.use file:
=dev-lang/php-4.3.11-r5 cli cgi apache2 ctype expat fastbuild force-cgi-redirect
 ftp gd iconv memlimit mysql nls pcre pic posix session socket ssl tokenizer tru
etype xml xsl zlib pear dba imap -recode -mssql

3. package.mask file:
>=dev-lang/php-4.3.12

As for your suggestion that I should complain upstream about horde apps not 
working, I very much disagree.  If gentoo developers include a package and
mark it stable, sysadmins will expect it to work.  More importantly, 
routine "emerge -uD world" issued on the production server should definitely
not bring any of its services down!  I don't think I'd be allowed to put
Gentoo on any other server if this assumption could not be safely made so 
I hope your view is not a majority one among the Gentoo developers.
Comment 23 Jakub Moc (RETIRED) gentoo-dev 2006-01-25 08:23:10 UTC
(In reply to comment #22)
Please, with sugar on top, don't clutter keywording bugs with irrelevant off-topic comments. Thanks.
Comment 24 Jeroen Roovers gentoo-dev 2006-01-27 05:40:00 UTC
hppa wants in. ;-)
Comment 25 Jeroen Roovers gentoo-dev 2006-01-27 13:42:54 UTC
All packages in the list that were hppa stable for dev-php/php should now be stable for dev-lang/php.
All packages in the list that were hppa unstable are left untouched for now.

tx
Comment 26 Jeroen Roovers gentoo-dev 2006-01-28 08:27:07 UTC
Now I marked new (dev-lang/php) versions as ~hppa when older (dev-php/php) versions were marked ~hppa. Unstable and stable hppa upgraders should be ok now. Keeping the CC for stabilizing at a later date.
Comment 27 Mike Green 2006-02-07 00:03:17 UTC
Add to the list:

PEAR-Archive_Tar
PEAR-Console_Getopt
PEAR-XML_RPC
Comment 28 Sebastian Bergmann (RETIRED) gentoo-dev 2006-02-07 00:11:51 UTC
Why? Those packages have been merged into the PEAR-PEAR package (to avoid file collisions, for instace).
Comment 29 Aron Griffis (RETIRED) gentoo-dev 2006-02-17 14:15:01 UTC
alpha/ia64 done
Comment 30 Jeroen Roovers gentoo-dev 2006-03-18 07:15:25 UTC
hppa done.
Comment 31 Joe Jezak (RETIRED) gentoo-dev 2006-03-30 11:46:25 UTC
These were not marked ~ppc yet, so I've marked them ~ppc and will keyword them stable when they've spent some time in ~ppc (unless you'd like them pushed to stable now):
dev-php/PEAR-Console_Table-1.0.2-r1
dev-php/PEAR-Net_SmartIRC-1.0.0
dev-php/PEAR-PHPUnit-1.3.0-r1

The others are all marked ppc stable.
Comment 32 Joe Jezak (RETIRED) gentoo-dev 2006-04-28 21:17:19 UTC
I marked the remaining ebuilds ppc stable.  Closing since we're the last arch.