Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 105721 - dev-util/cmake contains insecure RUNPATH's
Summary: dev-util/cmake contains insecure RUNPATH's
Alias: None
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo Security
Whiteboard: B3 [glsa]
Depends on:
Blocks: 81745
  Show dependency tree
Reported: 2005-09-12 12:20 UTC by Ashu Tiwary
Modified: 2005-10-17 01:25 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

logfile for "emerge dev-util/cmake" (3295-cmake-2.2.0.log,67.10 KB, text/plain)
2005-09-12 12:21 UTC, Ashu Tiwary
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ashu Tiwary 2005-09-12 12:20:57 UTC
when emerging dev-util/cmake-2.2.0, the emerge fails w/ "insecure

strip: i686-pc-linux-gnu-strip --strip-unneeded

QA Notice: the following files contain insecure RUNPATH's
 Please file a bug about this at
 For more information on this issue, kindly review:

!!! ERROR: dev-util/cmake-2.2.0 failed.
!!! Function dyn_install, Line 1044, Exitcode 0
!!! Insecure binaries detected
!!! If you need support, post the topmost build error, NOT this status message.

Reproducible: Always
Steps to Reproduce:
1. emerge "dev-util/cmake"

Actual Results:  
see above

Expected Results:  
should successfuly emerge

liberte insecure_runpaths # emerge --info
Portage 2.0.52-r1 (default-linux/x86/2005.1, gcc-3.4.4, glibc-2.3.5-r1,
2.6.13-gentoo i686)
System uname: 2.6.13-gentoo i686 Intel(R) Pentium(R) M processor 1700MHz
Gentoo Base System version 1.12.0_pre8
dev-lang/python:     2.3.5, 2.4.1-r1
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
CFLAGS="-O3 -pipe -march=pentium-m -mtune=pentium-m -fweb -ftracer"
CONFIG_PROTECT="/etc /opt/openjms/config /usr/kde/2/share/config
/usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown
/usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O3 -pipe -march=pentium-m -mtune=pentium-m -fweb -ftracer"
FEATURES="autoconfig distlocks fixpackages sandbox sfperms strict userpriv"
LINGUAS="en ar bg bn br bs ca cs cy da de el en_GB eo es et eu fi fr fy ga he hi
hsb hu is it ja lt mk nb nds nl nn pa pl pt pt_BR ro ru se sk sl sr sr@Latn sv
ta tg tr uk zh_CN zh_TW"
USE="x86 X aalib alsa apm arts avi bash-completion berkdb bitmap-fonts cdr crypt
cscope cups curl directfb doc eds emboss encode erandom esd fam flac foomaticdb
fortran freetds g++ g77 gcj gd gdbm ggi gif gjava gnat gnome gobjc gpm gstreamer
gtk gtk2 guile imagemagick imlib ipv6 jack java jpeg junit kde ldap libg++
libwww lirc mad mcal mikmod motif mozilla mp3 mpeg mysql nas ncurses nls nptl
nptlonly objc odbc ogg oggvorbis opengl oss pam pdflib perl pic png postgres
python qt quicktime readline ruby samba sdl slang snmp speex spell sqlite ssl
svga tcltk tcpd tetex tiff truetype truetype-fonts type1-fonts unicode
userlocales vorbis xml xml2 xmms xv zlib linguas_en linguas_ar linguas_bg
linguas_bn linguas_br linguas_bs linguas_ca linguas_cs linguas_cy linguas_da
linguas_de linguas_el linguas_en_GB linguas_eo linguas_es linguas_et linguas_eu
linguas_fi linguas_fr linguas_fy linguas_ga linguas_he linguas_hi linguas_hsb
linguas_hu linguas_is linguas_it linguas_ja linguas_lt linguas_mk linguas_nb
linguas_nds linguas_nl linguas_nn linguas_pa linguas_pl linguas_pt linguas_pt_BR
linguas_ro linguas_ru linguas_se linguas_sk linguas_sl linguas_sr
linguas_sr@Latn linguas_sv linguas_ta linguas_tg linguas_tr linguas_uk
linguas_zh_CN linguas_zh_TW userland_GNU kernel_linux elibc_glibc"

liberte insecure_runpaths # grep -E "dev-util/cmake" /etc/portage/package.use
Comment 1 Ashu Tiwary 2005-09-12 12:21:24 UTC
Created attachment 68281 [details]
logfile for "emerge dev-util/cmake"
Comment 2 Ashu Tiwary 2005-09-12 12:21:52 UTC
i was able to successfully emerge cmake using the makemaker perl hack
described in bug id 105054
Comment 3 Ashu Tiwary 2005-09-12 19:18:23 UTC
(In reply to comment #2)
> i was able to successfully emerge cmake using the makemaker perl hack
> described in bug id 105054

actually - i lied - in the hurry of copy/n/paste'ing to report these issues, i
had copied this section as well - the only one that has worked w/ the makemaker
perl hack has been "emerge media-gfx/imagemagick-"
Comment 4 Thierry Carrez (RETIRED) gentoo-dev 2005-09-14 03:00:19 UTC
CCing maintainers
Comment 5 Thierry Carrez (RETIRED) gentoo-dev 2005-09-21 05:33:41 UTC
Reporter : could you please check that it still happens after the latest Perl
Comment 6 Ashu Tiwary 2005-09-22 02:30:54 UTC
yep - still happens - i had emerged the latest perl ebuild (perl-5.8.7-r1)
yesterday ; tried "emerge dev-util/cmake" - got the same response; tried just
now after an "emerge sync" - same response....
Comment 7 Daniel Black (RETIRED) gentoo-dev 2005-09-24 16:09:42 UTC
Thierry - I'm still looking - just been very busy lately. 
Comment 8 Daniel Black (RETIRED) gentoo-dev 2005-09-26 03:45:44 UTC
target cmake-2.0.6-r1.ebuild for stable alpha and ia64  
please remove cmake-2.0.5.ebuild and cmake-2.0.6.ebuild when finished.  
Thankyou Ashu for the bug report and being so responsive for further testing. 
Comment 9 Fernando J. Pereda (RETIRED) gentoo-dev 2005-09-29 08:02:40 UTC
I just marked cmake-2.0.6-r1 stable on alpha, sorry for the delay.

Comment 10 Bryan Østergaard (RETIRED) gentoo-dev 2005-10-01 17:24:11 UTC
Stable on ia64.
Comment 11 Thierry Carrez (RETIRED) gentoo-dev 2005-10-15 03:11:55 UTC
Let's make a GLSA with those that are ready.
Comment 12 Thierry Carrez (RETIRED) gentoo-dev 2005-10-17 01:25:40 UTC
GLSA 200510-14